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About the Guide
This guide is designed for the administrators responsible for setting up and managing the PulsewayPSA software
solution. Depending on the size of your organization, you may want to limit the number of Global Administrators (the
highest level of permissions) in your system.

How the User Guide Is Organized

The user guide is designed by module, with the premise that some administrative work and system configuration needs
to be completed first.

Adding Basic Company Data

Before creating tickets and projects, assigning to-dos, generating invoices, and running reports, you'll want to add some
basic data specific for your company in the Admin Module.

In this module . . . You will find this kind of information . . .

Admin Setting up Your Company

• Creating departments, roles and rates for billing

• Custom fields to add to existing forms.

• Setting up account types and codes to integrate with your accounting software.

• Preconfiguring drop down lists – faster and easier to complete forms

• Creating work-flow rules to automate daily task and communicate with external and internal
customers.

Human
Resources - HR

Adding/Managing the Employees

• Selecting job titles and placing in the right department.

• Tracking personal contacts, wage history, time off balances.

• Applying the proper access level to PulsewayPSA.

• Quickly producing organization charts to visually see your company structure.

Finance Set up the Contracts/Billing

• Use roles and rates and services in the already entered into system to create T&M,

• Recurring, fixed price, prepaid hours and prepaid dollar contracts.

• Review time and expense entries

• Generate invoices or transfer to QuickBooks.
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Projects Create Projects and Assign Tasks

• Manage and monitor progress on a projects dashboard.

• Real time updates on estimate hours and used hours and budgets.

Service Desk Create and manage Support Tickets

• Access the dashboard by priority, by issue, by client, etc.

• Set up queues to manage tickets with common themes.

• Store and track all the assets your customers have

• Automatic alerts displayed and sent when a contract or warranty is set to expire.

CRM Store and Manage all the Accounts

• Clients, prospects, vendors, etc.

• Access contacts with phone numbers, emails, notes and future activities.

• Create and track opportunities and see all this information in pipeline reports.

Reports Create Reports

• Organized by modules, you will find it easy to run the reports you need for Service Desk –
Projects – CRM – Finance – Time-sheet and Expenses.

• With easy to use filters, you can generate and export in a multitude of formats.

• New Ad Hoc Report Writer
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System Requirements
The PulsewayPSA cloud-based solution runs on our servers, which means that the only requirements to run our
application are:

• Computer with a web browser (Internet Explorer, Chrome, Firefox, Safari.)

• iPad or tablet

• Internet Connection

So, if you are reading this now, you have everything you need to use the software. You do not need to purchase any
special hardware, download anything, or apply any add-on's to run PulsewayPSA.
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How to Login
Typically a new user receives a welcome email similar to the sample below.

To access PulsewayPSA:

1 Use a browser to log into https://psa.pulseway.com

2 Enter your credentials:

– Username

– Password

– Company Name
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Forget Your Password

If you forgot your password, click the Forgot Password link.

and the following screen appears.
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Enter your email address and Company Name

When you hit Reset Password it will send you an email with a new password.
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How to Navigate the Software
Global Navigation Bar

When you login to your database, a horizontal navigation bar runs along the TOP with words such as Service Desk, CRM,
Finance and Projects. This bar is called the global navigation bar and each of these words is the heading of a
PulsewayPSA module.

When you click on a module, such as the Service Desk module, notice the letters Service Deskturn white and a red
line appears under the words.

Local Navigation Bar

On the left side of the screen, a vertical navigation bar shows a list of options you can select.

This is called the local navigation bar. Selecting one of these options takes you further into the module.

Continuing in the Service Desk module, you can view a ticket screen by clicking the word Tickets located in the local
navigation bar.
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My Profile
Settings > My Profile

The My Profile section enables you to personalize your PulsewayPSA user experience.

• Sets your PulsewayPSA photo.

• Displays your personal ticket counts.

• Stores your personal information and contact information.

• Changes your password.

• Sets your default landing page when you login.

Reviewing My Profile

1 Select the Settings > My Profile page.

2 Review the Personal Information tab.

– Reset (Photo)

– Select Photo - jpg, jpeg, png, gif

– Your Ticket Statistics

• Opened

• Handled

• Resolved

– User Name

– E-mail
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– First Name

– Middle Name

– Last Name

– Birth Date

– Marital Status

– Gender

3 Review the Contact Information > Main Address tab and Secondary Contact tab.

– Address 1

– Address 2

– City

– State

– Zip Code

– Country

– Phone

– Ext

– Fax

– Mobile

– Email

4 Optionally change your password using the Change Password tab.

– Old Password

– New Password

– Confirm New Password

5 Optionally set options on the Preferences tab.

– Default Landing Page - The page displayed when you logon.

– Default Tickets Listing Click Behavior - Selects how a ticket opens from a list page.

• in the same page

• in a new tab

• in a new window
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Edit Access by URL
PulsewayPSA supports edit access by URL for the following types of records:

• Tickets by Ticket ID
https://psa.pulseway.com/MSP/TicketEdit.aspx?ID=15551

• Projects by Project ID
https://psa.pulseway.com/Projects/ProjectEdit.aspx?ID=2560

• Tasks by Task ID
https://psa.pulseway.com/Projects/TasksEdit.aspx?ID=22182

To identify the number of a ticket, project or task, create an Ad Hoc report that includes the Ticket ID, or Project ID or
Task ID columns, along with additional columns to help identify the corresponding ID.

Note: Navigate to the Reports > Ad-Hoc Reports page and click the icon in the upper right hand corner for
instructions on how to create Ad Hoc reports.

Caveats
Text enclosed in angle brackets < and > is not generally supported for security reasons. Try to use ( or ) instead as this is
a security consideration.
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Chapter 2: Pulseway Release Notes

Pulseway Release Notes
In this section:

PulsewayPSA (v4.0.42) - 13 March 2021
This release includes new features, improvements, and fixes.

New Features

Bundles in Quotes - An extension of the product bundles concept, a Quote Bundle is a container that holds multiple
quotable items of any type, e.g., products, services, and T&M. This feature enables the MSP to easily create new quotes
for common scenarios, like client site setups, frequent charges, and workstation configurations.

Xero Integration - PSA integration with Xero now supports OAuth 2.0. Using this we have implemented the offline mode
scope which allows the user to keep their integrated session active. This means that there will no longer be a 30 mins
limitation to an active session. We use refresh tokens to keep the sessions activated. The session will be disconnected
once the user manually chooses to Disconnect from Xero from the setup page.

Classes in Accounts - Automate adding classes to Invoices by mapping class to an account.

Release Notes

Reports In Ad-Hoc Reports, in the Finance category Invoice Design Details and Contracts fields can
be added to the report so that users can design invoices that contain contract and invoice
line items.

Service Desk When the Email Parser creates tickets based on an incoming email, and the To line
contains multiple addresses, all addresses on that line, other than the support email
address, are added as CCs on the ticket.

Service Desk Fixed: Batch actions on tickets with Issue Type populated failed and the system
displayed an error message.

Service Desk Fixed: If the connection to the mail server was temporarily interrupted the email parser
could miss emails when converting emails to tickets.

Service Desk Fixed: In Knowledge Base articles, hyperlinks rendered as plain text and so they were not
clickable. A hyperlink manager button is now available.

CRM Fixed: Rich text formatting on the Summary field of quotes was lost during conversion.

Workflows Fixed: The idle ticket settings in workflows would not trigger in certain scenarios.

Inventory Fixed: When adding a product to a Purchase Order, the product catalog displayed quantity
using a currency format rather than an integer format.
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PulsewayPSA (v4.0.41) - 13 February 2021
This release includes fixes.

Release Notes

General Fixed: Creation of API user type failed when the tenant has no active licenses.

Quickbooks Fixed: When attempting to export an invoice for a child account to QuickBooks Desktop, PSA
erroneously created a new account. Downloading the new version of the connector fixes the issue.

Finance Fixed: When cloning a recurring service contract, if the user changed the billable units, proration was
calculated incorrectly.

Service
Desk

Fixed: Saved views did not preserve the user selected order setting when ordering by ticket status.

Inventory Fixed: European currency formats were not displayed correctly in the Amount field of purchase order
charges.

PulsewayPSA (v4.0.40) - 16 January 2021
This release includes new features, improvements, and fixes.

New Features

• OAuth for Microsoft Inbound Email - PSA supports OAuth2.0 authentication for Microsoft IMAP connections. This
enhancement is related to inbound email capability and is in response to Microsoft's lifecycle announcement, in
which they indicate that they will begin deprecating Basic Authentication in October 2021. Here is the setup guide.

• Dedicated Integration Account - A dedicated user type has been introduced to enable MSPs to use the API for OAuth
based application integration without having to consume a paid license. Under HR > Employee it is called 'API
Employee'. This user will only be able to authenticate to the API, they will not be able to login to the user interface.
Here is the setup guide.

Release Notes

General The keywords in browser tabs have been reversed to apportion more space to the
page name.

Service Desk Under Admin > My Company > Company Settings > Service Desk > Ticket
Number Format > COUNT, this is a new format that does not include the date. You
can also set a Ticket starting number for the same.

Quickbooks The QuickBooks Desktop plug-in now has an option to set the To line in invoices
to the Account Name. Under the Options tab set 'Yes' for 'Set account name in
address line 1'.
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General Fixed: Users were logged out after a session time out even when remember me
was checked during the logon.

Quickbooks Fixed: When exporting invoices to QuickBooks for a non-taxable organization, the
tax code defaulted to the first taxable item instead of the selected option.

Quickbooks Fixed: Due to an API limitation, only 50 payments from the Import Payments
page were imported from Quickbooks.

Quickbooks Fixed: The QuickBooks plugin produced error logs as a result of a QuickBooks
SDK update.

Inventory Fixed: A display issue on the Stock Adjustments page prevented the user from
viewing the complete serial numbers for products.

CRM Fixed: On every save the quote expiry date decreased by one day.

CRM Fixed: Quotes did not show the tax amount for a taxable charge.

CRM Fixed: When adding an Activity inside a Contact, and the corresponding Account
had more than 10 Contacts, the update was applied to the incorrect Contact.

CRM Fixed: User contact profile picture was not rendered correctly on a Service desk
ticket.

Service Desk Fixed: The CCs field in tickets displayed duplicate email addresses.

Service Desk Fixed: The delete ticket button was decorated as disabled, but the action could
still be triggered by users with insufficient privileges.

Service Desk Fixed: Workflow did not update associated asset on a ticket.

PulsewayPSA (v4.0.39) - 12 December 2020
New Features

Unified quoting - CRM Quotes - Product and Service quotes are now completely unified, obviating the need to create two
separate quotes based on the type of item you are quoting. The new form is simply called 'Quotes' and contains all of the
functionality of the Product Quotes form.

Threading By Message ID - The system now threads emails based on the Message ID property in the email header. This
means that emails without a ticket number in the subject line can still be correlated to the proper ticket.

Deprecation Notice

The facility to create new Product Quotes is slated for removal. Existing product quotes may still be used until they are
they reach Accepted status.

Release Notes

28 PulsewayPSA Guide

Release 4.0.41 | March 2021

Chapter 2: PulsewayRelease Notes www.pulseway.com

https://www.pulseway.com/


29

Chapter 2: PulsewayRelease Noteswww.pulseway.com

Azure Integration Azure AD Integration now syncs phone types and phone numbers. If a phone type is
not present in the PSA, it will be created automatically so no mapping is required.

CRM The summary box for quotes is no longer restricted to 1000 character restriction.

CRM When creating an activity from a Contact, the Contact field now auto-populates.

General The alert message that is displayed when a company's PSA subscription expires has
been updated.

General Pagination has been added to the display of security roles.

Reports In Ad-Hoc Reports, the Inventory > Stock Adjustment New Item category now has
been added so that users can report on manual stock adjustments.

Reports In Ad-Hoc Reports, the Inventory > Stock Adjustment New Item category now has
been added so that users can report on manual stock adjustments.

Service Desk Hardware Asset field has been added to Search Tickets and column listing.
Technicians can look up tickets based on the affected hardware asset name.

Quickbooks Exporting invoices to Quickbooks now takes Invoice level tax item into
consideration.

If the invoice has a taxable product and "Tax Item" empty, it will be exported to
Quickbooks with Tax value as "Non".

If the invoice has a taxable product and "Tax Item" is applied on the invoice, the
exported invoice will show the tax value based on its tax settings.

Workflows The Work Type field has been added to the Updates section of a workflow.

CRM Fixed: After two consecutive save operations on a contact, the Enable Bill by
Contact field was disabled after the second save.

Email Parser Fixed: Email parser skipped incoming emails that had no value for the Content-Type
property in the email header.

Email Parser Fixed: The email parser could not process emails if there were angle brackets (<>)
in the email subject line. These characters are not stripped before the ticket is
generated.

Service Desk Fixed: The hyperlink to the agent procedures log inside the ticket activity log
returned a 404.

Security Fixed: When the number of employees was very large, the system returned an error
when attempting to add employees to a security scope.
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PulsewayPSA (v4.0.38) - 7 November 2020
This release includes new features, improvements, and fixes.

Release Notes

Reports In Ad-Hoc Reports, the Finance > Invoice Details category has a new Invoice Posted Date field, so that users
can report on when the invoice was posted.

Reports In Ad-Hoc Reports, the Inventory > Product Availability By Location category has been added so that users
can report on in-stock inventory and the serial numbers.

Azure
Integration

When an AD user is assigned to multiple mapping rules with different role types, the user role will be
created as a Contact or Client portal or Employee related to the first ordered mapping rule.

CRM Fixed: Under CRM > Contacts, the system reverted the user's Bill By Asset selection back to the default
option.

Finance Fixed: After all periods on a contract were posted, and a contract was extended, billing generated a
duplicate line item for the last posted period.

Email
Parser

Fixed: For parsers that have ProofPoint as part of the SPAM routing, emails were stripped of images before
their content was included in tickets.

Reports Fixed: In Ad-Hoc Reports, in the CRM > Contacts category, the Created By field reported the incorrect value.

Reports Fixed: In Ad-Hoc Reports, in the Service Desk > Ticket category, "Resolution Time" and "Response Time"
fields now display the correct date and time format.

Workflows Fixed: Cloned workflows retained the created date of the original workflow.

Workflows Fixed: Workflows that updated Issue Type did not set the field as specified in the workflow if Sub-Issue Type
was populated when the workflow triggered.

Service
Desk

Fixed: For recurring tickets, the system reverted the user's edits to CCs and Secondary Assignees to their
previous values.

Service
Desk Fixed: On the Hardware Asset List, the Contact column was empty for assets that did have a Contact.

Service
Desk

Fixed: Users could sometimes not add the desired contact to a hardware asset because the contact drop-
down did not populate correctly.

Service
Desk

Fixed: When notes containing images were added to a ticket from the parent tenant, the image did not
display in the child tenant.

Azure
Integration

Fixed: The QuickBooks Desktop Connector sometimes created an erroneous account when importing
payments for a child customer.

Azure
Integration

Fixed: The integration with Azure AD was disconnecting intermittently. Additional retries have been added to
improve stability.

RMM
Integration

Fixed: When tickets were created in the PSA for Continuum RMM, the default contract was not
automatically associated, though it should have been.

RMM
Integration

Fixed: When tickets were created in the PSA for Continuum RMM, those tickets did not reflect the timezone
setting in Continuum.

PulsewayPSA (v4.0.37) - 10 October 2020
This release includes improvements and fixes.
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Release Notes

Servicedesk Many MSPs have a dedicated person to tidy time entries on behalf of technicians. Previously this is
happening outside of the PSA. While edits to existing entries were already permitted, two new security
permissions are available to facilitate add and delete:

– Add Ticket Time Log Entries For Another User

– Delete Another User's Ticket Time Log Entries

– To enable this Navigate to Admin > Security > Roles > Service Desk module > Special
Features.

Servicedesk When a user edits a ticket via the Assign button, all changes are captured in the audit log, and all
changes are displayed in the activity log if the edits contain a comment.

Finance There was a global Bill By Contact switch under Admin > My Company. This switch controls the visibility
of Bill By Contact fields and was introduced to facilitate beta. It is now removed, and these fields are
now visible by default for all PSA tenants.

General Pagination has been added to the display of security roles to accommodate the display of roles with
many users assigned to it.

Timesheets When adding tasks to a timesheet, the user can filter for only tasks in open projects, regardless of the
task status.

Reports Ad hoc reports now support creating reports with Tickets and Contacts categories, e.g., in order to report
on tickets opened by contact.

Reports Ad hoc reports now support creating reports with the Product Availability and Product Supplier
categories, e.g., in order to report on products that need to be reordered.

API API command Get Ticket Timelogs now returns both public and internal notes.

Active
Directory

Fixed: Improved the log message produced when Active Directory is enabled but JIT is not working.

Integration Fixed: Long account names were truncated in the invoice record, which caused an error in Xero, and
prevented the invoice from being exported.

Servicedesk Fixed: The ticket audit log could not be displayed in German or Dutch.

Reports Fixed: Users were not able to run the ad hod report called Executive Report. This report has been
removed.

PulsewayPSA (v4.0.36) - 5 September 2020
This release includes new features, improvements, and fixes.
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Release Notes

Workflows For Service Desk tickets, a single email is sent when a notification is triggered. The email specifies the
ticket Contact in the To field, and all recipients specified in the ticket CC field are included in the email
CC field.

Finance To prevent proration errors, users cannot change the way units get derived after a service is saved.
Recurring Services Contract > Services > Add/Edit Services > Automatically Derive Billing Units option
will get disabled.

General Fixed: Closed administrative work types still appeared in the pop-up when adding admin tasks to a
timesheet.

CRM When a quote originates from QuoteWerks, the contact was not displayed in the quote list page.

CRM Fixed: Quotes originating from QuoteWerks could return a 500 error.

Finance Fixed: Billing Automation did not generate invoices for the 'Charges' Billing Type.

Integration Fixed: Invoices weren't exported to Quickbooks if sales tax was turned off.

PulsewayPSA (v4.0.35) - 8 August 2020
This release includes new features, improvements, and fixes.

New Features

• QuoteWerks Native Integration - As of QuoteWerks Version 5.5 Build 5.13, QuoteWerks offers native integration
with PulsewayPSA. Build quotes that mix and match products and services from PulsewayPSA and QuoteWerks
product data sources. Configure QuoteWerks to handoff when the quote converts in order in order to complete the
sales cycle in the PulsewayPSA.

Release Notes

API The API can now return the Bill By User status and Billing Effective Date for contacts.

Ad-hoc reports Additional Exago filters have been added to enable users to produce reports in the UTC time
range congruent with their user time zone.

System Fixed: When MFA is enabled, the browser forcus was on the username field rather than the
MFA code field.

CRM Fixed: The opportunity edit page listed the first contact in the drop-down rather than the
correct contact for the opportunity.

Finance Fixed: When updating unit price, the billing amount for the first period was calculated
incorrectly.

Finance Fixed: A one-day proration was applied to the first month of a contract when the service
effective date was the first of the month.

Adhoc Reports Fixed: Users were not able to add CRM data and Contract data to the same ad hoc report.

32 PulsewayPSA Guide

Release 4.0.41 | March 2021

Chapter 2: PulsewayRelease Notes www.pulseway.com

https://www.pulseway.com/


33

Chapter 2: PulsewayRelease Noteswww.pulseway.com

PulsewayPSA (v4.0.34) - 11 July 2020
This release includes new features, improvements and fixes.

New Features

• Bill By User - Bill accounts by number of supported users. Managers can choose exactly which contacts are billable.
The contacts billed are detailed in Billing Review and can appear on the invoice. Proration is automatically applied
when a change affecting billability changes in the middle of the billing period. Proration is automatically calculated
whether you bill at the beginning or the end of the billing period.

• Azure AD Integration - The PulsewayPSA integration with Azure Active Directory enables contacts and users to be
automatically created and synced based on the users that are defined in one or more Active Directory tenants.
Primary integration is with Azure AD, but it can be used with on premises Active Directory via Azure AD Connect.
Additionally, Active Directory records will propagate to IT Glue if that integration is enabled.

Release Notes

CRM In CRM > Accounts, additional columns are displayed in the Contacts tab to enable users to more quickly
find and add contacts.

CRM Batch delete and update actions are now available on the contact list page, CRM > Contacts.

CRM Additional columns and filters are available on the contact list page, CRM > Contacts.

Reports Ad Hoc Reporting Enhancements: 1) Resolution Summary has been added to the Tickets Table; 2) A Join
between the Tickets Table and the Invoice Design Detail Table has been added.

Service
Desk

On the ticket details page, the Notification tab under Add Notes and add Time Entries has been
refactored in order to improve performance for accounts with a very large number of contact records.

Security The API has been hardened against javascript injection.

APIs Fixed: The ticket details page did not display custom fields for contacts.

Finance Fixed: The system returned a 404 when attempting to open a invoice receipt attachment.

Finance Fixed: To avoid user error, users are prevented from creating invoice credits using negative prices. Only
negative quantities should be used to create service credits.

Finance Fixed: Emails sent by billing automation did not use the specified email template.

Finance Fixed: In Finance > Billing Automation, the time picker widget could sometimes display selections in
hh:mm:ss.sss. The display has been limited to hh:mm.

Finance Fixed: The system did not allow the user to use cent values South African currency. The system has been
updated to use "." as the decimal separator for this currency.

Email
Parser

Fixed: When an incoming email was from a domain that was defined, but a contact that was not defined,
the system did not create a ticket.
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Integration Fixed: A display issue in the QuickBooks integration wizard prevented the user from viewing/selecting
from the complete list of importable items.

Integration Fixed: Contact record updates were not syncing to Xero.

Integration Fixed: If a change in the Office 365 configuration caused the calendar sync to fail, the in-app
remediation offered to the user returned an error.

Integration Fixed: In the Related Documents tab, when a vaulted password was displayed, the Copy button copied
the encrypted value, not the real password. The behaviour of this button has been updated to redirect the
user to IT Glue to obtain the password.

Service
Desk

Fixed: Users could not absorb tickets while using the 3CX Chrome Extension.

Timesheet Fixed: When logging time under My Grouped Tasks, the Time Log pop-up did not default to the user's
rate as defined in the Project.

PulsewayPSA (v4.0.33) - 6 June 2020
This release has a number of incremental improvements and fixes.

Enhancements

PulsewayPSA CRM

• The contact may now be activated/deactivated with an effective date, when modifying a contact in an account
record.

PulsewayPSA General

Enhanced user interface styles:

• Rich text fields default to Open Sans;

• Updated the background colors for headers and sidebars.
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PulsewayPSA APIs

• Added a new API endpoint to retrieve Sales Tax Items.

• Added StartDateUTC and EndTimeUTC properties to the response for the GET Timesheet Timelogs API endpoint.

Bug Fixes

PulsewayPSA Service Desk

Fixed an issue where workflow cleared a contact from a ticket when it was configured to update the account field.

PulsewayPSA APIs

• Fixed an issue where users could not authenticate through SSO to the mobile application if they used an email
address as their username.

• Fixed an issue where emails were sent to CCs when internal notes were added to a ticket.

• Fixed an issue where Ticket Activity was missing from the Modules list under API Lookups in the API
documentation.

PulsewayPSA Inventory

• Fixed an issue when the same inventory item was added to a product quote multiple times, and the user attempted
to delete one, the system was deleted the selected duplicate item.

PulsewayPSA Finance

• Fixed an issue where updating a recurring service item in a contract, without updating the quantity, caused
incorrect calculation of proration amounts.

PulsewayPSA General

• Fixed an issue where irrelevant options appeared in CRM > Accounts > Location > Country drop-down when
modifying the address of an account location.

PulsewayPSA (v4.0.32) - 2 May 2020
This release has a number of incremental improvements and fixes.

Enhancements

PulsewayPSA APIs

• The API now supports the ability to set 'External Authentication Type' when importing contacts into PulsewayPSA.

• The API now includes GET endpoints for Work Type and (Finance) Role.

PulsewayPSAy CRM

• Added pagination to the Contact list to support thousands of contact for a single account on the Account page.

PulsewayPSA Email Parser

• Added logic to prevent email parser from looping.
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PulsewayPSA Service Desk

• Added an ability to have the ticket work type preset based on the ticket template.

PulsewayPSA Reports

• Under Ad Hoc Reports, CRM views can now be joined to the 'Invoice Design Header' view. This allows you to add
more fields from the CRM when creating custom invoice templates.

PulsewayPSA QB Integration

• The QuickBooks Desktop (QBD) connector application can now be used with a user account that requires Multi-
Factor Authentication.

• Added mapping on credit card payment method while importing invoice from QuickBooks Online.

Bug Fixes

PulsewayPSA QB Integration

• Fixed an issue where the correct currency did not sync during exporting of account to Quickbooks Online.

PulsewayPSA APIs

• Fixed an issue when creating or updating a Service Quote, the ContactID was always "Nulled" out.

PulsewayPSA Cytracom

• Fixed an issue when Cytracom integration did not recognize call center queue calls.

PulsewayPSA Finance

• Fixed an issue where keyboard shortcuts to Generate Invoice(G) did not work.

• Added inner exception logging in the Billing automation jobs to catch errors in case of failure.

• Fixed an issue where billing review`s Total Price column displayed Unite Price.

• Added filter to the Invoice Ad Hoc to reduce performance and service quotation template.

PulsewayPSA General

• Fixed an issue where the email address with an apostrophe in the name broke sync to ITGlue.

• Fixed an issue where special signs were not supported in PulsewayPSA email templates.

PulsewayPSA Reports

• Fixed an issue where Custom report created using the Delivery Product Charge table displayed wrong data.

PulsewayPSA Timesheets

• Fixed an issue where the date-time format failed back to US when the browser was opened and IIS was reset.

PulsewayPSA Workflows

• Added logic to clear the contact field when workflow changes the account on a ticket.
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PulsewayPSA (v4.0.31) - 4 April 2020
Release Highlights: Automated ticket remediation is now possible with the ability to execute agent procedures during
Service Desk workflow. Also, Quotes can now be completely customized.

Enhancements

PulsewayPSA Finance

Want to get your quotes looking just the way you want them? You now have unparalleled flexibility to do just that.
Similar to invoices, quote layouts and formats can now be completely customized leveraging the power and flexibility of
the Ad Hoc reporting engine. There is no need to build custom quotes from scratch: the quote templates that were
previously available have been reimagined as Ad Hoc templates which can be found under the 'System' folder in Ad Hoc
reports. These templates can be used as-is, or they can be copied to the Public Reports folder where they can be
customized. Using the Ad Hoc reporting tool you can tailor the quote templates to match your brand by formatting
borders, fonts, text & background colors, bold, italic, and more. You can also configure quote templates to show just the
data you want your clients to see by adding text and data fields to header, line-item, and footer areas.
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PulsewayPSA Authanvil(Passly)

The legacy AuthAnvil(Passly) authentication integration can no longer be activated. In those cases where it has been
previously activated, the legacy integration will remain active; however, it recommends using SAML SSO to integrate
with AuthAnvil(Passly).

PulsewayPSA Documentation

The PulsewayPSA About page and Release Banner were updated to point to the New Release Notes page.

PulsewayPSA Email Engine

Multiple replies to the same ticket notification will now be grouped in a single Conversation view in Outlook.

PulsewayPSA Reports

Multiple Ad Hoc reporting objects have been refactored resulting in significant performance improvement.
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PulsewayPSA Service Desk

Hardware assets can now be filtered by description both on the hardware asset list, and also when assigning an asset to
a ticket.

Bug Fixes

PulsewayPSA Email Parser

Added more logic to Email Parser to prevent issues arisen.

PulsewayPSA CRM

Fixed an issue where it was not possible to add m.network as a Domain Name in the CRM Account Domains.

Fixed an issue where adding a line item and selecting on the "Period" section "Per Day" set the quote to "Quarterly"
instead of "Per Day".

Fixed an issue where the Fax number was not copied when importing accounts toPulsewayPSA.

PulsewayPSA Finance

Fixed an issue when the contract had exclusions the time entries were set as zero value items.

Added inner exception logging to catch errors in the case of Billing Automation failure.

Fixed an issue where the invoice was generated based on the Original Template instead of the AD-HOC when it was
marked as Fully Paid and sent to the customer.

PulsewayPSA Project Management

Fixed an issue when Cost Type was not being set when importing the tasks using the excel import template for the
project.

PulsewayPSA QB Integration

Fixed the wrong validation message when user was trying to connect to the account with a wrong URL for target server.

Fixed an issue when Select All did not respect filtered results when exporting data.

PulsewayPSA (v4.0.30) - 7 March 2020
This release features a completely redesigned integration to Quickbooks Desktop. Also, building upon the invoice
configuration capability that was included in v4.0.29, this release includes even more options to control how invoices
appear.

Enhancements

QuickBooks Desktop Integration

• The QuickBooks Desktop (QBD) integration experience has been completely redesigned and has also been
upgraded to leverage the latest version of the QBD API for improved efficiency and stability. Enhancements include:

– Greatly improved user experience.

– Significant speed improvement when exporting invoices.
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– You can now define default account codes for services and inventory. In cases where account codes have not
been specified in the PulsewayPSA setup tables, the default codes will be used. This is a time saver when
exporting invoices as you no longer have to inspect the logs and manually make corrections for missing
accounts in the setup tables.

– See the new QuickBooks Desktop Integration Guide for further details.

Note: To use the new QBD connector, uninstall the existing QB Desktop connector, then download and install
the new connector (the download can be found under Home > Downloads). The new connector is
recommended going forward, and all future enhancements and fixes to the QBD integration will be made
via the new connector. The old connector can still be used on an as-is basis, but it will be retired in the
future.

Invoice Configuration

• A new option allows you to control what appears within the invoice line-item description. A flexible scheme allows
you to combine text and data fields tailored to each billing type (see screenshot). The line-item descriptions will
appear on the printed invoice, and will also be sent to your accounting system if you are using the Quickbooks or
Xero integrations.
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• A new option allows you to configure the order in which line-items for the different billing types will appear on
invoices. For example, you could specify that you want recurring service line-items to appear first, followed by labor
hours, expenses, and so on.
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• Additional control of the invoice line-item sort order is possible with a new option that allows you to control the
order in which recurring services line-items will appear.

PulsewayPSA Custom Templates

• A new invoice template has been added which focuses on recurring service billing. This invoice layout may be
familiar to some users of legacy PSA solutions. The new template is named 'Recurring Services Only (Legacy PSA).'

Bug Fixes

Database Performance

• Fixed an issue with missed index on SLA table, so it resulted in timeout.

PulsewayPSA Workflows

• Fixed an issue with stopping of Workflow service after adding max Idle Limit on Workflow fields.

PulsewayPSA Translation

• Fixed an issue with German translation.

PulsewayPSA SSO

• Fixed an issue with SAML SSO was not working if the Gateway URL was typed with capital 'G'.
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PulsewayPSA Service Desk

• Fixed an issue when Time on Print Ticket was not using the Correct TimeZone.

• Fixed an issue with visibility of details in PulsewayPSA Knowledge Base.

• Fixed an issue with small editing area while creating PulsewayPSA Knowledge Base article.

• Fixed an issue with random displaying of My Tickets in Service Desk module.

PulsewayPSA QuickBooks Integration

• Fixed an issue with importing child accounts with the same name but different parent accounts.

PulsewayPSA QuickBooks Online Integration

• Fixed an issue with error while exporting an invoice when Income and Expense accounts were not specified.

• Fixed an issue where multiple emails in Billing Address were not exported with the invoice to QuickBooks.

• Fixed an issue when the Service Date still showed after exporting invoices into QuickBooks while the Service Date
was turned off in QuickBooks Settings.

PulsewayPSA ITGlue Integration

• Fixed an issue with absence of added Asset information after 2 hours.

PulsewayPSA General

• Fixed an issue with incorrect labeling of Open File button while editing an attachment.

PulsewayPSA Finance

• Fixed an issue with breaking the Legacy Invoice Template if the Ticket Title had '&' character.

• Fixed an issue with Detailed Invoice template where the child account was not aligned and the address was not
displayed correctly.

• Fixed an issue with setting up a Yearly recurring agreement not based on the calendar year, where system showed
two periods the Billing Review instead of one record.

• Fixed an issue with midnight billing automation jobs where job was running constantly every minute and sent an
Email to the user for each successful run.

PulsewayPSA CRM

• Fixed an error thrown while deactivating contacts.

PulsewayPSA API

• Fixed an issue when running an API query for an invoice the ItemName fields were all null.

PulsewayPSA (v4.0.29) - 8 February 2020
This release features an amazing new Invoice customization capability, further improvements to the recently redesigned
QuickBooks Online integration, and a number of usability enhancements and fixes.
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Enhancements

PulsewayPSA Finance

• Want to get your invoices looking just the way you want them? You now have unparalled flexibility to do just that.
Invoice layouts and formats can now be completely customized leveraging the power and flexibility of the Ad Hoc
reporting engine. There is no need to build custom invoices from scratch: the most popular invoice templates have
been reimagined as Ad Hoc templates which can be found under the 'System' folder in Ad Hoc reports. These
templates can be used as-is, or they can be copied to the Public Reports folder where they can be customized.
Using the Ad Hoc reporting tool you can tailor the invoice templates to match your brand by formatting boarders,
fonts, text & background colors, bold, italic, and more. You can also configure invoice templates to show just the
data you want your clients to see by adding text and data fields to header, line-item, and footer areas. The Ad Hoc
invoice templates can be selected when generating invoices, and also when configuring billing automation jobs.

(A 'Classic' option allows you to use any of the original templates, as well as any custom templates that were
previously delivered via Professional Services.)
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• Added the ability to view PulsewayPSA Invoice numbers and invoice numbers that have been synced with an
accounting system such as QuickBooks or Xero.

• Added the new custom invoice templates to be used by the new Exago Designer Tool.

PulsewayPSA QuickBooks Integration

• Added a new warning message when importing data from QuickBooks Online: "NOTICE: Data imported from
QuickBooks will be permanently recorded. There is no way to undo the import, or bulk erase the data after the
import. Are you sure you want to proceed with the import?" Y/N.

• Added a new import service with Unit Cost.

• Enhanced mapping of product SKU.

• Enforced taxation on invoices when importing data from QuickBooks Online.

• Fixed an issue with the account code while exporting discount from PulsewayPSA to QuickBooks Online.

PulsewayPSA Reports

• Added an ability to join Invoices and Product Suppliers. These joins could be used to create a monthly report of
products, purchased each month by GL number with quantities, items received each month by GL number with
quantities, and items delivered each month by GL number with quantities.

PulsewayPSA Security

• Added a tooltip on the Security role user interface, explains that granting modify or delete permissions for batch
tickets will also grant these permissions to My tickets and Tickets modules.
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PulsewayPSA SSO

• Added Auto Redirect to SSO IdP when the username is specified in the URL for the Fusion mobile app login. This
improves the user experience when logging in to the Fusion mobile app via SAML SSO.

PulsewayPSA Xero Integration

• Added importing Address Line 2 field when importing contacts to accounts in Xero.

PulsewayPSA Localization

• Various fixes and improvements for German Language (Beta). Suggestions for further translation improvements
can be submitted via a Support Ticket.

• Various fixes and improvements for Swedish Language (Beta). Suggestions for further translation improvements
can be submitted via a Support Ticket.

Bug Fixes

PulsewayPSA APIs

• Fixed the country import by account location on Rest APIs.

PulsewayPSA CRM

• Fixed an issue when deactivated contact was able to login to the system.

PulsewayPSA Email Parser

• Fixed an iissue when Email Parser duplicated Email while replying to the ticket.

PulsewayPSA Finance

• Fixed an issue with Recurring Service Contract which added a new period while posting a non-fiscal contract that
has the end of the month as a start date.

• Fixed an issue with Vendor Bills where some free items were not showing on grid in some tenants.

• Fixed an issue with appearing HTML characters in Contract Description while creating contract invoice.

PulsewayPSA QuickBooks Online Integration

• Fixed an issue with exporting the vendor as a customer from PulsewayPSA to QuickBooks Online.

• Renamed Service Items Accounts to Service Items And Non-Inventory Products Accounts.

• Fixed an issue with exporting chart of account when Account Code displayed twice in the grid while re-exporting it.

• Fixed an issues with product import.

PulsewayPSA QuoteWerks Integration

• Added validation on the Doc Date on QuoteWerks Integration before sending to PulsewayPSA to validate DOC Date
and Expiry Date.

• Fixed an issue with QuoteWerks Connector where contacts with the same name but different accounts were
displaying incorrectly.
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PulsewayPSA Reports

• Fixed an issue with Invoice Filters were not filtering using typeahead.

PulsewayPSA Security

• Fixed an issue with MFA where validation message displayed behind the MFA pop-up.

• Fixed an issue with PulsewayPSA MFA on Microsoft Authenticator where Account Name was not fully displayed.

• Fixed a caching issue in the Master Tenant ID where error message appeared while importing Accounts from
QuickBooks Online into PulsewayPSA.

• Fixed an issue when Sync from Parent To Child Company was clearing the Allow Delete on the Child Company.

• Fixed an error appearing when trying to make an update on a role and deleting or adding a User role.

PulsewayPSA Timesheets

• Fixed an issue with Cleanup for old approval records.

PulsewayPSA Workflows

• Fixed a Workflows issue when an Activity Added From Anyone was not taking into consideration the Change
conditions.

PulsewayPSA (v4.0.28) - 14 December 2019
This release features a completely reimagined integration to Quickbooks Online, security improvements, and a number
of usability enhancements and fixes.

New Features

PulsewayPSA Security

• In Service Desk, security roles can now grant delete permissions separately from modify permissions allowing
more granular control. Permissions have also been added to govern the deletion of notes.
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• Parent employees can login to a child instance using MFA, SAML SSO, or AuthAnvil authentication.

PulsewayPSA CRM

• You can now capture an effective date when contacts are activated and deactivated. A log shows changes to the
active status.

PulsewayPSA APIs

• A new API Endpoint allows update of contact active status and effective date.

PulsewayPSA Finance

• A new invoice template is available called 'Detailed Invoice, Aggregated by Name, Desc & Unit Price.' With this
template, billing transactions with the same item name, description, unit price and effective date are aggregated
into a single line-item.

• Recurring services billing review now shows both the effective date and period end date for greater visibility of
recurring services transactions.
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Enhancements

PulsewayPSA QuickBooks Integration

• The QuickBooks Online (QBO) integration experience has been completely redesigned, and has also been
upgraded to leverage the latest version of the QBO API for improved efficiency and stability. Enhancements include:

– Redesigned user interface.

– You can now define default account codes for services and inventory. In cases where account codes have not
been specified in the PulsewayPSA setup tables, the default codes will be used. This is a time saver as you no
longer have to inspect the logs and manually make corrections for missing accounts in the setup tables.

– A new option allows you to assign QBO invoice numbers when creating invoices in QBO.

– Invoices can be exported without any prior sync operations. Any data needed to support the Invoice export will
be created on an as needed basis.

– Large import/export operations will now process in the background until they are complete. The previous time
limit that interfered with this process has been removed.
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Bug Fixes

PulsewayPSA APIs

• Fixed API issue when Products were not returning the Taxable Flag correctly.

• Fixed the issue in Recurring Contracts where Total Price saved wrong when using the Contract Service API.

PulsewayPSA Calendar Integration

• Fixed the issue when export Calendar into ICS was shifted by one hour.

PulsewayPSA CRM

• Fixed the issue with limitation of characters in Quotation Terms and Conditions text box.

PulsewayPSA Custom Templates

• Fixed the issue with printing out Summary Time Totals, Product Charges and Time Notes (Legacy PSA).

PulsewayPSA Finance

• Fixed the issue when First Period of Yearly Recurring Contracts was adding cents for the First Period.

• Fixed the issue with Billing Automation where Date Format displayed wrong when generation an invoice.

• Fixed the issue with Recurring Contracts where Invalid Data error appeared trying to update the Effective Date of
an exiting service in cloning contract.

• Fixed the issue with error after converting a Service Quote into Recurring Service and Activating.

• Fixed the issue when updating a Recurring Service and changing the effective date or the price without changing
the units didn't affect the selected period.

• Fixed the issue when invoice ended up as Duplicate when trying to generate it, clicking Cancel on the pop-up and
then trying to generate the invoice again.

• Fixed the issue when Search in Billing Review for Recurring Services was not working while searching in German
language.

PulsewayPSA General

• Fixed issue with Client Access Portal, where Incorrect Password message was displayed in wrong language.

PulsewayPSA Inventory

• Fixed issue with Manage Products where columns "Manufacturer" and "Brand" were inverted.

PulsewayPSA ITGlue Integration

• Fixed the issue with Related Items where ITGlue Widget was not showing items post version 4.0.26.

PulsewayPSA Project Management

• Fixed the issue with possibility of using HTML tags in task names.
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PulsewayPSA QuoteWerks Integration

• Fixed the issue with breaking of QuoteWerks Version 5.5 integration.

PulsewayPSA RMM Integrations

• Fixed the issue with Auto Closing Tickets in new VSA Integration when Integration Account was acting as a client.

PulsewayPSA Security

• Fixed the issue where Reset Password from the Gateway Page did not use the Password Templates.

PulsewayPSA Service Desk

• Fixed the issue when created ticket status displayed in the bottom of ticket status drop-down.

• Removed Sender Email validation.

• Fixed the issue when Primary Assignee could be searched only by username.

• Fixed the issue when user receives duplicated Email after merging tickets with one contact person.

PulsewayPSA Timesheets

• Fixed timeout issues when user is trying to fill timesheet by clicking on calendar icon.

PulsewayPSA Xero Integration

• Fixed the issue where Xero did not support Negative QTY but supported Negative Price.

• Fixed the issue of failure with Tax Code None error while exporting invoices to Xero Australian Version.

• Fixed the issue in Xero Australian Version where error occurred while trying to export invoice containing Sales tax
item.

PulsewayPSA (v4.0.27) - 9 November 2019
In this release we are continuing on the theme of enhanced security, this release features the ability to use and enforce
Mult-Factor Authentication for some or all users. The release also includes a number of incremental enhancements and
fixes.

See the topics below for a summary of new features, all enhancements and bug fixes in this release.

New Features

PulsewayPSA Security

• Multi-Factor Authentication (MFA)

– Employee Users and Client Access Portal Users can now enable Multi-factor authentication (MFA) using an
Authentication Application. Most OTP-compliant (one-time password) applications can be used, such as Google
Authenticator, Authy, AuthAnvil and more. Setup is quick and easy via 'My Profile'. Many OTP-compliant
applications are available for free, so this added layer of security as available at no extra charge.
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– Now Administrators can require users to login using Multi-factor authentication (MFA). This new capability can
be used instead of, or in conjunction with, the SAML Single Sign-On (SSO) option that was released in v4.0.25.
For those users who are not configured to use Single Sign-On (SSO), administrators can enforce the use of the
new Multi-factor authentication (MFA) feature included in this release ensuring that all logins are protected by
either an Identity Provider (IdP) via SAML Single Sign-On (SSO), or by built-in Multi-factor authentication (MFA).
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– Added an ability that allows administrators to audit which users are configured for SAML Single Sign-On (SSO)
or Multi-factor authentication (MFA).

Enhancements

Identity Providers (IdP)

• SAML Single Sign-On (SSO)

– Added support for SAML Single Sign-On (SSO) using Azure Active Directory.

• SAML Single Sign-On (SSO) & User Provisioning

– This release includes documentation describing how to use AuthAnvil and Azure AD for SAML Single Sign-On
(SSO) and Just-in-Time (JIT) User Provisioning. See the help guides for PulsewayPSA - AuthAnvil SAML Single
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Sign-On (SSO) and Just-in-Time (JIT) User Provisioning and PulsewayPSA - Azure AD SAML Single Sign-On (SSO)
and Just-in-Time (JIT) User Provisioning

PulsewayPSA Reports

• Ad Hoc Reports

– Added an ability to join to Delivery Product Charges, Purchase Order Items, and Receiving Order Items. These
joins could be used to create a monthly report of products, purchased each month by GL number with
quantities, items received each month by GL number with quantities, and items delivered each month by GL
number with quantities.

PulsewayPSA General

• Admin

– Updated the 'Imports And Exports' menu name to the 'Imports'' menu name to better reflect included
functionality.

Bug Fixes

PulsewayPSA Integration

• SAML Single Sign-On (SSO)

– Fixed an issue with "SAML Login Endpoint URL" values were not working with Okta when it contains a dash "-"
character.

PulsewayPSA Reports

• Ad Hoc Reports

– Fixed Vendor data issue not showing for any reports based on Hardware Assets.

PulsewayPSA Expense Sheets

• My Expense Reports

– Fixed an issue with "Expense report" was not showing receipt attachments.

PulsewayPSA ITGlue Integration

• IT Glue Widget

– Fixed an issue with embedded passwords imported into IT Glue with a null value in the 'Updated By' field was
causing an "Error Loading Data!" message.

PulsewayPSA Finance

• Recurring Service Contracts

– Fixed an issue with cloned contracts when trying to update services.

• Billing Review

– Fixed recurring services search issue when accessing results on any page other than page 1 resulted in an
error.
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– Fixed an issue with adjusted prices were no posting through under some circumstances.
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Pulseway PSA (v4.0.26) - 12 October 2019
This release features a powerful new Recurring Service Automation (Price-to-Asset) capability along with a greatly
improved Recurring Service Proration model. The release also includes improvements in Service Desk, Finance, and a
number of incremental fixes.

New Features

Finance - Recurring Service Proration

• We have greatly improved the user experience for entering and tracking prorated charges related to increases and
decreases in recurring service units. Includes a new section on the contract page which displays details about all
prorated charges by effective date. Proration model also applies to unit changes posted by partner integrations via
the API.
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Enhancements

This release adds the following enhancements:

General

• Added Company Name and Gateway URL that are displayed in My Profile page.

Service Desk

• Added pagination to the multi tenant list.

• Timesheet approvals or adjustments will not affect last activity date on tickets.

• A new configuration option (in Company Settings) allows you to configure how to track 'Actual Resolution Minutes'
when a ticket is reopened. Upon ticket reopen, you can add all of the time that transpired while the ticket was
closed, or not.

Finance

• Added ability for included labor hours to flow through to an Invoice as zero price labor entries showing the hours
that were entered. For example, included hours entered against a Retainer by Hours contract can be shown on an
Invoice (with a zero price since they are included in the retainer).

• Added a new invoice template entitled 'Summary Time Totals, Product Charges, and Time Notes (Legacy PSA).' This
invoice format will be familiar to some users of legacy PSA products.
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QuickBooks Online Integration

• Added two new sync options to set the QuickBooks payment options: "Allow Online ACH Payment" and "Allow Online
CreditCard Payment".

Reports

Renamed "Average Tickets and Time per Client" report to "Average Tickets & Time per Client" in Reports > AdHoc reports
> Service Desk.

Fixes

This release includes the following bug fixes:

General

• Fixed keyboard shortcut for confirming invoice generation.

• Fixed keyboard shortcut for sending Batch Invoices.

• Fixed the pop-up dialogues in Chrome browser.

CRM

• Fixed the issue with adding email domains in CRM accounts.

Finance-

• Fixed the issue with billing review that took the cost, if the price was set to 0 on charges.

• Fixed the issue with billing automation that was producing different results compared to manually processing items
through the billing review process.

• Fixed the issue with sorting details when generating/ regenerating 'Detailed Invoice With Detail Dates' Invoice
Template.

Service Desk Tickets

• Fixed the issue with ticket SLA that was not added to a ticket created in the Client Portal.

• Fixed the issue with pausing SLA clock for a ticket initially created with the “Waiting for Customer” SLA status.

• Fixed the issue with displaying the "Default gateway" field title.

IT Glue

• Fixed the issue with displaying the logo and name (created in IT Glue) in the Pulseway PSA widget.

REST API

• Fixed an issue in recurring service contracts when adding services using REST API.

• Fixed the issue with displaying phone number and email of a contact imported from OKTA.

QuickBooks Online Integration

• Fixed the issue with exporting discount items with a dash (-) in the COA name.
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• Fixed the issue with exporting invoices that have non-inventory items.

Pulseway PSA (v4.0.25) - 21 September 2019
The release includes SAML SSO authentication and Just-in-Time user provisioning as well as incremental enhancements
and fixes. See the topics below for a summary of all enhancements and fixes in this release.
SAML Sin g le Sig n -On (SSO)Au th e n tic a tio n

Identity Providers (IdPs) supporting SAML 2.0 SSO can now be used to authenticate users. Your IdP details can be
configured in the Admin module, and SAML SSO authentication can be enabled on a user by user basis for Employees
and Portal users. For this release, we have tested and documented usage with ADFS and Okta. Other IdPs will be tested
and documented going forward, but feel free to try this new feature with your favorite IdP (mileage may vary). For
configuration details, see the help guides for ADFS and Okta.

Just-in-Time (JIT) User Provisioning

With this release we are launching Just-in-Time (JIT) user provisioning which works in conjunction with SAML 2.0 SSO
authentication. As new users are authenticated via SAML SSO, PulsewayPSA users will be automatically created.
Mapping rules allow you create Employee users or Client Access Portal users based on the domain and security Group
information provided by your IdP via SAML. The rules allow portal users to be mapped to different client accounts based
on their domain. For example: Do you have end-users defined in ADFS that you would like to onboard to the Client
Access Portal? Just configure SAML SSO and JIT provisioning, distribute a link to the login page with instructions to login
using their AD credentials. For configuration details, see the help guides for ADFS and Okta.
En h a n c eme n ts

This release adds the following enhancements:

• General - Added the currency symbol for Nigeria.

• Service Desk Tickets - Added a new configuration option that allows you to suppress the assignee list on a new
ticket when the account field is blank. When using security scopes to control access to tickets, this option can
prevent someone from entering an assignee who may be out of scope once the account field has been entered.

F ix e s

This release includes the following bug fixes:

• Service Desk Tickets -

– Fixed an issue with resetting the timer when merging tickets.

– Fixed an issue with closed tickets were not automatically closing the corresponding alarms in the RMM when
merging tickets.

• Xero Integration -

– Fixed an issue with exporting to Xero Australian Version.

– Fixed an issue with the account default currency was not being applied during an import.

• REST API - Fixed an issue with the Filter by StatusId in the Tasks Rest API EndPoint.

• Quotes - Fixed an issue with the keyboard shortcut (Alt + S) for Generate(S) function when generating quotes.

Pulseway PSA (v4.0.24) - 24 August 2019
This release includes UI improvements for Billing Automation, a new Dutch language option, workflow improvements for
monitoring alarms, and a number of incremental enhancements. In addition, the release includes many behind the
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scenes improvements for performance and high availability.

See the topics below for a summary of all enhancements and fixes in this release.
En h a n c eme n ts

This release adds the following enhancements:

• Billing Automation - Enhanced the UI to bring attention to Job Schedule settings and their relation to the date range
settings for billable items. Added a tooltip to clarify Job Schedule Date settings.

• Accounts -

– Import from Excel - Account import now supports the Service Type field.

– Parent Tenant - Enhanced the performance of operations related to client accounts in child tenants.

• Employees - Enhanced performance of the Edit Employees page to enable faster edits.

• Languages - Dutch Language (Beta) can now be selected via Company Settings. The Dutch language is currently
available as a Beta. Suggestions for translation improvement can be submitted via a Support Ticket.

• Performance -
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– Enhanced system performance by upgrading a load balancing component. This enhancement also addresses
an issue where the system could become overloaded and stop responding.

– Optimized overall performance through database tuning.
F ix e s

This release includes the following bug fixes:

• Ad-hoc Reports -

– Fixed an issue with the data returned in the SLA Performance report. Data in the report now matches the ticket
data in the system reports.

– Exago - Fixed an issue where GL account codes did not display for ticket charge items.

• Attachments - Fixed an issue where attachments in contracts and product quotations failed to open upon clicking
Open Attachment.

• AuthAnvil Authentication - Fixed an issue where adding AuthAnvil two-factor authentication to an existing account
could interfere with a user's active session. If the administrator modified the account while the user was already
logged in to an active session, the user would be logged out and could not log back in until the browser had been
closed and reopened.

• Continuum Integration - Fixed an issue where the RMM tab for Account Locations did not display in environments
with more than one active integration.

• Email Parser - Fixed an issue where emails were not being sent if this parser setting was selected: Send Email to
Sender.

• Live Connect - Fixed an issue where the user's Live Connect session could terminate unexpectedly after 30
minutes.

• My Calendar - Corrected a typo in the My Calendar menu option in the local navigation bar.

• My Timesheet & Project Tasks - Improved performance in cases where a single Project Task has many members
with many time entries.

• REST API - Fixed an issue with the Created By user in notes that were added to tickets via API. The PulsewayPSA
user that added the note now displays in the Created By field, rather than the generic System user.

• Service Desk -

– Dashboard - Fixed a session timeout issue that could interfere with the Service Desk Dashboard.

– Batch Tickets - Fixed an issue where search by Ticket Owner did not return the correct data.

• Trial License - Fixed an issue that prevented users from logging in upon activating or extending their trial license.

Pulseway PSA (v4.0.23) - 12 July 2019
This release includes many new reports, increased flexibility in Billing Automation, a new German language option, and a
number of incremental enhancements.

See the topics below for a summary of all enhancements and fixes in this release.
En h a n c eme n ts

This release adds the following enhancements:
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• Ad-hoc Reports - 20 new reports have been added to the Ad-hoc Reports system folder. 48 Hour Ticket Inactivity,
Accounts Past Due, Project Over Budget, SLA Breach, and more.

• Billing Automation

– From and To date filters allow you to specify the date range for Billable items. These filters can now be aligned
with the 1st day or last day of a monthly or weekly period. From and To dates are always determined relative
to the Job Schedule date. For example, say you want to generate Invoices on the 20th of each month for next
month's recurring services - the screenshot shows these example settings:

Notes:

• Start of the date interval - This option specifies Sunday when combined with a weekly setting, or the 1st
when combined with a monthly setting.

• End of the date interval - This option specifies Saturday or the last day of the month.

• Calendar Days - This option specifies a fixed number of days: 7 per week or 30 per month.

• Languages - German Language (Beta) can now be selected via Company Settings. The German language is
currently available as a Beta. Suggestions for translation improvement can be submitted via a Support Ticket.

• REST API

– A count function has been added to all GET endpoints so that users can now get counts based on certain
filters.
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– Added an endpoint that can be used to enable/disable Pulseway PSA -IT Glue Integration.

– Accounts imported via API now take the Company Default Currency from Company Settings.

• Tickets

– You can now filter tickets by Ticket Owner with these options: Unassigned and not in a Queue, Unassigned and
in a Queue, Assigned to Anyone, and Check All (the default).

– The Customer Info dialog now includes any custom fields that have been defined for the Contact.

– The Ticket Assignee and Secondary Assignee lists are now restricted to only those employee users who have
access to the ticket via their Scope assignment.

• Workflows - Admin > Business Process > Workflow > Notifications > Resources - You can now opt to send
notifications to the person that created a ticket by configuring the new Created By option.

F ix e s

This release includes the following bug fixes:

• Ad-hoc Reports - Fixed a display issue that caused menu items to disappear when clicking on the report page.

• Billing Automation - Fixed an issue with updating job parameters that could prevent the job from running on the day
the updates were applied.

• Cytracom - The Outgoing Phone button no longer displays in the Contact popup for a client portal.

• Email Parser

– Fixed an issue that could prevent tickets from being created due to a case sensitivity mismatch between the
From Address in the email and the From Address stored in the database.

– Fixed an issue where sync to IT Glue would fail if the email did not contain a valid Contact Phone.

• Invoices - Fixed an address issue that could occur when regenerating an invoice.

• IT Glue Integration

– Updated the Important Contacts tooltip.

– Fixed the 404 error encountered when trying to open a password URL that was imported from IT Glue without
an http/https prefix.

• Outlook Calendar

– HTML tags no longer display in activity or service calls sent from Pulseway PSA to the Outlook online calendar.

– HTML tags no longer display in the Outlook online calendar when the text contains > or <.

• Performance - When pushing Template settings to multiple child instances, a timeout limit was preventing
successful completion of the process. This has been corrected.

• Project Management - Fixed an issue with the Add Task (A) keyboard shortcut initiating the wrong action. This was
due to the (A) shortcut also being used as the shortcut for Archive Project. With this fix, (A) now adds a task and (Z)
now archives a project.

• Sales Order - The Save, Add New, and Delete buttons are now disabled upon voiding a sales order.

• Service Desk
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– Service Desk Dashboard - Fixed an issue with executing ticket counts from the Tickets By Queue dashlet.

– Tickets - Fixed an issue where the ticket Open Date created for a child account could be incorrect due to using
the time zone of the parent account.

• Timesheets - Fixed a rounding error with the Overtime Spent calculation that could occur in cases where the End
Time contained seconds (e.g., End Time: 08:36:19.0000000).

• UI - Fixed a display issue with the My Profile dropdown list.

• Workflows - Fixed an issue where ticket CC options were not included when pushing workflows to Pulseway PSA
child tenants.

• REST API - Corrected the REST API documentation to indicate that the Attachments Module ID for Expense Entries is
85 (rather than 185).

Pulseway PSA (v4.0.22) - 18 June 2019
This release includes even more capabilities for the recently released IT Glue Integration, white label branding
enhancements for the Login page, and more.

See the topics below for a summary of all enhancements and bug fixes in this release.
En h a n c eme n ts

This release adds the following enhancements:

• IT Glue Integration

– You can now edit Contact and Location Notes directly from Pulseway PSA.

– For Accounts, upcoming expirations are displayed within Pulseway PSA, with deep links to IT Glue.

• UI - The Gateway Login page can now be configured with a custom background graphic and dedicated logo,
allowing you to bring increased awareness to your company brand.

• Ad-hoc Reports

– The report writer now includes the physical location field for hardware assets.

– Expense entries now include the Mark Up Amount per expense.

• Calendar Sync - A truncation limit has been added for Text Events based on Cronofy API.

• CRM - Added templates that enable quotations to be printed with and without discounts.

• Finance Dashboard - Added the ability to sort by Upcoming Expiry Contracts.

• Invoices - Added a Company Settings option to select whether to calculate invoice amounts to two or three decimal
places in printed invoices.

• REST API - APIs have been updated to take Default Order as the primary key of the DTO if no order is returned from
the calls.

• Tickets

– Added an Unknown Reason Field to note why a ticket is unknown.
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– Batch Actions - Added the ability to discard Queue or Primary Assignee changes.
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• VOIP Integration

– When a new Ticket is created based on an inbound call, the Ticket Source is automatically set to Phone.

– The Cytracom logo and dialog have been updated for brand compliance.

– Cytracom now validates authentication tokens for disabled users.

• Workflows - You can now select Anyone except Employees for Activity Added By.
F ix e s

This release includes the following bug fixes:

• Accounts - The Location Name in Update Account Location now accepts up to 255 characters.

• Ad-hoc Reports - The P&L operator in System Reports is now greater than and less than.

• Billing Review - Fixed an error in the Labor Hours specific view.

• Dispatch Calendar - Fixed an issue where the wrong day displayed when selecting Day View.

• Email Parser - Fixed an issue where tickets were created as Unknown if the CRM contact contained both an active
and an inactive email. Tickets are now assigned the active contact.

• Imports - Fixed an error that displayed when trying to import an account with only the required fields.

• Invoices - The salutation in the default email template has been updated from Dear Sir to Dear Sir/Madam.

• IT Glue Integration - Fixed an integer setting that was causing casting issues in Pulseway PSA. This corrects the
situation where IT Glue Integration was not working for customers using an IT Glue instance under eu.itglue.com.

• Products

– Product Quotation - Fixed an issue with Euro currency where quote amounts were generated incorrectly.

– Fixed an issue with bundled items where the Deliver functionality showed an incorrect number for QTY in
Stock.

• Project Management - Fixed an issue where members could not be added to sub tasks.

• REST API - Fixed an issue where the Products REST API returned an error when attempting to search by CreatedOn
date.

• Tickets

– Fixed an issue where duplicate ticket numbers were created from the Parent to Child Tenants if the timezones
were overlapping.

– Recurring Tickets - Cannot set Enable Scheduler to No if the Start date is not equal to the Current date.

• UI

– Fixed an issue on iOS / iPad (Chrome) where top bar options did not display.

– Fixed a performance issue in the new UI that was caused by unneeded calls to a stored procedure.

• VOIP Integration - Fixed an issue where Contact Phone numbers containing formatting characters did not match
inbound calls.
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• Workflows - Fixed an issue where workflows were not processing idle tickets that were created with a date older
than 15 Days.

Pulseway PSA (v4.0.21) - 18 June 2019
This release includes two exciting new integrations and a number of incremental enhancements.

See the topics below for a summary of the integrations, enhancements, and bug fixes in this release.
In te g ra tio n s

This release adds the following integrations:

• IT Glue Integration - Love IT Glue? Love Pulseway PSA? Then you’re going to love this:

– This release features an amazing new integration to IT Glue that allows IT Documentation to be viewed and
edited within Pulseway PSA! From any Ticket, a single click reveals IT Glue documentation for the Asset,
Account, Contact, and Location associated with the Ticket. Attachments, embedded passwords, related items,
notes and revisions are shown.

– Asset notes can be edited, embedded passwords can be viewed and copied to the clipboard, and related items
can be added, edited or deleted - all without losing your place in Pulseway PSA or fumbling between multiple
windows.

– IT Glue documentation is also available via a single click from any Account, Contact, or Asset.

– To use this new integration, first enable the 2-way sync in IT Glue. Then enable the integration under Admin >
My Company > IT Glue Settings. As each employee clicks IT Glue for the first time, they are prompted for their
IT Glue credentials, and the power of IT Glue is unleashed in full accordance with the IT Glue security model.

• Cytracom VOIP Integration - This release includes a new integration to the Cytracom VOIP phone system. Incoming
calls from known Contacts automatically display a pop-up window showing Contact details and offering the ability
to create a Ticket pre-populated with Account and Contact details. Outbound calls can be directly initiated while
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viewing the contact details on a ticket. The integration can be enabled under Admin > My Company > Cytracom
Integration, and each Employee can enter their Cytracom credentials to activate the calling capabilities.

En h a n c eme n ts

This release adds the following enhancements:

• REST API - Inventory Products - Added an API that enables the use of OData queries to retrieve data.

• Tickets - The form for Service Desk tickets has been enhanced with the following:

– Added Technician Name and Customer Name fields.

– The customer's full address now displays in the Location area.

• UI - The Login page and top navigation bar have been updated with a clean new look.

Note: Your customizable business logo (if configured) will now be displayed on a white background on the
Login page. For this reason you may want to upload a dark version of your logo.

F ix e s

This release includes the following bug fixes:

• Attachments - PRN files can now be uploaded successfully.

• Client Portal - Fixed an issue where the password notification email was not being sent upon creating a new client
portal from an agent.

• CRM

– Account - Fixed an issue where an error displayed when attempting to copy address information by clicking
Copy From Billing on the Main Address Info tab.

– Service Types - Fixed an issue where more than one default service type could be created.

• Email Parser

– Fixed an issue where the Created On Date was incorrect when adding notes with attachments.

– Fixed a ticket detail display issue in email sent from Office 365.

• Exago - Fixed an issue where the timezone for report schedules was not being adjusted properly for daylight
savings time.

• Invoices - Fixed an issue where the Invoice Date could be incorrect due to referencing the incorrect timezone.

• My Expense Reports - Fixed an issue where an error displayed when attempting to submit an expense report for
approval.

• Project Management

– Fixed an issue where inverted commas were not displaying correctly in Project Notes.

– Fixed an issue that prevented sub tasks from being added to a task.

• REST API

– Fixed an issue where the ticket workflow was not being triggered upon adding a note to a ticket.

– Fixed an issue where the POST/PUT Services APIs were not updating the API modified date.
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– Corrected the REST API documentation to indicate that requests are throttled to accept a maximum of 500
requests per hour per endpoint. Added details about using paging to bundle up to 100 objects per request,
which results in a capacity of 50,000 objects per hour.

• Service Quotations - Fixed a display issue in the product Search and Select window.

• Tickets -

– The Sender Email is now updated to Unknown if the email address is invalid.

– Fixed an issue where the Start Time and End Time were not calculated correctly after the ticket timer had been
paused.

Pulseway (v4.0.20) - 12 April 2019
This release continues our focus on architecture, performance, and feature improvements, including a number of
enhancements to reporting.

See the topics below for a summary of all enhancements and bug fixes in this release.
En h a n c eme n ts

This release adds the following enhancements:

• Ad-hoc Reports - For contracts, an Is Default field now displays, indicating whether the contract is company's
default.

• Ad-hoc Reports - The Function Editor now has the ability to check if one string contains another.

• Ad-hoc Reports - Added these fields for creating reports that include charges: Is Billed and Is Posted.

• Ad-hoc Reports - For Report Schedules, you can now set the Time Zone Basis to server timezone or user timezone.

Note: Changing this setting may change the time for currently scheduled reports. When changing this setting,
be sure to review and adjust existing report schedules as necessary.

• Reports - Added two new reports: Average Resolution by Queue and Tickets Open by Age.

• Support User - You can now include a note when activating a Support User.
F ix e s

This release includes the following bug fixes:

• Ad-hoc Reports - Fixed a performance issue that caused the User Activity report to time out.

• Pulseway PSA APIs - Fixed an issue where creating tickets by using APIs could remove Pulseway PSA account
details, such as Currency, Website, Tax Settings, Description, Credit Limit, and Net Days.

• Continuum Integration - Fixed an issue where the ticket owner could not be changed.

• CRM

– Dispatch Calendar - Fixed an issue where clicking Today could display the wrong date.

– Dashboard - Fixed an issue where the Opportunity Pipeline Value displayed incorrect data. (The same data
would display for Monthly, Quarterly, and Yearly.)
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• Finance - Billing Review > Labor Hours - Fixed a page number display issue . After posting an item, you are returned
to page 1. If the item was posted from a subsequent page, the contents of page 1 would display but the page
number was incorrect.

• Imports and Exports > Import Data - Fixed an issue with importing accounts where billing information was not being
imported.

• Inventory - Fixed an issue where a product's tax rate was not applied when posting Sales Orders. The tax rate in the
resulting Purchase Order was set to 0.00%.

• My Tasks - Fixed an issue where opening a Milestone Task erroneously displayed the Time Logs tab.

• Navigation menu - Fixed a display issue where the Settings link did not remain in a fixed location while scrolling
through the menu.

• Outlook Integration - HTML Tags are now removed when syncing meetings from Pulseway PSA.

• Products - Deliver Product Charges page - Fixed an issue where the default view was not listing all records.

• QuickBooks Integration - Fixed an issue where expense reimbursements were not being synced from QuickBooks
correctly.

• REST API

– When posting a Retainer by Hours contract that does not support contract hours and has no average rate
specified, the API now calculates and applies a default average rate.

– Fixed an issue where PUT Recurring Services Contract was not updating the billing periods.

– Fixed an issue where recurring services were not being created in some cases when using PUT/POST Recurring
Services.

• Reports - The Project By Status Chart icon has been removed from the system reports to fix an issue that caused
PDF export to fail.

• Service Quotations - Fixed an error with selecting a subsequent product after clicking Clear Search.

• Tickets

– Fixed an issue where tickets were not being formatted correctly if they contained HTML syntax errors (such as
a missing closing tag).

– Fixed an issue with using a template to add a time log. When selecting a template in the From Template list,
an error occurred and the log could not be added.

– Fixed an issue where the Sender name in an email could display as Unknown if the Contact Name matched
the email address and the From Name was empty.

– Fixed an issue with Recurring Master Tickets that are configured with the Create Ticket Incrementally option. If
the master ticket is deleted before all ticket occurrences have run, tickets would continue to be created for the
remaining occurrences.

– Fixed an issue that could cause additional workflows to be triggered when a ticket was created.

– Fixed an issue where a Read Only Scope was not preventing ticket edits in some situations
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Pulseway (4.0.19) - 01 March 2019
This release continues our focus on architecture, performance, and feature improvements - here are a couple of the
feature highlights:

• Recurring Service Contracts - Billing periods can now be based on the Contract Start Date instead of the calendar
year, providing more flexibility in how you bill your clients.

• Merged Tickets - Notifications can now include both the original and new ticket numbers resulting in better visibility
and clearer communication to end users.

• Internal Test Fixes (an inside view) - We've included a number of minor fixes related to our rigorous internal testing
efforts over the last few release cycles. These fixes have never been reported by customers, and each of them is
very minor, yet we feel that the cumulative effect of these fixes results in an improved user experience overall.

See these topics for a summary of all enhancements and bug fixes in this release:
En h a n c eme n ts

This release adds the following enhancements:

• Ad-hoc Reports - Added the ability to report and filter on survey scores.

• Contracts - Recurring Service Contract billing periods can now be established based on the Contract Start Date or
based on the Calendar Year as before. For example, a monthly contract based on Start Date beginning on January
17 would have billing periods that begin on the 17th and end on the 18th of each month. A monthly contract based
on Calendar year would have the first period beginning on January 17th and ending January 31st (prorated first
month), and each subsequent period would begin on the 1st of the month and end on the last day of the month.

Examples:
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• Continuum Integration - Added the ability to define the Default Ticket Owner for Continuum Integrations.

• Exports from list views - To enhance performance, Export All now exports a maximum of 2000 records at a time.

• Projects - Task status is now set to New by default.

• REST APIs

– POST/PUT/GET Ticket - Added Set/Get Sender name and email.

– POST/PUT/GET Ticket Note - Added Set/Get Sender name and email.

– POST/PUT/GET Ticket Note - Added the ability to upload attachments.

• Tickets - For merged tickets, you can now include the original and new ticket numbers in customized notifications.
F ix e s

This release includes the following bug fixes:

• Accounts

– Fixed an issue where values entered in non-required fields (such as sales tax items) were not saved. Users
would have to enter and save the values a second time for settings to persist.

• Ad-hoc Reports

– Fixed an issue where ad-hoc reports did not include a system version (for example, 4.0.19).

– Fixed an issue with the Account Filter timing out for reports that contain a large number of tickets.

• Admin > Service Desk - Fixed an issue where deleting a Ticket Type, Issue Type, or Ticket Priority could fail due to a
timeout error.

• Billing automation

– Italian translation added.

– Fixed an issue where the recurrence setting was not preserved in some scenarios.

• Client Portal

– The bell notification icon no longer displays for non-administrator users.
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– For Retainer By Hours contracts, the Prepaid Hours Summary label was mislabeled Hours Per Month. This
label has been changed to Hours Per Contract.

• Contracts - Fixed an issue where a new contract could not be created after updating another contract's Contract
Number to a 1-character value. When attempting to save the new contract, an Invalid length parameter passed...
error displayed.

• Continuum Integration - Fixed an issue where workflow updates to tickets were not added to Continuum.

• CRM

– When deleting an Account Location, its custom fields are now also deleted.

– CRM Dashboard Report - Fixed the chart so that dates now display in the correct order.

• Dispatch Calendar - Fixed a display issue where the entire End by Date was not visible.

• HR - Fixed an issue where an error displayed when attempting to save an Employee after deleting attachments.

• Invoices

– Fixed an issue where, if multiple discounts exist, default values would display in the Add/Edit window when
editing the last discount in the list.

– Fixed an issue with voiding partial payments where the invoice status remained Partially Paid after the
payment had been removed.

– Fixed an issue where apostrophes in detail line items did not print correctly.

• LiveConnect - Fixed a protocol issue that prevented LiveConnect from running correctly in some (not all) versions of
the Chrome browser.

• My Expense Reports

– Fixed an issue where an error displayed when attempting to edit a posted expense entry.

– Inactive users can no longer be added for approval or receive approval notifications.

• My Timesheets - Fixed an error that prevented searching for tickets by Status.

• Products

– Product Charges - Add/Edit window - Qty in Stock and Qty to Deliver fields have been modified to display
decimal values.

– Fixed an issue where the supplier's Currency value was not included when importing products by using Excel.

• Profile Image - Image files cannot exceed 500 KB. This message now displays when attempting to upload a larger
image: This file exceeds the maximum allowed size of 500 KB.

• Projects

– Fixed an issue where the Multiple Projects Gantt page could not be displayed.

– Fixed an issue where an error displayed when attempting to delete a sub task.

• QuickBooks - Fixed an issue where exporting invoices to QuickBooks could fail with the error: Failed to add Non-
Inventory Part Item yyy. Reason: The name ‘yyy’ of the list element is already in use.
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• Services

– Fixed an issue with editing the Income Account or Expense Account where the Service could not be saved if
HTML tags were included in the account description.

– Fixed an issue where discounts were not applied to the Unit Price and Total amounts in Service Quotations.

• Tickets

– Fixed an issue where an Invalid Data error displayed when attempting to add a service call to a ticket.

– For recurring master tickets, the End On field now enforces the weekly limit of 100 recurrences.

– Fixed a formatting issue with printed tickets. If the ticket details contained HTML syntax errors (such as a
missing closing tag), the format of the printed output did not display correctly.

– Fixed an issue with adding time via API where the EmployeeUsername in Timelogs contained the API user.
EmployeeUsername now contains the name of the user that added the time.

– Fixed an issue where Create Asset could add assets to multiple account locations. This could happen if Create
Asset was selected after adding and editing a ticket charge for an account with multiple locations.

• Users

– Fixed an issue where adding or reactivating a CSX Support user could fail with this error:Warning! You have
reached your license cap with the number of Active Employees accounts. New active employees cannot be
added, even if an unused license was available. This could happen once all licenses had been used, and then
one or more licensed users had been deactivated. The licenses of deactivated users were not being removed
from the in use license count.

– Fixed an issue where Support Users could not be activated if the Tenant's Job Title, Department, and Role were
not set to the default values.
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• Xero

– Italian translation added.

– Fixed an issue where importing updated payments failed with this error: Error 500.

– Fixed the Sort By functionality in Xero invoice export.

Pulseway (v4.0.18) 01 February 2019
This release continues our focus on architecture, performance, and feature improvements - here are a couple of the
feature highlights:

• Reports Refresh - All canned reports have been moved to the BI / Ad Hoc reports engine, providing a new level of
flexibility for reporting and eliminating prior restrictions with the legacy approach.

• Account Alerts - Ability to configure Alert messages that are surfaced in key areas of the CRM and Service Desk. For
example: “Itasca Office will be shutdown for the holiday period. All staff should be offsite.” could be set to display
for all New Tickets, while the message “Call CIO for authorization before creating new account contacts.” could be
set at the Account Detail level.

See these topics for a summary of all enhancements and bug fixes in this release:
En h a n c eme n ts

This release adds the following enhancements:

• Reports refresh - All system provided reports are now powered by the BI engine (the same engine that powers Ad
Hoc Reports), allowing any report to be scheduled, emailed, and custom filtered at runtime. We’ve also reviewed
the system provided reports and resolved a number of bugs and performance issues. Reports can be launched
from the Reports menu as before, and they can also be found in a new 'System' folder under Ad Hoc Reports where
you can make copies of the reports that can then be customized to meet your needs.

• QuickBooks - Added the ability to select the Default Tax Rate when exporting invoices.

• REST API - Added the ability to add a Retainer By Hours Contract.

• On any Account, you can now configure Alert messages that display on the Account, and on any new or existing
tickets for the Account.

• For projects with the setting Allow Weekend No, the selection of weekend Start and End Dates is now prevented.

• Added a Recurring Contract Profit and Loss Report to the built in ad-hoc system reports.

• Added an Ad Hoc Report object that can be used to improve performance when joining Tickets to Notes.

• Hardened security by preventing Google indexing from exposing client names in links to the login page published
on client websites.

• QuoteWerks Connector - Now supports adding large descriptions for products and items.

• QuickBooks Online Invoice Export - Modified wording of Invoice Status.

• Blocked the ability to execute files from the Attachment folder.

• Hardened security by blocking certain file extensions in email attachments.

• The Email parser now skips attachments larger than 20 MB.
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This release includes the following bug fixes:

• CRM Quotations API - Unique Quotation Numbers are now enforced.

• Fixed an issue where only one timestamp was being updated when a contact's Phone Type was modified. Both
Contact timestamps are now updated.

• Fixed an issue where Company News was using an incorrect time zone. The time zone of the user is now used.

• Fixed REST API Documentation for GET servicedesk/tickets.

• Fixed an issue with Contract Updates via API where Billing Price was not being recalculated correctly.

• Recurring Master Ticket - Fixed an issue where service call time was displaying in UTC time.

• Fixed the option to not send email for Service Quotes.

• Fixed an issue with Product search where products were not found if a space was entered before or after the search
text.

• Fixed an issue with the workflow not being triggered for tickets on which the SLA is paused.

• Fixed a spelling error in Batch Action > Choose Operation > Delete Tickets.

• Fixed an issue where the Ticket Timer was not resetting when a time entry was saved.

• Fixed an issue where disabled tickets were still showing in the Resolve box.

• Rest API - Fixed an issue where changing the status of a ticket to resolved did not set the Status Event and
Completed Date.

• Fixed an issue with Drag/Drop not working in the Dispatch Calendar for Service Calls.

• Fixed an issue with adding CC addresses when replying to a ticket. CC email addresses are now added to the ticket
correctly.

• Fixed an issue that was causing the error: 404 Missing resource Error - Loading.gif

• Fixed an issue where extra space was being added when using the [%Note Details%] token in an email template.

• Closing a ticket now automatically sets First Response in cases where First Response had never been set.

• Billing Review_Labor Hours is now ordered by number of labor hours.

• Fixed an issue with adjusting timesheets where a record could become disabled if displayed in a popup windo

• Fixed an issue where updating the Retainer by Amount Contract could reset the Consumed Amount.

• Fixed an issue where API Throttling was returning 429 HTTP status codes for unauthorized requests.

• Fixed an issue with the QuickBooks Sync Tool where Item names were not always included when exporting
invoices to QuickBooks.

Pulseway PSA (v4.0.17) - 14 December 2018
This release focuses upon performance and feature improvements, and we're very excited to announce the following
changes:
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• Merge Ticket improvements - since releasing this feature in October, we've received tremendous interest and
customer feedback which we're proud to have incorporated into this build.

• Recurring Master Ticket creation - prior to this release, creating large numbers of recurring tickets resulted in the
user having to wait for all tickets to be created at once. Now we can create these tickets over time, allowing the
user to continue on with their tasks, and improving the platform's overall performance.

See these topics for a summary of all features, enhancements and bug fixes contained within this release:
Fe a tu re s

This release adds the following features:

• Recurring Master Tickets can now be created incrementally as opposed to all at once.

• License Count Information is now shown in Company Settings and on the Employee list.

• Added support for on-demand synchronization of asset details with VSA via a new 'Sync' button on the Asset screen.

• Added Company Settings Configuration to control parent/child loading of contracts on tickets form.

• Added Account name filter to the Related Ticket search and select screen.

• Implement throttling policies on API endpoints (excluding integration endpoints).
En h a n c eme n ts

This release adds the following enhancements:

• Added these enhancements that greatly improve control over workflow and notifications for Merged Tickets:

– A new option to configure the Status to be used for Merged Tickets.

– The ability to configure if the Merge note should be Internal or External.

– Workflow now has a new Activity Type for Merged Tickets.

– Added filters and display columns to the Merge search and select screen to help you find what you are looking
for when Merging Tickets.

• Time Zone and Date/Time format for the Client Portal can now be configured via new fields on Account Location.

• Added support for Email parser to ingest emails with blank body.

• Added mapping for Invoice line-item Value Date to Service Date in QuickBooks.

• Increased length of email addresses to 250 characters.

• Added "Receive Invoices" as a Field to CRM Contacts Post, Put, Get, and Import APIs.

• Added functionality to allow users to specify if Retainer by Hours are Taxable or Not on the Contract Level.

• When adding Service Calls to Tickets, the default start date will now be the current date instead of the ticket's open
date.

• Exposed Start Time as a Filter in the Ad-Hoc Reports for Task Time Entries Category.

• Email Parser failure notifications for Custom SMTP configurations will now use the default SMTP Server and display
as a System Notification.

• Added two new product mapping fields to the QuoteWerks Connector: Labor & Fixed Price.

• Enhanced the Billing Review Performance Search when using Tier Billing and Contract Exclusions.
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• Account is Taxable is now updated based on the sales tax item in REST API.

• Billing Automation - Removed Attachment Path from arguments.

• Added new Payment Type Personal Checks to Lookup Data of Payments.
F ix e s

This release includes the following bug fixes:

• Defaulting of dates on Billing Review > Labor Hours was incorrect in some timezones. This has been corrected.

• QuickBooks Desktop Item comparison - Start with/equals.

• Used Hours in Tasks not showing correctly.

• Issue exporting QB Invoices with Items having colon character in it.

• Billing Automation - recurrence is disappearing in specific scenarios.

• When an employee adds time to Admin Task, he/ she can see everyone else's entires on that Task.

• CC - The Cc textbox is not loading the contacts related to the account selected.

• QuoteWerks- Sales Representative field loads inactive and external users.

• Tickets - Javascript error displays when opening SLA pop up.

• Client Portal is showing Created By as Empty for tickets opened by parser.

• Xero - Incorrect dates for the Xero integration.

• The Product Locations.Warehouse field is not showing the value on the Ad Hoc report.

• Tickets - Javascript error displays when editing a time log.

• HR - Departments - Manager drop down gets inactive users.

• Security Role - Can not delete a user.

• QBO - & Symbol in Item name is breaking the Invoice Sync.

• Batch Actions does not respect Sort Order of the Listing.

• Expenses - Expense note is displaying in single line when notified user by email.

• Xero - Items Search not working.

• Ad-Hoc Reports error on Products Category when Custom Fields exist.

• Open File in Attachment Control is still not encrypted.

• QuickBooks Integration: Work type description was incorrectly being recorded as the Work type name on Invoices.

• Continuum Integration: When updating the "Modified By" and "Created By" fields, the user specified will now be the
account used for integration.

• Opportunity Performance Metric/Widget is wrong.

• Due Date can not be Deleted in Ticket Edit and was reverting back to old value.

• Xero integration: Tax rates not attached on new invoices when tax rate is re-created in Xero.
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• Copied quotations do not copy taxable setting for line items.

• Add Company Logo on the VSA Registration Page coming from VSA Agent Link.

• VSA Agent Onboarding does not allow scrolling.

• Fix the Put API for Tickets to not clear the Ticket Number since the Ticket Number is not in the Payload of the DTO.

• When Ticket is Opened from Email Parser the Notify CCs will work only if the CC is not a Contact in the System. (

• Email Parser not creating a contact on reply for Accounts with email domain.

• LastActivityUpdate is updating to NULL when Deleting Product Charge on Tickets or Deleting Time Entries.

• Duplicate Invoices as a Result of Modifying Billing Job Automation Parameters.

• Billing Automation Invoice Error - Template Detailed Invoice Sort By Date.

Pulseway PSA (v4.0.16) - 2 November 2018
This release contains new features, enhancements, and bug fixes. See these topics for details:

Features

This release adds the following features:

• Tickets now have a CC field to track multiple employees, contacts, and email addresses. CCs can be entered
manually, or can be picked up automatically from inbound emails based on a new configuration option in the email
parser. Notifications to CC'd parties can be controlled via Workflow.

• Multiple tickets can now be merged together via two new options on the ticket form (see the 'More' dropdown). You
can merge a single ticket into another, or absorb/merge multiple tickets in a single operation. Merge details are
tracked via Activity notes and Related Ticket links. The new Ticket CC field tracks all parties associated with the
merged tickets.

• Added ability to bulk import Services into the Finance module (see Admin > Imports & Exports).

Enhancements

• Added a new field to Service Desk Rest API that will return the Hardware Asset ID for future Put and Updates.

• Billing Automation Scheduler: added the ability to set a schedule for the last day of the month.

• Added Active/Inactive flag to the Import Contacts Rest API.

• Enabled 2FA for external users in the Client Portal to be redirected to AuthAnvil 2FA.

• Reduced the number of required characters to 1 for Usernames.

• Changed the Font Size on Quotation Template to smaller size as originally designed.

• Added the ability to Override Recurring Service Description Via Post and Put APIs.

Custom Invoices

This release adds the following invoice enhancements:

• Custom Invoices for C3 Security.
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• Adjustments to Existing Invoices for Tweeweg IT.

• Custom Invoice Template for ANA Telecom.

• Update Jirah Custom Invoice to Include Item Code for T & M and remove SOFreeItems from the Types.

• Windward Technology Customized Invoice Template.

• WJP Invoices Update.

• Hyopsys Invoice Update for Charge Names.

Fixes

This release includes the following bug fixes:

• Fixed a Bug for IT Glue Contacts Integration for Contact provisioned via VSA.

• Ignore case when checking Email Parser Black List emails.

• On Activating Contract: if Contract Number is empty, the system is still saving.

• Fixed "New News" paste function error.

• Tickets - Print ticket page shows incorrect spelling for Assets.

• Email Parser breaking styles in some scenarios where styles are embedded inside the body of the email.

• OKTA SSO not signing in.

• External Client Portal Users using AuthAnvil cannot see their location when creating a ticket.

• When in Parent Child Mode, the Icon on the Ticket Attachments does not show.

• AllActivityDetails is changing the format of the HTML messages in the Email Templates.

• Parent Contracts should not show in the Child Accounts during creation of tickets.

• Inconstancy between Service Quotation and Product Quotation when printing and sending emails.

• Service Description is not propagating the new lines into invoices.

• Email template being sent from automated billing is not correct - needs to be reformatted.

• Error when entering Hebrew Language.

• Time Entries on Tickets are not respecting Day Light Saving when showing the Time on the Tickets View.

• Client Location Address - Tab order out of order - New Accounts.

• CRM notes display issue.

• Fixed billing automation to accommodate All Invoice Templates that exist in the system.

• Fixed a UI issue for Projects Dashboard showing two links highlighted.

• Fixed the issue on security when clicking on a queue that is assigned to you, you can reach other queue tickets.

• Quoteworks Connector: Creating a new product does not add the Tax field on Product but it does on the Quotation.
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• Spelling mistake - Billing automation.

• Quoteworks Connector: No validation message displays when trying to convert quotation to order and there is a
required field empty.

• Tickets - Error displays when trying to print a ticket but the user don't have access to Expense and Time entries.

• Quickbooks - Resyncing an updated customer in QB is not updated in Pulseway.

• Fixed the attachments links to have encrypted links.

• Added a retry feature for sending emails up to three trials before the email gets stuck in failed status.

Pulseway PSA (v4.0.15) - 5 October 2018
This release contains new features, enhancements, and bug fixes. See these topics for details:

Features

This release adds the following features:

• ITG Integration for searching and viewing assets from any website.

• Added Bulk Import For Inventory Products.

• Changed the Rest API of Service Desk Time to Dynamic Paging.

Enhancements

This release adds the following enhancements:

• Add Unknown Workflows to templates.

• Give the Default Due Date to be Now when Adding new To-Do from Tickets or Main Dashboard.

• Status of task is wrong when status of subtasks are a mix of closed and completed.

• Ability to Add multiple Hardware Items with the Same name in the Product Quotations.

• QuickBooks Desktop Sync - Customers - Sync Credit Limit, Net Days, Description.

• Generate tickets for accounts that have the status as prospect.

• Enhance the Workflow Due and Overdue Trigger Speed.

• Button Colour change for New Priority.

• Change the Attachment Path to take from Configuration file instead of Absolute Path.

• Set MaxFileSize limitation on File Upload for Attachments to 20 MB.

• Add a new End Point for VSA to Increment the Ticket Occurrence instead of Adding Note when Alarm is reoccurring.

• Check if Company is Active or Trial from Cronofy Integration to Prevent Calendar Sync after Deactivation.

• Update Get Past Items Filter to include 3 month filter.
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Fixes

This release includes the following bug fixes:

• QB Desktop - Spelling Errors.

• Ad-Hoc Reports are failing when using Custom Fields on Employee Categories.

• Import Contacts - ConnectWise via Sizzle Tool is not Working.

• Tickets in APAC region are getting duplicate numbers in specific scenarios from Email Parser.

• Clicking Cancel button in existing workflow redirects to new workflow page.

• QuickBooks Desktop - Wrong validation message appear when exporting a Reimbursement without a reference
number.

• QuickBooks Desktop - Can not Export the Reimbursement.

• Rest API - Fix Post Service Quotations.

• TimeSheet - Wrong data in pdf when there is multiple time logs for a task.

• Formatting Error when a Ticket Note is created.

• My Templates - Breadcrumbs Glitch - Not reflecting the correct path.

• Import Tickets Via Rest API is always defaulting to UTC instead of Reading the Main Branch Timezone Date.

• PulsewayPSA Users created as employees with external access cannot create tickets with 2FA Enabled.

• Exporting items from PulsewayPSA to Xero showing items not related to the current tenant.

• Recurring Tickets - UTC Time saved for the recurring tickets in the Tickets Tab.

• Products Quotation - in the Views, when you add the Column "Converted to Sales Order", there is nothing displayed.

• Import Accounts - wrong functionality for the import when importing an account with account manager as client
portal.

• My ticket - Print Ticket not working properly.

• QB Desktop - Spelling Errors.

• Views - Same column in the listing section displaying multiple time.

• Invoice - Delete Discount is not deleted from the first time.

• Xero - Work type exported with different name.

• Inventory - Deliver Product Charges -Searching by specific clients still displays all clients.

• QB Sync - Voided Reimbursements Showing for Sync.

• Ticket By Assignee is not Showing Correct Number for APAC Region Users.

• Spelling Fixes - In Email Templates.

• Due Date is Showing incorrectly on the Ticket Listing inside the Master Recurring Tickets.
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• Company News Not using the Publish Date to Show the News on the Dashboard.

• PulsewayPSA API - Task Timelogs request results in error 500.

• Billing Automation - Scheduler not updated when saving new job information.

• Tickets Listing - Search not working on Queue when Queue Name includes a comma (,) and Statuses.

• Quote Template - Alignment Issue of Total Price.

• Add-Hoc Report Performance Issue for Ticket Activity Notes.

• Client Location Address - Tab order out of order.

• General - Fix Default Contract for Tickets Created from Pulseway.

Pulseway PSA (v4.0.14) - 7 September 2018
This release contains new features and bug fixes. See these topics for details:

Features

This release adds the following features:

• Print Ticket to be an HTML Page instead of PDF.

• Opportunity Performance Metrics are Incorrect on Dashboard.

• Add First name and Last name to ad-hoc report Contact Emails module.

• QuoteWerks - Search on Enter Button.

• Add Sunday as a formula option to filters in ad hoc reports.

• Remove Soundex Algorithm During Import.

• Change the Exago Reports Joining of Ticket Status Change to minimize Joining Time for Tickets.

• Add DayofWeek and DayofYear Functions to Exago.

• Exago AccountLocations Change to new Ticket Style.

• Enhance the QW Error Logging on the UI.

• Added First Name and Last Name as Separate Columns in Exago Employee Object.

• QW - Display the contacts related to active locations when creating a new Opportunity.

• New Bulk Operations capabilities On Assets, Accounts and Contacts.

• Improved performance of Workflow Service Query.

Fixes

This release includes the following bug fixes:

• Dispatch Calendar - Holiday are not displaying in the calendar.

• Custom Fields - Error 500 appear when deactivate a custom field used in a view.
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• TODO Widget - Clicking on the Todo text/description renders is completed.

• Former Employee Still Shows in Roles (Search and Select).

• My Group Tasks - Error 500 appear when trying to open the page.

• (Italian Language) -Billing Review - Error when search for reccuring service contract.

• Service Desk - Service Desk Tab not working without permissions to service desk dashboard.

• Outbound Emails are not Showing on I.E Edge.

• Time is showing on Recurring Services Items.

• Rest API - Time Entries - New Roles should be linked to the user.

• Xero - Export Account - Search by Code not working properly.

• Views - Error appear when trying to update a view.

• Inventory - Manage Products - Error appear when the Product name is too long & Description.

• Invoice - Error appear when generating an invoice.

• Print layout updates for Invoices.

Pulseway PSA (v4.0.13) - 10 August 2018
This release contains new features, enhancements, and bug fixes. See these topics for details:

Features

This release adds the following features:

• Added Support for TLS 1.2.

• New Invoice Template for Customer.

• New Quotation Template for Customer.

Enhancements

This release adds the following enhancements:

• Ad-Hoc Reporting - Added a Direct join between time entries and accounts.

• Adjusted a custom invoice for Customer.

• Calendar Sync - Cronofy - Enhanced how private meetings are handled.

• Hide Inactive Assets by Default on Tickets.

• Add Missing Fields on Ticket Master Reccuring Listing. Fields are: Duration and End Date Fields.

• Ad-Hoc Reporting - Add Receive Invoices Flag field to CRM - Contacts.

• Prevent adding a custom field in the same module with duplicate names.
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Fixes

This release includes the following bug fixes:

• Fix display of balance due amount on invoices when there is tax and discount applied.

• Fix Ticket Type field clearing issue in My Templates - Ticket Template.

• Fix Worktype setting for billing configuration not overriding company settings for Bill Zero Value Items.

• Billing automation - Fix Inactive Jobs Still Running.

• QuickBooks Desktop Sync Tool - Fix Large Description Text Breaking Invoice Sync.

• Fix Email Praser Not running every 1 minute.

• Fix Billing automation showing wrong invoice dates on the invoice generation.

• Fix Adjust timesheet allowing to adjust time on tickets with multiple time entries in the excel like grid.

• Fix converting a quotation in QuoteWerks as closed is still updating the Pulseway PSA Opportunity as Open and
disregarding the mapping settings.

• Xero - Invoice Sync - Fix Missing out Item if Name doesn't match.

• Fix products created from Rest API not displaying in the search and select popup when adding them as charges to
tickets.

• Lists - prevent user from deleting default items.

• Rest API - Fix Import Contacts Updating wrong contact.

• Dispatch Calendar - Fix Views drop down list displaying empty.

• Dispatch Calendar - Fix error when adding appointment to unassigned user.

Pulseway PSA (v4.0.12) - 6 July 2018
This release contains new features, enhancements, and bug fixes. See these topics for details:

Features

This release adds the following features:

• New Excel Import Wizard in the Admin Module - Ability to Import Hardware Assets with Custom Fields. (Support for
additional data objects coming soon.)

• Rest API to Support Custom fields (Put, Post and Get).

• Support for SAML 2.0 identity providers (such as Okta) for Single Sign-on (SSO). See new guide in online help for
details.

• Rest API - SSO Authentication Support for SAML 2.0. Check the Rest API Documentation for more Information.

• QuoteWerks Connector - Ability to Map Fields for Product Identifier.
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• Split Outbound Email Setting Configuration from under the Company Settings Page to a separate page under My
Company. To avoid configuration issues, you must now complete a successful connection test before saving
changes.

• QuoteWerks Connector - Add the Support for Convert To Sale Lost.

• Add the ability to set default ticket type from the company settings.

• Security - New Feature "Has API Access" to allow Non-admin users to Invoke APIs.

• Rest API - Import Contact - Ability to import multiple phones and email addresses.

• Rest API - New Endpoint to Validate Authentication for Client Portal Users. Check the Rest API Documentation for
more Information. (https://server_name/api/authenticate).

• Rest API - Authentication Unauthorized User Error Distinguish between unauthorized and no rights to invoke APIs.

• Rest API - Endpoint to Enable/Disable AuthAnvil SSO.

• Rest API - New Statistics API to Get tickets count by Status.

• Rest API - New Statistics API to Get Customer by time.

• Rest API - New Statistics API to Get Technician Bandwith.

• Rest API - New Statistics API to Get tickets count by Queue.

• Rest API - New Statistics API to Get tickets count by Due Date.

Enhancements

This release adds the following enhancements:

• Ticket Print - Add Ticket Title to Print Out.

• Ad-Hoc Reporting - Add Fields "Discontinued" and "Taxable" to Products.

• Ability for Administrators to Unlock Root Users.

• Rest API - Enhance the Name and Extension of the Attachment Downloaded File.

• Add the Ability for Parent Accounts to see Contracts for Child Accounts from Client Portal.

• Xero Integration - Display a General Failure Alert if one or more failure happened in the Xero Job.

• Clone Exclusions when Cloning Contracts.

• Outlook Sync Tool - Minimum Auto-Sync Interval set to 15 min.

Fixes

This release includes the following bug fixes:

• QuoteWerks Connector - Fix Opportunity DropDown records loaded limit.

• Workflow based on Due Date was being incorrectly affected by Ticket Status and associated SAL Event. This has
been fixed.

• Fix 404 Error when adding lots of roles to contracts.
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• Tickets - Error 500 appear when copy time sheet has time log related to a ticket.

• Rest API - Fix Issue with import CRM Activities endpoint creating activity with end time lesser than start time.

• QuoteWerks Connector - Fix loading of app when QW has multiple installations

• Fix Issue with Dispatch calendar actions link not working.

• Fix New line added to description in contracts after being activated.

• Batch tickets - Fix Update assignee and queue not working.

• Batch tickets - Fix Update priority not working.

• Fix Wrong Date Format when logging in with AuthAnvil.

• QuoteWerks Connector - Fix The pop up page close automatically when clicking on "map Item Type" button.

• Fix Dispatch Calendar Not Sending Appointments if Manager is Assigning an Item to other Employees for Service
Calls only.

• Billing - Generate Invoice - Round line items Total to 2 Digits in Billing Automation.

• Xero Accounts Import Load Breaking when Address Object is Null.

• Tickets - Start / End time for Ticket Service call emails is not correct.

• Rest API - Locations Endpoint - Address Country Id Always returned null.

• Fix Billing Automation showing Services as US Date Format in EMEA.

• Fix Sync Assets from VSA Assets overwrites Acquisition Date.

• Fix Dispatch Calendar - Showing Duplicate Appointments.

• Tickets - Remove the Image manager button.

• Admin Tasks - Fix Wrong Start Date issue.

• Fix issue with TODO when double quotes are added.

• Fix issue with PDF Print of Expense sheet if an Ampersand (&) Character exists in the notes.

• Custom Field - Fix display of same module twice.

• Email templates - Remove the "SLA Remaining Hours" and SLA Related Fields.

• My Profile - fix issue with saving my preferences.

• RMM Integration - Fix error showing when sending a ticket to a deleted queue.

• Fix duplicate email address showing on the "To" Field when sending the invoice.

• SLA - Fix SLA's related to deleted branch are not displaying anymore.

• Product Quotation - Cannot select which PDF version to email.

• Dispatch Calendar - Fix issue with search popup not showing after a search action.

• Projects - Service calls display Time as UTC.
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• Dispatch Calendar - Fix entries not showing when selecting Work Week View.

• Tickets - batch action - fix issue clearing assignee when updating queue.

• Can not assign primary contact for Assigned Resources for an Account.

• Should not be able to delete contact if related to a ticket. (

• Fix issue duplicating records when importing hardware assets using CSV.

• Billing automation - Fix the processing and update alert message showing.

• QuoteWerks Connector - Fix Search and Paging issue.

• Tickets - Time logs - fix dates not displaying completely.

• Tickets - Fix Expense notifications not displaying the total amount.

• Fix Time zone issue in activities start time.

• Rest API - Fix User is able to access attachments data that are not for his tenant.

• RMM Integration Setting Server Address: Missing Server Side Validation.

• Fix sorting of linked accounts list to be sorted alpabetically.

• Fix import activities api when keeping opportunity field empty.

• QuickBooks Online - Combine the multiple discounts from Pulseway PSA to QBO.

• Ticket Hardware Asset and Software Asset giving Error when combined in Tickets Ad-Hoc Report.

• Fix incorrect name of column In finance contract (Total Hours Per Month).

• Service Quotation - Contract description displaying in the same line.

• QuickBook Online - Cannot Search Invoice within Quickbooks Sync Grid.

• RMM Integration - Error 500 appear when inserting wrong URL address.

• Milestone - Fix the validation message when trying to add a new milestone with an existing name.

Pulseway PSA (v4.0.11) - 11 May 2018
This release contains new features, enhancements, and bug fixes. See these topics for details:

Features

This release adds the following features:

• The marquee feature for this release is real time two-way calendar synchronization with Office 365, Exchange (on-
premise), Outlook.com, Google and iCloud. Setup is quick and easy via Home > My Calendar > Calendar Sync.
Calendar type can vary by Employee (e.g. one Employee can sync with Office 365, while another syncs with
Google). Details on synced calendar items have been enhanced including Map, Ticket and Task links where
appropriate. This cloud-to-cloud sync leverages the Cronofy Calendar API, and is included at no extra charge. While
the Outlook Connector is still supported, we recommend using the new Calendar Sync instead so that calendars
remain up to date even when Outlook is not running.
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• A new column and filter have been added to HR > Employees allowing you to view which Employees have the
Calendar Sync enabled.

• Enhanced the Ticket details shown on a TODO item added in Dispatch Calendar, and made sure TODO gets
removed from My TODOs when deleted from the related ticket.

• Customized descriptions on Quotes now flow through to the Contract.

• For Workflow notifications, added the option to include Internal Notes.

• Added a new Workflow condition field that targets Ticket Notes / Activity Details including those coming from email
replies. For example, Workflow can be configured to close a Ticket if an Employee replies to a Ticket email
notification and includes a token like 'CloseTicket' in the reply.

• Added the ability to blank out primary assignees and queues in Workflows Update section.

• Show Custom Fields in Ad-Hoc Reports for Time Entries.

• CRM Accounts - Show notes field in the Linked accounts grid.

• Added a new option in the Email Parser setup screen that allows users to prevent adding the original email as an
attachment to the Ticket.

• Added a new Rest API Endpoint to allow updating Software Assets.

• Added a new Rest API Endpoint to allow creating new Software Assets.

• Implement new way of sending emails in a Queueing mechanism with retry feature if failed.

Enhancements

This release adds the following enhancements:

• For an improved user experience, the Dispatch Calendar now loads in a searate browser tab and the View Tickets
Mode is enabled by default.

• Migrated Exago to the newest Version Exago 2017 Release Version.

• Added the ability to update the Ticket Open Date through Rest API Tickets Endpoint (PUT).

• QuickBooks Desktop Sync - Added the ability to update items in Pulseway PSA that already exist.

• QuoteWerks Connector - Use Account Billing Address when selecting a Contact in the QuoteWerks Contact
Manager.

• Transfer the PO Number from Quotations and Sales Orders to the Invoice level when generating an invoice.

• Ad-Hoc Reporting - Exposed Account Location for Tickets.

• Service Quotation - Rename Button Label "Convert to Project/Contract(s)" to "Convert to Project/Contract(s)/SO".

• Update Last Activity Date of the Ticket on Status change of the ticket.

• Hardware Assets - Extend the Asset Name field size to hold 200 characters.

• QuoteWerks Connector - Hide Inactive contacts in the Contacts Manager.

• Hide time spent label when in client portal since we do not show the time entries.
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• Added missing fields to software assets in Ad-Hoc reporting.

• QuickBooks Desktop Sync - When Exporting Invoices, include the company name in the billing address.

• Do not allow edits to time entries that have been billed or posted.

• Rest API - Contacts - Add POC and IsActive fields when adding new (POST) or updating (PUT) Contacts.

• Ad-Hoc Reporting - Added new Fields to Contacts and Accounts - Created by and Last Modified By.

• On the Email Parser list, a column label was changed from "Last Time Checked" to "Last Time Email recieved" to
more accurately reflect the meaning of this field. A separate column, "Last Time Run," shows the last time that the
mailbox was checked for new emails.

• Handle Pulseway Tickets opened throught integration with titles having line characters.

Fixes

This release includes the following bug fixes:

• Fix time entry rounding issue due to wrong calculation by ticket time log timer.

• VSA Integration - Fix Workflow trigger when ticket is Auto resolved.

• Opportunities - Fix the sorting of the Opportunities Type to be ordered alphabetically.

• Fix filter By Project Manager Full Name is not working under Projects Module.

• Fix resetting description to default when converting Quote to sales order.

• Fix the Markup Down not printing on Tickets from Expenses.

• Service Quotation - Stop Rounding "Quantity" value in the line Items.

• Fix Email Notification is Picking the Ticket Created Date before Updating it from the Workflow in the Email
Notifications.

• Fix Expense Sheet Status not showing in Approval History.

• Fix Attachments not opening from the Attachment Tab of a Project.

• Business Process - Fix Wrong spelling in Breadcrumbs of Email Templates.

• QuickBooks Online - Fix scroll bar not displaying in payments import result grid when importing payments multiple
payments.

• Check if Email Parser Reboots would create the email again if it was pulling it.

• Custom Fields - Fix Display issue with multiline custom field.

• Ticket Notes - Internal Notes - Fix note Formatting when internal notes have invalid HTML.

• Fix Error When Clicking on the Expense Button in Finance - Reimbursement.

• Tickets - Fix the naming of Primary Technician to Primary Assignee.

• Fix Service Call not being pulled correctly in Outlook Sync.
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• Fix ability to Hide "Discontinued" Product from List View & Tickets > Add Product, and Unable to Delete Newly
Created Product Not Used.

• Fix Recurring Tickets not carrying software asset information to the created tickets.

• Quoteworks - Opportunity not closed automatically when changing the status to "Lost".

• Fix Issue with payment rounding.

• Fix Adding Time Entries from Rest API is not Saving the Time in UTC and causing the Ticket not to open.

• Ticket - Expense - Date not displaying completely.

• Fix Error when adding newly created admin task in timesheet.

• Fix permission issue to select suppliers from CRM Accounts when adding new Products.

• Fix Inactive Employees showing in the Dispatch Calendar.

• Xero Integration - Fix Accounts Import Grid limitation of 100 Records.

• Email Template - Fix Ticket Open By Field not being populated.

• Fix Business Type Lists to be sorted Alphabeticall in CRM - Accounts.

• Fix Custom Fields Multiline field not allowing new lines in Projects.

• Quotation - Don't show the inactive pricing levels for product items.

• Fix discontinued products that are displaying in new PO.

• Service Quotation - SO not displaying in the summary page.

• Adjust Timesheets - Fix issue with Total Hours calculation.

• Tickets - Fix Negative Mark Down expense not saving when adding new expense.

• Tickets - "Is recurring Ticket" column not displaying correct data.

• Quoteworks Connector - Fix Item Type Drop down list always saved empty.

• QuoteWerks Connector - when creating quotation line items, import the taxable flag from the QW item directly, not
form the Pulseway PSA product data

• QuoteWerks Connector - Fix Save Options Popup not displaying on top

• Administrative Work - Fix the cancel button not working properly

• Employees - Fix External Authentication Type Column always displaying empty.

• Forgot Password Should not Prompt for Company while in the Gateway Page.

• Security roles: fix 'allow modify all' tab not working after add a role to a specific user.

• Fix Error in My Calendar when Exporting Calendar.

• Fix Ticket Notes Attachment Load in Tickets.

• Timesheet - Add Tickets and Tasks Search Popup fix Issue with Clear Search.

92 PulsewayPSA Guide

Release 4.0.41 | March 2021

Chapter 2: PulsewayRelease Notes www.pulseway.com

https://www.pulseway.com/


93

Chapter 2: PulsewayRelease Noteswww.pulseway.com

• Project - Charges - fix the description of project charges is not updated.

• My Timesheet - Fix rounding issue of time logged in the grid.

Pulseway PSA (v4.0.10) - 4 March 2018
This release contains new features, enhancements, and bug fixes. See these topics for details:

Features

This release adds the following features:

• The Invoice generation process can now be completly automated. A new Billing Automation option in the Finance
module provides flexible filters and recurring scheduling options allowing you to automatically generate Invoices
for some or all Contracts. This new option allows you to completely bypass the multi-step Billing Review process.

• All Ticket Fields are now available in the Ticket Notes Email Templates.

• All Ticket Fields are now available in the Ticket Time Entry Email Templates.

• Added Employee Title as a field for Email Templates.

• Added ability to set the Listing Auto Refresh option to a minimum value of 5 Minutes in Company Settings.

• Added Taxable/Non-Taxable option for all Quotation Line Item types (Service, T&M, Labor, Fixed Price, etc.).

• New Rest API Endpoint to retrieve all Locations.

• New Rest API Endpoint to Update (PUT) Hardware assets.

• Ability to define Multi-line Custom Field

• Added new Exago Built-in Functions to Get the Month Name, Quarter Name, Quarter Number, and Date Filter to get
Past 12 Months from Today.

• Create new Contact directly from QuoteWerks if the Contact Name is entered manually.

Enhancements

This release adds the following enhancements:

• Add the ability to specify which employees have External Authentication (AuthAnvil) enabled.

• Allow Emails to open tickets via the Email Parser even if the email has no body.

• Update the Contact Modified On when users update the Email or Phone Number of the contact.

• In the Ticket view, the Service Contract label is now a clickable link allowing you to quickly see Contract details.

• Rest API - Enhance Products Endpoint to update Unit Price.

• QuoteWerks Logging Enhancement to write logs without Admin Access Rights.

• The default Quote Template has been enahnced to leave more room for line-item descriptions.

• The Ticket 'Batch Actions' user experience has been improved to display Job Status and a detailed Log.
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• Added the ability to edit Recurring Services Description in Contracts.

• Set Ticket Creator to "From Parser" when the email belongs to two contacts for two different Accounts in CRM.

Fixes

This release includes the following bug fixes:

• Italian Translation corrections.

• Fix issue with Outlook Plugin losing config on Outlook Update.

• Projects - Fix issue when adding a related opportunity to a project.

• QuickBooks Desktop Sync - Importing a Service does not import the service description

• Rest API - Add IsDefault field to Contact Phone and Email.

• Rest API - Import Employees - Add IsActive Field.

• Tickets - Contacts - Changing the Users Location clears the contact phone and email.

• Rest API - Retrieve Locations with Accounts Endpoint and Phone/emails with Contacts endpoint.

• Company Settings are Not overriding system defaults: Billing Review options.

• Fix the error message when deleting ticket linked to a Knowledge base article

• Knowledge base - Error appears when updating an article.

• Security Roles - Missing Translations.

• QuoteWerks - Contact Manager always opening even if third party CRM is not selected.

• Software Asset - Wrong Location is selected after deactivating the selected location.

• Spelling mistake under Settings --> My Profile --> 'Marital Status'. (

• Quotewerks Integration - Reset the contact paging after changing the number of user should display in the page.

• Financial Dashboard Issues

• QuickBooks Desktop Sync - Issue when Syncing Invoice with Address Line 2 Specified.

• Tickets - Hide the Timer entry Timer when the feature "Hide Ticket Time Entries Tab" is checked.

• Tickets - Assign Button not working properly when removing secondary assignee.

• Italian Translation Mistakes.

• Xero - Invoice Export - Check Item Code When Item Name is Null in Inventory Items List.

• Billing - Generate Invoice - Round the line Items total to 2 Digits after decimal point.

• QuickBooks Sync - Export Invoices to Parent Company When Bill to Parent is specified.

• Expense Type - No validation message appear when trying to delete a used expense type.

• Knowledgebase - Breadscrumb not updated when saving new Knowledge base.
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• Issue when having a custom field error message having a quote.

• Tickets - The Timer is giving wrong results when calculating Seconds for the Start and End Time.

• Projects - Project Start Date format changes after saving.

• Rest API - SKU field is returned in response yet empty.

• Sorting Issue on Lists > Opportunities --> CRM Opportunity Types.

• Phone Types are not showing Correctly in the Filters of the Ad-Hoc Reports.

• Security Role - Fields displaying without translation.

• Software Asset - Error validation message appear when saving a new license.

• Contacts - An error appear when trying to open a contact related to inactive location.

• CRM Dashboard Spelling Issue.

• Discount Type - The currency displaying for the percentage Discount Type instead of %.

• QuoteWerks - Popup Windows not showing always on Top.

• Search Ticket View Not Displaying Associated Work Type. (

• Invoice Edit Grid Item is showing only 1 digit after decimal point when paying against the invoice.

• Timezone Issue on Start and End Time under Tickets Activity Logs.

• Quotewerks Integration - Contacts screen does not scroll to additional pages when more than 100 contacts.

• Tickets Listing - Work Type not showing Value in Grid.

• Sorting by 'Account' column in 'Home > My Tickets' does not work.

• Finance - Invoice -The invoice review screen will show &amp; in the tax name.

Pulseway PSA (v4.0.9.1) - 13 January 2018
This release contains new features, enhancements, and bug fixes. See these topics for details:

Features

This release adds the following features:

• Integration with Xero accounting system.Xero Contacts (Accounts), Items (Services, Products, etc.), and Chart of
Accounts can be imported and exported. Invoices can be exported to Xero, and Payments can be imported from
Xero.No 3rd party connector software is needed for the Xero integration.

• Added ability to define External Employees that are associated with the 'Internal' Account and have Portal access
(only).

• Add new Currency Symbol support for Aruba - (ƒ).

• Rest API - Add the ability to Create and Update Ticket Notes (POST/PUT Verbs).

• Add the ability to use Survey Result information fields in Service Desk Email Templates.
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Enhancements

This release adds the following enhancements:

• When a new ticket is generated by the email parser, the Ticket 'Created by' field will be set to the email sender
name.

• Added a new 'Members' filter to the All Projects list to show Projects where a particular Employee is assigned to one
or more tasks.

• Show only Active Contacts in Notifications Tabs (example: when adding Ticket Note, Time Entry, etc.).

• Contracts - Change Default Contract Label Text to "Default Contract for Service Desk".

Fixes

This release includes the following bug fixes:

• Fixed some labels in Italian Language option.

• Allow decimal quantity when receiving items in Receiving Orders in case of Non-Serialized items.

• Email Parser - Tooltips not displaying completely.

• Time Entry Email Templates not showing Internal Notes in [%ActivityDetails%].

• Project Task Members cannot see Projects in Collaboration module.

• Fix Export to Excel Licensing Issue.

• Wrong user name is showing in ticket note when notification is issued.

• Editing a service on a Quotation is failing when the service is inactive.

• Project Dates updated with different date format when updating tasks dates from inline editing form.

• My Templates - Delete notification showing wrong message when deleting a template.

• Projects - Milestone Date is not respecting Date Format specified in Company Settings.

• QuickBooks Desktop - Issue Exporting Invoice When Account had Trailing Spaces at the end - Name matching
failed.

• Rest API - When Posting (adding) new ticket - affected hardware asset was not linked.

• Submitting Time sheet is inserting wrong history records in the time sheet history tab.

• Time Entry - Rounding Time Spent is not showing correct results if the user has multiple shifts per day.

• Error when removing public flag from a Favorite View which has a Default Sorting order specified.

• Hardware Assets - Contacts Drop Down List not Sorted Alphabetically.

• Rest API - Fix Recurring Services PUT/POST Verbs to update Service Name and Description.

• Adding a Note and Closing a ticket is not firing a workflow with custom fields filter set to Empty.

• Fix incorrect country record entry - United Kingdom on the EMEA Server.

• QuickBooks Desktop - Issue Exporting Invoice with Notes.
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• Workflow Custom Field Conditions for Accounts And Contacts not working on creating a new ticket from email
parser.

• Rest API - Error Finding Created On Field for Physical Assets.

• Inactive Queues are showing on Ticket Creation.

• Contracts - Cloning a contract is copying the history of the Services as well.

• Tickets - Images saved in Base64 Format when added when resolving Ticket.

• Email Logs - Email log not reflecting email notifications to 'Internal Resources' and 'Others'.

• Rest APIs - Error when updating contacts.

• Finance - Revenue by client dashboard - not displaying correct data.

• Tickets - Views not working properly when it is used from My Queues.

• Sending batch invoices not refreshing grid if one Invoice was Failing due to missing POC.

• Service Desk - Ticket List - Ticket status is not being sorted based on Configuration.

Pulseway PSA (v4.0.8.1) - 11 November 2017
This release contains enhancements and fixes. See these topics for details:

General

This release includes the following general enhancements and fixes:

• Added the Ability to Select the Default Language under company Settings for Italian or English for now. Italian
Language is Enabled now for Beta Launching.

• Added the Drag and Drop functionality for Service Calls on the Calendar Page.

• Update the Ticket Page to allow users to Edit or Delete a Charge even if it was created by another user.

• Removed Account Settings from the Left Menu Under My Company.

• Fixed the Home Page Message widget dashboard. It was hiding all the Dashboard Widgets the next time the User
Log in after you minimize it.

• Fixed the client portal view shring to limit the scope of the shared view between client portal accounts.

• Fixed the Outlook Connector losing settings on system reboot.

CRM

This release includes the following CRM enhancements and fixes:

• Added the ability to Select Supplier on SO Posting Screen before creating the Purchase Orders.

• Removed the Duplicate field "Quotation Number" under CRM-> Opportunity-> Quotation Tab.

• Removed spaces form Account code when saving an account.

• Fixed the URL validation of the Accounts Websites to accept complex URL formats.
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Email Parser

This release includes the following Email Parser enhancements and fixes:

• Added a new Blocking Keywords on Email Parser. Block by Subject and Body.

• Added a new System Log Notification module where you can see all the Notifications with variuos Types (Info,
Critical, Warning ETC...).

• Added the ability to Include Inline Images in the Ticket Details and Ticket Activities.

• Changed the Email Parser to remove the Greater than and Less than characters because the Ticket was failing to
be created since < and > are considered non safe HTML Tags.

• Enhanced the Email Parser Not to Inject div styles during Ticket Creation and move the styling to the Ticket View
Page.

Finance

This release includes the following Finance enhancements and fixes:

• Enhanced the Services Description field under Finance-->Services to allow Multiple Lines.

• Lengthen dropdown menu Under Unknown Ticket.

• Fixed the contracts to disallow Adding Inactive Services for a New Recurring Service Contract.

• Contracts-Clone-Client field should be required and fix the label to "Account".

QB Integration

This release includes the following QB Integration enhancements and fixes:

• Added the Ability for Users to Map Invoice PO number to field in Quick Books Online.

• Fixed the QuickBook Desktop and Online Sync to create New Products as Inventory Items instead of Services when
transferring Invoices to QuickBooks.

• QBO - Items exporting to QB yet remains in the grid.

Reports

This release includes the following Reports fixes:

• Fixed the Ad Hoc Report permissions where ser can create report for a section he doesn't have the permission to
see it.

Service Desk

This release includes the following Service Desk enhancements and fixes:

• Added the ability to Assign Secondary Assignee in the Ticket Assign Screen.

• Changed the Size of Issue and Sub Issue Type to 60 Characters instead of 30.

• Enhanced the Speed of Clients Search in the Tickets Page.

• Moved the Batch Updates (Delete)of Tickets into a Scheduling/Queue Structure. User will see a responsive UI
changes while waiting for the Batch Job to complete.
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• Moved the Batch Updates (Assign)of Tickets into a Scheduling/Queue Structure. User will see a responsive UI
changes while waiting for the Batch Job to complete.

• Moved the Batch Updates (Assign)of Tickets into a Scheduling/Queue Structure. User will see a responsive UI
changes while waiting for the Batch Job to complete.

• Lengthen dropdown menu Under Unknown Ticket.

• Added the Batch Action Tickets on the Parent Company in (Parent Child Tenants).

• Added the ability to accept Hyperlink images attached to emails and show them as inline images and hyperlinks.

• Fixed the Recurring Master Tickets .After saving the Master Ticket, user could not update the End Date

• Fixed deleting a ticket that has already CRM Activities.

• Fixed hiding In Active Contacts from Showing on New Tickets.

• Fixed Recurring Master Tickets - Error appear when Trying to add new recurring ticket with service call.

• Fixed the Right Click Open of Tickets on Chrome to show directly above the pointer.

• Fixed the Access Denied Issue for Client Portal when you remove access to Dashboard.

Timesheets

This release includes the following Timesheets fix:

• Fixed hiding Inactive Worktypes in the Add Time Entries from the Inner Timesheet Module. It works on Tickets and
Tasks.

Pulseway PSA (v4.0.7) - 14 October 2017
This release contains enhancements and fixes. See these topics for details:

General

This release includes the following general enhancement:

• Delete all related Custom Fields and attachments when deleting hardware assets.

CRM

This release includes the following CRM enhancements and fixes:

• Accounts - Location - Changed position order of the "Post Code" and "State" fields.

• CRM - Accounts - Add New Child - Enable Multilevel Child Support

• Improve the way an account can be set as a child to another account, or disconnected to become a parent account.

• Fixed refresh issue when adding attachments to Service Quotations.

• Fixed issue while importing Accounts from Excel, having an account type which doesn't already exist in the system.

• Fixed issue with website format accepting the Dash character (-).

• Allow Custom fields to show when adding new Product Quotations, not only when editing an existing one.
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Dispatch Calendar

This release includes the following Dispatch Calendar fix:

• Fixed issue with Service calls being displayed incorrectly on the calendar.

Finance

This release includes the following Finance enhancements and fixes:

• Added a new invoice template "Detailed Invoice Without Employee" With Custom Sorting.

• Extended the Invoice Description Field to Accept Multiple Lines.

• Extend the Contract Description Field to Max Characters.

• Enhance the Accounts drop down to support virtual records loading to improve performance.

• Enhance the Invoice generation process to include the ability to link to the child account and bill it to the parent
account.

• Fixed issue with "Comprehensive Ticket" report which was showing $0.00 in Billing Hours.

• Fixed issue in Finance - Contracts section when adding a non-existent service (in the drop down list) to a recurring
service contract.

QB Integration

This release includes the following QB Integration enhancements and fixes:

• Enhance customers notes synchronizations from QuickBooks Online. Only update notes when it is empty in
PulsewayPSA.

• QuickBooks Sync - Synchronized Taxation flag (Is Taxable) when importing Inventory/Non-Inv Items.

• Extend the Contract Description Field to Max Characters.

• QuickBooks Online - add the ability to import child accounts.

• QuickBooks Online - add the support to link invoices to Child accounts when synchronizing an invoice initiated by a
child account in PulsewayPSA.

• QuickBooks Desktop - Allow import of Jobs as Child accounts.

• QuickBooks Desktop - add the support to link invoices to Child accounts when synchronizing an invoice initiated by
a child account in PulsewayPSA.

• Fixed issue loading Items list from QuickBooks Desktop using the sync tool.

Reports

This release includes the following Reports fix:

• Fixed issue with "Comprehensive Ticket" report which was showing $0.00 in Billing Hours.

Service Desk

This release includes the following Service Desk enhancements and fixes:
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• Add hardware assets missing fields to Ad-hoc reports, example: Manufacturer, OS Info, User Info, etc….

• Fixed time on tickets listing column "Last Ticket Activity" which was not taking into consideration the user's
timezone.

• Fixed issue with tickets batch actions not inheriting the queue view filters and listing the correct data.

Services

This release includes the following Services enhancement:

• Add the ability to Hide Ticket Tabs (Expenses, Activities, Charges, Attachments) as Special Feature in Security
Roles.

Timesheets

This release includes the following Timesheets enhancement:

• Add the Total Hours of the Timesheet on the Approval Screen.

Workflows

This release includes the following Workflows fix:

• Fixed issue with workflow notification not sending email when condition set to changed, and ticket didn't have a
selected primary assignee.

API

This release adds the following APIs:

• Added new Put API for Recurring Services Contracts.

• Added new Post API for Recurring Services Contracts.

• Added new Post API for Activate Recurring Services Contracts.

• Added new Post API for Deactivate Recurring Services Contracts.

• Added new Delete Rest API to Delete Contracts.

Pulseway PSA (v4.0.6) - 16 September 2017
This release contains enhancements and fixes. See these topics for details:

General

This release includes the following general enhancements and fixes:

• Updated the order of fields displayed in mailing and billing address forms to conform with standard US address
formatting.

• Fixed an issue with searching by full name.

• The New button on ticket list pages now honor creating a new ticket in a new window, if this preference is set using
the Settings > My Profile > Preferences > 'Default Tickets Listing Click Behavior' > 'Open in New Window' option.
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Ad Hoc Reports

This release includes the following Ad Hoc Reports enhancements:

• Added a new built in Ad-Hoc function UTCNow that enables filtering on the current UTC time.

• All missing Hardware Assets fields were added to Ad-Hoc Reports.

Admin

This release includes the following Admin enhancements and fixes:

• The following fields were added to email templates used with processing tickets in the Service Desk module:

– Location Address 1

– Location Address 2

– Location City

– Location State

– Location Zip code

– Location Phone Number

• Email Parser timeouts were set to 2 hours. Previously they were set to 15 minutes.

• Fixed an issue that prevented workflows from working when business hours were specified for the Sydney
timezone.

• Attachments added to inbound emails are now included as attachments in the outbound notification emails
triggered by workflows.

• Fixed an issue with time entries in tickets and tasks not defaulting to the default role, if the default role was
configured using the Admin > Finance > Roles page instead of the HR > Employees > Employee Roles tab.

• The names of Admin > Finance > Sales Tax Items now support the ampersand (&) character.

• Fixed an issue with attachments processed by the email parser not being attached to the resulting ticket correctly,
when the attachment had an extra dot in the filename.

Client Portal

This release includes the following Client Portal fix:

• Fixed an issue that prevented company messages created using the Admin > Company Settings > Company News
page, was not displaying in the Client Portal module.

CRM

This release includes the following CRM enhancements and fixes:

• Adding an attachment to a product quotation refreshes the list now without you having to refresh the page.

• Fixed an issue with CRM activities being offset by 5 hours when downloaded to the Outlook Calendar.

Finance

This release includes the following Finance enhancements and fixes:
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• Posting non-billable hours related to a retainer contract no longer affects the hours shown in retainer contracts and
invoices.

• The buffer size for the QuickBooks Desktop Sync tool was increased to prevent timeouts for large data imports.

• Fixed an issue where accounts created by bulk importing them from QuickBooks were not showing in CRM if the
account manager was missing.

Home

This release includes the following Home enhancements and fixes:

• Added a new Home > 'My Grouped Tasks' menu option. This page lists all tasks you are assigned to by project first,
then by task.

• The 'Hide Recurring Tickets' search parameter was added to the Home > My Tickets list page.

• Fixed an issue that caused the Home > Dashboard page to show blank, if the client was logged into a trial tenant
and closed the 'Populate Demo Data' widget on the dashboard.

• You can now use custom fields on timesheets and expense sheets.

• The Home > My Queues page now shows the correct ticket numbers.

• Unknown tickets are now hidden from the Home > My Tickets page.

Inventory

This release includes the following Inventory fix:

• Fixed a picking issue using the advanced inventory feature.

Projects

This release includes the following Projects fix:

• The All Tasks page now respects the 'Access to All Employees Project Data (Bypass ORG Chart)' special features
option in the Admin > Security > Roles page. When this option is disabled, an employee should only see tasks in
projects the employee manages.

QuoteWerks

This release includes the following QuoteWerks Integration fixes:

• Fixed QuoteWerks Integrator to update opportunities after updating the quotations on the QuoteWerks side.

• Fixed an issue with the QuoteWerks Integrator not saving warehouse settings.

• Fixed an issue with the QuoteWerks Integrator not importing the first item if it was a service item.

• Fixed the product import API to add billing configurations correctly using QuoteWerks.

RMM Integration

This release includes the following RMM Integration enhancement:

• With this release, if you change the name of a Pulseway PSA account that is integrated with an organization in the
VSA, the VSA organization name is also updated.

PulsewayPSA Guide

Release 4.0.41 | March 2021

https://www.pulseway.com/


Service Desk

This release includes the following Service Desk enhancements and fixes:

• Inline images added to the notes of tickets are now included as notification email attachments, when triggered by
a workflow.

• Added an isolation iframe to the ticket body to ensure the whole ticket displays properly, regardless of the HTML
formatting adopted in the body of the ticket.

• The ticket numbering procedure was enhanced to prevent racing, when two different email parsers attempt to
create a ticket at the same time.

• The Batch Actions wizard launched from ticket list pages no longer shows 'Completed Tickets' by default.

• Ticket due dates were not showing the correct due date for the timezone used by the current user's location.
Instead it was showing UTC due dates. This has been fixed.

• Fixed an issue with the sorting of tickets on ticket list pages, so as to honor the Admin > Company Settings >
Service Desk > Status Order > Sort Status By drop-down list: Alphabetical or Status Order.

• Fixed an issue that caused the Last Status and Priority dashlets on the Service Desk > Dashboard page to be
missing one status type and priority type in their respective lists.

Pulseway PSA (v4.0.5) - 5 August 2017
This release contains enhancements and fixes. See these topics for details:

General

This release includes the following general enhancements and fixes:

• Added a new Column Chooser option and dialog for list pages. Users can select and order their column choices,
then save them as a view or export the data displayed on the list page.

• Fixed an issue that preventing removing an account if the account was using service levels.

Ad Hoc Reports

This release includes the following Ad Hoc Reports enhancements:

• Added two new fields to all Ad-Hoc report objects: 'Created On' and 'Modified On'.

• You can now search by date and time in all date and time fields in Ad-Hoc Reports.

• Added support for Unicode characters when exporting Ad-Hoc reports to PDF output. This feature requires using the
HTMLDecode() string function in the cell of a report:

– Right-click the cell of a designed report.

– Select the Insert > Formula option.

– Use the following string function in the Formula edit box: HTMLDecode(column_name)

Admin

This release includes the following Admin enhancements and fixes:
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• Added a new Assets section to the Conditions tab for workflows. When an asset is associated with a ticket,
comparisons can be made using the following asset properties:

– Name

– Description

– Category

– Business Impact

– State

– Brand

– Manufacturer

– Machine Group ID

– Product Name

– Serial

– Model Number

– Asset Tag

– Acquisition Date

– Expiration Date

– Warranty Expiration Date

– Barcode

– Vendor

• You can now add custom fields for Contacts to the Custom Fields section of the Conditions tab in workflows.

• You can now add custom fields for Accounts to the Custom Fields section of the Conditions tab in workflows.

• Fixed an issue preventing the deletion of a workflow, if the operator was empty for the Account Name in the
Conditions tab.

• Fixed an issue that prevented generated emails from showing the data specified by the
[%AllActivityDetails%] field placeholder in the body of the email template, when a time-based trigger was
used in a workflow.

• Fixed an issue with workflow fields using the Is Empty and Is Not Empty operands on the Conditions tab.

• A Logs tab was added to email parsers created using the Admin > Service Desk > Email Parsers page. Use the
Logs tab to help troubleshoot issues with processing inbound emails using a specific email parser. A corresponding
Notification tab specifies who is notified for various types of email parser events.

Finance

This release includes the following Finance enhancements and fixes:

• Added a check to prevent the grand total of invoices from being less than the discounted value.
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• Fixed a download error in the QuickBooks installer.

• Selecting the Netherlands Antilles Guilder ANG currency in the Currency field of the Admin > My Company >
Company Settings > General tab now shows a corresponding ƒ currency symbol throughout the system.

Home

This release includes the following Home fixes:

• Fixed the ticket counts for queues listed under the Home > My Queues menu option.

• Fixed an issue updating the Outlook Tasks List using Outlook Sync.

• Fixed a JavaScript error that displayed when right-clicking a task in the Home > My Tasks page and selecting the
'Open in New Window' option.

• Fixed an issue with searching to add project tasks to a timesheet on the My Timesheets page. The search list was
not returning tasks for the correct date range.

REST API

This release includes the following REST API enhancements:

• Improved performance by having time entry REST APIs use SQL Server paging instead of Code Behind paging.

• Updated the text of an error message shown by the Account Locations REST API when validating against duplicate
names.

• Added a new API to allow adding expenses to projects, similar to tickets.

Service Desk

This release includes the following Service Desk enhancements and fixes:

• Saving changes to a ticket in a separate tab or popup view auto-refreshes the data shown in ticket list pages
immediately.

• Fixed an issue with the Service Desk > Dashboard page showing inactive ticket statuses.

• The default user for the Assignee field is now applied by email parsers to 'unknown' tickets.

• The Service Desk > Asset Management > Software Assets page now supports attachments using the .msg
extension.

Reports

This release includes the following Reports fix:

• Fixed an issue with expenses linked to projects not showing in reports.

Pulseway PSA (v4.0.4) - 1 July 2017
This release contains enhancements and fixes. See these topics for details:

General

This release includes the following general fixes:

106 PulsewayPSA Guide

Release 4.0.41 | March 2021

Chapter 2: PulsewayRelease Notes www.pulseway.com

https://www.pulseway.com/


107

Chapter 2: PulsewayRelease Noteswww.pulseway.com

• Fixed the listing of filtered views that use European date formats.

• Dashlets now persist their minimized/maximize states and the date filtering options when you navigate away and
come back to a dashboard page.

Ad Hoc Reports

This release includes the following Ad Hoc Reports fix:

• Fixed Ad Hoc Reports to show time entries in the user's timezone instead of UTC.

Admin

This release includes the following Admin enhancements and fixes:

• Many additional ticket, account and contact fields can now be referenced by workflows as conditions, including
ticket custom fields. Workflow update fields now display on a new Update tab.

• Added new operators to date-based workflow conditions:

– Greater Than

– Less Than

– Greater or equal

– Less or equal

– Between

• The following ticket fields have been added to workflow conditions:

– Service Contracts

– Work Types

– Open Date

– Due Date

• Fixed an issue with the workflow condition Changed To operator.

• Fixed workflows to update tickets with the default contract of an account, if the workflow updates the account.

CRM

This release includes the following CRM fix:

• Fixed CRM > Activities to show start times in the user's timezone instead of UTC.

Finance

This release includes the following Finance enhancements:

• Two Euro currency formats are now provided: Euro (€ 1,234.56) or Euro (€ 1.234,56). This option is set on the
Admin > My Company > Company Settings > General tab.

• The drop-down list of payments types on expense entry windows now displays in alphabetical order.
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Home

This release adds these new types of ticket templates to the Home > My Templates page:

• Ticket Note Templates - Defines custom templates for notes in tickets. You select this type of template using the
'From Template' field when adding a note to a ticket.

• Ticket Time Entry Templates - Defines custom templates for time log entries in tickets. You select this type of
template using the 'From Template' field when adding a time log entry to a ticket.

Projects

This release includes the following Projects enhancements and fixes:

• Added an option to import tasks from inside a project that is currently open for editing.

• Inactive work types no longer show on new tasks in projects.

• Fixed an issue when running Batch Actions on tasks within a project. All employees were not showing.

REST API

This release adds the following REST APIs:

• Added a new REST API 'Update Hardware Asset'.

• Added a new REST API 'Update Contact'.

• Added a new REST API 'Update Account'.

• Added a new REST API 'Update Account Location'.

• Added a new REST API 'Update Account Location'.

• Added a new REST API 'Create Hardware Asset'.

• Added a new REST API 'Create Contact'.

• Added a new API to batch resolve tickets.

Service Desk

This release includes the following Service Desk enhancements and fixes:

• Enhanced the timer feature in tickets. You can now start, stop and reset the timer when you open or edit a ticket.
You can see the elapsed time while you work the ticket. As was true before, the elapsed time of the running timer
populates the time log entry window when you open it, and continues to update it while the timer runs. You can
configure the timer to start automatically whenever a ticket is opened by setting a new Enable Stopwatch Autostart
option to Yes. This option is located on the Admin > My Company > Company Settings > Service Desk tab.

• A new user preference on the My Profile page allows you to select how a ticket opens: from a list page in the same
page, in a new tab, or in a new window.

– in the same page

– in a new tab

– in a new window
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• Fixed a ticket numbering issue with tickets imported from Connectwise.

• Added validation to prevent a recurring master ticket from having more than 500 tickets at a time.

Pulseway PSA (v4.0.3) - 3 June 2017
This release contains enhancements and fixes. See these topics for details:

General

This release includes the following general fixes:

• Fixed an issue that prevented deleting views that included special characters. A view is a user-defined filtered
search of a specific list page.

• Fixed listing pages to save the sort order and apply this sort order on auto refresh.

Ad Hoc Reports

This release includes the following Ad Hoc Reports enhancements and fixes:

• Fixed an issue with the start time not showing when Start Date is selected from the Timesheet > Timeentries
category in Ad-hoc Reports.

• Added a new field 'Description' to the Hardware and Software Assets in Ad-hoc Reports.

• Added Service Calls as a category to Ad-hoc Reports.

• Added a 'Expense Sheet Approval History' category to Ad-hoc Reports.

• Added a Project > 'Project Charge Delivery Details' category and Service Desk > 'Ticket Charge Delivery Details'
category to Ad-hoc Reports.

Admin

This release includes the following Admin enhancements and fixes:

• Fixed the search for the 'Notified Internal Resources' fields on the Admin > Service Desk > Email Parser >
Notifications tab.

• Fixed workflows to save the Sub Issue Type value entered in the Conditions section.

• Fixed an issue that prevented notifications being sent to all employees entered in the 'Notified Internal Resources'
fields of the Admin > Service Desk > Email Parser > Notifications tab.

• Fixed an issue with workflows not working when the Is Empty operator is selected in a condition.

• Fixed an issue with workflows not working when the Changed operator is selected in a condition.

• Fixed the email timeout for custom email servers to send emails normally. Custom email servers are specified
using the Admin > My Company > Company Settings > Outbound Email tab.

CRM

This release includes the following CRM enhancement:
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• An Invoice column was added to the Accounts Contacts tab of the Edit Account page. This column displays the
value set for the existing 'Receive Invoices' option.

Finance

This release includes the following Finance enhancements and fixes:

• When posted retainer hours equal the hours specified in the contract, overage hours now show as zero.

• Fixed the Finance > Billing page to show billing entries for all clients when the Check All checkbox is checked in
the Clients search parameter drop-down list.

• The following QuickBooks import rule was added:

Customers are set to taxable by default when imported from QuickBooks, or the following applies:

– If Sales Tax Item in QuickBooks was not set, then the customer is set to not taxable.

– If Sales Tax Item in QuickBooks was set, then the Tax Rate Value for that item is tested. If zero, the customer is
not taxable. If > 0 then the customer is set to taxable.

Home

This release includes the following Home enhancements and fixes:

• Submitted timesheets for the root user are now always approved. Previously, the root user's submitted timesheet
could never be approved, as there was no manager above the root user to approve it.

• Fixed an issue with service call records downloaded to the Outlook Calendar showing HTML tagging in the subject
line, such as line break <br> tags.

• Inactive work types are now removed when adding new time entries.

• Previously time entries added using the Home > Adjust Timesheets page were auto-approved. Now time entries
added using this page follow the status of the timesheet.

• A new Downloads page was added to the Home module. This page consolidates downloads for available Pulseway
PSA integration tools.

REST API

This release adds the following REST API:

• Added a new REST API 'GetTicketByTicketNumber'.

Service Desk

This release includes the following Service Desk enhancements and fixes:

• Notification emails sent when adding time entries to a ticket now display the line breaks the way they were entered
in the general note.

• Using the ticket Assign button is now interpreted by the 'Activity Added By' trigger field in workflows as an
'Employees' activity, not a 'Clients' activity.

• Fixed the selection list for adding related tickets to not show already added tickets.

• Ticket types can no longer be deleted if they are used elsewhere in the system.
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• Due Dates now also display a timestamp on ticket list pages.

• Added a new 'Create Multiple Items' option (yes/no) on the Charges tab of projects and tickets. Selecting yes for
this option splits the total quantity into individual lines, each with a quantity of 1.

Pulseway PSA (v4.0.2) - 6 May 2017
This release contains enhancements and fixes. See these topics for details:

General

This release includes the following general enhancements fixes:

• Added a new Admin > Imports & Exports > Import Data page. The new page provides a wizard to import data from
ConnectWise.

• Favorite searches can now include the sort order when they are saved.

• New windows opened by Pulseway PSA are now smaller and located in the center of the screen.

Admin

This release includes the following Admin enhancements:

• When replying to an email notification sent from Pulseway PSA, the 'reply to' email address now defaults to the
Admin > My Company > Company Settings > Outbound Email > Business Email address.

• Added a new 'Sort Status By' option to sort ticket pages by ticket status, either alphabetically or by ticket status
order. This option is located on the Admin > My Company > Company Settings > Service Desk tab.

Client Portal

This release includes the following Client Portal fix:

• Fixed a ticket search error in Client Portal, when specifying a priority.

Finance

This release includes the following Finance fixes:

• The format of date fields in the Invoice Email Template no longer displays the time, just the date.

• Fixed the version number of the Quickbooks sync tool.

Home

This release includes the following Home enhancement:

• Added a link to the related task or ticket in the service call popup window displayed in the Home > My Service Calls
page.

Projects

This release includes the following Projects fix:

• Fixed a javascript unresponsive error on the Resource Utilization page.
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Reports

This release includes the following Reports fix:

• Fixed the 'Retainer by Hour Contract Profit and Loss' report to show the right calculation of 'Overage' hours.

Service Desk

This release includes the following Service Desk enhancements and fixes:

• Fixed email parsers to send emails to both the sender and any CC'd email recipients after creating the ticket.

• When clicking the link of an 'unknown' ticket in an email, the ticket now opens in view mode using the Service
Desk > Unknown Tickets page.

• When editing a ticket, the selected contact no longer displays a '-' character between the first and last name.

• Fixed an issue that caused 'unknown' ticket details to not be populated with the sender name and sender email
address.

• Rearranged columns to match their headers, in the Search Tickets window displayed when adding related tickets
to existing tickets.

• Email parsers now add the reply to tickets that are sent by an email shared by a contact and employee as
employee notes and not as client notes.

• Fixed an issue that prevented the processing of workflows when ticket details included special characters &, <, and
>.

• Fixed an issue with workflows running multiple times after the close of SLA business hours.

• Fixed an issue that could prevent the closing of tickets because of a 'null SLA' data error.

• Fixed a validation error when adding a new knowledge base article.

REST API

This release adds the following REST APIs:

• Added a new REST API to get services.

• Added a new REST API to insert services.

• Added a new REST API to update services.

• Added a new REST API to get opportunity status.

• Added a new REST API to insert opportunities.

• Added a new REST API to update opportunities.

• Added a new REST API to insert activities.

• Added a new REST API to update activities

• Added a new REST API to insert quotations.

• Added a new REST API to update service quotations.
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• Added a new REST API to insert tickets.

• Added a new REST API to update tickets.

• Added a new REST API to insert products.

• Added a new REST API to update products.

• Added the following fields to the project REST API:

– Is Internal

– Is Template

– Is Archived

– Is Active

Pulseway PSA (v4.0.1) - 15 April 2017
This release contains enhancements and fixes. See these topics for details:

General

This release includes the following general enhancement:

• Added the ability to right-click any record and select an 'Open in new window' option.

Admin

This release includes the following Admin enhancements and fixes:

• You can now use the % symbol with LIKE and NOT LIKE operators in workflows to act as wildcard strings. Example:
Network Backup %successful

• Fixed an issue using Like and Not Like operators in workflows.

• Fixed an error that displayed when trying to save a new Admin > My Company > Administrative Work record.

• Fixed the Due Date in 'To Dos' to default to the current date, based on the timezone specified for the main location
in the Admin > My Company > Locations page.

CRM

This release includes the following CRM enhancements and fixes:

• Reopening a sales order now shows a linked project as expected.

• Fixed the line item totals shown in printed quotations for discounted items when the items are included in the
quote at no charge.

• The Excel spreadsheet used to import customer accounts now highlights the 'Main Location Name' and 'Billing
Country' column headers in red, to indicate these are required fields.

Finance

This release includes the following Finance enhancements:
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• Quickbooks Sync now adds the customer name to the bill-to address of transferred invoices.

• Importing Quickbooks Desktop Sync data into Pulseway PSA now includes updating the following fields in
Pulseway PSA customer accounts:

– Is Taxable

– Description

– Website

– Account Type

– Business Type

– Default Currency

Home

This release includes the following Home fixes:

• Clicking the 'Dismiss All' button on a calendar reminder popup window now prevents all listed reminders from
reappearing.

• Fixed an issue with drop-down lists for search parameters on the Dispatch Calendar page.

• Fixed an issue that was preventing recurring appointments from showing multiple times in calendars.

Ad Hoc Reports

This release includes the following Ad Hoc Reports enhancements:

• Added the 'Completed' field to the Service Desk > To Do category in Ad Hoc Reports.

• Added 'Expense Account' and 'Income Account' fields to the Inventory > Products category in Ad-Hoc Reports.

Service Desk

This release includes the following Service Desk enhancements and fixes:

• An email sent using the notification tab in a ticket now displays the 'From' address specified in the Admin >
Company Settings > Outbound Email > Business Email field.

• A ticket created from an email that includes attachments, now includes those attachments in email notifications.

• Workflows were updated to include attachments in email notifications when a note with attachments is added to a
ticket.

• The Home > My Tickets page now shows tickets as follows:

By default, you only see tickets assigned to you as Primary Assignee.

You can use search parameters to show tickets:

– Assigned to you as a 'Secondary Assignee' or 'Created by Me' using the Ticket Owner parameter.

– Assigned to you by queue using the Queue parameter.
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• Clearing the search list on the Home > My Tickets page returns the search list to the default view of tickets
assigned to you as Primary Assignee.

• Ticket numbering now uses the timezone of the company's main location to create the date portion of the ticket
number.

• Fixed an issue with font colors for ticket status rows on the Service Desk > Dashboard page not honoring the
settings on the Admin > Service Desk > Ticket Status page.

Pulseway PSA (v4.0) - 1 April 2017
This release contains new features and enhancements. See these topics for details:

Views

The Home > Favorite Filters page was renamed Views. Views are now supported on most list pages throughout the
system. Views can be made public or private and set to be the default view for your user logon. They can be shared with
specific users or queues of users.

Email Logs

A new Admin > Logs > Email Logs page provides an audit of all outbound email used to notify customers.

• The Email Log Info tab shows the content of the email.

• The Email Log History tab shows a history of email sending events.

• You can browse, delete, or forward email from the log.

Accounts

The POC (Point of Contact) status of a contact now displays on rows listed on the CRM > Accounts > Account Contact tab.

Workflows

This release includes the following Workflows enhancements:

• New conditions were added to workflows:

– Account Type (Client, Vendor, etc.)

– Service Type

– Primary Assignee

– Ticket Sender Email

• New comparison operators were added for conditions in workflows:

– Changed

– Changed From

– Changed To

– Is Empty

– Is Not Empty
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– Like

– Not Like

– New workflow triggers were added:

• New workflow triggers were added:

– Activity Type - time, expense, activity

– SLA first Response overdue by

• You can now clone an existing workflow.

Email Templates

A new [%AllActivityDetails%] placeholder field has been added to email templates. Use this placeholder field to
include all ticket notes in an email notification.

Dispatch Calendar

The Dispatch Calendar has been redesigned. You can optionally display a list of tickets and drag and drop a selected
ticket into the dispatch calendar of an employee. The service call is then linked to the ticket and the identifiers of the
ticket added to the description of the service call. When you create or edit a service call you can update ticket properties
and notify employees and other email recipients.

Queues on My Tickets Page

You can search for all tickets assigned to the queues you are a member of, using the Queue search parameter on the My
Tickets page.

To Dos

• To Dos were added as objects to Ad Hoc reports.

• To Dos associated with a ticket display the name of the ticket along with a link on Dashboard pages. You can click
the link to access the ticket immediately.

Service Calls

Service calls now contain two new tabs:

• Assign - Update a linked ticket with changes to the assignee, queue, primary technician, or add a comment to the
ticket.

• Notification - Use the Notification tab to notify employees and other email recipients.

When a service call associated with a ticket or a task is created, the description of the service call is populated with the
ticket or task identifiers.

Ticket Audits

A new Audits button has been added when you open/view a ticket. Two tabs display:

• Ticket Logs tab - Displays a log of all changes to a ticket, by both users and workflows.

• Workflow Log tab - Shows actions performed on a ticket by a workflow.
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Ticket Customer Info

The Ticket View tab you see when you first open/view a ticket has been redesigned. Below the ticket title is the
customer's name with a link. Click this link to show the Customer Info window. This includes a link to show the
customer's address on Google Maps.

SLA Status of Tickets

On the Ticket View tab you now see both an SLA field and an SLA Status field. For tickets assigned an SLA, the SLA
Status field shows a link. Click this link to see the estimated and actual times specified by the SLA for resolving the
ticket. This includes a state called Waiting. SLA timers are paused while waiting for the customer to respond.

Ticket Notes

Ticket notes have been redesigned to make user comments easier to read.

Ticket Prefix and Format

Two new system settings were added to the Company Settings > Service Desk tab:

• Ticket Number Prefix - Adds a prefix to ticket identifiers. Defaults to blank.

• Ticket Number Format - Specifies the date and count format of the ticket identifier. Defaults to COUNT-MMDDYYYY.

Service Types and Scopes

A new Admin > CRM > Service Type page has been added to classify CRM accounts. Service types are subsequently
assigned to scopes.

A new Admin > Security > Scopes page determines employee access to Service Desk tickets, and only if the CRM
account has been assigned a service type. Permission types for accessing a ticket can include:

• Read/Write

• Read Only

• No Access

Ad Hoc Reports

New features in Ad Hoc Reports include:

• The ability to retrieve a list of values for a parameter from a data source and display the values in a dynamically
populated dropdown.

• A new Action Event allows dashboard layouts to be adjusted dynamically for different screen sizes including mobile
devices.

• A new Action Event enables or disables parameters as needed when a parameter value is changed.

• A new Server Event modifies or sorts a list of parameters when they are loaded into the report.

• A modified Scheduler architecture allows an external custom queue service and load balancing of schedule reports.
Data can be sorted by formula calculation. This also allows "true" grouping by formula; the ability to group on a
formula that does not exist as a sort has been removed.

• Rows in the Scheduled Reports Manager can be sorted by clicking on the column headers in the table, and filtered
by using the search box.
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• Each recipient of a scheduled report can receive customized report output based on data ("batch report execution").

• Scheduled emails can be sent without report output attached. This enables the sending of data-driven emails and
alerts.

• Chained reports can be collated based on a common sort field in the child reports.

• The email body of scheduled reports can be formatted using HTML.

• Custom fields can be specified to link to and from, when linking one report to another.

• A formula can be specified to filter which records from a parent report are included when drilling into to a child
report.

• Session Info can now be accessed in data source assemblies.

• Performance has been improved when using Azure for report and folder management.

• Added the ability to run the Exago Linux installer without prompts.

• A group min/max filter flag has been added to the Administration Console to apply a group filter to an entire result
set.

• Express View Reports with Live Mode were added.

Pulseway PSA (v3.11.7) - 18 March 2017
This release contains enhancements and fixes. See these topics for details:

Admin

This release includes the following Admin enhancements and fixes:

• The minimum date limitation for date of birth in Employee records has been removed.

• The 'Users' security role was updated to allow access to quotes only, without requiring a link to a sales order. By
default the 'Users' security role provides users with limited access: either view only, or view and modify on selected
modules in the system.

• Switched the order of the Description and Name columns in the Admin > Service Desk > Queues search page to be
consistent with other modules.

• Fixed an issue with saving security roles. Saves were taking too long and timing out.

Finance

This release includes the following Finance enhancements and fixes:

• When billing project charges, the project name now shows in generated invoices.

• Fixed an issue with the Admin > Finance > Billing Configuration page showing incorrect items or duplicate items.

• Adding a note to an invoice now updates two fields in Quickbooks: Memo and Invoice Message.

• Fixed the parent/child items sync between QuickBooks and Pulseway PSA. Initially it was not respecting the
parent/child items relationships and creating them as one level.
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• Fixed an issue adding charges to project and tickets using the South African currency.

• Fixed a slow display issue with the Finance > Dashboard page.

Home

This release includes the following Home enhancement:

• Turned off appointment alerts on the Home > Dispatch Calendar page.

Inventory

This release includes the following Inventory enhancements:

• Product searches now exclude 'Discontinued' products. A product is set to 'Discontinued' using the Inventory >
Products > Manage Products > Options tab.

• Changing the warehouse on purchase orders now changes the warehouse on corresponding receiving orders.

Reports

This release includes the following Reports enhancements:

• Added the primary key field pkSiteID to the Sites category in Ad-Hoc Reports, to support join queries in reports.

• Added a new Project#/Ticket# field in Ad-Hoc reports to show the linked project # or ticket # when the
Timeentries object is selected.

Service Desk

This release includes the following Service Desk enhancements and fixes:

• Fixed an issue with the HTML format of workflow email notifications for time entry notes.

• Enhanced the speed of email parser processing and added a new Last ID check to speed up checking for new
emails.

• When clicking the Assign button while editing a ticket, if the Comments field is left empty and the status is
changed, the status change is now saved.

• Eliminated the creation of an unnecessary placeholder '--' note when clicking the Assign button in a ticket, assigning
a new user, and not entering any Comments.

Pulseway PSA (v3.11.6) - 18 February 2017
This release contains enhancements and fixes. See these topics for details:

• General

• CRM

• Finance

• Home

• Projects

• Reports
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• Service Desk

General

This release includes the following general enhancement:

• Listings now sort all pages instead of sorting just one page.

CRM

This release includes the following CRM enhancements:

• Users can now edit the notes created by other users for an account record in CRM.

• You can now enter a string to search for parent accounts, using the 'Select Parent Account' combo box.

Finance

This release includes the following Finance fix:

• Fixed QuickBooks Sync to enforce the end date sent to QuickBooks.

Home

This release includes the following Home enhancement:

• Service calls added to the Outlook calendar now include ticket and task information, even if the service call
Description field is left blank.

Projects

This release includes the following Projects fix:

• Fixed the project start and end dates to follow European date format.

Reports

This release includes the following Reports enhancements and fixes:

• Fixed Unit Cost to show correctly on the Inventory Master Report.

• Added the expiration date for a software license in Ad-hoc reports.

• Fixed reports to support HTML formatting of time entry and expense entry notes.

Service Desk

This release includes the following Service Desk enhancements and fixes:

• EML attachments are no longer sent in notification emails.

• Fixed an issue with workflow calculation of an SLA based on business hours.

• Inactive accounts are now hidden when editing a ticket.

• Assigning a ticket using the Assign button is now flagged as an internal activity to prevent sending a notification to
the customer.
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Pulseway PSA (v3.11.5) - 28 January 2017
This release contains enhancements and fixes. See these topics for details:

• Client Portal

• CRM

• Finance

• General

• Home

• Inventory

• Projects

• Service Desk

• Reports

Client Portal

This release includes the following Client Portal enhancement:

• Entering an Issue Type is now required when adding a ticket from the Client Portal.

CRM

This release includes the following CRM enhancements:

• Updated the Contacts dialog to show the contacts even if the contact is associated with an inactive location.

• Imported accounts now use the default currency of the company.

Finance

This release includes the following Finance enhancements:

• Added a new 'Bill Zero Value Items' option on the Admin > My Company > Company Settings > Invoice tab to show
or hide zero value items in Finance billing pages.

• Added the ability to change the customer associated with the ticket if the ticket is in billing review and there are no
posted entries.

General

This release includes the following general enhancements:

• Searches now ignore leading and trailing spaces whenever a search is executed.

• Dashboards now auto-refresh every 15 mins.

Home

This release includes the following Home enhancement:

• Added a hyperlink URL on the ticket number and task name in a timesheet.
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Inventory

This release includes the following Inventory enhancement:

• Updated Inventory > Stock Adjustments to handle the processing of a large number of items in one record.

Projects

This release includes the following Projects enhancement:

• Updated the task notes to show the creator of the note.

Service Desk

This release includes the following Service Desk enhancements and fixes:

• Updated the email parser to handle lost connections and antivirus messages.

• Updated the email parser to calculate the 'SLA Time to Resolution' when a new ticket is added.

• Updated the Edit Ticket page to refresh the due date after saving.

• Updated the Service Desk > Service Desk Dashboard page to hide inactive statuses in the 'Tickets By Status'
dashlet.

• Marking a ticket as complete within the time log no longer sends out an internal note to the customer.

• Fixed an issue with internal notes being being sent out as 'ticket overdue' messages when the 'SLA Resolution
Overdue By' trigger was enabled for tickets in workflows.

• Updated the email parser to prioritize associating newly created tickets with contacts before employees.

• Resolving a ticket using the Resolve button now identifies the user that resolved the ticket in the generated note.

• Updated the ticket to pause calculating the SLA whenever it is in a waiting for customer status.

• Updated the Ticket Edit page to show the contact.

• The drop-down list for the Ticket Type search parameter on ticket list pages is now sorted alphabetically.

Reports

This release includes the following Reports enhancements and fixes:

• Fixed the time format of the execution date displayed on reports.

• Updated the Service Desk > Asset Information report to show data.

Pulseway PSA (v3.11.4) - 7 January 2017
This release contains enhancements and fixes. See these topics for details:

• Admin

• CRM

• Finance

• Home
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• HR

• Inventory

• Reports

• Service Desk

Admin

This release includes the following Admin enhancements:

• The SMTP server is now tested to verify its connection is working, before a password reset email is sent.

• Added validation when entering an improperly formatted email address.

CRM

This release includes the following CRM fix:

• Fixed an issue changing the 'Has Client Portal access' option when adding or editing a contact using the HR >
Employees > Accounts > Account Contacts tab.

Finance

This release includes the following Finance enhancements and fixes:

• Fixed the display of the navigation breadcrumb line on the Admin > Finance > Discount Type page.

• Adding a purchase order to a project, and then billing by project, now shows the purchase order on the generated
invoice.

• Quickbooks Sync now correctly updates the Pulseway PSA product description with the corresponding product
description from Quickbooks.

• Added a Payment Date field to Finance > Payments records. You can also search for a range of Payment Dates.

• The order of detail lines in a printed quotation now matches the order of detail lines in the quotation.

• Fixed an issue that prevented users with security access to tickets and products from also being able to add
charges.

• Fixed an issue syncing invoices related to taxes, using the Australian version of Online Quickbooks.

Home

This release includes the following Home fixes:

• Fixed the height of rows on the Dispatch Calendar page when using Chrome and Firefox.

• Fixed an issue that prevented service calls from showing in dispatch calendars.

HR

This release includes the following HR fix

• Fixed the display of the navigation breadcrumb on the HR / Departments page.
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Inventory

This release includes the following Inventory enhancement:

• Updated the wording displayed when generating a purchase order to 'ordering from the vendor'.

Reports

This release includes the following Reports fix:

• Fixed the display of *Totals* fields in pre-defined reports.

Service Desk

This release includes the following Service Desk enhancements and fixes:

• Fixed an issue when adding the same employee to a series of new tasks, using the Save and Add New button in a
ticket.

• Technicians are now able to add a contact via the New Ticket button without having security role access to the CRM
module. The blue New Ticket button displays in the header of the user interface and is enabled by checking the
Quick Add Ticket permission in a security role.

• Fixed an issue displaying contacts in the Contact drop-down list when creating a ticket using the 'New Ticket'
button.

• Selecting an Issue Type on the Defaults tab no longer hides options on the Recurrence tab of a Recurring Master
Ticket. (

• Fixed an issue with parsing emails containing high-bit characters.

• Fixed an issue sending emails with PDF attachments when multiple contacts were specified.

• A 'From Name' field was added to email templates so that email parsers can include this field in tickets.

• Fixed two sorting errors:

– Sorting by Ticket number on the All Tickets page.

– Sorting by Task Name on the Timesheets > Add Admin Task dialog.

• Ticket templates can now be sorted alphabetically.

• Added back support for EML attachments in email parsers.

• Added the 'Sub Issue' field as a search parameter on ticket list pages.

• Refreshing the Service Desk Dashboards page no longer causes the 'Tickets by Status' dashlet to change the order
of statuses.

• You can now update the SLA field in tickets using a workflow.

Pulseway PSA (v3.11.3) - 9 December 2016
This release contains enhancements and fixes. See these topics for details:

• CRM

• Finance
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• Home

• Reports

• Service Desk

CRM

• Added support for non-conventional top-level-domain names when validating emails and email domains on the
CRM > Accounts > Email Domains tab.

Finance

• Fixed an issue with scrolling the list of invoices displayed on the Finance > Quickbook Sync > Invoices tab.

• Fixed a 500 error that could occur when syncing payments with Quickbooks.

• You can now export invoices to Quickbooks with a status of 'Partially Paid' and 'Fully Paid'. Previously only 'Sent' and
'Ready to Send' could be exported.

Home

• If an expense report is submitted and the approval route split, the report is split into sub reports, one for each
project manager approver. Report attachments are now split as well, based on the project manager approver for
each sub report.

• Timesheets can now be PDF printed in date order. A new 'Client' column was also added.

Reports

• Added the Task ID and Project ID to the Ad-Hoc Report project and task objects.

• Added the customer account code 'Post Code' column to the Invoice object in Ad-Hoc reports.

Service Desk

• Email parsers can now specify a different email folder to check for new inbound email using a new Search Folder
field on the Admin > Service Desk > Email Parser > IMAP Settings tab. The default value is 'Inbox'.

• Unknown tickets now identify the sender's name and email address. An Unknown Tickets page displays in the
Service Desk module when an Admin > Service Desk > Email Parser receives email from an email address that is
not recognized as belonging to any employee or company contact.

• Fixed the display of the font color for ticket counts in the Tickets by Status dashlet of the Service Desk Dashboard
page. Colors are configured using the Admin > Service Desk > Ticket Statuses page.

• SMTP server communication was switched from sync to async, to reduce latency issues when processing notes and
opening tickets.

• Fixed an issue with extra line breaks being added to ticket notes created by inbound email.

• When a ticket is created:

– If a hardware asset is linked to a ticket, the Client, Client Location and Contact fields default from the
hardware asset.

– If no hardware asset is linked to the ticket, these fields default from the CRM account.
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Pulseway PSA (v3.11.2) - 19 November 2016
This release contains enhancements and fixes. See these topics for details:

• Admin

• CRM

• Finance

• Service Desk

Admin

• Fixed an issue sorting custom fields after v3.11.1.

CRM

• Taxes are now calculated and included for fixed price items on service quotations.

• You can now enter a decimal value for a product item in the QTY field for a service quotation.

• Services are now listed in alphabetical order when selecting a service to add to a service quotation.

Finance

• Fixed an issue with syncing reimbursements using QuickBooks Sync.

• Fixed an issue with syncing items containing special characters using QuickBooks Sync.

Service Desk

• Fixed an issue that prevented the Admin > Business Process > Workflow > 'Idle For' trigger to not fire when the
ticket was attached to an SLA.

• Fixed an email parser issue creating a ticket when the email's attachment was not valid. Now the ticket is created
without the broken attachment.

• Fixed an issue stopping the SLA timer, after creating a ticket and manually setting the Status to 'Waiting For
Customer'.

• Fixed the display of tickets created using the email parser, when notes were added.

Pulseway PSA (v3.11.1) - 27 October 2016
This release contains enhancements and fixes. See these topics for details:

• Admin

• Finance

• HR

• Service Desk

• Reports
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Admin

• Fixed an issue with the Help icon masking other options when the web page was resized. 

Finance

• You can now customize the default future date shown by the 'Default End Date' search field on the Finance >
Billing Review page. This same change also applies to the 'To Date' search field on the Finance > Billing page. Use
the new Admin > Company Settings > Invoice tab > Billing End Date option to adjust this default.

• Added a new 'Payments' tab to the Finance > Quick Books Sync page. Use this tab to sync payments from your
Online QuickBooks account.

• Added four new settings to the Admin > My Company > Company Settings > Invoice tab:

– Show VAT Number - If Yes, a VAT identifier displays on printable documents.

– VAT Number Text - Specifies the string portion of the VAT identifier shown on printable documents.

– VAT Number - Specifies the numerical portion of the VAT identifier shown on printable documents.

– Invoice Title - Customizes the title at the top of the invoice. The default is 'Invoice'.

• Importing data using QuickBooks Sync now updates the CRM > Accounts > (selected account) > Net Days field.
This value comes from the Quickbooks > (selected customer) > Payments and Billing > Terms field.

HR

• Fixed a JavaScript error that displayed after clicking the HR > Employees > (selected employee) > 'Reset and Email
Password' option. 

Service Desk

• Fixed a bug related to clicking the 'Save and Add New' button in the task dialog. The new task dialog that opened
was blocked and the user could not save the new task.

• Entering changes in projects and tasks now refresh only the changed records or rows, instead of refreshing the
entire screen or grid. This greatly improves performance, especially in situations where there is high network
latency.

• Added a new 'Reply to' option to the Admin > Service Desk > Email Parser > (selected email parser) > Notifications
> Notify Sender section. The option has two settings:

– Sender - Sends reply email only to the sender of the original inbound email.

– All (CC) - Sends reply email to all email recipients, including recipients copied (CC) on the original inbound
email.

• Completed tickets are no longer included in the list of overdue tickets shown when you click the Overdue Count
icon on the Tickets dashboard. 

• Fixed an issue with custom fields not working on tasks when you accessed the task from the Home > My Tasks list
page.

• Added two new fields to an email template based on the Service Desk module.

– Prim Tech Email
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– Contact Email
These email recipients can be automatically notified based on a triggered event in a workflow. Email templates are
configured using the Admin > Business Process > Email Templates page.

• Fixed an issue with the display of ticket notes caused by incorrect HTML formatting in inbound emails. 

Reports

• Added two options to the Reports > Ad-Hoc Reports page, enabling you to export and import any Ad Hoc report.

– Download - Right-click a selected Ad-Hoc report and click the Download option to export the report.

– Upload - Imports a previously exported Ad Hoc report with a '.wr' extension.

• Fixed a bug in the 'Profit and Loss Summary by Project' report. Decimals were not showing correctly.

Pulseway PSA (v3.11) - 1 October 2016
This release contains enhancements and fixes. See these topics for details:

• Admin

• CRM

• Finance

• Home

• Service Desk

• Reports

Admin

• Added the ability to grant or block access to the 'About' dialog via the Admin > Security Roles page. Removed client
portal access to the About box.

• The 'Income Account' and 'Expense Account' values defined for each billing configuration specified on the Admin >
Finance > Billing Configuration page are now included in exports to Quick Books.

CRM

• Added support for multiple templates for quotations and sales orders. As has been done with invoices, a variety of
templates will be added over time.

Finance

• Added two new search parameters to the Finance > Billing Review > Labor Hours page:

– Task Status

– Ticket Status

• Added two new search parameters to the Finance > Billing Review > Expenses page:

– Ticket Status

– Project Status

128 PulsewayPSA Guide

Release 4.0.41 | March 2021

Chapter 2: PulsewayRelease Notes www.pulseway.com

https://www.pulseway.com/


129

Chapter 2: PulsewayRelease Noteswww.pulseway.com

• Fixed a QuickBooks Desktop > Invoice Date discrepancy due to a time zone issue in the web service.

• Fixed an issue with missing product charges in invoice line items when synchronizing with QuickBooks.

• Fixed an issue with synchronizing an invoice when the sales rep specified a middle name in Quick Books.

• Fixed an issue with posting the same record twice if opened concurrently in two different windows.

• Quickbooks Sync now includes the export of sub-accounts in the Chart of Accounts.

• Fixed an issue that prevented syncing invoices that included an item description containing the ampersand (&)
character.

Home

• The Home > My Timesheet > 'Notes' tab was renamed 'Internal Notes', to make it clear notes added to this tab are
not shown to clients.

Service Desk

• Added the Contact field as a search parameter to the Service Desk > Assets Management > Hardware Assets
page.

• Added the address of the customer account location to printouts of service desk tickets.

• When a client sends in an email to create a ticket, the system now responds with a 'Reply All' email message
instead of a "Reply" message.

• You can now update a ticket linked to an inactive contract.

• Added the ability to set the text foreground color for a specific ticket status. This option is set using the Admin >
Service Desk > Ticket Statuses page. (

Reports

• Added Hardware Assets and Software Assets to the Report > Ad Hoc Reports page. (

• Added a new 'Report Logo' option to the Admin > Company Settings > General tab. This option affects all reports
and forms that support showing a logo. This is a separate option from the 'Logo' option used to display a logo in the
user interface.

Pulseway PSA (v3.10.4) - 12 September 2016
This release contains enhancements and fixes. See these topics for details:

• CRM

• Service Desk

CRM

• Fixed an issue with opening sales orders that had inactive contacts.

• Fixed an issue updating the data displayed in the PDF file when re-generating a quotation.
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Service Desk

• You can now assign a contact to a ticket from a different location than the location assigned to the ticket. The drop-
down box to select the contact is now sorted by the assigned location first.

Pulseway PSA (v3.10.3) - 2 September 2016
This release contains enhancements and fixes. See these topics for details:

• Admin

• CRM

• Finance

• Home

• Project

Admin

• Added a new 'Quotations Terms and Conditions' field to the Admin > My Company > Company Settings > CRM tab.
New CRM > Service Quotations and Product Quotations use the value in this field by default.

• Email notification templates created for purchase orders, sales orders, service quotations and product quotations
now use the contact's first name and last name instead of the contact's full name. Email templates are maintained
using the Admin > Business Process > Email Templates page.

CRM

• An Account Code column has been added to the Excel spreadsheet import template used to import new customer
records into the CRM > Accounts page. The same column was also added to the Reports > Ad-Hoc Reports page.

• A Tax Value field now displays in CRM > Quotations > Service Quotations. Previously they only showed in product
quotations.

• When converting a service quotation to a project you now can copy either from Template Projects or from All
Projects. Previously you could only copy from All Projects.

• Active customer accounts now display by default on the CRM > Accounts page. Previously both active and inactive
customer accounts displayed by default.

Finance

• Added a new 'Detailed Invoice without Employees" invoice template. An invoice template is selected when you
generate or re-generate the invoice for a selected invoice record on the Finance > Invoices page.

• Added the Billing Cycle column to the Finance > Contracts list page. The field can be used as a search parameter.

• Added 'EFT Transfer' as a new Payment Type on the Finance > Payments page.

• The Finance > Quickbooks Sync page now supports multiple users working with the Quickbooks Sync page
concurrently.

• All invoice templates now display Tax Value, Total and Grand Total fields.
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• Fixed the popup calendar for the Service Desk > Tickets > Due Date field to highlight today's date correctly, even
when logged in using a different time zone than the server.

• Updated the 'Default End Date' search field on the Finance > Billing Review pages to default from today's date to
three months into the future. Applied the same fix to the 'To Date' search field on the Finance > Billing page.

• The Finance > Billing Review > Recurring Services page now lists contracts grouped by customer and sorted by
date in a descending order.

• The date used to bill a recurring service on the Finance > Billing Review page is now correctly determined by the
'Issue Invoice on' option in the contract: 'Beginning of Billing Cycle' or 'End of Billing Cycle'.

Home

• Tool tips now display longer on the Home > My Calendar page and Dispatch Calendar page.

• Changing the location of a service call now correctly updates the tool-tip shown on the Home > Dispatch Calendar.

Project

• Added a new 'Group By' search parameter to the Home > My Tasks page. When 'Group By Projects' is selected, a
search lists all projects with tasks assigned to the user. Selecting a project in the list shows just the tasks assigned
to the user in that project.

• The All Projects > (selected project) > Actions > Copy Project dialog includes an option to Copy Project Charges. All
service quotations converted to a project now copy project charges.

• Fixed an error that displayed when clicking a Preview hyperlink in a rich-text editor field, such as the Project
Description field in the Project tab for a selected project.

Pulseway PSA (v3.10.1 and v.3.10.2) - 25 August 2016
This release contains enhancements and fixes. See these topics for details:

• Admin

• Finance

• Projects

• Reports

Admin

• Email parsers are now prevented from converting incoming email into tickets if the email uses the same "From"
email address as the email parser.

Finance

• Fixed a QuickBooks Desktop > Invoice Date discrepancy due to a time zone issue in the web service.

• The 'Detailed Invoice without Dates' template now includes the tax. An invoice template is selected when you
generate or re-generate the invoice for a selected invoice record on the Finance > Invoices page.
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Projects

• Fixed an issue with updating tasks using the inline Edit dialog in the Project module. European dates were causing
JavaScript errors on saving.

Reports

• Added a new Ad-Hoc Reports category for all inventory objects: PO, SO, RO, etc.

Pulseway PSA (v3.10) - 13 August 2016
This release contains enhancements and fixes. See these topics for details:

• Admin

• CRM

• Finance

• Home

• Bug Fixes

Admin

• The Company List user interface was improved.

CRM

• A new Account Code field was added to the CRM > Accounts > Account tab. You can filter the Accounts page using
this new field.

• On the CRM > Quotations > Service Quotations page, the Period column was added to the Line Items tab and the
Convert to Contract step in the Convert Quotation dialog.

• You can now filter sales orders by Project Name on the CRM > Sales Orders page.

Finance

• You can now add custom fields to invoices and to invoice category reports in Ad-Hoc Reports.

• You can now add custom fields to payment records and to payment category reports in Ad-Hoc Reports

Home

• Managers can now see submitted timesheets and expense sheets in read-only mode on the Home > Adjust
Timesheets and Home > Adjust Expenses pages, while these records are being reviewed for approval.

Bug Fixes

• Fixed an invalid calculation of expenses mark up or mark down when reimbursing employees or billing a vendor.

• Fixed an issue with deleting service calls, todos, appointments and other items from the Home > Dispatch
Calendar page.

• Fixed an issue with incorrect dates and times for calendar items synchronized using the Outlook Calendar
extension.
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• The Home > My Tasks page no longer displays tasks of archived projects.

• Exporting invoices using the Finance > Invoice > Export menu and sub-menu options now match the list of invoices
you selected.

• Fixed an issue with timesheet approvals when timesheets contain entries for multiple projects with different
approval routes. If no time is entered for a task, misleading emails are no longer sent that say the timesheet was
partially approved.

• Fixed an issue on list pages with the filter being reset after selecting a different column to sort by.

• A “completed” task now allows the status to be changed to “closed”.

• Fixed an issue with specifying Recurrence or Edit using the IE 11 browser on the Service Desk > Recurring Master
Tickets page.

Pulseway PSA (v3.9) - 8 July 2016
This release contains enhancements and fixes. See these topics for details:

• Admin

• Service Desk

• CRM

• Home

• Finance

• Inventory

• Projects

• Reports

Admin

• You can now set a 'Is Default' option for one item in each list in the Admin > My Company > Lists page. Previously,
the first item in the list served as the default list item.

• Custom fields now support two new field types: Numeric and Money.

• The Finance > Billing Configuration page includes the following changes:

– The 'AR Account / GL Account' field was renamed 'Income Account'.

– A new 'Expense Account' field was added.

Service Desk

• A new Batch Actions button was added to Service Desk > Tickets and My Tickets pages. It displays two options:

– Current Page - Performs batch actions on tickets in the current page only.

– All Pages (max 500) - Performs batch actions on tickets in the current search context, up to 500 tickets at a
time.
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• Clicking either option displays a 'Batch Tickets' wizard that steps you through the following choices:

– Choose Tickets

– Choose Operation - Update Tickets, Assign Tickets or Delete Tickets.

– Operation Details

– Confirmation

• For more information see Batch Actions for Tickets in PulsewayPSA documentation.

CRM

• Items added to a sales order that are not in inventory—identified as "Free Items", meaning non-inventory—are now
displayed along with the inventory items when posting the sales order.

• You can now filter the Accounts search list page by whether the account is internal or external or either.

Note: The internal CRM customer account is a feature that already exists in PulsewayPSA. It's created for you and
matches your company name by default. Your internal CRM customer account is used when you ship
inventory between warehouses.

• A new Email Domains tab was added to the CRM > Accounts page. You can use it to define multiple email domains
for each accounts. The email parser uses these multiple email domains to correctly match emails with each
customer account.

Home

• The My Tasks page now shows a 'Planned Hours' field.

Finance

• You can now filter the Invoices page by Project Name.

Inventory

• Finance account fields on the Manage Products page—the Expense Account and Income Account fields—now
display a drop-down list of accounts to choose from.

Projects

• Completed projects no longer show by default when listing projects.

Reports

• AdHoc Reports now includes wages information when the Employee category is selected.

Pulseway PSA (v3.8) - 14 May 2016
This release contains enhancements and fixes. See these topics for details:

• Home

• Admin

• Service Desk
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• Finance

Home

• You can save search filters by name to a new Favorite Filters page in the Home module. You can edit, copy,
rename and delete existing Favorite Filters. To use one, select the Home > Favorite Filters page and click a filter.
The corresponding page will display, using the search filter you selected.

Admin

• Companies can now use their own SMTP mail servers. Select the Admin > My Company > Company Settings >
SMTP Config tab. Set the new option 'Use Custom SMTP Settings' to Yes. Configure your custom Outgoing Mail
Server. This forces your instance of Pulseway PSA to send all outgoing email and notifications through your
company's mail server instead of the default SMTP server.

Service Desk

• A new Related Tickets tab has been added to tickets. Clicking a related ticket opens the ticket in a new window or
tab, enabling you to work on related tickets in tandem.

Finance

• You can exclude selected roles and work types from a contract, using a new Exclusions tab. If hours are reported
using the excluded role, the hours are reported against a 'Default Fallback Contract'.

• On the Contract Information tab of a contract, you can now override the default value set for the 'Issue Invoice on'
field, either 'Start of Billing Cycle' or 'End of Billing Cycle'. Previously this value was fixed for all contracts in your
company. The default is set using the Admin > Company Settings > Invoice tab.

Pulseway PSA (v3.7) - 4 April 2016
This release contains enhancements and fixes. See these topics for details:

• Service Desk

• Projects

• Finance

• Admin

• Reports

• Client Portal

• CRM

Service Desk

• Any unassigned service calls you create can now be accessed using the Home > My Service Calls page.

• Notification emails sent for ticket notes now include attachments.

• Ticket notes also now show the actual sender of the note.

• The Details (ticket description) field was added as a search filter field to the Tickets and My Tickets pages.
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• Ticket note email templates can be configured using the Admin > Business Process > Email Templates page and
specifying the Ticket Note module. These templates can now include a Contact's first name and last name

Projects

• Added Members as a search filter field to the All Tasks page.

• Enhanced the inline editing of tasks to prevent updating multiple tasks at the same time.

• When copying a template project using the Service Desk > Template Projects page, the attachments linked to the
template project are now copied to the new project.

Finance

• Added the ability to show/hide zero value hours for fixed price and recurring services in the Finance > Billing
Review > Labor Hours page. This option is configured using the Admin > My Company > Company Settings >
Invoice tab.

• Added the option on the Admin > Finance > Sales Tax Items page to create a tax group that consists of multiple tax
Items. Invoices now can be linked to a tax group or tax item.

Admin

• Added a new Admin > My Company > Single Sign On page. Use this page to enable/disable single sign on
integration with with a single sign on server.

• Admin > My Company > Locations now provide Date Format and Time Format options.

– Date Formats

• American Format (MM/dd/yyyy)

• European Format (dd/MM/yyyy)

– Time Formats

• 12 Hours Format (Ex: 8:00 A.M , 8:00 P.M)

• 24 Hours Format (Ex: 8:00 , 20:00)

• Workflows on the Admin > Business Process > Workflow page can now:

– Notify queues and assigned resources.

– Update Ticket Type, Issue Type, Sub Issue Type and Clients.

Inventory

• Added an Inventory > Fulfillment > Deliver Product Charges page for Simple Mode Inventory.

• Printed POs now show the Supplier Code instead of the UPC.

Reports

• Ad-Hoc reports can now be created using the Employee Address.

• Ad-Hoc reports can now be created using published Knowledge Base Articles.
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Client Portal

• Clients now receive emails on Client Portal Reset or Creation based on defined email templates in the Admin >
Business Process > Email Templates page.

CRM

• CRM > Quotations > Service Quotations can now include:

– Product Items - Enables you to combine both products and services in a single quotation.

– Retainer by Hour Items

– Retainer by Amount Items

• If a sales order is linked to a project, the items listed in the sales order display in the project as a charge when the
sales order is posted.
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Dashboard (Home)
Home > Dashboard

Admin > Dashboard

HR > Dashboard

All modules have a dashboard to display important data. The Administrator Dashboard tracks important events and
activities, not necessarily identified as a ticket or project or CRM activity.

1 Click the Admin module on the far right of the global navigation bar.

2 Click Admin Dashboard, the first selection on the local navigator bar on the left.

– My To Do List - A place to set reminders. For example: stop by HR and get benefit change form. Enter
text, then click the calendar and set the date, or simply enter the word tomorrow. Press the Enter key on your
keyboard to add the entry. To Dos created for a ticket display the name of the ticket along with a link. You can
click the link to access the ticket immediately.

– My Notes - A quick summary of thoughts or ideas that you don’t want to forget during the day.

– News - Company news generated from the Admin module.

Sharing

If user has the rights, he or she can use the system to share information such as events, announcements, and news.
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Removing My To-Do List Items

The user can remove items in the My To-Do List by clicking the red X in the Already Done tab and clicking on the red X.
The user can reset the My To-Do List by clicking the yellow arrow, if an item was completed by mistake.

Deleting

The user can simply erase My Notesby highlighting the words and selecting delete on the keyboard.
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My Company
Locations 142

Company Settings 146

Outbound Email 159

Custom Fields 160

Lists 161

Company News 163

Holidays 165

Administrative Work 166

Single Sign On 167

Admin > My Company

The My Company menu specifies settings about your own company.

1 On the global navigation bar, click Admin.

2 On the local navigation bar, click My Company
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Locations
Moving Users 144

Location Hours 145

Admin > My Company > Locations

The Manage Locations page specifies your company locations. These fields are used throughout the system to track
information about your various offices.

• Address information will appear on your invoices.

• You will be able to quickly see which employees are located at which location, etc.

The Main Branch is the default. If you have other locations—like a remote sales office or a store in a different city—you
will create them here as well.

Add Locations

1 Click New on the Manage Locations page.

2 Enter the following on the Location Data tab.

– Location Name

– Website

– Time Zone

– Date Format

• American Format (MM/dd/yyyy)

• European Format (dd/MM/yyyy)

– Time Format

• 12 Hours Format (Ex: 8:00 A.M , 8:00 P.M)

• 24 Hours Format (Ex: 8:00 , 20:00)

– Main - Yes or No.

– Click Save.

3 Enter the following on the Address > Shipping Contact tab. Optionally click Copy From Billing to populate these
fields from the Billing Contact tab.

– First Name

– Last Name

– Address Line 1

– Address Line 2

– City
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– State

– Zip Code

– Country

– Phone

– Ext

– Fax

– Mobile

– Email

4 Enter the following on the Address > Billing Contact tab. Optionally click Copy From Shipping to populate these
fields from the Billing Contact tab.

– First Name

– Last Name

– Address Line 1

– Address Line 2

– City

– State

– Zip Code

– Country

– Phone

– Ext

– Fax

– Mobile

– Email

5 Click Save.
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Moving Users
Admin > My Company > Locations > Edit > Users

The Users tab associates users with a single location. Users initially are members of the Main Branch location.

To Move Users Between Locations

1 Click Move.

2 A Search and Select screen appears.

3 Select the employees you want to move.

4 Click OK.

5 Click Save.

144 PulsewayPSA Guide

Release 4.0.41 | March 2021

Chapter 3: Admin www.pulseway.com

https://www.pulseway.com/


145

Chapter 3: Adminwww.pulseway.com

Location Hours
Admin > My Company > Locations > Edit > Working Hours

The Working Hours section specifies the working hours for your location.

1 Use the check box and select the WeekDay days your location is open.

2 Enter your hours per day by clicking on the next to Starttime and Endtime.

3 Click Save.

Note: If you have multiple locations, you will need to set the working hours for each location.
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Company Settings
General 147

Time Sheet 149

Project 150

Service Desk 151

Invoice 153

Contract 155

CRM 156

Inventory 157

User Account 158

Admin > My Company > Company Settings

In the section, you set global settings and defaults for modules and the entire system.
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General
Admin > My Company > Company Settings > General

The General tab specifies how your company name and logo is displayed in the user interface and in communications
with your customers. It also specifies currency and dashboard settings.

• Business Name - The business name displayed in invoices.

• Business Email - The FROM address of emails sent to recipients.

Note: If you create email templates in the Business Process section, the email you enter in the FROM field on the
template will override the Business Email address created above.

• Business Email Display Name - The display name included with the FROM email address. Optional.

• Business Logo - The business logo shown on this page displays throughout the user interface, for both users and
clients accessing client portal. To change the business logo:

– Click Select.

– Upload your business logo. Uploaded business logos are re-sized to 20px in height.

– Click Save.

• Report Logo - The report logo is shown on all reports and forms. To change the report logo:

– Click Select.

– Upload your report logo. Uploaded report logos are re-sized to 20px in height.

– Click Save.

• Listing Auto Refresh in - Set how frequently, in minutes, you want your dashboards to refresh their data.

• Currency - Select which currency you want to display in your system.

1 Delete the existing text and a list of available currencies display.

2 Select the currency from the data list.

3 Click Save.

4 Log out and then login for the change to apply.
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Time Sheet
Admin > My Company > Company Settings > Time Sheet

The Time Sheet tab sets defaults and global settings for your company’s timesheets. A timesheet period is one week.

• TimeSheet Week Day Starts On - Select a day of the week to start each timesheet.

• Allow Future View of Timesheets - The number of weeks into the future employees can view their timesheets.
Maximum 2 years.

• Allow Past View of Timesheets - The number of weeks into the past employees can view their timesheets.
Maximum 2 years.

• Preload Timesheets - If Yes, tickets and project tasks preload future timesheets.If No, tickets and project tasks do
not preload future timesheets. Many project focused organizations are accustomed to seeing all of their assigned
tasks displayed immediately on timesheets at the beginning of the week as well as on future timesheets.

Note: Current employee time entered on tickets and project tasks are automatically added to current timesheets.
In effect, timesheets are built as work is entered and completed during the week.

• Limit of items to preload in Timesheets - Limits the number of items preloaded in timesheets.

• Round Time Logs - Rounds time entries in logs to the nearest specified interval, in minutes. Enter 0 to 60.

• Up/Down - Select to round time entries up or down.
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Project
Admin > My Company > Company Settings > Project

The Project tab sets defaults for new projects.

• Project Number Prefix - Specifies the default prefix for new projects.

• Project Starting Number - Specifies the default starting number for new projects.

Note: When you save a project you can type over the project number and override the system generated number.

Whenever a new project is created, the default time sheetsheet approval route and expense sheet approval route are
automatically assigned to the new project. A project manager can override these default approval routes or select None.
If None is selected, submitted timesheets and expenses are auto-approved. Approval routes are created in the Admin >
Business Process > Approval Routes folder.

• Default Timesheet Approval Route

• Default Expensesheet Approval Route
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Service Desk
Admin > My Company > Company Settings > Service Desk

The Service Desk tab sets defaults for new tickets. For example, when a customer calls in and user clicks New Ticket...
the priority and source will already be populated with the values you specify here.

• Default Ticket Priority - Select the default ticket priority. Priorities are maintained using the Admin > Service Desk
> Priorities page.

You can set up approval routes for timesheets and expense sheets in the system. If you are using the Service Desk
module and you want all timesheets with entries from tickets to route to a specific person or manager, select default
approval routes here.

• Default Timesheet Approval Route: Select approval routes that are create in the Business Process >Approval
Routes section in Admin Module.

• Default Expense sheet Approval Route: Select approval routes that are created in the Business Process > Approval
Routes section in Admin Module.

• Default Ticket Source - The default method of communication used by the customer to initiate the creation of
ticket.

• Default SLA - The default service level agreement. Applies to customers that do not have a contract. SLAs are
maintained using the Admin > Service Desk > SLA page.

• Sort Status By - Sorts ticket pages by ticket status, either alphabetically or by ticket status order.

• Ticket Number Prefix - Adds a prefix to ticket identifiers. Defaults to blank.

• Ticket Number Format - Specifies the date and count format of the ticket identifier. Defaults to COUNT-MMDDYYYY.
Changing the format affects new tickets only.

• Default Ticket Type - Select the default ticket type . Priorities are maintained using the Admin > Service Desk >
Ticket Types page.

• Merge Status - When a ticket is merged, this field will determine which status to be merged to.

• Merge Activity Type - This option allows you to define the type of note to be added (Internal vs External) when a
ticket is merged.

• Enable Stopwatch Autostart - If enabled, When working on a ticket, the time starts automatically as soon as the
ticket is opened.

• Load Parent Account Contracts - When this is enabled and a ticket is created for a "Child Account" the contract
drop-down will show the child & parent contracts associated with that account.

• Load Assignees by Account Service Type - If checked, when assigning a technician for a ticket, this will check all
the technicians with the corresponding scope and only those associated can be assigned.

• Suppress Assignee list when Account is blank - When creating a new ticket if the account is not filled, the assignee
list will not show the names of the technicians.
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Invoice
Admin > My Company > Company Settings > Invoice

The Invoice tab sets defaults and global settings for your invoices.

• Invoice Number Prefix - Specifies the default prefix for new invoices.

• Invoice Starting Number - Specifies the default starting number for new invoices.

• Issue Invoice on - When an invoice is issued. You can override this default setting in the header of a contract.

– Beginning of Billing Cycle - Invoices are created in advance and will appear in the Billing review folder
on the first day of the month or quarter.

– End of Billing Cycle - Invoices are created in advance and will appear in the Billing review folder on the
last day of the month or quarter.

• Post T&M Entries

– Only Approved - Only approved timesheet entries and expense entries are posted to billing.

– All - All timesheet entries and expense entries are posted to billing.

• Post Zero Entries - If Yes, zero value hours are posted for fixed price and recurring services on the Finance > Billing
Review > Labor Hours and Recurring Services pages.

• Bill Zero Value Items - If Yes, show zero value items in billing pages. If No, hide them.

• Use Classes - In QuickBooks Desktop version, you can create classes that you assign to transactions. These classes
enable you to track account balances by department, business office or location, separate properties, or by any
other meaningful breakdown of your business. Use classes are maintained using the Admin > Finance > Class List
page.

• Show VAT Number - If Yes, a VAT identifier displays on printable documents.

• VAT Number Text - Specifies the string portion of the VAT identifier shown on printable documents.

• VAT Number - Specifies the numerical portion of the VAT identifier shown on printable documents.

• Billing End Date - Sets the default number of days or months into the future future date shown by the Default End
Date search field on the Finance >Billing Review page. This same change also applies to the To Date search field
on the Finance >Billing page.

• Invoice Title - Customizes the title at the top of the invoice. The default is 'Invoice'.

• Notes to clients - Any notes entered here will display on all invoices generated from the Finance module.
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Contract
Admin > My Company > Company Settings > Contract

The Contract tab sets defaults for contracts. Contracts are maintained in the Finance module.

• Contract Number Prefix - Enter a string prefix for the names of new contracts. Optional.

• Contract Starting Number - Enter a starting number for new contracts.
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CRM
Admin > My Company > Company Settings > CRM

The CRM tab sets defaults for the CRM module

• Quotation Number Prefix - A prefix added to the names of new quotations.

• Quotation Starting Number - The starting number for new quotations.

• Pipeline Factor - The default probability that sales opportunities in the sales pipeline will be converted into sales.
Used by the CRM dashboard and the Pipeline Value portion of the Pipeline Report CRM Dashboard.

• Quotations Terms and Conditions - New CRM > Service Quotations and Product Quotations use the value in this
field by default.
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Inventory
Admin > My Company > Company Settings > Inventory

The Inventory tab sets defaults for records that affect inventory management. Types of records include:

• PO - purchase order

• RO - received order

• UPC - universal product code

• DO - dispatch order

• SO - sales order

• AD - inventory stock adjustment

These are the default settings for each field:

• PO Number Prefix - PO_

• PO Starting Number - 1

• RO Number Prefix - RO_

• RO Starting Number - 1

• UPC Prefix - 111111

• UPC Length - 5

• Adjustment Number Prefix - AD_

• Adjustment Starting Number - 1

• SO Number Prefix - SO_

• SO Starting Number - 1000

PulsewayPSA Guide

Release 4.0.41 | March 2021

https://www.pulseway.com/


User Account
Admin > My Company > Company Settings > User Account

The User Account tab sets defaults for new employees and clients.

• New Employee Email Template - Select an email template for new employees to use.

• New Client Portal User Email Template - Select an email template for new portal user clients to use.

• Password Reset Email Template -
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Outbound Email
The Outbound Email page enables you to configure a custom outgoing mail server. This forces your instance of
PulsewayPSA to send all outgoing email and notifications through your company's mail server instead of the default
SMTP server.

• Use Custom SMTP Settings - If Yes, enables the other fields.

• Outgoing Mail Server (SMTP) - The name of your outbound mail server.

• Username - The account username for outbound mail.

• Password - The account password for outbound mail.

• Server Port Number - 465 (default)

• Encryption Type - SSL (default), TLS, Non-Encrypted
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Custom Fields
Admin > My Company > Custom Fields

The Custom Fields page maintains custom fields you can use in forms in many different modules. For example, you can
add custom fields to forms in:

• CRM - Accounts, Contacts, CRM Activities, CRM Opportunities, CRM Quotes and Sites, Sales Order.

• Projects - Projects and Project Tasks

• Service Desk - Tickets, Pending Tickets and Assets (Physical and Software).

• Inventory - Dispatch Orders, Products, Product Quotations, Receiving Purchase Orders.

• HR - Employee Records

Custom fields can also be included in Ad Hoc Report Writer reports.

Editable Fields

• Field Name - The name of the custom field.

• Field Type - Free Text, Date, Data List, Numeric, or Money

• Module Name - The module using the custom field.

• Order - The order custom fields display in a form.

• Status - Active or Inactive

• Required Custom Field - If Yes, entering a value in a custom fields is required to save a form.
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Lists
Admin > My Company > Lists

The Manage Lists page maintains the list of values displayed by list fields used in standard forms. Each list is predefined.
You cannot add a new list. Click any row in the Manage Lists page to edit that list.

Manage Lists

If you want to populate a drop-down field with list items, you should have the Admin permissions and do the following
steps:

1 Navigate to Admin > My Company > Lists.

2 Choose the List Name(or name of a drop-down field).

3 Select the Add button.

4 Enter the Name for a list item you would like to see in the drop-down of the selected field.

5 Select Save button.

You can add more than one drop-down list items.

Note: If you do NOT want the item to be visible immediately, make sure you select No in the Active option, when
adding a List item.

Editable Fields

• List Name - A value in the drop-down list.

• Is Default - Sets a single item to be the default.

• Is Active - If checked, the value displays in the drop-down list.

Types of Lists and Where They are Used

• CRM

– Accounts - Business Types

– Contacts - Phone Type

– Contacts - Email Type

– Activities - CRM Activity Type ( like Call, Email)

– Activities - CRM Activity Status ( New, In progress, Complete)

– Opportunities - CRM Opportunity Type

– Opportunities - CRM Opportunity Status

– Opportunities - CRM Opportunity Rating

– Opportunities - CRM Opportunity Lead Source

– Sites - Site Market Type\
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• Projects

– Projects - Project Type

– Projects - Project Assessment

– Projects - Collaboration Type

• Service Desk

– Tickets - Ticket Note Type

– Software Assets - Asset Software Category

– Hardware Assets - Asset Hardware Category

– Hardware Assets - Asset Vendors

– Hardware Assets - Asset Brands

– Hardware Assets - Asset Business Impact

– Knowledgebase - Knowledge Category

• Inventory

– Purchase Orders - Ship Method

– Purchase Orders - Payment Term

– Purchase Orders - Purchase Order Charge Type

– Products - Product Composition Materials

– Products - Product Brand

– Products - Product Manufacture

– Products - Product Cost Codes

– Products - Product Pricing Levels

– Stock Adjustment - Warehouse Adjust Reason

• HR

– Employees - Education Institute Name

– Employees - Education Field of Study

– Employees - Education Degree
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Company News
Admin > My Company > Company News

The Company News page manages communications published in module dashboards and the client portal dashboard.
Types of communications include:

• Announcement

• Event

• Information

• Message

• News

Editable Fields

• Title - The title of the communication.

• Type - The type of communication.

• Display On - Select the module dashboards this communication will be published to.

– Admin

– Client Portal

– CRM

– Finance

– Home

– HR

– Inventory

– Projects

– Reports
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– Service Desk

• Publish Date - The date the communication start being displayed on dashboards.

• Expires On - The date the communication stop being displayed on dashboards.

• Content - The body text of the communication.
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Holidays
Admin > My Company > Holidays

The Manage Holidays page specifies the holidays recognized by your company. Holidays are shown on company
calendars, so customers will know with your team is unavailable.

Editable Fields

• Holiday Name - The name of the holiday.

• From - The date the holiday begins.

• To - The date the holiday ends.

• Is Recurring - If Recurring, the holiday recurs each year.

• Status - If Active, the holiday displays on company calendars.

• Holiday Locations - The locations this holiday applies to.
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Administrative Work
Admin > My Company > Administrative Work

The Administrative Work page creates tasks used to track time against company activities not associated with projects
or tickets. Typically Administrative Work tasks are non-billable. Once created, tasks are available on employee
timesheets to classify time entries. Examples include paperwork, meetings, training, holidays, sick days, vacation, jury
duty, etc.

Editable Header Fields

The following header fields apply to all Administration Work tasks.

• Name - The display name for Administration Work category tasks.

• Status - The default status.

• Manager - The manager.

• Timesheet Route - The timesheet approval route.

• Expensesheet Route - The expense sheet approval route

Editable Task Fields

• Task Name - The name of the task

• Status - The status of the task

• Assign Work Type to the Administrative Task - The work type associated with this task. In most cases
Administrative Work tasks are set to Non Billable Labor Hours.
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Single Sign On
The Single Sign On page enables/disables integration with a single sign on (SSO) server.

• Enable Single Sign On to AuthAnvil™ - Yes or No

• Reply to URL - The URL of the single sign on SSO server.

• Upload Certificate / Delete Certificate - Uploads/deletes the certificate provided by the SSO service provider.
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Business Process
Email Templates 169

Approval Routes 171

Workflow 174

Admin > Business Process

The Admin > Business Process menu provides access to templates and records used by the Business Process module.
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Email Templates
Admin > Business Process > Email Templates

The emails you create and send to customers or employees are based on standard templates you maintain using the
Email Templates page. Email templates are classified by the module they apply to.

Many default email templates used by the system are not shown on the Email Templates page. You must create your
own custom email template and select it elsewhere in the system to override the default email template being used by
the system.

Email template examples include:

• Service Desk - Sending communications based on ticket creation, assignment, status changes, requests for
information and closure

• CRM - Sending quotations to prospects or customers

• HR - Welcoming new employees to logon the first time.

• Inventory - Sending a purchase orders to suppliers

• Finance - Sending invoice to your customers

• Client Portal - Sending new client portal user and reset client portal user password emails to your customers.

Field Placeholders

Field placeholders inserted into the body text of email templates enable you to quickly send out customer-specific or
employee-specific emails.

Editable Header Fields

• Email Template Name - The name of the email template.

• Description - A longer description of the email template.

• Module - The module using this email template.

• Status - If Active, this email template can be used.
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Editable Email Template Details

• From - Defaults from the Admin > My Company > Company Settings > General > Business Email field.

• CC - Additional recipients to copy.

• BCC - Additional recipients to blind copy.

• Subject - The subject of the message.

• Content - The body text of the message.

Note: If you want to support replies to emails sent out for tickets, include the Ticket Number field in the body text.

• Fields - Insert your cursor anywhere in the body text area of your message, then click any field listed in the Fields
list. A field placeholder will be inserted into the body text. When a message is sent these field placeholders are
resolved to specific values. The list of fields available to select is based on the module you select in the Module
field in the header.
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Approval Routes
Admin > Business Process > Approval Routes

The Approval Routes page defines approval processes in your company. An approval route refers to a specific sequence
of approval steps. Each step requires one or more approvers to approve that step.

• You can define an unlimited number of routes. Each route can have any number of approval steps.

• Modified routes only impact new employee actions, not those already in-route.

• Designated approvers get notified by email and the internal messaging system.

• Recursive approvals can be forwarded from one supervisor to the next, ascending the levels of the organizational
chart, for the number of levels you specify.

Approving Timesheets and Expense Reports

• Submitted time-sheets and expense-sheets can be managed using approval routes. Each employee's My
Approvals page in the Home module displays the timesheets and expense sheets waiting for their approval. If an
expense report is submitted and the approval route split, the report is split into sub reports, one for each project
manager approver.

• For projects, approval routes are assigned at the project-level. Each project may have its own unique approval route
to follow. If no route is assigned to a project, it defaults to auto-approval. Default approval routes for timesheets
and expense reports are assigned to Projects using the Admin > My Company > Company Settings > Project tab.

• Default approval routes for timesheets and expense reports are assigned to tickets using the Admin > My
Company > Company Settings > Service Desk tab.

• Default approval routes for timesheets and expense reports are assigned to administrative work using the Admin >
My Company > Administrative Work tab.

Creating New Approval Routes

1 Select the Admin > Business Process > Approval Routes page.

2 Click New.

3 Enter the following header fields:

– Route Name - The name of the approval route.
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– Route Description - A one line description of the approval route.

– Active - Yes

– Click Save. A new Steps section displays below the header fields.

4 Click Add Step.

5 Enter the following step fields:

– Step Name - The name of the step.

– Pick Step Type - The person approving this step.

• Specific Person(s) - A specific employee. Select one or more people from a drop-down list.

• Manager of Submitter - The manager of the employee. Managers of employees are specified in the HR
module.

• Project Manager - The manager of a project. Project managers are specified in the Projects module.

• Recursive Approval - Approvals are forwarded from one supervisor to the next, ascending the levels of the
organizational chart, for the number of levels you specify.

6 Repeat steps 4 and 5 to add as many additional approval steps as your approval process requires.
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Workflow
Admin > Business Process > Workflow

The Workflows page defines workflows that automate the processing of tickets when triggers and conditions are met.
For example you can use a Workflow:

• When Tickets are Assigned - Based on the source, priority, issue or client, or any combination of these conditions,
automatically assign the ticket to the best person in your company.

• When Tickets are Reassigned or Escalated - If a ticket sits idle for too many days or hours, automatically send a
reminder or re-assign the ticket to another technician and bump the priority to a higher level.

• When Tickets are Edited - We can send a notification if a note or time is entered on a ticket.

• When Tickets are Resolved - Send an email with a summary of what was done with a 'thank you' message
included.

Creating Workflows

1 Select the Admin > Business Process > Workflow page.

2 Click New.

Note: You can also Clone an existing workflow and modify it.

3 Ensure the Workflow Rule tab is selected.

4 Enter the following header fields:

– Workflow Name – The name of the workflow.

– Description - A one line description of the workflow.

– Active - If Yes, the workflow is being used.

5 Define Triggers for ticket workflows in the Triggers section.

– Created By - Anyone, Employees, Clients

– Updated By - Anyone, Employees, Clients

Note: An update is a change of status, change of primary assignee or queue, change of priority, change of ticket
type.

– Activity Added By - Anyone, Employees, Clients
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Note: An activity is a time entered, note added, or expense entered.

– Activity Type - Time, Expense, Activity

– Idle For - The tickets sit idle—with no activities or no time entries—for hours or minutes.

– Due In - The ticket has a due date on it and that date is approaching, in hours or minutes

– Overdue By - The due date has passed, in hours or minutes.

– SLA First Response Due In - Specifies when an SLA first response is due and sends an alert, in hours or
minutes.

– SLA First Response Overdue By

– SLA Resolution Due In - Specifies when an SLA resolution is due and sends an alert, in hours or minutes.

– SLA Resolution Overdue By - Specifies when an SLA resolution is past due and sends an alert, in hours or
minutes.

6 Select the Conditions tab.

– Each condition provides a set of comparison operators. Comparison operators can include: In, Not In,
Changed, Changed From, Changed To, Is Empty, Is Not Empty, Like, Not Like, Greater Than, Less
Than, Greater or equal, Less or equal, Between

The following fields are set in the Tickets section of the Conditions tab. These conditions test for values in the ticket.

7 Use the Tickets section to set conditions for values in the ticket.

– Status - Changes the status of a ticket.

– Priority - Sets the item's priority

– SLA

– Issue Type - Updates the issue type.

– Sub-issue Type - Updates the sub-issue type.

– Source

– Ticket Type - Updates the ticket type.

– Queue - Assigns a ticket to a queue.

– Primary Assignee - Assigns a primary technician

– Title

– Details

– Satisfaction Score

– Ticket Sender Email

– Service Contract

– Work Type
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– Open Data

– Due Date

– Account Type

– Account

– Service Type

8 Use the Accounts section to set conditions for values in the CRM account associated with the ticket.

– Account Type

– Account Name

– Location

– Description

– Service Type

– Account Code

– Business Type

– Account Manager

– Status

– Acquired Date

9 Use the Contacts section to set conditions for values in the CRM account contact record associated with the ticket.

– First Name

– Middle Name

– Last Name

– Job Title

– Status

– Point of Contact

– Receive Invoices

– Has Client Portal Access

10 Use the Assets section to set conditions for assets associated with the ticket.

– Name

– Description

– Category

– Business Impact

– State
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– Brand

– Manufacturer

– Machine Group ID

– Product Name

– Serial

– Model Number

– Asset Tag

– Acquisition Date

– Expiration Date

– Warranty Expiration Date

– Barcode

– Vendor

11 Use the Custom Fields section to set conditions for custom fields added to the ticket.

12 Define the actions taken using the Updates tab.

– Account - Assigns the ticket to an account.

• Updates the ticket with the default contract for the account.

• Updates the SLA with the SLA specified by the default contract.

– Status - Changes the status of a ticket.

– Priority - Sets the item's priority

– SLA

• Updates the SLA with this SLA, overriding the SLA specified by any contract.

– Issue Type - Updates the issue type.

– Sub-issue Type - Updates the sub-issue type.

– Ticket Type - Updates the ticket type.

– Queue - Assigns a ticket to a queue.

– Primary Assignee - Assigns a primary technician

– Contract - Enter an account to enable this drop-down list.

• Updates the ticket with this contract, overriding the default contract for the account.

• Updates the SLA with the SLA specified by the specified contract.

PulsewayPSA Guide

Release 4.0.41 | March 2021

https://www.pulseway.com/


13 Select the Notification tab.

14 Specify who will be notified when a workflow is triggered.

– Assigned Queues - Yes or No. Notifies all users who are members of the listed queue assigned to the ticket.

– Assigned Resources - Yes or No. Notifies the primary assignee or secondary assignees assigned to the ticket.

– Account Associate Resources - Yes or No. Notifies all resources added to the CRM > Account >Associated
Resources tab for this client.

– You can also add specific employees by name.

15 Select the customers to be notified in the Client section. Contacts only display in this section if clients were selected
in the Workflow Rule > Conditions > Client drop-down list.

– Ticket Contact - If Yes, clients are notified if they submitted a ticket.

– Point of Contacts - If Yes, clients are notified if they are designated the point of contact for a customer account.

16 Select the email template used to create notifications for this workflow.
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17 Click Save.
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HR (in Admin)
Admin > HR

Note: See Human Resources for a description of these support tables. The same support tables can be accessed in
the user interface using either the Admin module or the Human Resources module.
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CRM (in Admin)
Accounts 182

Opportunity Statuses 183

CRM Account Types 184

Service Types 185

Admin > CRM

CRM stands for customer relationship management. A CRM solution allows you to manage the business relationship
and interactions you have with customers, prospects, vendors, etc., and store all the data about these relationships.
These interactions can be sales related—calls, emails, meetings and demonstrations - as well as support related—service
tickets and projects. The benefit of a CRM is having all your business data stored and accessible from one central
location. The CRM module provides:

• Immediate employee access to the data they need.

• Sharing of important data between departments.

• Management insight into activity across the organization and helps them understand where they can improve
processes.

Customers are first added as accounts in CRM. After that you can create projects, open tickets, and set up contracts on
their behalf.
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Accounts
Admin > CRM > Accounts

Note: See Accounts in the CRM module for a description of these support tables. The same support tables can be
accessed in the user interface using either the Admin > CRM menu or the CRM module.
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Opportunity Statuses
Admin > CRM > Opportunity Statuses

The CRM Account Types page maintains a status list for opportunities.

Creating Opportunity Statuses

1 Select the Admin > CRM > Opportunity Statuses page.

2 Click New.

3 Enter the following fields.

– Name

– Base Status

– Probability

– Is Active - Yes or No

– Include in Pipeline - Yes or No

– Description
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CRM Account Types
Admin > CRM > CRM Account Types

The CRM Account Types page maintains a list used to identify primary business relationships with accounts. By default,
this list includes Client, Competitor, Former Client, Miscellaneous, Partner, Unknown, Vendor. In addition you
can flag an account as either a client or vendor or both.

Creating Account Types

1 Select the Admin > CRM > CRM Account Types page.

2 Click New.

3 Enter the following fields in the Account Types header section.

– Account Type Name

– Status - Active or InActive

– Client - Yes or No

– Vendor - Yes or No
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Service Types
Admin > CRM > Service Type

The Service Type page defines basic records used to classify CRM accounts. Service types are subsequently assigned to
scopes. A scope determines which users have access to which tickets, based on security types assigned the scope and
the CRM account assigned the ticket.

You define the following for a service type:

• Name

• Description

• Active

• Default
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Security
Roles 187

Scopes 191

186 PulsewayPSA Guide

Release 4.0.41 | March 2021

Chapter 3: Admin www.pulseway.com

https://www.pulseway.com/


187

Chapter 3: Adminwww.pulseway.com

Roles
Admin > Security > Roles

The Roles page determine the access an employee has to different modules, menus and selected settings. The system
provides several predefined security roles for both internal and external users. You can also add custom security roles. A
person assigned multiple security roles has access to the combined privileges of all assigned roles. Certain permission
categories include special features.

Pre-Defined Security Roles

• Six (6) pre-defined internal roles - Administrator, Project Manager, CRM Manager, Finance Manager,
Service Desk Manager, and User.

• Two (2) pre-defined external roles - External User and External Manager. These are used by clients using
Client Portal.

Pre-Defined
Internal

Roles

Description

Administrator The highest level of permissions. Complete access to add/edit/delete, and configure any
record across the system.

Project
Manager

Access to Project Management modules and related reports. Add/edit/delete projects,
clients, approval routes, and employees. Also, adjust/approve time and expense-sheets.

CRM
Manager

Access to CRM modules and related reports. Add/edit/delete customer contacts,
opportunities, activities, and customer quotes.

Finance
Manager

Access to Finance modules and related reports. View/update/process billing, invoicing,
receivables, account setups, and payments.

Service Desk
Manager

Access to Service Desk module and related reports. Add/edit/delete service desk settings in
Admin module. Create workflow rules, etc.

User Access restricted to personal information, time and expense sheet entries, and time-off
requests.

Special Features

You can enable special features for certain categories of permissions.

• Home

– Access to All Employees Timesheet Data ORG Chart

– Access to All Employees Expense Data (Bypasee ORG Chart)

• Service Desk
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– Quick Add Ticket - If checked, a blue New Ticket button displays in the header. Users can click the button to
add a new ticket immediately from anywhere in the user interface.

– Live Connect - If checked, enables Live Connect access from a ticket to a corresponding hardware asset.

– Customer Survey Scores - If checked, enables visibility of survey score data.

• CRM

– Access to All Employees CRM Data (Bypass ORG Chart)

• Projects

– Access to All Employees Project Data (Bypass ORG Chart)

– Hide Financials Tab on Projects

• HR

– Bypass Timesheet and Expense Sheet Approvals

Quick Tickets

Security roles have a Client Portal option called Quick Tickets. When checked in a security role, customers are presented
with a simplified page layout when adding new tickets. If unchecked, customers are presented with the same page
layout that employees see.

Adding Security Roles

1 Select the Admin > Security Roles page.

2 Click New.

3 Enter the following fields in the Security Role Information header section.

– Name

– Description

– Client

• Internal - This security role can only be assigned to employees and not to CRM customer account
Contacts given client portal access.

• External - This security role can be assigned to both employees and to CRM customer account Contacts
given client portal access.

– Status - Active or InActive
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4 Expand each permission category displayed on the Permissions tab.

5 Optionally toggle the Allow View All or Allow Modify All buttons to check or uncheck all checkboxes in a permission
category.

– View - Allows users assigned this security role to view data.

– Modify - Allows users assigned this security role to change data.

6 Optionally check or uncheck each item in an expanded category separately.

7 Optionally enable special features at the bottom of each category. Not all categories have them.
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8 Click the Role Users tab.

9 Click Add.

10 Select one or more users to assign them to this security role.

11 Click OK.

12 Click Save the save the security role.
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Scopes
Admin > Security > Scopes

The Scopes page determines employee access to user-defined data in the system. Currently scopes only control
employee access to user-defined data in Service Desk tickets, and only if the CRM account has been assigned a service
type.

Note: By default Service Desk users continue to have read/write access to all tickets created for all CRM accounts
that have not been assigned a service type controlled by a scope.

Configuration

1 Create Service Types.

2 Assign service types to accounts using the CRM >Accounts > Account tab > Service Type field.

3 Create a new scope using the Admin > Security > Scopes page.

4 Add service types to the scope record you just created.

– Each scope can include multiple service types.

– Select the Service Desk Permission Type.

• Read/Write

• Read Only

• No Access

5 Add users to the scope record you just created.
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Admin > Finance Roles

The Finance menu in the Admin module defines support tables used by all your financial transactions. This includes:

• Roles and rates for your employees

• Work types

• Services and their unit price

• Expense categories for employee billing
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Roles
Admin > Finance > Roles

The Manage Roles page defines roles used by employees to classify the work bill billed to customers.

• Each role has a defined default billing rate.

• Roles are applied when entering labor time on tickets or project tasks.

• Roles are assigned to by employee or by job title.

• Employees assigned multiple roles can usually select any of their roles when working a task or ticket.

• In Projects, the project manager can lock down the role when assigning a task to an employee.

• You can override role rates by creating a 'New Time and Material Contract' for a specific customer.

Creating Roles and Rates

1 Select the Admin > Finance > Roles page.

2 Click New.

3 Enter the following fields.

– Role Name

– Description

– Billing Rate - The per hour billing rate.

– Status - Active or InActive

4 Click Save.
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Work Type
Admin > Finance > Work Type

The Work Type page maintains a list used to classify the work performed on tickets and tasks. You can optionally specify
a custom billing rate by work type that overrides the billing rate specified by a user's selected role on a ticket or task.

• Work types are used for tracking and reporting purposes

• Work types are match them to your general ledger codes on the Billing Configuration page.

• You can create additional work types to apply a custom rate to labor time entries on a ticket.

Creating Work Types

1 Select the Admin > Finance > Work Types page.

2 Click New.

3 Enter the following fields.

– Work Type Name

– Description

– Status - Active or InActive

– Invoice

• Non-Billable do not show on Invoice

• Non-Billable show on Invoice

• Billable

– Overtime Multiplier Rate - Multiplies the hourly billing rate for overtime. Defaults to 1.

– Billing

• Use Role Rate - Billings use the hourly rate specified for the role the user selects in a ticket or task.

• Use Custom Rate - If selected, the Custom Rate field displays. Enter a custom hourly billing rate for this
work type.

4 Click Save.
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Services
Admin > Finance > Services

The Services page maintains a list of standard services. A service is work performed for a customer that is billed on a
weekly, monthly, quarterly, or annual basis and is typically part of a recurring service contract. A flat fee is specified for
each type of device or service that is supported in your client’s environment. These services are available in a drop-down
list when building recurring contracts using the Finance Module > Contracts page.

Creating Services

1 Select the Admin > Finance > Services page.

2 Click New.

3 Enter the following fields.

– Service Name

– Description

– Unit Price

– Unit Cost

– Status - Active or InActive

– GL Account - Select general ledger account to record postings.

– Taxable - Taxable or Non Taxable

4 Click Save.
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Expense Type
Admin > Finance > Expense Type

The Expense Type page maintains a list of standard expenses types—meals, travel, lodging., etc.—that employees may
incur during work related activities. Expenses can be:

• Entered costs on a ticket, project task, or regular expense sheet

• Marked as billable

• Marked as reimbursable

• Defined on a per unit basis. For example, mileage.

Expense rules can:

• Limit the expense amount entered per category

• Allow a specific user to enter an amount over the standard limit

• Require a receipt be attached to expense.

• Be applied by individual employee

• Be applied by department

Creating Expense Types

1 Select the Admin > Finance > Expense Type page.

2 Click New.

3 Enter the following fields in the Details section.

– Name

– Description

– Per Unit - If Yes, a Unit Amount field displays. For example, mileage.

– Billable - Yes or No

– Allow Billable Modification - Yes or No

– Is Attachment Required - If Yes, an attachment, typically a receipt, is required to record an expense.

– GL Account - Select general ledger account to record postings.

– Taxable - Taxable or Non Taxable

– Available for

• Employees

• Vendors - For example, you may wish to specify rent or utilities to as a vendor expense type those
expenses appear in the Finance module to pay vendors.

• Employees and Vendors
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– Active - Yes or No

4 Specify rules by clicking Add in the Rules section.

– Name - The name of the expense type rule.

– Department - The department this expense type is applied to.

– Resources - The employee this expense type is applied to.

– Limit Amount - The amount this expense type is limited to.

– Overage - If yes, the use or department, can override the Limit Amount.

5 Repeat step 4 for as many rules as appropriate for this expense type.

6 Click Save.
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Milestone Type
Admin > Finance > Milestone Type

The Milestone page maintains a list of standard milestone types. A milestone type specifies the % total fee a client pays
over the course of a project. Instead of paying everything upfront, payments are divided into milestones. For example a
client could pay you 40% upfront, then 30% mid-project, then pay the last 30% on project completion. In the Contracts
module, when creating a fixed price contract, these milestones are available in a drop-down list to quickly create phased
billing.

Creating Milestone Types

1 Select the Admin > Finance > Milestone Types page.

2 Click New.

3 Enter the following fields.

– Milestone Type Name

– Description

– Status - Active or InActive

– GL Account - Select general ledger account to record postings.

– Taxable - Taxable or Non Taxable

4 Click Save.
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Account Type
Admin > Finance > Account Type

The Account Type page maintains a list of standard account types. Account types are used to group general ledger
account codes. For example, Accounts Receivable (A/R), Accounts Payable (A/R), and Expenses.

Creating Account Types

1 Select the Admin > Finance > Account Types page.

2 Click New.

3 Enter the following fields.

– Account Type Name

– Description

– Status - Active or InActive

– GL Account - Select general ledger account to record postings.

– Taxable - Taxable or Non Taxable

4 Click Save.
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Account Code
Admin > Finance > Account Code

The Account Type page maintains a list of account codes. Sub-accounts are supported by specifying the parent account
of an account code. Account codes are used to integrate with matching accounts codes in an integrated accounting
software package such as QuickBooks.

Creating Account Types

1 Select the Admin > Finance > Account Code page.

2 Click New.

3 Enter the following fields.

– Account Code

– Description

– Status - Active or InActive

– Account Type

– Parent Account

4 Click Save.
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Discount Type
Admin > Finance > Discount Type

The Discount Type page maintains a list of standard discounts types. A discount type specifies a percentage or amount
to optionally discount an invoice. The default value can be overridden.

Creating Account Types

1 Select the Admin > Finance > Discount Types page.

2 Click New.

3 Enter the following fields.

– Name

– Value

– Discount Type - Amount or Percentage

– Description

– GL Account

– Taxable - Taxable or Not Taxable

4 Click Save.
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Charge Type
Admin > Finance > Charge Type

The Charge Type page maintains a list of standard charge types. Charge types specify additional charges entered when
maintaining an invoice. For example, you may wish to add a one time handling fee to an invoice.

Creating Account Types

1 Select the Admin > Finance > Charge Type page.

2 Click New.

3 Enter the following fields.

– Charge Type Name

– Description

– Status - Active or InActive

– GL Account

– Taxable - Taxable or Not Taxable

4 Click Save.
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Billing Configuration
Admin > Finance > Billing Configuration

The Billing Configuration page assigns accounts codes to values defined in other Finance setup tables. Accounts codes
can be specified separately for each value in each Finance setup table. Account codes are used to integrate with
matching accounts codes in an integrated accounting software package such as QuickBooks.

Creating Billing Configuration

1 Select the Admin > Finance > Billing Configuration page.

2 Enter accounts for fields in the Work Types tab.

– Income Account

– Expense Account

– Taxable

3 Repeat step 2 for each of the following tabs.

– Expense Types

– Services

– Milestone Types

– Discount Types

– Products
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– Charge Types

– Taxable

4 Click Save.
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Sales Tax Items
Admin > Finance > Sales Tax Items

The Sales Tax Items page maintains a list of standard sales tax items. You can also group tax rates together using group
tax items.

Creating Sales Tax Items

1 Select the Admin > Finance > Sales Tax Items page.

2 Click New.

3 Enter the following fields.

– Name

– Tax Rate - Enter a percentage.

– Tax Agency - A CRM account classified as a vendor.

– Tax Group - Accept default No.

– Description

4 Click Save.

Creating Group Tax Items

1 Select the Admin > Finance > Sales Tax Items page.

2 Click New.

3 Enter the following in the Sales Tax Item Info tab.

– Name

– Tax Group - Yes.

– Description

4 Enter the following in the Group Tax Items tab.

– Click Add.

– Select one or more sales tax items.

– Click OK.

5 Click Save.
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Exchange Rates
Admin > Finance > Exchange Rates

The Exchange Rates page maintains a list of exchange rate records, one for each pair of currencies in the system. After
saving an exchange record for the first time, you can add additional records specifying exchange rate values and the
dates these exchange rates take effect.

Creating Exchange Rate

1 Select the Admin > Finance > Exchange Rates page.

2 Click New.

3 Enter the following fields.

– Currency From - Select a currency.

– Currency To - Select a currency.

4 Click Save. An Exchange Rate Values tab displays.

5 Click Add and enter values for the following fields.

– Exchange Rate Date - The date the exchange rate takes effect.

– Exchange Rate Value - The multiplier used to convert FROM currency amounts to TO currency amounts.

6 Repeat step 5 each time you want define a new exchange rate and the date when it takes effect.

7 Click Save again.
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Class List
Admin > Finance > Class List

The Class List page maintains a multi-level list of class names. Classes provide an alternate way of classifying income
and expenses from the chart of accounts. For example you could classify income and expenses by department, location,
property, project or event. Once created and assigned to transactions, you can filter reports by class.

Creating Class Lists

1 Select the Admin > Finance > Class Lists page.

2 Click New.

3 Enter the following fields.

– Class Name

– Status - Active or InActive

– Add Parent Class - If Yes, select a Parent Class from the drop-down list.

4 Click Save again.
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Inventory (in Admin)
Warehouses 210

Product Categories 211

Admin > Inventory

The Inventory menu in the Admin module defines support tables used by your inventory operations.
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Warehouses
Admin > Inventory > Warehouses

The Warehouses page specifies the physical dimensions and maximum weight allowed for each warehouse.
Warehouses are required to store inventory quantities.

Inventory quantities are stored in a default "virtual" location. Received quantities are also stored temporarily in the
default virtual location. The location is identified by the Warehouse Prefix and word Default. For example,
W0987_:Default.

Creating Warehouses

1 Select the Admin > Inventory > Warehouses page.

2 Click New.

3 Enter the following fields in the Warehouse section.

– Warehouse Name

– Description

– Width / (unit of length)

– Height / (unit of length)

– Depth / (unit of length)

– Max Weight / (unit of weight)

– Warehouse Prefix

4 Click Save.
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Product Categories
Admin > Inventory > Product Categories

The Product Categories page specifies categories and sub categories products. These are used to classify inventory.

Creating Product Categories

1 Select the Admin > Inventory > Product Categories page.

2 Click New.

3 Enter the following fields in the Category Info section.

– Category Name

– Description

– Status - Active or InActive

4 Click Add to add a sub categories in the Sub Categories section.

– Name

– Description

– Is Active

5 Repeat step 4 to add additional sub categories as required.

6 Click Save.
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Email Logs
Admin > Logs > Email Logs

The Email Logs page provides an audit of all outbound email used to notify customers.

Note: A similar log is provided for each email parser used to process inbound email from customers.

On the list page you can:

• Search for emails using the From, To, Display Name, Subject and Body fields, or by date range.

• Export the email log.

Click any single row to see the details of that email:

• The Email Log Info tab shows the content of the email.

• The Email Log History tab shows a history of email sending events.

• You can Delete, Resend or Forward the email.

• Clicking Forward displays dialog that enables you to edit the email before you forward it.
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Import Data
Admin > Imports & Exports > Import Data

The Import Data page imports customer accounts and contacts from other PSA vendor systems. Currently only
ConnectWise systems can be imported.

Importing Data from ConnectWise

In ConnectWise

1 Create public and private keys.

2 Login into ConnectWise.

3 Navigate to My Account.

4 Click the API Keys tab.

5 Click the + icon.
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6 Enter Integration as the Description, then save the record. The page should refresh.

7 Make note of the displayed Public Key and Private Key.

In

1 Start a data import job.

2 Login into .

3 Select the Admin > Imports & Exports > Import Data page.

4 Click the ConnectWise logo.

5 Enter the following ConnectWise authentication details:

– Public Key

– Private Key

– Server

• If your customer login URL looks like this...
na.myconnectwise.net
... the API URL for Data Import needs to be entered as this:
api-na.myconnectwise.net/v4_6_release/apis/3.0/

• In this example, na changes to api-na.

• Append /v4_6_release/apis/3.0/ to the end of the URL.

– Company

Job Processing and Notification

will queue your job and process it. When processing completes you will be notified by email. The following is a sample
email:

<your_<A>_account_name>,

Your ConnectWise data import has been completed.
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8 Client Accounts and 13 Contacts were imported from your
ConnectWise account to .

For questions and assistance, contact Support.

Thank you,
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Admin > Service Desk

The Service Desk menu in the Admin module defines support tables used by all your service desk operations. This
includes values required to create, classify, assign, track and report on tickets in the system.
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Issue Types
Admin > Service Desk > Issue Types

The Issue Types pages maintains the list of issues and sub-issues that customers typically request support for in your
system. This list is useful for tracking and reporting purposes. You can use workflows to automate responses to
customer support requests, based on the issue type assigned to the request. Issue types and issue sub types can be
included in an SLA objective.

Creating Issue Types

1 Select the Admin > Service Desk > Issues Types page.

2 Click New.

3 Enter the following fields in the Issue Type Info section.

– Issue Type Name

– Description

– Status - Active or InActive

4 Click Add to add a new record in the Issues Sub Types section.

– Name

– Description

– Status - Active or InActive

5 Repeat step 4 to add more issue sub types.

6 Click Save.
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Ticket Types
Admin > Service Desk > Ticket Types

The Ticket Types pages maintains a list of ticket types used to classify tickets. You can create a workflow, run reports
and create views based on ticket type.Types of tickets could include:

• Service Request: A request from a user for information, or advice. A service request can be for a move, add or
change, which relocates, changes or installs some equipment or service. This could be an installation of an
application, purchasing hardware or providing additional access.

• Incident Ticket: An unplanned interruption to an IT service. An Incident is when something the customer currently
has is broken and needs to be fixed as soon as possible. These are commonly referred to as "break/fix tickets."

• Problem Ticket: A cause of one or more Incidents. A problem is a condition often identified as a result of multiple
incidents that exhibit common symptoms. A problem can also be identified from a single incident, but this incident
is significant any can affect many users. For example, a server is down, this problem would create multiple incident
request and affects many.

• Change Request: A ticket requesting a significant change that may require approval from someone within the
clients’ organization.

Creating Issue Types

1 Select the Admin > Service Desk > Ticket Types page.

2 Click New.

3 Enter the following fields.

– Ticket Type Name

– Description

– Status - Active or InActive

4 Click Save.
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Queues
Admin > Service Desk > Queues

The Queues page maintains the ticket queues used by your Service Desk module. Tickets are assigned to queues.
Technicians assigned to a queue are responsible for working the tickets in that queue. A workflow can automatically
assign a ticket to a queue, based on the settings of the ticket. You can search for all tickets assigned to the queues you
are a member of using the Queue search parameter on the My Tickets page.

• You create a queue first.

• Then you add employees to the queue.

Creating Queues

1 Select the Admin > Service Desk > Queues page.

2 Click New.

3 Enter the following fields in the Queue Information section.

– Name

– Description

– Status - Active or InActive

4 Click Add to add one or more employees in the Queue Users section.

– Select one or more rows in the employee list.

– Click OK.

5 Click Save.
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Priorities
Admin > Service Desk > Priorities

The Priorities pages maintains a list of priorities used to rank the urgency or importance of tickets in the Service Desk
module. Each priority is assigned a color to help you quickly identify high priority tickets in your dashboard. Priorities can
be included in an SLA objective.

Creating Priorities

1 Select the Admin > Service Desk > Priorities page.

2 Click New.

3 Enter the following fields.

– Priority Name

– Description

– Color - Select a background color from the color picker.

4 Click Save.
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SLAs
Admin > Service Desk > SLAs

The SLAs page maintains a list of service level agreements. A service level agreement (SLA) is an agreement between a
service provider and the customer that defines the level of service expected from the service provider. It defines the
response time, escalations and potentially, resolution times per incident in a contract format between you and your
customer. The SLA specifies, in measurable terms, how your company responds to the client’s needs and service
requests. SLAs are critical towards formalizing expectations around services with end users and customers. Without
these, customer expectations will assume that everything will be delivered and available at a 100% level all the time.
These SLAs can be individualized for each client based upon your contract agreement with them.

Tickets

• A Default SLA is set for all tickets using the Admin > My Company > Company Settings > Service Desk tab.

• Email parsers calculate the SLA Time to Resolution when a new ticket is added.

• The SLA Time to Resolution is paused whenever a ticket is in the waiting for customerstatus.

• For tickets assigned an SLA, when editing a ticket you will see a link next to an SLA Status field on the Ticket View
tab. Click this link to see the estimated and actual times specified for resolving the ticket by the SLA.

Workflows

Workflows contain several SLA options that affect how tickets are processed.

Triggers

• SLA First Response Due In - Specifies when a SLA first response is due and sends an alert, in hours or minutes.

• SLA Resolution Due In - Specifies when a SLA resolution is due and sends an alert, in hours or minutes.

• SLA Resolution Overdue By - Specifies when a SLA resolution is past due and sends an alert, in hours or minutes.

Conditions

• SLA - A ticket is assigned/not assigned to one or more selected SLAs.

Update

• SLA - Assigns a ticket to a specified SLA.

Contracts

• Contracts can also be assigned to SLAs. A contract associated with an SLA overrides the Default SLA when the
ticket is linked to the contract.

Creating SLAs

1 Select the Admin > Service Desk > SLAs page.

2 Click New.

3 Enter the following fields in the Service Level Agreement Information section.
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– SLA Name

– Description

– Business Hours Of: - Select one of your company's locations. Each location specifies the hours it is available to
be contacted by customers.

– Status - Active or InActive

4 Click Save.

5 Click the new SLA row you just created to open it again.

6 Click Add and enter the following fields in the SLA Objectives section.

– Priority

– Issue Type

– Issue Sub Type

– Timeframe - The timeframe specifies how SLA response times are calculated:

• All (24x7) - Using all 24 hours, seven days a week.

• Business Hours - Using the business hours defined for this location. For example, a location defines
business hours as 8:00 a.m to 5:00 p.m., Monday through Friday. You have a 4 hour SLA for an incident
and the ticket comes in at 3:00 p.m. on Monday. Based on these hours of operation, you have until 10:00
a.m. on Tuesday to respond.

• Extended - Using business hours and the hours beyond the normal end of the same workday for this
location. Excludes weekends and holidays. For example, a location defines business hours as 8:00 a.m to
5:00 p.m., Monday through Friday. You have an 8 hour SLA for an incident and the ticket comes in at 3:00
p.m. on Monday. Based on these hours of operation, you have until 11:00 p.m. of the same day, Monday,
to respond.

– Resolve Time (in hours)
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– Click Save.

7 Repeat step 6 to add as many SLA Objectives as you require.

8 Click Save.
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Ticket Statuses
Admin > Service Desk > Ticket Statuses

The Ticket Statuses page maintains a list of ticket status records. A ticket's status identifies where it is in the process of
being resolved. The system comes with several pre-defined statuses. You can create additional statuses to meet your
business requirements. Each status is assigned a color to help you quickly identify the status of tickets in your
dashboard. Typically statuses include:

• New - The ticket has not yet been worked on.

• In Progress - The ticket is being worked on.

• Waiting for customer - The ticket is waiting for the customer to respond to a query from your company.

• Complete - The ticket has been resolved.

New, Waiting for Customer and Completed statuses cannot be made inactive.

Creating Ticket Statuses

1 Select the Admin > Service Desk > Ticket Statuses page.

2 Click New.

3 Enter the following fields:

– Status Name

– SLA Event - The selected SLA event is calculated based on setting a ticket to this status.

– Display Order - Tickets can be sorted in drop-down lists based on this ranking. The sort order of ticket pages
can also be optionally affected by the Sort Status By option.

– Description

– Color - Displays the status of a ticket using this background color.

– Font Color - Displays the status of a ticket using this font color.

– Status - Active or InActive

4 Click Save.
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Email Parser
Admin > Service Desk > Email Parser

The Manage Mailboxes page maintains configuration settings for email parsers. Each active email parser converts
incoming email into support tickets. Email messages are parsed into separate elements, then each element is mapped
to the appropriate field of a new service desk ticket. With the email parser you can:

• Create new tickets from emails sent to support@mycompany.com

• Add attachments from emails to the ticket

• Auto notify the sender of the success or failure of ticket creation

• Auto assign the ticket to a queue

• Take email responses from customers and add it as note to an existing ticket

• Review "unknown" submissions and convert them to tickets or discard them using the Service Desk > Unknown
Tickets page.

Email Submitted by Employees

Email parsers create tickets using the internal client account when the email is submitted by an employee that has no
contact record. When a new ticket is created using the email address of both an employee and a contact, the new ticket
is associated with the client account of the contact. Subsequent replies to tickets using an email address shared by a
contact and employee are added as employee notes and not as client notes.

Logs and Notifications

Use the Logs tab to help troubleshoot issues with processing inbound emails using an email parser. The Notifications tab
specifies who to notify for different types of email parser events.

Creating Email Parsers

1 Select the Admin > Service Desk > Email Parser page.

2 Click New.

3 Enter the following fields in the Basics section.

– Mailbox Name

– Email

Note: Aliases for inbound email addresses are not supported.

– Password

– User Name

– Status - Active or InActive

– Add Attachments to Tickets - Yes or No

4 Enter the following fields in the Defaults tab. These are the default values for the ticket created from email.
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– Priority

– Queue

– Primary Assignee

– Ticket Type

– Ticket Note Type

5 Enter the following fields in the IMAPs tab.

– Incoming Mail Server - Must be an IMAP server. POP is not supported.

– Server Port Number - Defaults to a value based on the encryption type selected.

– Encryption Type - SSL, TLS or Non-Encrypted

– Search Folder - Optionally specify a different email folder to check for new inbound email. Defaults to Inbox.

6 Enter the following fields in the Notifications tab > Notify Sender section.

– On Success Template

– On Failure Template

– Reply to

– Sender - Sends reply email only to the sender of the original inbound email.

– All (CC) - Sends reply email to all email recipients, including recipients copied (CC) on the original inbound
email.

Note: Email templates are maintained using the Admin > Business Process > Email Templates page.

7 Enter the following fields in the Notifications tab > Notify Internal Resources section.

– On Success Template

– Notified Internal Resources - Select one or more employees.

– Notified Others - Email recipients.

– On Failure Template

– Notified Internal Resources - Select one or more employees.

– Notified Others - Email recipients.

8 Enter the following fields in the Black List tab. Ignores email sent from these addresses.

– Email Address

9 Click Save.
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Customer Thermometer
In Customer Thermometer

1 Watch a video that explains how to 'Embed 1-click icons inside your ticket notifications' provided by Customer
Thermometer.

2 Generate Customer Thermometer feedback buttons and tracking links.

3 Copy the code in the 'HTML code for pasting' text box provided by Customer Thermometer.

In PulsewayPSA

4 Paste code from the 'HTML code for pasting' text box into the Template Content tab of your new integration record
on this page.

5 Add the %CUSTOMER_SURVEY_Customer_Thermometer%] field placeholder to any email template you wish to use to
display a survey link when an email notification based on that template is sent out.

6 Optionally configure a workflow notification to use the email template with the survey link. Otherwise you must
remember to select the email template when sending email notifications manually.
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Organizational Chart 252

The following support tables are configured for human resource tracking and reporting purposes. When completed you
will be able to:

• Run reports based on your company's job titles and departments.

• Send messages to your company's departments.

• Classify projects worked on by your company's departments.

• Generate an organization chart in the Human Resources module based on your company's departments and job
titles.

230 PulsewayPSA Guide

Release 4.0.41 | March 2021

Chapter 5: HumanResources www.pulseway.com

https://www.pulseway.com/


231

Chapter 5: HumanResourceswww.pulseway.com

Dashboard
Note: See the Home > Dashboard for a description of this topic. The same Dashboard displays in the Home, Admin

and HR modules.
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Departments
HR > Departments

Admin > HR > Departments

Creating Departments

1 Select the Admin > HR > Departments page.

2 Click New.

3 Enter the following fields:

– Department Name

– Description

– Manager

– Annual Budget - The annual budget of this department.

– Cost Center - The account cost center associated with this department.
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Job Titles
HR > Job Titles

Admin > HR > Job Titles

Creating Job Titles

1 Select the Admin > HR > Job Titles page.

2 Click New.

3 Enter the following fields:

– Job Title

– Description

– Status - If Yes, this job title is used.
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Skill Categories
HR > Skill Categories

Admin > HR > Skill Categories

The Skill Categories page defines job skills referenced by other modules. For example:

• Admin > HR > Employees

• Projects > (any project) > (any task)

Creating Skill Categories

1 Select the Admin > HR > Skill Categories page.

2 Click New.

3 In the Skill Category section add the following:

– Skill Category Name

– Description

4 In the Skill section enter the following:

– Name

– Description

5 Click Add to add addition skills as necessary.
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Employees
Contact Information 238

Wages 239

Shifts 241

Associated Clients 242

Associated Queues 243

Custom Fields (for Employees) 244

Employee Roles 245

Security Roles 246

Attachments (for Employees) 247

Education 248

Skills 250

HR > Employees

Admin > HR > Employees

The Employees page maintains your company's employee profiles. This same page displays in the HR module if you
have permission. Initially you create a basic profile. After you save an employee profile the first time, multiple tabs
display for you to enter additional details.

Creating Employee Profiles

1 Select the Admin > HR > Employees page.

2 Click New.

3 Enter the following basic fields in the New Employee page.

– User Name

– First Name

– Last Name

– Emp ID

– Email Address

– Job Title

– Department

– Manager

– Employment Type

– Employee Roles
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– Security Roles

– Location

4 Click Save.

– A new user can start using the system with just this basic information.

– The new user is automatically sent an email with login credentials, similar to the image below.

5 Click the row of the employee profile you just created to add additional information.

– The Edit Employee page displays.

– Use the additional fields and tabs to maintain more details about an employee.

6 The first tab, the Personal Details tab, provides the following additional fields.

– Hire Date

– Termination Date

– Birthday

– SSN - Social security number

– Marital Status

– Status - If Yes, this is a current employee.

Note: You cannot delete employee profiles. Set an employee's Status to No so you can see continue to see historical
data associated with this employee.

– Gender

– Photo - Upload a photograph of your employee. Employee photos display on their dashboard when they login

– Password Management

• Reset and Email Password - Resets the user password when the user has forgotten the password. A
randomly generated password is sent by email to the user.

• Unlock User's Account - Unlocks a user account if the account has become locked after several invalid
login attempts.
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Note: The user can also optionally change his or her password in the My Profile page.
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Contact Information
HR > Employees > Contact Info

Admin > HR > Employees > Contact Info

The Contact Info page records contact information for an employee.

• Use the Main Address for the employees work place address.

• Use the Secondary Contact tab for an emergency contact record.
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Wages
HR > Employees > Wages

Admin > HR > Employees > Wages

The Wages page records the wages paid an employee.

Note: The employee is already identified as hourly or salaried or a contractor on thePersonal Details tab.

Hourly Pay

• Hourly Pay Rate - The hourly pay rate for the employee.

• Burden Rate - The allocation rate at which indirect costs are applied to the direct costs of either labor or inventory.
These costs can include but are not limited to payroll taxes, pension costs, health insurance, dental insurance, and
any other benefits that a company provides an employee.

• Over Time Pay Rate - The hourly overtime pay rate for an employee.

• Pay Period - Weekly, Monthly, Quarterly, Yearly, Contract Length.

• Currency

Rate Calculation Guide

This is just a guide to help quickly calculate the hourly wage for an employee. It's a basic calculation of annual salary
divided by working hours.

• Working Hours Per Year - There are 52 weeks x 40 hours a week = 2080 hours. Adjust for part time employees

• Annual Salary - Put the annual salary in this field and then click Calc to display an hourly wage. Does not include
the Burden Rate.

External Employee

• Vendor - Links this employee to a vendor. Required to add expense entries and time entries associated with
projects and tickets to Vendor Bills. Vendor bills can be processed in Quickbooks.

Employee Financials

• Equivalent Vendor Record - Creates a vendor alias for an employee. The vendor alias is required to process
reimbursements in Quickbooks. For example, use the employee's name with a _v suffix in this field.
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Shifts
HR > Employees > Shifts

Admin > HR > Employees > Shifts

The Shifts page records the weekly work schedule for an employee.

Creating Work Schedules

1 Select the Admin > HR > Employees > Shifts tab.

2 Set Allow Overtime - Yes or No. The pay rate for overtime is set on the Wages tab.

3 Click Add to add a new shift.

4 Enter the following:

– Week day

– Start Time

– End Time

5 Repeat steps 3 and 4 to add as many shifts for this employee as required.
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Associated Clients
HR > Employees > Associated Clients

Admin > HR > Employees > Associated Clients

The Associated Clients tab links your employee, typically a technician, to one or more clients. When a client opens Client
Portal, linked employees are listed as primary contacts for messaging.

Adding Clients

1 Select the Admin > HR > Employees > Associate Clients tab.

2 Click Add.

3 Select one or more clients.

4 Click OK.
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Associated Queues
HR > Employees > Associated Queues

Admin > HR > Employees > Associated Queues

The Associated Queues tab assigns an employee to one or more ticket queues. Queues group tickets by the state they
are in. Employees work tickets in the queues they are assigned to. Queues are maintained using the Admin > Service
Desk > Queues page.

Adding Queues

1 Select the Admin > HR > Employees > Associate Queues tab.

2 Click Add.

3 Select one or more queues.

4 Click OK.
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Custom Fields (for Employees)
HR > Employees > Custom Fields

Admin > HR > Employees > Custom Fields

The Custom Fields tab maintains data entered in custom fields for employee profiles. Data types for custom fields can
be Free Text, Date or Data List. Custom fields can be set to required. Custom fields are created using the Admin
module > My Company > Custom Fields page.
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Employee Roles
HR > Employees > Employee Roles

Admin > HR > Employees > Employee Roles

The Employee Roles tab assigns roles to an employee. Each role determines the work billed to customers on tickets and
tasks. Roles and rates are maintained using the Admin > Finance > Roles and Rates page. Employees assigned multiple
roles can usually select any of their roles when working a task or ticket. In Projects, the project manager can lock down
the role when assigning a task to an employee.

Adding Roles

1 Select the Admin > HR > Employees > Employee Roles tab.

2 Check the Has Role checkbox for any role that applies to this employee.

3 Select the Default role for this employee. This role automatically populate the Role field when the user enters time
on a task or ticket.
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Security Roles
HR > Employees > Security Roles

Admin > HR > Employees > Security Roles

The Security Roles tab assigns security roles to an employee. Security roles determine the access an employee has to
different modules, menus and selected settings. The system provides several predefined security roles for both internal
and external users. You can also add custom security roles. Security roles are configured using the Admin > Security
Roles page.

Adding Security Roles

1 Select the Admin > HR > Employees > Security Roles tab.

2 Check the Has Role checkbox for any security role that applies to this employee.
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Attachments (for Employees)
HR > Employees > Attachments

Admin > HR > Employees > Attachments

Use the Attachments tab to upload files to an employee profile.

Adding Attachments

1 Select the Admin > HR > Employees > Attachments tab.

2 Click Upload a new file.

3 Browse, then Select a file to upload.

4 Optionally enter an Alias name.

5 Click Save.
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Education
HR > Employees > HR > Education

Admin > HR > Employees > HR > Education

The Education tab documents the education of an employee. The Institute Name, Degree and Field of Study drop-down
lists are maintained using the Admin > My Company > Lists page.

Adding Education Records

1 Select the Admin > HR > Employees > HR > Education option.

2 Click Add.

3 Enter the following:

– Institute Name

– Date Attended

– Degree

– Field of Study

– Grade

– Description

4 Click Save.
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Skills
HR > Employees > HR > Skills

Admin > HR > Employees > HR > Skills

The Skills tab identifies the job skills an employee has. This helps users determines the types of tickets and tasks a user
should be assigned to. Job skills are maintained using the Admin > HR > Skill Categories page.

Adding Education Records

1 Select the Admin > HR > Employees > HR > Skills option.

2 Click Add.

3 Enter the following fields:

– Category

– Skill

– Year(s) Of Experience

– Experience Level

4 Click Save.
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Organizational Chart
HR > Organization Chart

An Organizational Chart page displays a hierarchical chart of all employees in your company, based on supervisor and
subordinate relationships. Org charts:

• Helps clarify the working relationships between executives and managers.

• Establishes the hierarchical structure for decision-making and authority.

• Serves as an information portal, by clicking an employee's name in the chart to open up that employee's record.

• Helps visualize changes to the company's structure.

• Helps executive officers establish clear management procedures within a company.

• Helps guide employees about who to contact in other parts of the organization.

You can generate an organization chart in two ways:

• By Manager

• By Department
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Dashboard (Finance)
Finance > Dashboard

The Dashboard displayed in the Finance module includes specialized dashlets highlighting important financial concerns.

• Revenue by Client

• Revenue Still To Invoice Current Month

• Contracts Expiring Next 90 Days

See Dashboard (Home) for a description of general purpose dashlets that also display on this page.
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Contracts
Time and Materials 256

Recurring Services 258

Fixed Price 261

Retainer By Amount 264

Retainer By Hours 266

Finance > Contracts

The Contracts page registers billing agreements between you and your clients. The selected contract type determines
how billing is processed. There are five contract types.

• Time and Material - The customer is charged for all of hours of work performed, any direct expenses incurred, and
all materials purchased to support the resolution of tickets and the completion of projects. Time entered on tickets
and tasks generates billable amounts for labor on invoices. The role assigned a labor time entry determines the
rate charged for that labor. Default rates for roles can be adjusted on a per contract basis.

• Recurring Services - Services are billed on a contract length, weekly, monthly, quarterly, or yearly basis.

• Fixed Price - A fixed priced contract is not subject to any adjustment on the basis of the provider’s cost experience
in performing the contract. A fixed price contract is typically tied to a single project, but some users use them for
support contracts. In many contracts the fixed price is divided into smaller milestone payments.

• Retainer by Amount - The total price of the contract is prepaid. Clients schedule services when needed. Billings
decrement the contract amount purchased.

• Retainer by Hours - Hours of service are prepaid. Clients schedule services when needed. Labor time entries
decrement the retainer hours purchased. The total price of contract is calculated by multiplying the number of
contract hours purchased by an average rate.

Additional guidelines:

• A customer can have multiple contracts.

• You can pick a default contract for service tickets for a client, thus eliminating the guess work if something is
covered or not.

• You can link a service level agreements (SLA) to a contract
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Time and Materials
Finance > Contracts > New > Time and Materials

The customer is charged for all of hours of work performed, any direct expenses incurred, and all materials purchased to
support the resolution of tickets and the completion of projects. Time entered on tickets and tasks generates billable
amounts for labor on invoices. The role assigned a labor time entry determines the rate charged for that labor. Default
rates for roles can be adjusted on a per contract basis.

Creating Time and Materials Contracts

1 Select the Finance > Contracts page.

2 Click New > Time and Materials.

3 Enter the following in the Contract Information section.

– Contract Number - Only displays when editing a contract.

– Contract Name

– Contract Description

– Client

– Start Date

– End Date

– SLA - A contract associated with an SLA overrides the Default SLA when the ticket is linked to the contract.

– Setup Fees

– Issue Invoice on - Overrides the default value set for the 'Issue Invoice on' field, either Start of Billing
Cycle or End of Billing Cycle. The default is set using the Admin > Company Settings > Invoice tab.

– Reference Number
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– Default Contract - Yes or No

4 Enter additional information in the Custom Fields section.

5 Click Save.

6 Adjust rates for roles for this contract in the Billing Information tab.

– Maximum Hours - Limits the hours billable for this role.

– Contract Billing Rate - Adjusts the default billing rate for this role.

7 Optionally exclude roles and work types that can report hours to this contract using the Exclusions tab.

– If hours are reported using an excluded role or work type, the hours are reported against the Default Fallback
Contract you specify.

8 Upload files to the contract using the Attachments tab.

9 Click Save.

10 Optionally reopen the contract and click Activate to begin using this contract to create billing entries.
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Recurring Services
Finance > Contracts > New > Recurring Services

Services are billed on a contract length, weekly, monthly, quarterly, or yearly basis.

Creating Recurring Services Contracts

1 Select the Finance > Contracts page.

2 Click New > Recurring Services.

3 Enter the following in the Contract Information section.

– Contract Number - Only displays when editing a contract.

– Contract Name

– Contract Description

– Client

– Start Date

– End Date

– SLA - A contract associated with an SLA overrides the Default SLA when the ticket is linked to the contract.

– Setup Fees

– Reference Number

– Billing Cycle - Contract Length, Weekly, Monthly, Quarterly, Yearly

– Issue Invoice on -

– Default Contract - Yes or No

– Billing Periods based on Calendar Year - Yes or No
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Note: Billing entries are not generated for hours reported on tickets and tasks linked to a recurring service
contract. To prevent generating billing lines for labor hours independently of a contract, set the Default
Contract option to Yes for that contract. When a new ticket or task is created, the default contract is linked to
the ticket or task automatically.

Examples:

Recurring Service Contract billing periods can be established based on the Contract Start Date or based on the Calendar
Year. For example, a monthly contract based on Start Date beginning on January 17 would have billing periods that
begin on the 17th and end on the 18th of each month. A monthly contract based on Calendar year would have the first
period beginning on January 17th and ending January 31st (prorated first month), and each subsequent period would
begin on the 1st of the month and end on the last day of the month.
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4 Enter additional information in the Custom Fields section.

5 Click Save.

6 Click Add to add services in the Billing Information tab. You can adjust the calculated extended cost and price for
each service add to this contract.

– Service

– Effective Date

– Unit Price

– Extended Unit Price

– Unit Cost

– Extended Unit Cost

– Units

– Total Price

– Total Cost

7 Click Save.

8 Review the Contract Billing Price. This is the total price for all the services added.

9 Optionally exclude roles and work types that can report hours to this contract using the Exclusions tab.

– If hours are reported using an excluded role or work type, the hours are reported against the Default Fallback
Contract you specify.

10 Upload files to the contract using the Attachments tab.

11 Click Save.

12 Optionally reopen the contract and click Activate to begin using this contract to create billing entries.

13 When the contract changes, you can review those changes using the Contract History tab.
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Fixed Price
Finance > Contracts > New > Fixed Price

A fixed priced contract is not subject to any adjustment on the basis of the provider’s cost experience in performing the
contract. A fixed price contract is typically tied to a single project, but some users also use them for support contracts. In
many contracts the fixed price is divided into smaller milestone payments.

Creating Fixed Priced Contracts

1 Select the Finance > Contracts page.

2 Click New > Fixed Price.

3 Enter the following in the Contract Information section.

– Contract Number - Only displays when editing a contract.

– Contract Name

– Contract Description

– Client

– Start Date

– End Date - Milestones due dates default to this date.

– SLA - A contract associated with an SLA overrides the Default SLA when the ticket is linked to the contract.

– Setup Fees

– Reference Number

– Default Contract - Yes or No
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– Accumulating Contract - If Yes, the total contract amount starts at zero (0) and increases each time you add a
new milestone. If No, the total contract amount is set to that fixed amount. You can add milestones whenever
you like, so long as the total contract amount does not exceed the fixed amount.

– Alter From Project - If Yes, a project phase milestone is added to the project linked to this contract each time
you add a new milestone to the contract.

4 Enter additional information in the Custom Fields section.

5 Click Save.

6 Click Add to add milestone payments in the Billing Information tab.

– Name

– Type

– Amount

– Due Date - Defaults to the end date of the contract. For milestone payments Billing Review lists billable
amounts using this date. You may wish to adjust this date for earlier milestone payments to ensure they
display sooner in Billing Review.

– Description

Note: The Billing Information tab displays Billed and Posted checkbox columns. Billing Reviewposts a line item.
Generating an invoice using Billingbills that line item.

7 Click Save.

8 Review the following in the Billing Information tab

– Contract Billing Price - The total of all milestone amounts.

– Billed Amount

– Remaining Amount

9 Optionally exclude roles and work types that can report hours to this contract using the Exclusions tab.

– If hours are reported using an excluded role or work type, the hours are reported against the Default Fallback
Contract you specify.

10 Upload files to the contract using the Attachments tab.

11 Click Save.

12 Optionally reopen the contract and click Activate to begin using this contract to create billing entries.
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Retainer By Amount
Finance > Contracts > New > Retainer by Amount

The total price of the contract is prepaid. Clients schedule services when needed. Billings decrement the contract
amount purchased. Billable labor time on tickets and tasks consume the amount. Charges and expenses do not
consume the amount.

Creating Retainer by Amount Contracts

1 Select the Finance > Contracts page.

2 Click New > Retainer by Amount.

3 Enter the following in the Contract Information section.

– Contract Number - Only displays when editing a contract.

– Contract Name

– Contract Description

– Client

– Start Date

– End Date

– SLA - A contract associated with an SLA overrides the Default SLA when the ticket is linked to the contract.

– Setup Fees

– Reference Number

– Default Contract - Yes or No
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Note: To prevent generating billing lines for labor hours independently of a contract, set the Default Contract option
to Yes for that contract. When a new ticket or task is created, the default contract is linked to the ticket or task
automatically.

4 Enter additional information in the Custom Fields section.

5 Click Save.

6 Adjust rates for roles for this contract in the Billing Information tab.

– Contract Billing Rate - Adjusts the default billing rate for this role.

7 Review the following in the Billing Information tab

– Contract Billing Price - Enter the total amount that can billed to this contract.

– Consumed Amount - The total amount of billings applied to this contract.

8 Optionally exclude roles and work types that can report hours to this contract using the Exclusions tab.

– If hours are reported using an excluded role or work type, the hours are reported against the Default Fallback
Contract you specify.

9 Upload files to the contract using the Attachments tab.

10 Click Save.

11 Optionally reopen the contract and click Activate to begin using this contract to create billing entries.
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Retainer By Hours
Finance > Contracts > New > Retainer by Hour

Hours of service are prepaid. Clients schedule services when needed. Labor time entries decrement the retainer hours
purchased. The total price of contract is calculated by multiplying the number of contract hours purchased by an average
rate. Retainer by Hour contracts are billed by billing periods. The total hours specified by the contract are distributed
evenly across all the billing periods contained by the contract's date range. When a billing period within the contract is
closed, unconsumed retainer hours can be optionally carried forward to the next billing period.

Creating Retainer by Hours Contracts

1 Select the Finance > Contracts page.

2 Click New > Retainer by Hours.

3 Enter the following in the Contract Information section.

– Contract Number - Only displays when editing a contract.

– Contract Name

– Contract Description

– Client

– Start Date

– End Date

– SLA - A contract associated with an SLA overrides the Default SLA when the ticket is linked to the contract.

– Setup Fees

– Reference Number
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– Billing Cycle - Contract Length, Weekly, Monthly, Quarterly, Yearly

– Default Contract - Yes or No

Note: To prevent generating billing lines for labor hours independently of a contract, set the Default Contract option
to Yes for that contract. When a new ticket or task is created, the default contract is linked to the ticket or task
automatically.

4 Enter additional information in the Custom Fields section.

5 Click Save.

6 Click Add to add milestone payments in the Billing Information tab.

– Average Rate

– Contract Hours

– Bill For - Actual Hours or Actual Hours + Overage

– Carry Over Extra Hours to the Next Billing Cycle - If Yes, unconsumed retainer hours are carried forward to the
next billing period when a billing period is closed using Billing Review > Retainer Hours page.

7 Click Save.

8 Review the following in the Billing Information tab

– Contract Billing Price - The Average Rate times the Contracts Hours.

9 Optionally exclude roles and work types that can report hours to this contract using the Exclusions tab.

– If hours are reported using an excluded role or work type, the hours are reported against the Default Fallback
Contract you specify.

10 Upload files to the contract using the Attachments tab.

11 Click Save.

12 Optionally reopen the contract and click Activate to begin using this contract to create billing entries.

13 When labor time entries are applied to this contract, you can review the hours consumed using the PrePaid Hours
Summary tab.
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Billing Review
Labor Hours 270

Expenses 272

Recurring Services 274

Fixed Price Milestone 276

Retainer Amount 278

Retainer Hours 280

Finance > Billing Review

The Billing Review menu enables you to review billing entries and create invoices. Invoices can be sent out before or
after the customer receives services. A separate billing review page is provided to review each type of billing entry.

PulsewayPSA Guide

Release 4.0.41 | March 2021

https://www.pulseway.com/


Labor Hours
Finance > Billing Review > Labor Hours

The Labor Hours page lists billing entries for labor hours entered on tickets and tasks. Review one or more entries, make
adjustments if necessary, then post them. Posting moves billing entries to Billing. For a billing entry to display on this
page:

• Hours must be reported in a ticket or task. The ticket or task may be optionally optionally linked to a time and
materials contract. The contract must be active.

• The billing entry must match search filter parameters.

• Zero value hours can be posted or ignored using the Admin > Company Settings > Invoice > Post Zero Entries
option.

Reviewing Labor Hour Billing Entries

1 Select the Finance > Billing Review > Labor Hours page.

2 Optionally change Search filter settings. The default date range is from today's date to 3 months into the future. This
can be customized using the Admin > Company Settings > Invoice tab > Billing End Date setting.

3 Click Search. A list of entries displays in the Results tab.

4 Optionally review the ticket or task for a billing entry by clicking the link in the Ticket/Project column.

– The icon indicates a ticket billing entry.

– The icon indicates a project/task billing entry.

5 Optionally review the contract for a billing entry by clicking the link in the Contract column.
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6 Optionally adjust billing entries.

– Overtime Hours to Bill

– Overtime Billing Rate

– Hours to Bill

– Billing

Note: Adjustments do not change time entries on employee time sheets.

7 Check one or more rows you want to post.

8 Click Post to post checked rows.
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Expenses
Finance > Billing Review > Expenses

The Expenses page lists billing entries for expenses entered on tickets and tasks. Review one or more entries, make
adjustments if necessary, then post them. Posting moves billing entries to Billing. For a billing entry to display on this
page:

• An expense must be added to a ticket or task or expense report.

• The billing entry must match search filter parameters.

Reviewing Expense Billing Entries

1 Select the Finance > Billing Review > Expenses page.

2 Optionally change Search filter settings. The default date range is from today's date to 3 months into the future. This
can be customized using the Admin > Company Settings > Invoice tab > Billing End Date setting.

3 Click Search. A list of entries displays in the Results tab.

4 Optionally review the ticket or task for a billing entry by clicking the link in the Ticket/Project column.

– The icon indicates a ticket billing entry.

– The icon indicates a project/task billing entry.

5 Optionally review the contract for a billing entry by clicking the link in the Contract column.

6 Optionally adjust billing entires.

– Billing Price

Note: Adjustments do not change expenses on employee expense sheets.
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7 Check any row you want to post.

8 Click Post to post checked rows.
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Recurring Services
Finance > Billing Review > Recurring Services

The Recurring Services page lists billing entries for recurring services. For a billing entry to display on this page:

• A recurring service must be added to a recurring services contract.

• The contract must be active.

• The billing entry must match search filter parameters.

Billing is by contract billing period. Once a recurring services contract is active, any of the time periods can be billed at
any time. Review one or more entries, make adjustments if necessary, then post them. Posting moves billing entries to
Billing.

• Billing entries are not generated for hours reported on tickets and tasks linked to a recurring service contract. To
prevent generating billing lines for labor hours independently of a contract, set the Default Contract option to Yes
for that contract. When a new ticket or task is created, the default contract is linked to the ticket or task
automatically.

• Zero value hours can be posted or ignored using the Admin > Company Settings > Invoice > Post Zero Entries
option.

Reviewing Recurring Services

1 Select the Finance > Billing Review > Recurring Services page.

2 Optionally change Search filter settings. The default date range is from today's date to 3 months into the future. This
can be customized using the Admin > Company Settings > Invoice tab > Billing End Date setting.

3 Click Search. A list of entries displays in the Results tab.

4 Optionally adjust billing entries.
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– Quantity

– Unit Price

5 Check any row you want to post.

6 Click Post to post checked rows.
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Fixed Price Milestone
Finance > Billing Review > Fixed Price Milestones

The Fixed Price Milestone page lists billing entries for fixed price milestones. Milestones are created using fixed price
contracts. Review one or more entries, make adjustments if necessary, then post them. Posting moves billing entries to
Billing. For a billing entry to display on this page:

• A fixed priced milestone must be added to a fixed priced contract.

• The contract must be active.

• The billing entry must match search filter parameters.

A fixed priced contract is typically linked to a project. Once a fixed price contract is active, you can bill any of its fixed
price milestones at any time.

Reviewing Recurring Services

1 Select the Finance > Billing Review > Fixed Priced Milestones page.

2 Optionally change Search filter settings. The default date range is from today's date to 3 months into the future. This
can be customized using the Admin > Company Settings > Invoice tab > Billing End Date setting.

3 Click Search. A list of entries displays in the Results tab.

4 Optionally adjust billing entries.

– Amount
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5 Check any row you want to post.

6 Click Post to post checked rows.
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Retainer Amount
Finance > Billing Review > Retainer Amount

The Retainer Amount page lists billing entries for retainer by amount contracts. Review one or more entries, make
adjustments if necessary, then post them. Posting moves billing entries to Billing. For a billing entry to display on this
page:

• A retainer by amount contract must be active.

• The billing entry must match search filter parameters.

Once a retainer by amount contract is active, the total price of the contract can be billed at any time.

Reviewing Recurring Services

1 Select the Finance > Billing Review > Retainer Amount page.

2 Optionally change Search filter settings. The default date range is from today's date to 3 months into the future. This
can be customized using the Admin > Company Settings > Invoice tab > Billing End Date setting.

3 Click Search. A list of entries displays in the Results tab.

4 Check any row you want to post.

5 Click Post to post checked rows.
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Retainer Hours
Finance > Billing Review > Retainer Hours

The Retainer Hours page lists billing entries for retainer hours. Retainers hours are consumed when hours are reported
on tickets or tasks linked to a retainer by hours contract. Billing is by contract billing period. Review one or more entries,
make adjustments if necessary, then post them. Posting moves billing entries to Billing. For a billing entry to display on
this page:

• Hours must be reported in a ticket or task.

• The ticket or task must be linked to a retainer by hours contract.

• The contract must be active.

• The billing entry must match search filter parameters.

Once a retainer hours contract is active, any of the time periods can be billed at any time, unless the billing period has
been closed.

Note: To prevent generating billing lines for labor hours independently of a contract, set the Default Contract option
to Yes for that contract. When a new ticket or task is created, the default contract is linked to the ticket or task
automatically.

Reviewing Recurring Services

1 Select the Finance > Billing Review > Retainer Hours page.

2 Optionally change Search filter settings. The default date range is from today's date to 3 months into the future. This
can be customized using the Admin > Company Settings > Invoice tab > Billing End Date setting.

3 Click Search. A list of entries displays in the Results tab.
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4 Check any row you want to post.

5 Click Post to post checked rows.

6 Optionally close billing periods using the Billing Periods tab.

– Close Billing Periods - If checked, clicking this button closes checked billing periods. If the Carry Over Extra
Hours to the Next Billing Cycle option is set to Yes in the retainer by hours contract, unconsumed retainer
hours are carried forward to the next billing period when a billing period is closed.
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Billing
Finance > Billing

The Billing page creates invoices from posted billing lines.

Creating Invoices

1 Select the Finance > Billing page.

2 Optionally change Search filter settings. The default date range is from today's date to 3 months into the future. This
can be customized using the Admin > Company Settings > Invoice tab > Billing End Date setting.

3 Click Search. A list of entries displays in the Results tab. Review the rows displayed.

4 Select one or more rows to invoice.

– By default, a single invoice is generated for each customer, for all selected items.

– To generate additional invoices, one for each project for each customer, set the Generate Invoices by Project
option to Yes.

5 Click Generate Invoice.

Unposting Billing Lines

Instead of creating an invoice, you can unpost billing lines and send them back to Billing Review.

1 Select the Finance > Billing page.

2 Optionally change search filter settings. The default date range is today's date.

3 Click Search. A list of entries displays in the Results tab. Review the rows displayed.

4 Select one or more rows to unpost.

5 Click Unpost.
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Invoices
Invoice Details 285

Invoice Discounts 287

Invoice Receipts 289

Invoice Attachments 290

Generate and Preview 291

Resetting a Posted Invoice 293

Sending an Invoice 294

Voiding an Invoice 295

Finance > Invoices

The lnvoices page manages and generates invoices. Batch generation of invoices is supported.

To manage a single invoice, click any row to display the following:

• Invoice information

• Billing address

• Tax calculations

• Invoice details

• Attached receipts

• Attached files

You can also perform the following actions:

• Generate the invoice

• Preview the invoice

• Edit the invoice and regenerate it
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• Send the invoice

• Void the invoice

• Discount the invoice

• Add hidden notes
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Invoice Details
Finance > Invoices > (selected invoice) > Invoice Details

The Invoice Details tab lists each line item in the invoice. For each line item, you can edit the following fields:

• Item Name

• Description

• Class

• Quantity

• Unit Price

Reviewing Invoice Details

1 Select the Finance > Invoices page.

2 Select a row with a Status of Ready to Send.

3 Review and optionally edit rows listed in the Invoice Details tab.

– Item Name - The labor, entry, recurring services, milestone payment type, etc.

– Item Description - Depends on the type of line item:

• Labor - the note entered for the labor entry on the ticket or task

• Milestone Payment - the milestone name

• Expense - the expense note field

• Recurring Services - the description entered for the service name. This supports multiple lines, including
line breaks as entered in the service page, as opposed to all the lines merged into a single line

• Retainer By Hours - the Contract Description field in the contract. This supports multiple lines, including
line breaks as entered in the service page, as opposed to all the lines merged into a single line

• Retainer By Amount - the Contract Description field in the contract

– Quantity - The number of each item.

– Unit Price - The price per item.

– Total Price - Unit price times the quantity.

– Value Date - The date the time entry was made or the date the expense was entered.
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Invoice Discounts
Finance > Invoices > (selected invoice) > Invoice Discount

The Invoice Discount tab enables you to apply a discount to the invoice. A discount can be a percentage or dollar
amount.

To Apply a Discount

1 Select the Finance > Billing page.

2 Click an invoice row with a Status of Ready to Send.

3 Click the Invoice Discount tab.

4 Click Add.

– Discount Type - Assigns a default discount type percentage or amount.

– Class - The finance class of this discount. Optional.

– Default Value - Accept or override.

– Notes - Entered notes display on the invoice.

– Click Save. The Grand Total reflects the discount immediately.

5 Click Save.
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Invoice Receipts
Finance > Invoices > (selected invoice) > Receipts

The Receipts tab displays receipts for line items included in the invoice. For example, if expenses require a receipt be
attached, you would see receipts for expense line items here. When you send the invoice to the customer, the receipts
will be included in the email.
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Invoice Attachments
Finance > Invoices > (selected invoice) > Attachments

The Attachments tab enables you to upload attachments to an invoice. When you send the invoice to a customer, the
attachment will be included in the email.
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Generate and Preview
Finance > Invoices > (selected invoice) > Regenerate

Invoices are generated by clicking the Regenerate button.

You can generate either a detailed or summary invoice.

A message indicates the successful creation of your invoice.

Click Preview to review this invoice before sending it.
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Resetting a Posted Invoice
Finance > Invoices > (selected invoice) > Reset Posted to Accounting

If you want to adjust an Invoice that has already been posted to Quickbooks Accounting, click "Reset Posted to
Accounting" button so that you can edit the Invoice data in the Finance > Billing. Once you are done with editing the bill,
you have to post the invoice to Quickbooks Accounting once again.

You can also click the "Reset Posted to Accounting" button, if you have posted an Invoice to Quickbooks, but for some
reason the invoice has not been successfully synchronized by Quickbooks app. In this case, you will cancel the previously
posted invoice and will be able to submit it to Quickbooks Accounting once again.
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Sending an Invoice
Finance > Invoices > (selected invoice) > Send to Customer

Send an invoice by clicking the Send to Customer button.

Select the contacts you wish to send the invoice to, then click Send.

A message indicates the invoice was sent.
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Voiding an Invoice
Finance > Invoices > (selected invoice) > Void Invoice

Voice an invoice by clicking the Void Invoice button. Voiding unposts all the billing lines in the invoice and sends them
back to Billing Review.

A message indicates the invoice was voided.
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Payments
Finance > Payments

The Payments page matches payments received from customers to invoices. For each invoice linked to a payment you
can optionally edit the payment Amount received and enter an additional Discount amount. To set an invoice line to
Fully Paid, the Amount and Discount must equal the Total. You can also upload attachments to a payment record.

Header Fields

• Client

• Payment Date

• Reference

• Created By

• Payment Type

• Amount

• Memo

Invoice Fields

• Status

• Invoice Number

• Client

• Date

• Due Date

• Total

• Paid

• Due

• Amount

• Discount
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Vendor Bills
Finance > Vendor Bills

The Vendor Bills page records time and expenses incurred by vendors and contractors. This includes:

• Labor entries linked to a ticket or task.

• Expenses linked to a ticket or task.

• New expenses not necessarily linked to a ticket or task.

Entries added to vendor bills can be marked up in price, posted and billed to your customers. Billing can occur at any
time, regardless of the status of the entry on the Vendor Bills page.

Note: Entries added to this page are assumed to be subsequently processed by an integrated accounting package,
such as Quickbooks.

Prerequisites

On the > Admin > Finance > Expense Type page:

• An expense type must be set to Available For: Vendor or Employees or Vendors.

• For Quickbooks integration, expense items must be linked to both an income account and an expense account.

To add items to the > Finance > Vendor Bills > (vendor bill) > Item tab:

• Adhoc items do not have to be approved.

To add items to the > Finance > Vendor Bills > (vendor bill) > Expense Entries tab and Time Entries tab:

• The employee must be linked to a vendor using the HR > Employees > (employee) > Wages > Vendor field.

• For timesheet entries, on the same employee Wages page, specify a Burden Rate > 0.

• The roles specified for billable entries require an Admin > Finance > Roles > Billing Rate.

• Vendor-linked employee expense entries or timesheet entries must be approved.

Processing Vendor Bills

1 Create and save a new vendor bill.

– The vendor bill status will be New.

2 Add entries for Items, Expense Entries and Time Entries.

– Ensure entries are checked as billable if you intend on billing the customer for the work outsourced to the
vendor.

3 Click Save

– The vendor bill status will be Processed the first time you save the vendor bill with an entry.

– Saved vendor bill entries cannot be edited. You can still add new entries.

4 Use the Finance > Billing Review > Expenses page to post billable vendor bill expense entries.
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5 Use the Finance > Billing Review > Labor Hours page to post billable vendor bill labor entries.

6 Use the Finance >Billing page to create an invoice that includes posted vendor bill entries.

Header Fields

• Vendor

• Created On

• Created By

• Due Date

• Reference #

• Amount

Items tab

• Expense Type

• Date

• Amount Spent

• Mark up / down

• Total Amount

• Notes

• Expense Associated With - Project, Ticket, Internal Expense - Internal expenses are added to the
Administration Project for your company.

Expense Entries tab

Click Add to select expense entries.

Time Entries tab

Click Add to select labor time entries.

Attachments

Click Upload a new file to upload files to a Vendor Bill record.
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Reimbursements
Finance > Reimbursements

The Reimbursements page records payments to employees who have incurred expenses on behalf of your company.

Note: Entries added to this page are assumed to be subsequently processed by an integrated accounting package,
such as Quickbooks.

Prerequisites

On the > Admin > Finance > Expense Type page:

• An expense type must be set to Available For: Vendor or Employees or Vendors.

• For Quickbooks integration, expense items must be linked to both an income account and an expense account.

To add items to the > Finance > Vendor Bills > (vendor bill) > Item tab:

• Adhoc items do not have to be approved.

To add items to the > Finance > Vendor Bills > (vendor bill) > Expense Entries tab and Time Entries tab:

• The employee must be linked to a vendor using the HR > Employees > (employee) > Wages > Vendor field.

• For timesheet entries, on the same employee Wages page, specify a Burden Rate > 0.

• The roles specified for billable entries require an Admin > Finance > Roles > Billing Rate.

• Vendor-linked employee expense entries or timesheet entries must be approved.

Creating Reimbursements

1 Select the Finance > Reimbursements page.

2 Click New.

3 Enter the following fields.

– Employee

– Created On

– Created By

– Payment Type

– Reference #

– Amount

– Memo

4 Click Save.
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QuickBooks Integration
Finance > QuickBooks

The QuickBooks Integration allows you to exchange financial data between your system and an instance of Quickbooks.
For more information download the or guides.

Pulseway PSA QuickBooks Sync is supported in the following countries:

• Australia

• Canada

• India

• United Kingdom

• United States

The following versions of QuickBooks Desktop are supported:

• 2018

• 2017

• 2016

• 2015

• 2014

• 2013

• 2012

• 2011

QuickBooks Integration does not support Apple Online QuickBooks.
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Chapter 7: CRM Module
Dashboard 302

Accounts 304

Contacts 324

Activities 328

Opportunities 330

Quotations 333

Sales Orders 345

Sites 350

CRM stands for customer relationship management. A CRM solution allows you to manage the business relationship
and interactions you have with customers, prospects, vendors, etc., and store all the data about these relationships.
These interactions can be sales related—calls, emails, meetings and demonstrations—as well as support related—service
tickets and projects. The benefit of a CRM is having all your business data stored and accessible from one central
location. The CRM module provides:

• Immediate employee access to the data they need.

• Sharing of important data between departments.

• Management insight into activity across the organization and helps them understand where they can improve
processes.

Customers are first added as accounts in CRM. After that you can create projects, open tickets, and set up contracts on
their behalf.
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Dashboard
Finance > Dashboard

The Dashboard displayed in the CRM module includes additional dashlets that highlight important sales cycle concerns.

Note: If you are a Manager and have employees reporting to you, the CRM Dashboard rolls up all the values for you
and your employees. If you do not have anyone reporting to you, the CRM Dashboard only displays your
values.

Specialized dashlets provided by the CRM > Dashboard include:

• Pipeline - The dollar value of opportunities in the system:

– Pipeline value - The value of all opportunities equal to or greater than the Pipeline Factor set in Admin > My
Company > CRM > Opportunities. Click View Details.

– Total Value - All opportunities in the system regardless of the Pipeline Factor, meaning any opportunity with a
percent between 0% and 99%. Click View Details.

• Opportunity Amount Value by Lead Source - A chart of the opportunities grouped by lead source. Hover the cursor
over any color to display its dollar value. Filter the chart by This Month, This Quarter, This Year.

• Opportunity Pipeline Value - A chart of of the pipeline value. Filter the chart by This Month, This Quarter, This Year.

• Opportunities Converted to Projects - A chart of the number of opportunities converted to projects.

• Opportunity Performance - An opportunity performance table by sales representative. The Probability is the
average for all opportunities for the selected period: This Month, This Quarter, This Year. Provides the value of
opportunities Won, Lost and Open.

See Dashboard (Home) for a description of general purpose dashlets that also display on this page.
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Accounts
Locations 308

Contacts 310

Assigned Resources 313

Email Domains 314

Tax Settings 315

Opportunities 316

Activities 317

Linked Accounts 319

Notes 320

Custom Fields (for Accounts) 322

Attachments (for Accounts) 323

Admin > CRM > Accounts

The Accounts Management page maintains your account profiles for every organization you do business with. This
includes clients, prospects, vendors, competitors, former clients, business partners, and miscellaneous
organizations.This same page displays in the CRM module if you have permission. Initially you create a basic account.
After you save an account the first time, multiple tabs display for you to enter additional details.

Creating Accounts

1 Select the Admin > CRM > Accounts page.

2 Click New.

3 You can select two types of accounts.

– Account Code - An account code associated with this customer organization.

– Account Name - The main account name for a customer organization.

– Child Account - An subordinate account for a larger customer organization. If Route Invoice to Parent is set to
Yes for this child account, billables are routed to the parent organization for payment. If set to No, parent-child
accounts are used for reporting purposes only.

4 Select Account.

– Enter the following fields in the Account header section.

– Account Name

– Account Type - Client, Competitor, Former Client, Miscellaneous, Partner, Unknown, Vendor
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Note: One of your accounts is an internal account. The internal CRM customer account is created for you and
matches your company name by default. Your internal CRM customer account is used when you ship
inventory between warehouses. You can filter accounts to identify your internal account.

– Business Type - This list is maintained using Admin > My Company > Lists page.

– Website

– Acquired Date

– Credit Limit

– Default Currency

– Net Days

– Account Manager - The employee in your company assigned to manage this account.

– Description

5 Enter the main business address in the Main Address Info tab. Optionally click Copy From Billing to populate these
fields from the Billing Address Info tab.

– Address Line 1

– Address Line 2

– City

– State

– Post Code

– Country

– Phone Number
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– Fax Number

– Longitude

– Latitude

6 Enter the billing account address in the Billing Address Info tab. Optionally click Copy From Main to populate these
fields from the Main Address Info tab.

– Email Address

– Address Line 1

– Address Line 2

– City

– Post Code

– State

– Country

– Phone Number

– Fax Number

– Longitude

– Latitude

7 Click Save.

8 Click the row of the new account you just created to add additional information.

– The Status option in the header is now available to maintain. If Yes, the account is being used.
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9 Use the tabs at the bottom of the page to maintain more details about each account.
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Locations
CRM > Accounts > Locations

Admin > CRM > Accounts > Locations

Use the Locations tab to maintain physical address locations for each account.

Adding New Account Locations

1 Select the Admin > CRM > Accounts > Locations tab.

2 Click Add.

3 Enter the following fields in the Address Info tab.

– Location Name

– Status

– Address Line 1

– Address Line 2

– City

– Post Code

– State

– Country

– Phone Number

– Fax Number

– Longitude

– Latitude

4 Optionally click Convert to Main (M) set a location as the 'main address' for an account.

5 Click Save.
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6 Click the Custom Fields tab.

– Enter values in the custom fields, as appropriate for this record.

– Custom fields are maintained using the Admin > My Company > Custom Fields page.
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Contacts
CRM > Accounts > Account Contacts

Admin > CRM > Accounts > Account Contacts

Similar to CRM > Contacts

Use the Account Contacts tab to maintain contacts for each account. These are the individuals that the sales team work
with to sell products and services. These are the people that your project team is delivering a completed project to. These
are the people that are calling you for support and who you are opening tickets for.

Adding New Account Contacts

1 Select the Admin > CRM > Accounts > Account Contacts tab.

2 Click Add.

3 Enter the following fields in the Account Contact tab.

– First Name

– Middle Name

– Last Name

– Location Name

– Job Title

– Phone Type

– Phone

– Status

– Email Type

– Email

– Point of Contact - If Yes, this person will be notified if a workflow rule is configured to send notifications to
Point of Contact.
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– Has Client Portal Access - If Yes, the client has portal access. Two extra fields Username and Security Role
display.The first time this setting is saved, the contact is sent an email with a user name, password and
instructions on how to login to the portal.

– Receive Invoices

4 Click the Custom Fields tab.

– Enter values in the custom fields, as appropriate for this record.

– Custom fields are maintained using the Admin > My Company > Custom Fields page.
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Assigned Resources
CRM > Accounts > Assigned Resources

Admin > CRM > Accounts > Assigned Resources

Use the Assigned Resources tab to link employees—typically a technician—to an account.

• When a client composes a message in Client Portal, Assigned Resources display in the client's recipient search list.

• Assigned Resources can be notified when a ticket workflow is triggered.

Adding Assigned Resources

1 Select the Admin > CRM > Accounts > Assigned Resources tab.

2 Click Add.

3 Check one or more employee rows.

4 Click OK.
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Email Domains
CRM > Accounts > Email Domains

Admin > CRM > Accounts > Email Domains

Associate one or more Email Domains with a CRM customer account. This enables the PulsewayPSA email parser to
determine the related account to create tickets for in Service Desk. If used, creates a new contact record for the sender
of the email and associates that new contact with the new ticket.

• Only applies if the sender's email address is not recognized as an existing contact record. In this case, a ticket is
created and associated with the existing contact.

• If an email cannot be associated with any existing contact or email domain record, the email parser creates the
ticket and identifies its sender as Unknown.

• Specified email domain names should not be public domains such as yahoo.com, google.com or hotmail.com,
and should be unique for each account.

Adding Email Domains

1 Select the Admin > CRM > Accounts > Email Domains tab.

2 Click Add.

3 Check one or more email domains rows.

4 Click OK.
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Tax Settings
CRM > Accounts > Tax Settings

Admin > CRM > Accounts > Tax Settings

The Tax Settings tab specifies tax related information for an account.

• Tax ID - The tax identifier for this account.

• Tax Rate - Applies to the labor entered on tickets and tasks. Displays on invoices.

• Is Taxable - Yes or No.
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Opportunities
CRM > Accounts > Opportunities

Admin > CRM > Accounts > Opportunities

Similar to CRM > Opportunities

The Opportunities tab maintains opportunities for each account.

Adding Opportunities

1 Select the Admin > CRM > Accounts > Opportunities tab.

2 Click Add.

3 Enter the following fields.

– Subject

– Next Step

– Account

– Type

– Status

– Location

– Probability

– Rating

– Contact

– Sales Representative

– Customer PO#

– Phone

– Close Date

– Lead Source

– Amount

– Probability Adjusted Revenue

– Description

4 Click Save.
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Activities
CRM > Accounts > Activities

Admin > CRM > Accounts > Activities

The Activities tab maintains a history of the interactions between your company and the contacts for an account. Many
activities may need to be tracked to support converting an opportunity into a sale.

Adding Activities

1 Select the Admin > CRM > Accounts > Activities tab.

2 Click Add.

3 Enter the following fields.

– Subject - Summary of this activity.

– Status - Status of this activity.

– Type - Appointment, Ask for Sale, Call, Demo, Email, Follow up, Inquiry, Marketing, Memo, Proactive
Call, Quote, Renew Agreement, Task

– Due Date - Due date for this activity.

– Reminder - Reminder date for this activity.

– Contact - Contact for this activity.

– Start Time - Start time for this activity.

– Assigned To - Employee assigned this activity.

– Phone - Contact's phone.

– End Time - End time for this activity.

– Assigned By - Employee who assigned this activity.

– Notes - Additional notes about this activity.

4 Click Save.
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Linked Accounts
CRM > Accounts > Linked Accounts

Admin > CRM > Accounts > Linked Accounts

The Linked Activities tab associates an accounts with other accounts in your system.

Adding Linked Accounts

1 Select the Admin > CRM > Accounts > Linked Accounts tab.

2 Click Add.

3 Enter the following fields in the Linked Account tab.

– Account - Select another account to link with this account.

– Link Type - General

– Notes

4 Click Save.

5 Click the Custom Fields tab.

– Enter values in the custom fields, as appropriate for this record.

– Custom fields are maintained using the Admin > My Company > Custom Fields page.

PulsewayPSA Guide

Release 4.0.41 | March 2021

https://www.pulseway.com/


Notes
CRM > Accounts > Notes

Admin > CRM > Accounts > Notes

The Notes tab stores notes for an account. Copy text from proposals, signed contracts, statements of work, network
diagrams, user guides, etc.—anything important about this client you want to reference quickly.

Adding Notes

1 Select the Admin > CRM > Accounts > Notes tab.

2 Click Add.

3 Type or paste text into the Note Text edit box.,

4 Click Save.
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Custom Fields (for Accounts)
CRM > Accounts > Custom Fields

Admin > CRM > Accounts > Custom Fields

The Custom Fields tab maintains data entered in custom fields for account profiles. Data types for custom fields can be
Free Text, Date or Data List. Custom fields can be set to required. Custom fields are created using the Admin
module > My Company > Custom Fields page.
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Attachments (for Accounts)
CRM > Accounts > Attachments

Admin > CRM > Accounts > Attachments

Use the Attachments tab to upload files to an account profile.

Adding Attachments

1 Select the Admin > CRM > Accounts > Attachments tab.

2 Click Upload a new file.

3 Browse, then Select a file to upload.

4 Optionally enter an Alias name.

5 Click Save.
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Contacts
CRM > Contacts

Similar to CRM > Accounts > Account Contacts and Admin > CRM > Accounts > Account Contacts

Use the Contacts tab to maintain contacts for each account. These are the individuals that the sales team work with to
sell products and services. These are the people that your project team is delivering a completed project to. These are
the people that are calling you for support and who you are opening tickets for.

Adding New Account Contacts

1 Select the Admin > CRM > Accounts > Account Contacts tab.

2 Click Add.

3 Enter the following fields in the Account Contact tab.

– First Name

– Middle Name

– Last Name

– Job Title

– Account

– Location Name

– Status - Active or Inactive

– Point of Contact - If Yes, this person will be notified if a workflow rule is configured to send notifications to
Point of Contact.

– Receive Invoices - Yes or No

– Photo - Reset or Select Photo
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4 Click the Phones tab and enter the following. Click Add to add additional rows.

– Phone Type

– Phone Number

– Is Default - The default phone number displays when you create an activity.

5 Click the Emails tab and enter the following. Click Add to add additional rows.

– Email Type

– Email

– Is Default

6 Click the Client Portal Access tab.
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If you are using the Service Desk module, you can turn on Client Portal for all contacts in your accounts that are clients.
The client portal is a secure place for your customers to submit and track help tickets. There is also a Message center
that allows the user to send messages directly to their service provider, making it easier to follow up with any tickets and
questions that may not be support related. Security roles are provided that makes it easy to turn on the portal and give
the right permission levels to your clients.

– Has Client Portal Access - If Yes, the client has portal access and two extra fields Username and Security Role
display. The first time this setting is saved, the contact is sent an email with a user name, password and
instructions on how to login to the portal.

– Username - The username the client will use to logon to the client portal.

– Reset and Email Password - Enabled if the user requests a new password.

– Security Role

• Client Access

• External User - Allow the client to view/edit their own profile and messages, as well as tickets assigned
to them.

• External Manager - Allow the client to view/edit their own profile and messages. However, unlike
'External User' this option will allow the client to view all tickets.

7 Click the Notes tab. Click Add to add notes.

8 Click the Activities tab. Click Add to add additional activities.

Activities are a history of the interactions between your company and the contacts for an account. Many activities may
need to be tracked to support converting an opportunity into a sale.

– Subject - Summary of this activity.

– Status - Status of this activity.

– Type - Appointment, Ask for Sale, Call, Demo, Email, Follow up, Inquiry, Marketing, Memo, Proactive
Call, Quote, Renew Agreement, Task

– Account - The customer account.

– Due Date - Due date for this activity.

– Reminder - Reminder date for this activity.

– Contact - Contact for this activity.

– Start Time - Start time for this activity.

– Assigned To - Employee assigned this activity.Phone - Contact's phone.

– End Time - End time for this activity.

– Assigned By - Employee who assigned this activity.

– Notes - Additional notes about this activity.

9 Click the Custom Fields tab.

– Enter values in the custom fields, as appropriate for this record.
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– Custom fields are maintained using the Admin > My Company > Custom Fields page.
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Activities
CRM > Activities

Similar to CRM > Accounts > Activities and Admin > CRM > Accounts > Activities

The Activities tab maintains a history of the interactions between your company and an account. Many activities may
need to be tracked to support converting an opportunity into a sale. The page:

• Does not require you to enter an account or contact with an activity.

• Enables you to link an activity to a project, opportunity or ticket.

Adding Activities

1 Select the Admin > CRM > Activities tab.

2 Click New.

3 Enter the following fields.

– Subject - Summary of this activity.

– Status - Status of this activity.

– Type - Appointment, Ask for Sale, Call, Demo, Email, Follow up, Inquiry, Marketing, Memo, Proactive
Call, Quote, Renew Agreement, Task

– Account - The customer account.

– Due Date - Due date for this activity.

– Reminder - Reminder date for this activity.

– Contact - Contact for this activity.

– Start Time - Start time for this activity.

– Assigned To - Employee assigned this activity.

– Phone - Contact's phone.

– End Time - End time for this activity.

– Assigned By - Employee who assigned this activity.

– Project - Requires an account be selected. An associated project.

– Opportunity - Requires an account be selected. An associated opportunity.

– Ticket - Requires an account be selected. An associated ticket.

– Notes - Additional notes about this activity.

4 Click Save.
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Opportunities
CRM > Opportunities

The Opportunities tab maintains opportunities across all accounts. Creating opportunities helps the sales team track and
manage the sale pipeline.

Leads vs Opportunities

Lead

• A qualified prospect that proactively wants to learn more about your products and services.

• A type of prospect who has a problem we can solve and we can sell to.

• The prospect is proactively looking: requested a white paper, a demonstration. They have questions.

• A list of names to cold call is not a lead. It's a prospect list.

Opportunity

• When the conversation turns into near-term purchase possibility.

– They have a defined time-line to make a purchase.

– You are talking with the decision maker(s) and they are actively seeking to solve problem / issue.

– Budget has been discussed and is available.

– The buyer has agreed upon next steps, which may or may not be to purchase from you.

• If you've converted a lead into an opportunity, you have an expected close date.

Adding Opportunities

1 Select the CRM > Opportunities tab.

2 Click New.

3 Enter the following fields.

– Subject

– Next Step

– Account

– Type

– Status

– Location

– Probability

– Rating

– Contact
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– Sales Representative

– Customer PO#

– Phone

– Close Date

– Lead Source

– Amount

– Probability Adjusted Revenue

– Description

4 Select the Activities tab and enter the following. Click Add to add additional rows.

– Subject - Summary of this activity.

– Status - Status of this activity.

– Type - Appointment, Ask for Sale, Call, Demo, Email, Follow up, Inquiry, Marketing, Memo, Proactive
Call, Quote, Renew Agreement, Task

– Account - The customer account.

– Due Date - Due date for this activity.

– Reminder - Reminder date for this activity.

– Contact - Contact for this activity.

– Start Time - Start time for this activity.
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– Assigned To - Employee assigned this activity.

– Phone - Contact's phone.

– End Time - End time for this activity.

– Assigned By - Employee who assigned this activity.

– Notes - Additional notes about this activity.

5 Select the Quotations tab and enter the following. Click Add to add additional rows.

A quote is a form that you send to your prospect or client that lists the prices for the items and services you are selling.

– Quotation Number

– Status

– Name

– Expiry Date

– Created By

– Creation Date

– Summary

– Click Save.

• After you save a quotation, a new Line Items tab displays. You can use it to Add line items to the
quotation.

• You can subsequently Generate, Preview, and Send to Customer all from within this tab.

• You can then set the Status of the quotation to Approved from within this tab. Once approved, you can
Convert the quotation into one or more contracts and a single project.

• For more information see Quotations.

6 Click the Notes tab. Click Add to add notes.

7 Click the Custom Fields tab.

– Enter values in the custom fields, as appropriate for this record.

– Custom fields are maintained using the Admin > My Company >Custom Fields page.

8 Click Attachments tab.

– Click Upload a new file to upload files to this record. For example, a request for proposal (RFP).

9 Click Save.
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Quotations
Service Quotations 334

Product Quotations 337

Processing Service Quotations 340

Processing Product Quotations 343

CRM > Quotations

Part of the sales process is sending your prospects or customers a quote for your products and services. A sales quote
allows the prospective buyer to see the cost for the products and services and make a decision. PulsewayPSA allows you
to generate Quotations that are linked to your opportunities.
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Service Quotations
CRM > Quotations > Service Quotations

The Service Quotations page manages quotes for service items. You can also include product items in service
quotations. Each service line item can override the default prices specified for labor and services. A service quotation
supports the following types of line items:

• Service Items

• Labor Items

• Fixed Labor Item

• Fixed Price Item

• Product Item

• Retainer by Hour Item

• Retainer by Amount Item

Note: For a description of service quotation actions see Processing Service Quotations.

Create New Service Quotations

1 Select the CRM > Quotations > Service Quotations tab.

2 Click New.

3 Enter the following in the Customer Info panel.

– One of the following:

• By Opportunity

• By CRM Account

• By Project

– Contact

4 Enter the following fields in the Quotation Info tab.

– Quotation Number

– Status

– Name

– Expiry Date

– Created By

– Creation Date

– Summary
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5 Click the Custom Fields tab.

– Enter values in the custom fields, as appropriate for this record.

– Custom fields are maintained using the Admin > My Company >Custom Fields page.

6 Click Save. Two additional tabs display: Line Items and Attachments.

7 Click the Line Items tab.

8 Click Add. Select one of the following service items.

– Service Item

– T&M Labor Item

– Fixed Labor Item

– Fixed Price Item

– Product Item

– Retainer by Hour Item

– Retainer by Amount Item

9 When adding a Service Item enter the following:

– Service - Select a service.

– Unit Price - Accept the default or override.

– Quantity - Accept the default or override.

– Period - Recurring or One Time

– Description - Enter a description.

10 When adding a T&M Labor Item entering the following:

– Role - Select a role.

– Unit Price - Accept the default or override.

– Quantity - Accept the default or override.

– Period - Per Hour or Per Day

– Description - Enter a description.

11 When adding a Fixed Labor Item entering the following:

– Name - Enter a name.

– Unit Price - Accept the default or override.

– Quantity - Accept the default or override.

– Period - Per Hour or Per Day

– Description - Enter a description.
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12 When adding a Fixed Price Item entering the following:

– Name - Enter a name.

– Milestone Type - Select a milestone type.

– Unit Price - Accept the default or override.

– Quantity - Accept the default or override.

– Period - Per Hour or Per Day

– Description - Enter a description.

13 When adding a Product Item enter the following:

– Product

– Price Level

– Discount

– QTY

– Price

– Description

14 When adding a Retainer by Hour Item entering the following:

– Name - Enter a name.

– Unit Price - Accept the default or override.

– Quantity - Accept the default or override.

– Period - Contract Length, Weekly, Monthly, Quarterly, Yearly

– Description - Enter a description.

15 When adding a Retainer by Amount Item entering the following:

– Name - Enter a name.

– Retainer Amount - Enter an amount.

– Description - Enter a description.

16 Click Attachments tab.

– Click Upload a new file to upload files to this record. For example, a request for proposal (RFP).

17 Click Save.
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Product Quotations
CRM > Quotations > Product Quotations

The Product Quotations page manages quotes for products. Products are typically defined in inventory first. But product
quotations also supports specifying "free form" products not in your inventory. Each quotation can override the default
prices specified for products.

Note: For a description of product quotation actions see Processing Product Quotations.

Create New Product Quotations

1 Select the CRM > Quotations > Product Quotations tab.

2 Click New.

3 Enter the following in the Customer Info panel.

– Destination Type - Location, Site, Warehouse

– Destination

– Contact

4 Enter the following fields in the Quotation Info tab.

– Quotation Number

– Quotation Date

– PO

– PO Date

– Ship by Method

– Ship by Date

– Project

– Payment Term

– Sales Rep

– Pricing Level

– Shipment Type

– Status

– Notes

5 Click Save. Tabs display at the bottom of the page.

6 Click the Inventory Items tab.

– Click Add.
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– Select one or more products.

– Click OK.

7 Update the following default values for each inventory item added. Changes are reflected in the Grand Total at the
bottom of this tab after you save.

– Pricing Level

– Quantity

– Unit Price

– Discount

8 Click the Items tab and click Add. These are "free form" items that are not defined in your inventory. After you save a
row, click the row to edit it. Changes are reflected in the Grand Total at the bottom of this tab after you save. Repeat
this step to add as many rows as you require.

– Item

– Item Description

– QTY

– Unit Price

– Discount

– Taxable - Yes or No

– Total

– Click Save.

9 Click the Charges tab click Add. After you save a row, click the row to edit it. Repeat this step to add as many rows
as you require.

– Charge

– Currency

– Amount

– Date

– Notes

– Click Save.

10 Click Notes tab.

– Click Add to add a note.

11 Click the Custom Fields tab.

– Enter values in the custom fields, as appropriate for this record.

– Custom fields are maintained using the Admin > My Company >Custom Fields page.
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12 Click Attachments tab.

– Click Upload a new file to upload files to this record. For example, a request for quote (RFQ).

13 Click Save.
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Processing Service Quotations
CRM > Quotations > Service Quotations

Note: To create a service quotation see Service Quotations.

Statuses

Typically each service quotation progresses through one or more of the following statuses:

• New

• Ready to Send

• Sent

• Approved

• Rejected

• Convert to Projects/Contracts

Note that a Rejected quotation can be subsequently Approved.

Actions

Clicking the Action button sets the appropriate status for the service quotation and usually displays a dialog or window
for you to complete the action or review the results.

• Copy Quotation - Copies this quotation to a new quotation

• Generate Quotation - Creates a printable quotation.

• Print Quotation - Displays a printable PDF of the quotation

• Send Quotation - Sends the PDF to email recipients.

• A quotation is changed to Approved or Rejected by selecting either status from the Status field in the header.

• Convert to Projects/Contracts - Converts a quotation to contracts, projects, or both. A quotation must be Approved
before it can be converted.

Messages confirm an action has completed successfully.

Processing Service Quotations

1 Select the CRM > Quotations > Service Quotations tab.

2 Click a quotation with a Status of New.

3 Click Actions > Generate Quotation.

– The Status is set to Ready to Send.

4 Click Actions > Print Quotation.

– Review the PDF to ensure it is correct.
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– If necessary, make changes to the quotation, regenerate and review the PDF again.

5 Click Actions > Send Quotation.

– Email Template

– Attach Quotation - Yes or No.

– Send Email - Separate Recipients or Combined Recipients

– Contacts - Optionally uncheck to exclude.

– Other Email - Enter email addresses manually.

– Attachments - Optionally check to include.

– Click Send.

– The Status is set to Sent.

6 When a client approves or rejects the quotation, set the Status field to:

– Approved

– Rejected

7 Click Save. If the quotation is Approved, you can convert the quotation.

– If converting to a project, only one project will be created. You can optionally copy the structure of an existing
project during conversion.

– If converting to contracts, one contract will be created for each contract type included in your quotation—
Service Items, Labor Items, Fixed Labor Item, Fixed Price Item. You must activate contracts before you can bill
for them.

– If both a contract and project are converted, you must activate the contract before the corresponding project
shows itself linked to the contract. If multiple contracts and a project were created, ensure the correct contract
is linked to the project.

8 Click Actions > Convert to Projects/Contracts.

– A three-step wizard dialog displays.

9 Convert to Project - Set to Yes to enable the other fields in this wizard page.

– Name

– Start Date

– End Date

– Project Manager

– Department

– Copy Project From - Project Templates or All Projects

– Project - Select the specific project template or project to copy from.

– Description
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10 Convert to Contract - Set to Yes to enable the other fields in this wizard page.

– Select one or more service quotation line items to convert to contracts.

– If the quotation is also being converted to a project, any contracts you create will be linked to the project.

11 Convert to Sales Order - Set to Yes to enable the other fields in this wizard page.

– PO #

– PO Date

– Ship By

– Price Level

– Delivery Method

– Payment Term

– Delivery Type

– Link To Project:- Existing Project or Converted Project

– Project - Select if Existing Project was selected.

– Sales Rep

– Notes

12 After conversion, click the Project/Contract button.

– Click the project created for this service quotation, if created. A new window or tab displays the project.

– Click any of the contracts created for this service quotation, if created. A new window or tab displays the
contract. You must activate created contracts to begin billing for their delivery.
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Processing Product Quotations
CRM > Quotations > Product Quotations

Note: To create a product quotation see Product Quotations.

Statuses

Typically each product quotation progresses through one or more of the following statuses:

• New

• Ready to Send

• Send

• Approved

• Rejected

• Convert to Sales Order

Note that a Rejected quotation can be subsequently Approved.

Actions

Clicking the Action button sets the appropriate status for the quotation and usually displays a dialog or window for you to
complete the action or review the results.

• Generate Quotation - Creates a printable quotation.

• Print Quotation - Displays a printable PDF of the quotation

• Email Quotation - Sends the PDF to email recipients.

• Accept - Marks the quotation as accepted by the customer.

• Reject - Marks the quotation as rejected by the customer.

• Convert to Sales Order - Converts the quotation to a sales order. A quotation must be Approved before it can be
converted.

Messages confirm an action has completed successfully.

Processing Product Quotations

1 Select the CRM > Quotations > Product Quotations tab.

2 Click a quotation with a Status of New.

3 Click Actions > Generate Quotation.

– The Status is set to Ready to Send.

4 Click Actions > Print Quotation.

– Review the PDF to ensure it is correct.
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– If necessary, make changes to the quotation, regenerate and review the PDF again.

5 Click Actions > Email Quotation.

– Email Template

– Send Email - Separate Recipients or Combined Recipients

– Contacts - Optionally uncheck to exclude.

– Other Email - Enter email addresses manually.

– Attachments - Optionally check to include.

– Click Send.

– The Status is set to Sent.

6 Do one of the following:

– Click Actions > Approve to set the Status of the quotation to Approved.

– Click Actions > Reject to set the Status of the quotation to Rejected.

7 If the quotation is Approved, click Actions > Convert to Sales Order.
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Sales Orders
Processing Sales Orders 348

CRM > Sales Orders

The Sales Orders page manages sales orders for products. Products are typically defined in inventory first. But sales
orders also support specifying "free form" products not in your inventory. Each sales order can override the default prices
specified for products.

Note: For a description of sales order actions see Processing Sales Orders

Create New Sales Orders

1 Select the CRM > Sales Orders tab.

2 Click New

3 Enter the following in the Customer Info panel.

– Destination Type - Location, Site, Warehouse

– Destination

– Contact

4 Enter the following fields in the Sales Order tab.

– Sales order Number

– Sales order Date

– PO

– PO Date

– Ship by Method

– Ship by Date

– Project - If a project is entered, items listed in the sales order display in the project as a charge when the sales
order is posted.

– Payment Term

– Sales Rep

– Pricing Level

– Shipment Type

– Status

– Notes

5 Click Save. Tabs display at the bottom of the page.
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6 Click the Inventory Items tab.

– Click Add.

– Select one or more products.

– Click OK.

7 Update the following default values for each inventory item added. Changes are reflected in the Grand Total at the
bottom of this tab after you save.

– Pricing Level

– Quantity

– Unit Price

– Discount

8 Click the Items tab and click Add. These are "free form" items that are not defined in your inventory. After you save a
row, click the row to edit it. Changes are reflected in the Grand Total at the bottom of this tab after you save. Repeat
this step to add as many rows as you require.

– Item

– Item Description

– QTY

– Unit Price

– Discount

– Taxable - Yes or No

– Total

– Click Save.

9 Click the Charges tab click Add. After you save a row, click the row to edit it. Repeat this step to add as many rows
as you require.

– Charge

– Currency

– Amount

– Date

– Notes

– Click Save.

10 Click Notes tab.

– Click Add to add a note.

11 Click the Custom Fields tab.
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– Enter values in the custom fields, as appropriate for this record.

– Custom fields are maintained using the Admin > My Company >Custom Fields page.

12 Click Attachments tab.

– Click Upload a new file to upload files to this record.

13 Click Save.
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Processing Sales Orders
CRM > Sales Orders

Note: To create a sales order see Sales Orders.

Statuses

Typically each sales order progresses through one or more of the following statuses:

• New

• Ready to Post

• Posted

• Voided

Actions

Clicking the Action button sets the appropriate status for the sales order and usually displays a dialog or window for you
to complete the action or review the results.

• Post Order - Posts the sales order.

• Generate Order - Creates a printable sales order.

• Print Order - Displays a printable PDF of the sales order

• Email Order - Sends the PDF to email recipients.

• Void Order - Voids the orders.

Messages confirm an action has completed successfully.

Inventory

Inventory Product quantity will be decremented upon Delivering the Products. Posting will allow you to Bill the Customer.

Note: Updating customer hardware assets and software assets from completed sales orders is not currently
supported.

Processing Sales Orders

1 Select the CRM > Sales Orders tab.

2 Click a sales order with a Status of New.

3 Click Actions > Generate Order.

– The Status is set to Ready to Post.

4 Click Actions > Print Order.

– Review the PDF to ensure it is correct.

– If necessary, make changes to the sales order, regenerate and review the PDF again.
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5 Click Actions > Email Order.

– Email Template

– Send Email - Separate Recipients or Combined Recipients

– Contacts - Optionally uncheck to exclude.

– Other Email - Enter email addresses manually.

– Attachments - Optionally check to include.

– Click Send.

6 Click Actions > Post Order.

– The Status is set to Posted.

PulsewayPSA Guide

Release 4.0.41 | March 2021

https://www.pulseway.com/


Sites
CRM > Sites

The Sites page defines field locations where work is performed for a customer. Sites are not considered standard
business addresses for your customer. There may be no permanent personnel at the site. A site could be a:

• a temporary construction site

• a cell tower

You can ship inventory for a sales order or project to a site address, rather than ship it to your customer's standard
business locations. You can quickly create a series of projects, one for each selected site, using a Site Project.

Adding Sites

1 Select the CRM > Sites page.

2 Click New.

3 Enter the following fields in the Site Info tab.

– Site ID

– Site Name

– Owner

– Site Number

– Market Type

– Gate Combination

– Door Combination

– Notes

– Direction

4 Select the Address tab and enter the following.

– Address 1

– Address 2

– City

– State

– Zip Code

– Country

– Latitude

– Longitude
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5 Click the Custom Fields tab.

– Enter values in the custom fields, as appropriate for this record.

– Custom fields are maintained using the Admin > My Company > Custom Fields page.

6 Click Attachments tab.

– Click Upload a new file to upload files to this record. For example, a site map.

7 Click Save.
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Chapter 8: Service Desk
Service Desk Dashboard 353

My Tickets 354

Tickets 355

Hardware Assets 376

Software Assets 379

Knowledgebase 381

Recurring Master Tickets 382

Service Calls 385

The Service Desk module is the central place to manage all the support tickets between you and your clients.

• The Service Desk Dashboard provides real time information on the progress and status of the tickets as they move
through your company’s support process.

• Workflow rules ensure tickets move through your support process in a timely manner and reminders sent along the
way until final resolution.

• The Asset Management folder is a centralized place to store all your clients hardware and software assets.

• Knowledgebase helps share information with employees and reduces the time to find resolutions.
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Service Desk Dashboard
Service Desk > Service Desk Dashboard

The Service Desk Dashboard provides help desk managers with real time information about the status and progress of
tickets as they move through your company's support process. Workflow rules ensure tickets move through your support
process in a timely manner and generate reminders that display on this page.

Specialized dashlets provided by the Service Desk Dashboard include:

• Today's Tickets - A place to set reminders.

• Tickets By Issue Types - A place to set reminders.

• Tickets By Status - A place to set reminders.

• Tickets By Assignee - A place to set reminders.

• Tickets By Priority - place to set reminders.

• Tickets By Queue - A place to set reminders.

See Dashboard (Home) for a description of general purpose dashlets that also display on this page.
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My Tickets
Home > My Tickets

Service Desk > My Tickets

The My Tickets page manages tickets assigned to yourself as the primary assignee. If you assign the ticket to another
employee, the ticket no longer displays on this page. Ticket assignments to queues are ignored by this page. You can
search for all tickets assigned to the queues you are a member of using the Queue search parameter.

Note: See Service Desk > Tickets for a detailed description of how to work with tickets on this page.
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Tickets
Creating/Editing Tickets 357

Processing Tickets 359

Adding Notes to Tickets 361

Adding Time to Tickets 363

Adding Expenses to Tickets 365

Adding Charges to Tickets 367

Adding Service Calls to Tickets 369

Adding To-Dos to Tickets 370

Adding Related Tickets 371

Custom Fields, Attachments for Tickets 372

Batch Actions for Tickets 373

Unknown Tickets 375

Service Desk > Tickets

The Tickets page manages tickets created for customer support issues. A support issue may be a question, a problem, a
request for service, or a suggestion for a future enhancement.

Tickets are assigned to employees (technicians) and queues (groups of employees) to work on the support issue. The
ticket helps track the progress of issue towards resolution. Based on billing agreements with each client, labor time
entries can generate billable hours or deduct a pre-paid amount, or deduct retainer hours.

Tickets creation is initiated by:

• Phone - The client calls and a technician creates the ticket manually.

• Email - An email to support is converted into a ticket automatically.

• Client Portal - The customer creates the ticket manually.
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Creating/Editing Tickets
Service Desk > Tickets

You can set any of the header fields of a new ticket when it is New or when you Edit the ticket.

Creating New Tickets Within PulsewayPSA

1 Select the Service Desk > Tickets page.

2 Click New.

3 You can pre-populate field values in the header of the ticket by selecting a ticket template using the From Template
drop-down list.

4 Enter the following in the Ticket Details > Customer Info panel.

– Client

– Site

– Contact

– Contact Phone - Defaults to the selected contact's phone number.

– Contact Email - Defaults to the selected contact's email.

– Source - The default source is maintained using the Admin > My Company > Service Desk Settings tab.

5 Enter the following fields in the Ticket Details > Ticket Properties panel.

– Ticket Type

– Issue Type

– Sub-Issue Type

– Service Contract - The contract selected will determine how the labor is tracked on this ticket. If there is a
default contract for tickets, it will automatically appear in this field. The default service contract are created
using the Finance > Contracts page.

– SLA - Displays the default service level agreement, if one is set, and allows you to assign one.

– Work Type

6 Enter the following fields in the Ticket Details tab.

– Ticket Title - A one line summary. Used to search tickets by title.

– Ticket Priority

– Status - New, Waiting for Customer, In Progress, Escalated, Assigned, Completed, Customer
Responded. Defaults to New. Customize using the Admin > Service Desk Settings > Ticket Statuses page.

– TTR - Estimated time to tesolution, in hours or minutes.

– Details - Enter expanded description of the support issue.
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– Primary Assignee - The primary employee assigned to work this ticket.

– Open Date - The date/time this ticket was created.

– Queue - Assigns a ticket to queue. Employees assigned to a queue will see tickets assigned to the same
queue displayed on their Home > My Queues page.

– Due Date - The date/time the ticket is scheduled to be resolved.

– Secondary Assignees - One or more employees also assigned to work this ticket. Secondary assignees can
enter time and notes.

– Affected Hardware Asset - Identifies a hardware asset affected by this issue. Records of a client's hardware
assets are maintained using the Service Desk > Asset Management > Hardware Assets page.

– Affected Software Asset - Identifies a software asset affected by this issue. Records of a client's software
assets are maintained using the Service Desk > Asset Management > Software Assets page.

– Select or Drag and Drop Files - Select files to attach to the ticket.

7 Click Save. See the following topics to maintain existing tickets:

– Adding Notes to Tickets

– Processing Tickets

– Adding Time to Tickets

– Adding Expenses to Tickets

– Adding Charges to Tickets

– Adding Service Calls to Tickets

– Adding To-Dos to Tickets

– Adding Related Tickets

– Custom Fields, Attachments for Tickets

– Batch Actions for Tickets

– Unknown Tickets
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Processing Tickets
Service Desk > Tickets

Note: To create a ticket see Creating/Editing Tickets.

Statuses

Each ticket typically progresses through one or more statuses.

• A new install of PulsewayPSA provides the following statuses: New, Waiting for Customer, In Progress,
Escalated, Assigned, Completed, Customer Responded.

• You can customize the list using the Admin > Service Desk Settings > Ticket Statuses page.

• Three "system" statuses cannot be made inactive:
New, Waiting for Customer, and Completed.

• Tickets default to New.

• The Tickets and My Tickets list pages do not display Completed tickets by default. Clicking the Search button
without specifying any parameters includes Completed tickets.

Actions

Tickets support the following types of actions. Each action displays a dialog of additional settings.

• Audits

– Ticket Logs tab - Displays a log of all changes to a ticket, by both users and workflows.

– Workflow Log tab - Shows actions performed on a ticket by a workflow.

• Assign Ticket

– Status - Changes the status of the ticket.

– Queue - Assigns the ticket to a group of employees responsible for the ticket.

– Primary Technician - Assigns an employee to the ticket.

– Comments

• Resolve Ticket

– Status

– Comments

– Publish to Knowledge Base - Yes or No - See Knowledgebase.

• Print Ticket - Displays a printable PDF of the ticket.

– With Notes

– With Time Entries

– With Expenses
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Business Processes

Use the Admin > Business Process:

• Email Templates page to customize ticket email notifications.

• Approval Routes page to create approval items used in workflows.

• Workflow page to automate the processing of tickets.

Customer Info

When you first open a ticket, the Ticket View tab displays. Below the ticket title is the customer's name with a link. Click
this link to show the Customer Info window with the following information:

• Name

• Location

• Account Type

• Address

• Locate on Google Maps - Click this link to show the address on Google Maps.

• Phone

• Fax Number

• Contact Person

– Name

– Phone

– Email

SLA Status

On the Ticket View tab you will see both an SLA field and an SLA Status field. For tickets assigned an SLA, the SLA
Status field shows a link. Click this link to see the estimated and actual times specified for resolving the ticket by the
SLA. The workflow assigned to a ticket can be used to specify when employees or customers should be notified, based
on SLA benchmarks. The Waiting SLA State is time spent waiting for the customer to respond. SLA timers are paused
while waiting for the customer to respond.
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Adding Notes to Tickets
Service Desk > Tickets > (selected ticket)

When you add notes to a ticket you can:

• Change the status of a ticket.

• Notify others of the note you're adding.

• Include an attachment with the note.

Adding Notes to Tickets

1 Select the Service Desk > Tickets page.

2 Click an existing ticket.

3 Click the Activities tab.

– This same tab can be used to Add Time to a ticket.

4 Click Add.

– From Template - Pre-populate field values in the note by selecting a ticket note template.

– Note Date

– Type - The ticket note type.

– Status - Optionally change the status of the ticket when this note is saved.

– Internal Note - If Yes, this note is hidden from clients.

– Details

– General Notes - Optionally enter a note for this labor time entry that will display on the invoice.

– Internal Notes - Optionally enter a hidden not that will not display the invoice.

– Click Save.
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Adding Time to Tickets
Service Desk > Tickets > (selected ticket) > Time Logs

The Time Logs tab adds time to a ticket.

• Time log entries can be created with or without using a timer.

• Time entered on tickets automatically updates the user's timesheet.

• If linked to an active contract, time entered on a ticket can:

– Create billable events for Time & Materials contracts

– Deduct prepaid hours for Retainer by Hours contracts

– Deduct prepaid amounts for Retainer by Amount contracts.

– Track but not bill time for Recurring Services contracts.

Adding Ticket Time Without Using a Timer

1 Select the Service Desk > Tickets page.

2 Click an existing ticket.

3 Click the Time Logs tab.

4 Click Add.

– From Template - Field values can be pre-populated by selecting a ticket time entry template.

– Date Started - The date this labor time started.

– Start Time - The time this labor time started.

– Time Spent (hrs) - The duration of hours worked.

– Role - The role best describing the person performing this work. The role, and optionally the work time,
determine the rate charged for billable hours.

– Work Type - The work type best describing the work itself.

– Status - Optionally change the status of the ticket when this time entry is saved. .

– General Notes - Optionally enter a note for this labor time entry that will display on the invoice.

– Internal Notes - Optionally enter a hidden not that will not display the invoice.

– Click Save.

Adding Ticket Time Using a Timer

You can start, stop and reset a timer when you open or edit a ticket. You can see the elapsed incrementing while you
work the ticket. The elapsed time of a running timer populates the time log entry window when you open it and
continues to update it while it runs.
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You can configure the timer to start automatically whenever a ticket is opened by setting a Enable Stopwatch Autostart
option to Yes. This option is located on the Admin > My Company > Company Settings > Service Desk tab.

5 Select the Service Desk > Tickets page.

6 Click an existing ticket.

7 Optional start, stop, reset the timer in the upper right corner.

8 Click the Time Logs tab.

9 Enter the following:

– From Template - Field values can be pre-populated by selecting a ticket time entry template.

– Date Started - The date this labor time started.

– Start Time - The time this labor time started.

– End Time - The time this labor time ended.

– Time Spent (hrs) - The duration of hours worked.

– Role - The role best describing the person performing this work. The role, and optionally the work time,
determine the rate charged for billable hours.

– Work Type - The work type best describing the work itself.

– Status - Optionally change the status of the ticket when this time entry is saved.

– General Notes - Optionally enter a note for this labor time entry that will display on the invoice.

– Internal Notes - Optionally enter a hidden not that will not display the invoice.

10 Click Save.
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Adding Expenses to Tickets
Service Desk > Tickets > (selected ticket) > Expenses

Service Desk > Tickets > (selected ticket) > Expenses & Charges

Expenses entered on tickets automatically update the user's expense sheets. Alternatively, users can enter an expense
on a expensesheet and link it to a ticket. These can include:

• Expenses billed to customers.

• Expenses reimbursed by your company to the employee.

You can use pre-configured expense types to save time. You can also adjust the default amount for each expense.

Adding Expenses to a Ticket

1 Select the Service Desk > Tickets page.

2 Click an existing ticket.

3 Click the Expenses tab.

– You can also add expenses using the Expenses & Charges tab. The same dialog displays either way.

4 Click Add.

5 Enter the following in the Expense Info tab.

– Expense Type

– Date - The date the expense was incurred

– Amount Spent

– Mark Up / Down - Adjust up or down by amount ($) or percent (%).

– Payment Types - Cash, Check, Debit Card, Credit Card, Other, Company Credit Card.

– Classification - Reimbursable or Non-Reimbursable

– Billable - Yes or No

– Available Expense Sheets-Select an existing expense sheet or add a new one.

– Add New Expense Sheet - If checked, the following display:

• New Expense Sheet Name

• New Expense Sheet Date

– General Notes - Optionally enter a note for this labor time entry that will display on the invoice.

– Internal Notes - Optionally enter a hidden not that will not display the invoice.

6 Enter the following in the Receipts tab.

– Upload a new file
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– Have Receipt - Yes or No

– Notes

7 Enter the following in the Notifications tab.

– Contact

– Resources

– Email template to use

– Other Emails

8 Click Save to save the expense.

9 Click Save to save the ticket.
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Adding Charges to Tickets
Service Desk > Tickets > (selected ticket) > Expenses & Charges

You can add charges to tickets that optionally:

• Are billable or not billable.

• Sells—or provides at no charge—products to your client, decrementing them from your inventory.

• Transfers the products to the client's hardware assets or software assets.

Adding Charges to Tickets

1 Select the Service Desk > Tickets page.

2 Click an existing ticket.

3 Click the Expenses & Charges tab.

4 Click Add.

5 Enter the following in the Charge Info tab.

– Product

– Charge Name

– Status - Pending, Need to Order / Fulfill, Ready to Deliver / Ship, Cancelled. For reporting
purposes only.

– Price Level

– Purchase Date

– Purchase Order

– QTY

– Price

– Billable Amount

– Description

– Unit Cost

– Total Cost

– Billable - Yes or No

– Create Multiple Items - Yes or No - Selecting Yes for this option splits the total quantity into individual lines,
each with a quantity of 1.

– Optional review the Stock Info tab.

6 Enter the following in the Receipts tab.

– Upload a new file
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7 Click Save to save the charge.

8 Click Save to save the ticket.
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Adding Service Calls to Tickets
Service Desk > Tickets > (selected ticket) > Service Calls & To-Dos

The Service Calls & To-Dos tab adds service calls to a ticket.

• Each service call is added to the timesheet of the employee assigned that service call, for tracking purposes.

• Service calls are always non-billable.

• Service calls are first scheduled, then marked as complete after the service call has occurred.

• You can also manage service calls using the Service Desk > Service Calls page and within project tasks.

• You can see any unassigned service calls you create on your My Service Calls page.

Adding Service Calls to Tickets

1 Select the Service Desk > Tickets page.

2 Click an existing ticket.

3 Click the Service Calls & To-Dos tab and click Add.

4 On the Service Call tab:

– Resource

– Start Date

– End Date

– Description - The description is populated with some basic info.

• Client

• Location

• Ticket Number

• Ticket Title

5 On the Notification tab optionally enter:

– Resources - Employees to be notified.

– Email template to use

– Other Emails - Other email recipients to be notified.

6 Click Save.
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Adding To-Dos to Tickets
Service Desk > Tickets > (selected ticket) > Service Calls & To-Dos

The Service Calls & To-Dos tab adds to-dos to a ticket. To-dos can be assigned to yourself or any other employee. To-dos
provide each user with his or her own system-wide checklist of reminder tasks to perform, with due dates and
completion states. Each user's entire to-do list displays on module dashboard pages.

Adding To-Dos to Tickets

1 Select the Service Desk > Tickets page.

2 Click an existing ticket.

3 Click the Service Calls & To-Dos tab click Add.

– Client

– Location

– Complete - Yes or No

– Start Date

– End Date

– Description

4 Click Save.
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Adding Related Tickets
Service Desk > Tickets > (selected ticket) > Related Tickets

The Related Tickets tab links other tickets with the current ticket. Clicking a related ticket opens the related ticket in a
new window or tab, enabling you to work on both tickets in tandem. When you add a related link, links are created in
both tickets.
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Custom Fields, Attachments for Tickets
Service Desk > Tickets > (selected ticket) > Custom Fields

Service Desk > Tickets > (selected ticket) > Attachments

Additional ticket tabs include:

• Custom Fields

– Enter values in the custom fields, as appropriate for this record.

– Custom fields are maintained using the Admin > My Company > Custom Fields page.

• Attachments

– Lists all attachments for the ticket.

– Click Upload a new file to upload files to this record. For example.
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Batch Actions for Tickets
Service Desk > Tickets

Service Desk > My Tickets

Home > My Tickets

The Batch Actions button on ticket search pages enables you to perform actions on multiple tickets at the same time.
When you click the button, two options display:

• Current Page - Performs batch actions on tickets in the current page only.

• All Pages (max 500) - Performs batch actions on tickets in the current search context, up to 500 tickets at a time.

Batch Tickets Wizard

Clicking either of the options above displays a Batch Tickets wizard that steps you through the following choices:

• Choose Tickets

• Choose Operation

• Operation Details

• Confirmation

Step 1 - Choose Tickets

1 Select one or more tickets in the list to batch process.

2 Click Next Step.

Step 2 - Choose Operation

3 Select one of the following options.

– Update Tickets - Updates selected fields in the tickets.

– Assign Tickets - Assigns the tickets to an assignee and/or queue.

– Delete Tickets - Deletes the tickets.

4 Click Next Step.

Step 3 - Operation Details

5 Complete the following, depending on the choice you made in step 2.

– If Update Tickets was selected, you can update the following ticket fields.

• Status

• Priority

• Source

• Issue Type
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• Sub Issue Type

• Ticket Type

– If Assign Tickets was selected, you can change who the ticket is assigned to:

• Change Primary Assignee

• Change Queue

– If Delete Tickets was selected, no detail choices are required.

6 Click Next Step.

Step 4 - Confirmation

7 Review the list of tickets that are about to be batch processed.

– For Update Tickets and Assign Tickets, a list of the fields selected for updating shows the new values that will
be assigned.

– For Delete Tickets, a warning message displays before final confirmation.

8 Click Confirm.
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Unknown Tickets
Service Desk > Unknown Tickets

An Unknown Tickets page displays in the Service Desk module when an Admin > Service Desk >Email Parser receives
email from an email address that is not recognized as belonging to any employee or company contact. Use the Unknown
Tickets page to manually assign tickets to the appropriate customer account or delete them.

PulsewayPSA Guide

Release 4.0.41 | March 2021

https://www.pulseway.com/


Hardware Assets
Service Desk > Asset Management > Hardware Assets

The Hardware Assets page registers hardware owned by the client and located at client location. Hardware assets can
be added using this page, or by adding a charge to a ticket.

Adding Hardware Assets

1 Select the Service Desk > Asset Management > Hardware Assets page.

2 Click New.

3 Enter the following in the Asset Info tab.

– Name

– Category

– Physical Location Info

– Client

– Client Location

– Contact

– Business Impact

– State

– Brand

– Description

4 Click to maintain/review the Additional Info tab.

– Acquisition Date

– Expiration Date

– Warranty Expiration Date

– Purchase Cost

– BarCode

– Vendor

5 Click to maintain/review the Asset Details tab.

– Manufacturer

– Serial

– Model Number

– Machine Group ID

376 PulsewayPSA Guide

Release 4.0.41 | March 2021

Chapter 8: Service Desk www.pulseway.com

https://www.pulseway.com/


377

Chapter 8: Service Deskwww.pulseway.com

– Product Name

– Machine Version

– OS Type

– OS Info

– Version (Major | Minor)

– Login Name

– Last Login Name

– Current User

– First Check In

– Last Check In

– Last Reboot

– Asset Tag

– Max Memory Size

– Max Memory Slots

6 Click to maintain/review the Network Details tab.

– IP Address

– Subnet Mask

– Default Gateway

– Mac Address

– DNS Server(s)

– Connection Gateway IP

– Wins Enabled: Yes or No

– DHCP Enabled: Yes or No

– Primary Wins Server

– Secondary Wins Server

– DHCP

7 Click to maintain/review the Motherboard Info tab.

– Motherboard Manufacturer

– Motherboard Product Code

– Motherboard Version

– Motherboard Serial Number
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– Bus Speed

8 Click to maintain/review the Chassis Info tab.

– Chassis Manufacturer

– Chassis Type

– Chassis Version

– Chassis Serial Number

– Chassis Asset Tag

9 Click the Custom Fields tab.

– Enter values in the custom fields, as appropriate for this record.

– Custom fields are maintained using the Admin > My Company > Custom Fields page.

10 Click Save.
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Software Assets
Service Desk > Asset Management > Software Assets

The Software Assets page registers software owned by the client and located at a client location. Software assets can be
added using this page, or by adding a charge to a ticket.

Adding Software Assets

1 Select the Service Desk > Asset Management > Software Assets page.

2 Click New.

3 Enter the following in the Software Asset tab.

– Client

– Client Location

– Contact

– Name

– Software Category

– Version

– Brand

– Additional Location Info

– Model Number

– Description

4 Click the following in the Software License tab.

– License Name

– License Type

– No. Of Licenses

– Purchase Cost

– Acquisition Date

– Expiration Date

– License Key

– Description

5 Click the Custom Fields tab.

– Enter values in the custom fields, as appropriate for this record.

– Custom fields are maintained using the Admin > My Company > Custom Fields page.
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6 Click Save.

Importing Software Assets

1 Select the Service Desk > Asset Management > Software Assets page.

2 Click Import(I).

3 Click Download Template(T).

– Enter values in the fields and save the template.

4 Click Select and select import file from your directory.

5 Click Import(I).

Note: If there are two or more identical Asset names of the same type of software, PulsewayPSA creates a master
record and then enters each license under the ‘Software License’ tab.
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Knowledgebase
Service Desk > Knowledgebase

The Knowledgebase page manages knowledge base articles related to customer support issues. Typically knowledge
base articles are started by copying them from an actual customer ticket when the ticket is resolved, then updating the
article to serve as a general reference. You can also create a knowledge base article using this page.

• Each knowledge base article can be linked to one or more tickets.

• Each article can include attachments.

• You cannot browse for a knowledge base

Creating New Knowledge Base Articles

1 Select the Service Desk > Knowledgebase page.

2 Click New.

3 Enter the following in the Articles tab.

– Title

– Category

– Keywords

– Publish Date

– Details

4 Select the Related Tickets tab.

– Select one or more tickets.

– Click OK.

5 Click Attachments tab.

– Click Upload a new file to upload files to this record.

6 Click Save.
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Recurring Master Tickets
Service Desk > Recurring Master Tickets

The Recurring Master Tickets page creates a series of "child" tickets for a recurring support issue. For example, a
maintenance service call might be required on a recurring basis for a hardware asset.

• You can create a series of service calls, with each service call linked to its own child ticket.

• You can link a recurring master ticket to a contract. When you do, each child ticket will be linked to that contract.

• Once the recurring master ticket is saved the first time, defaults on the Defaults tab cannot be changed.

• You can select any created child ticket from the Tickets tab of the recurring master ticket.

• You can create additional child tickets by extending the recurring time period on the Recurrence tab. This is the
only recurrence setting you can change.

Creating New Recurring Master Tickets

1 Select the Service Desk > Recurring Master Tickets page.

2 Click New.

3 Enter the following in the Defaults tab.

– Title

– Client

– Location

– Main Branch

– Contact

– Primary Assignee

– Queue

– Issue Type

– Sub-Issue Type

– Ticket Type

– Status

– Priority

– Medium

– Work Type

– Contract

– Due Time
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– Estimated Hours

– Affected Hardware Asset

– Affected Software Asset

– Ticket Details

4 Select the Recurrence tab. Specify how many tickets to create in the series and the interval between them.

• Duration

– Start Date

– End After <N> occurrences

– End On

• Recurrence - A recurrence can only be modified if it's incremental.

– Repeats - Daily, Weekly, Monthly, Yearly

– Repeats <periods>

– Repeats every<N> <periods>

• for weekly Repeat on

– Sun, Mon, Tue, Wed, Thu, Fri, Sat

• for monthly Repeat on

– Day <N> of the month

– The <N> <weekday> of the month

• for yearly Repeat on

– Every <calendar_month> <day_of_month>

– The <N> <weekday> of <calendar_month>

5 Select the Service Calls tab. Optionally create service calls, one for each ticket in the series.

– Create service calls - Yes or No

– Start Time

– End Time

– Description

6 Click the Custom Fields tab.

– Enter values in the custom fields, as appropriate for this record.

– Custom fields for the TicketRecurringMaster module are maintained using the Admin > My Company
>Custom Fields page.

7 Click Save.
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8 Click the new Tickets tab added to the recurring master ticket.

– A series of child tickets are listed.

– Click each ticket to view or work that individual ticket.

– If service calls were created for each ticket, click the Service Calls & To-Dos tab inside the individual ticket to
see it listed.

– If a service contract was added to the recurring master ticket, each individual ticket is linked to this same
contract.
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Service Calls
Service Desk > Service Calls

The Service Calls page creates and manages all service calls created throughout the system.

• Each service call is added to the timesheet of the employee assigned that service call, for tracking purposes.

• Service calls are always non-billable.

• Service calls are first scheduled, then marked as complete after the service call has occurred.

• Using a recurring master ticket you can create a series of child tickets and service calls, with each service call
linked to its own child ticket.

• You can see any unassigned service calls you create on your My Service Calls page.

Adding Service Calls

You can add a Service Call:

• In a Task: see Service Calls topic.

• In a Ticket: see Adding Service Calls to Tickets topic.

• In a Dispatch Calendar: see Dispatch Calendar topic.

Editing a Service Call

1 Select the Service Desk > Service Calls page.

2 Select the Service call you would like to add. If the list is long, you narrow the search results by adding the following
parameters:

– Account

– Start Date

– End date

– Complete (status)

– Created By

– Created On

3 Edit the following in the Service Call tab.

– Resource - Select an employee.

– Complete - Yes or No

– Start Date

– End Date

– Description
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4 On the Notification tab optionally enter:

– Resources - Employees to be notified.

– Email template to use

– Other Emails - Other email recipients to be notified.

5 Click Save.
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Chapter 9: Projects
Projects Dashboard 388

Projects 389

Tasks 403

Resource Utilization 422

Multiple Projects Gantt 423

Archived Projects 424

Template Projects 425
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Projects Dashboard
Projects > Projects Dashboard

The Projects Dashboard displayed in the Projects module provides instant access to projects and tasks requiring your
attention. Drill into dashlet indicators to view lists of corresponding projects and tasks.

Specialized dashlets provided by the Projects Dashboard include:

• My Open Projects - Lists each project assigned to you as the project manager.

• Project Vitals - Projects Over Budget, Projects Over Hours, Unstaffed Projects - Click any count to
display a list of projects in the All Projects page using this filter criteria.

• Projects by Status - Today, This Month, This Year, All - Displays a bar chart by project status.

• Tasks Statistics - Due Today, Due This Week, Due This Month - Click any count to display a list of tasks in the
All Tasks page using this filter criteria.

• Timesheets Statistics - Opened, Submitted, Approved, Rejected

See Dashboard (Home) for a description of general purpose dashlets that also display on this page.

388 PulsewayPSA Guide

Release 4.0.41 | March 2021

Chapter 9: Projects www.pulseway.com

https://www.pulseway.com/


389

Chapter 9: Projectswww.pulseway.com

Projects
Creating a New Project 391

Adding/Viewing Project Financials 394

Adding Related Opportunities to Projects 396

Adding Expenses to Projects 397

Adding Charges to Projects 399

Receipts, Custom Fields, Attachments for Projects 401

Copy Projects 402

Projects > All Projects

Projects and tasks are often better suited than a ticket to track and manage more complex work efforts.

• The All Projects page lists all projects currently being used. Projects are removed from the page when archived. By
default, the search filter does not include template projects.

• You can quickly create new projects by copying an existing project or template project.

• A PulsewayPSA project supports dependencies between tasks, unique deadlines for each task, and can coordinate
the allocation of resources and service calls across multiple projects and tasks.

• Each project provides a complete financial summary of the costs and pricing associated with that project. All labor
time entries, expenses and charges applied to a project are tracked by the Finance module for both billing and
reporting purposes.

• Projects can be created from a service quotation and linked to a corresponding contract. The method used to bill a
project depends on the contract linked to the project. If no contract is linked, the project is billed on a time and
materials basis.

• Expenses can be entered for a project. Alternatively, users can enter an expense on a expensesheet and link it to a
project.

• Products required to complete the project are entered using a charge. Charged products can be added to the
customer hardware assets or software assets.

Once you create or select an existing project you add, maintain and view project details using the following tabs:

• Projects

– Financials

– Related Opportunities

– Expenses

– Charges

– Receipts

– Custom Fields
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– Attachments

• Tasks

– Basics

– Members

– Time Logs

– Service Calls

– Notes

– Custom Fields

– Attachments

Some tabs are not available until the first time you save the project.
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Creating a New Project
Projects > All Projects > New > Project

You start a new project by entering general information in the Project tab.

Project Actions

• Copy Project - Copies the open project to new project.

• Archive Project - Archives the open project.

Creating a New Project

This procedure describes just the main Projects tab within a project. Child tabs are described in other topics.

Select the Projects > All Projects page.

Click New.

Enter the following in the Project tab.

– Project Number

– Project Name

– Client

– Percent Done

– PO# (Project Code)

– Project Type

– Status - Defaults to Open. Users assigned to tasks are not allowed to enter time entries when the project status
is set to Hold or Completed or Closed. Project managers can always add time regardless of the status.

– Priority

– Project Assessment - Classifies the risk level of this project.

– Project Manager

– Department - Department leading this project. You can run a projects by department report.

– Project Management

– Contract - If blank, this project is billed on a time and materials basis.

Contracts must be activated before they display in this drop-down list.

If both a contract and project were converted from a quotation, activating the contract automatically populates this field
with the converted contract.

If multiple contracts and a project were converted from a quotation and the contracts activated, ensure the correct
contract is linked to the project.

– Start Date - The start date of the entire project. Once tasks are entered, this field is determined by the earliest
start date of any task in the project. See Scheduling Projects and Tasks
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– Planned End Date - The planned end date of the entire project. Once tasks are entered, this field is determined
by the latest end date of any task in the project.

– Actual End Date - The actual end date of the entire project. You can manually maintain this date without being
constrained by any tasks.

– Timesheet Route - The timesheet approval route. If None, then timesheets are auto-approved.

– Expensesheet Route - The expenseheet approval route. If None, then expensesheets are auto-approved.

– Site

– Template - Yes or No

– Allow Tasks on Weekends - Yes or No

– Project Description

Click Save. Additional tabs display after the first save.
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Adding/Viewing Project Financials
Projects > All Projects > (selected project) > Financials

The Financials tab summarizes the costs and pricing associated with a project. All labor time entries, expenses and
charges applied to a project are totaled in this tab and tracked by the Finance module for both billing and reporting
purposes.

You can edit the following fields:

• Planned Budgets

• Planned Hours

• PO Amount

• Cost Type

• Cost Center

Note: A user's view of Financial tab data can be hidden, by checking the Hide Financials Tab on Projects checkbox
for the security role being used.

Adding/Viewing Project Financials

1 Select the Projects > All Projects page.

2 Click an existing project.

3 Select the Project > Financials tab.

– Planned Budget - Estimated cost to complete the project.

– Used Budget Labor (Dollars) - Auto-calculated. The number of hours of labor entered multiplied by the wages
of those employees.

– Used Budget Expenses (Dollars) - Auto-calculated. The total of all expenses submitted for the project.
Expenses are added to tasks by employees or added to the project by the project manager using the Expenses
tab.

– Remaining Budget - The total of Planned Budget minus the Used Budget.

– Percent Used (Budget) - Auto-calculated.

– Planned Hours - Estimated hours to complete the project.

– Used Hours - Auto-calculated. Hours entered for the project's by employees.

– Remaining Hours - The total of Planned Hours minus Used Hours.

– Percent Used (Hours) - Auto-calculated.

– PO Amount - Enter the monetary amount of this project as it appears on the purchase order provided by the
client.

– Total Billing - Estimated total billings for the project.
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– Actual Billing - Auto calculated.

– Remained Unbilled

– Cost Type - Define if project is CAPEX, OPEX, None or Client Billable.

– Cost Center
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Adding Related Opportunities to Projects
Projects > All Projects > (selected project) > Related Opportunities

The Related Opportunities tab shows the links between a project and quotation and one or more opportunities. If a
project was created by converting an opportunity into a service quotation, and then converting the service quotation into
a project, these display as Converted From links.

Adding Related Opportunities

1 Select the Projects > All Projects page.

2 Click an existing project.

3 Select the Project > Related Opportunities tab.

4 Click Add.

– Select one or more opportunities created for this same customer.

– Click OK.

5 Click Save.

396 PulsewayPSA Guide

Release 4.0.41 | March 2021

Chapter 9: Projects www.pulseway.com

https://www.pulseway.com/


397

Chapter 9: Projectswww.pulseway.com

Adding Expenses to Projects
Projects > All Projects > (selected project) > Expenses

Expenses entered on projects automatically update the user's expense sheets. Alternatively, users can enter an expense
on a expensesheet and link it to a project. These can include:

• Expenses billed to customers.

• Expenses reimbursed by your company to the employee.

You can use pre-configured expense types to save time. You can also adjust the default amount for each expense.

Adding Expenses to a Project

1 Select the Projects > All Projects page.

2 Click an existing project.

3 Click the Project > Expenses tab.

4 Click Add.

5 Enter the following in the Expense Info tab.

– Expense Type

– Date - The date the expense was incurred

– Amount Spent

– Mark Up / Down - Adjust up or down by amount ($) or percent (%).

– Payment Types - Cash, Check, Debit Card, Credit Card, Other, Company Credit Card.

– Classification - Reimbursable or Non-Reimbursable

– Billable - Yes or No

– Available Expense Sheets-Select an existing expense sheet or add a new one.

– Add New Expense Sheet - If checked, the following display:

• New Expense Sheet Name

• New Expense Sheet Date

– General Notes - Optionally enter a note for this labor time entry that will display on the invoice.

– Internal Notes - Optionally enter a hidden not that will not display the invoice.

6 Enter the following in the Receipts tab.

– Upload a new file

– Have Receipt - Yes or No

– Notes
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7 Click Save to save the expense.

8 Click Save to save the project.
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Adding Charges to Projects
Projects > All Project > (selected project) > Charges

You can add charges to projects that optionally:

• Are billable or not billable.

• Sells—or provides at no charge—products to your client, decrementing them from your inventory.

• Transfers the products to the client's hardware assets or software assets.

Adding Charges to Tickets

1 Select the Projects > Project page.

2 Click an existing ticket.

3 Click the Project > Charges tab.

4 Click Add.

5 Enter the following in the Charge Info tab.

– Product

– Charge Name

– Status - Pending, Need to Order / Fulfill, Ready to Deliver / Ship, Cancelled. For reporting
purposes only.

– Price Level

– Purchase Date

– Purchase Order

– QTY

– Price

– Billable Amount

– Description

– Unit Cost

– Total Cost

– Billable - Yes or No

– Create Multiple Items - Yes or No - Selecting Yes for this option splits the total quantity into individual lines,
each with a quantity of 1.

6 Optionally review the Stock Info tab.

7 Enter the following in the Receipts tab.

– Upload a new file
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8 Click Save to save the charge.

9 Click Save to save the project.
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Receipts, Custom Fields, Attachments for Projects
Projects > All Projects > (selected project) > Receipts, Custom Fields, Attachments

Additional child tabs on the Projects tab include:

• Receipts

– Lists all expense receipts for the project.

• Custom Fields

– Enter values in the custom fields, as appropriate for this record.

– Custom fields are maintained using the Admin > My Company >Custom Fields page.

• Attachments

– Lists all attachments, for both the project and for specific tasks.

– Click Upload a new file to upload files to this record. For example, a project proposal or statement of work.
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Copy Projects
Projects > All Projects > (selected project) > Copy Project

Use the Action > Copy Project button to quickly create new projects by copying an existing project or template project.

Copying Projects

1 Select the Projects > All Projects page.

2 Click an existing project.

3 Click Actions > Copy Project.

– Original Project Name

– New Project Name

– Start Date

– Planned End Date

– Additional Options

• Copy Tasks - Includes tasks, but not members.

• Copy Tasks and Resources - Includes tasks and members.

• None - Excludes tasks and members.

– Copy Tasks Status - Yes or No

– Enforce Project End Date on Tasks - If Yes, all tasks are scheduled within the Start Date and Planned End
Date you specify in the dialog. If No, the Planned End Date is reset, if necessary.

4 Click Finish. The newly copied project displays.
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Tasks
Using the Tasks Tab 405

Adding Task Basics 407

Scheduling Projects and Tasks 408

Adding Members to Tasks 409

Adding Time to Tasks 411

Adding Service Calls to Tasks 414

Adding Notes to Tasks 416

Custom Fields, Attachments for Projects 417

Adding Task Dependencies 418

Updating Tasks by Batch 420

All Tasks 421

Projects > All Projects > (selected project) > Tasks

Within a selected project the Tasks tab maintains all the tasks for that project.

• A project usually comprises a series of shorter-duration tasks.

• You can define an unlimited number of tasks for each project.

• Tasks can be multi-level.

• Each task's start and end date must be within the start and end date of its parent task or project.

• Employees enter labor time for a task, not a project, so at least one task is required to log time. Time entered for a
task is also entered in that employee's timesheet.

• Employees can be assigned to tasks and are called Members of the task. Tasks assigned to an employee display
on the employee's My Task page and on the employee's timesheet, if the task and timesheet date ranges overlap.

Four Types of Tasks

There are four types of tasks you can include in a project:

• Task - A standard task.

• Summary Tasks - A container task. You cannot assign members and enter time for summary tasks. This
supports the project convention of reporting actual work using the lowest level tasks in a project.

• Clock Task - Reserved for future use.

• Milestones - A zero duration task with only an end date. Milestone tasks mark the completion of a phase in a
project. Milestone tasks are typically used with a fixed priced contract to trigger milestone payments. Enabling the
Alter From Project option in a fixed price contract adds a milestone task to a linked project each time you add a
new milestone payment to the contract.
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Note: Unless otherwise noted in the documentation, assume a standard Task is being described.
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Using the Tasks Tab
Projects > All Projects > (selected project) > Tasks

The Tasks tab displays and manages all the tasks in your project.

Project Actions

• Add Task - Adds a new task. When you open a standard task the following tabs display:

– Basics - Sets general properties for a task.

– Members - Assigns employees to a task.

– Time Logs - Enters labor time.

– Service Calls - Schedules a service call.

– Notes - Add notes to a task.

– Custom Fields - Updates custom fields.

– Attachments - Adds attachments.

• Import Tasks - Imports tasks from an Excel spreadsheet into a project. You can download a template to guide you
on how to format your data for import.

• Gantt Chart - Displays all tasks as a Gantt chart. See Adding Task Dependencies. See Multiple Projects Gantt.

• Batch Actions - Updates task by batch within the project.

Task Actions

• Edit Task - Click the task icon to edit an existing task.

• In-Line Edit Click to enable in-line editing of cells in a selected row. Click to save your inline edits.

– Task name

– Duration

– Start Date

– End Date

– Plan Hrs

– Status

– % Done

• Add Dependency Click enter a dependency between the selected row any other row.

• Add Sub-Task - Click add sub-task to the currently selected task.
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• Delete - Click to delete the task.

• Expand/Collapse - Click and to toggle the expansion/collapse of a selected row's child tasks.

• Move - Drag and drop a to move a task.
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Adding Task Basics
Projects > All Projects > (selected project) > Tasks > Add Task > Basics

The Basics tab provides general information about a task.

Adding Task Basics

This procedure is based on a standard Task .

1 Select the Projects > All Projects page.

2 Select an existing project.

3 Select the Tasks tab.

4 Click Add Task.

5 Select Task. This is a standard task type.

– Task Name

– Status - New, Open, In Progress, Completed, Closed. Set to Open to allow employees to enter time. A
program manager can always enter time, regardless of the status.

– Used Hours

– Percent Used

– Cost Type

• (blank) - None.

• Capex - Capital expense.

• Opex - Operating expense.

• Client Billable

– Planned Hours

– Percent Done

– Work Type

– Duration (Days) - The number of days between the Start Date and End Date.

– Start Date - The planned start date of this task. See Scheduling Projects and Tasks

– End Date - The planned end date of this task.

– Task Description

6 Click Save to save the task.

7 Click Save to save the project.
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Scheduling Projects and Tasks
Projects are scheduled from the project start date. Initially you set the project start date and project planned end date
manually. Once you start adding tasks:

• The earliest start date for any task in the project determines the entire project's start date.

• The latest end date for any task in the project determines the entire project's planned end date.

• You can manually maintain an actual end date for the entire project without being constrained by any tasks.

When working with task date ranges, you'll notice that:

• The start date and end date of a new task defaults to either its parent task, if it has one, or to the start date and
planned end date for the entire project.

• Manually changing the start date of a task causes the task end date to shift, preserving the same duration for the
task.

• Manually changing the end date of a task causes the task duration to change, preserving the start date of the
task.

• Making tasks dependent enables you to shift the dates for an entire series of tasks at one time. See Adding Task
Dependencies. Dependencies also enable you to schedule backwards if you like, from the last task in a series of
tasks to the first task in that series.

When working with the date ranges of parent tasks and child tasks:

• Parent task date ranges cannot be adjusted manually. The date range for a parent task is determined by the date
ranges of its child tasks. The same is true for multiple levels of parent tasks.
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Adding Members to Tasks
Projects > All Projects > (selected project) > Tasks > (selected task) > Members

The Members tab assigns one or more employees to a task. Tasks assigned to an employee:

• Display on the employee's My Task page.

• Display on the employee's timesheet, if the task and timesheet date ranges overlap and Admin > Time Sheet >
Preload Timesheets is enabled.

• Display on the Resource Utilization page.

Note: The Members tab is hidden when a task is opened using the All Tasks page.

Constraining Employee Hours for a Task

For each task you can constrain:

• The number of Hours a specific employee is allowed to enter for a task. If Hours is set to zero, any number of hours
can be entered.

• The Role a specific employee must use when entering time for a task. If set to ALL, the employee can select any
role enabled for his or her employee record.

Adding Task Members

This procedure is based on a standard Task .

1 Select the Projects > All Projects page.

2 Select an existing project.

3 Select the Tasks tab.

4 Select an existing task.

5 Click the Members tab.

6 Click Add.

– Select an employee.

– Click OK.

7 Change the role from ALL, if more than one role can be selected.

8 Click the clock icon in the Hours cell.

– The From Date and To Date default to the start and end date of the task. These date ranges are for forecasting
and employee calendars only. They do not constrain when an employee can enter time.

– Enter the number of Hours this employee is allowed to enter for this task.

– Clicking the Populate Periods button enables you to quickly add a series of time periods:
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• Daily Recurring Periods

• Weekly Periods

• Monthly Periods

• Monthly Periods

9 Click Save to save the Members tab.

10 Click Save to save the project.
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Adding Time to Tasks
Projects > All Projects > (selected project) > Tasks > (selected task) > Time Log

The Time Logs tab adds time to a task.

• Time log entries can be created with or without using a timer.

• Time entered on a task automatically updates the user's timesheet.

• If linked to an active contract, time entered on a task can:

– Create billable events for Time & Materials contracts

– Deduct prepaid hours for Retainer by Hours contracts

– Deduct prepaid amounts for Retainer by Amount contracts.

– Track but not bill time for Recurring Services contracts.

• These procedures are based on a standard Task .

Adding Time to a Task Without Using a Timer

1 Select the Projects > All Projects page.

2 Click an existing project.

3 Select the Tasks tab.

4 Click an existing task.

5 Click Add.

6 Click the Time Logs tab.

– Date Started - The date this labor time started.

– Start Time - The time this labor time started.

– End Time - The time this labor time started.

– Time Spent (hrs) - The duration of hours worked.

– Role - The employee's role when performing the work. The role, and optionally the work time, determine the
rate charged for billable hours.

– Work Type - The type of work performed.

– General Notes - Optionally enter a note for this labor time entry that will display on the invoice.

– Internal Notes - Optionally enter a hidden not that will not display the invoice.

7 Click the Notifications tab.

– Resourses

– Email templates to use
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– Other emails

– Click Save to save the time entry.

8 Click Save to save the Time Logs tab.

9 Click Save to save the task.

10 Click Save to save the project.

Adding Time to a Task Using a Timer

1 Select the Projects > All Projects page.

2 Click an existing project.

3 Select the Tasks tab.

4 Click an existing task.

5 Click the Time Logs tab.

6 Click Start Timer.

– A new green row displays.

– The Start Timer is replaced by a Stop Timer button.

– You may close the ticket and return later.

7 Click Stop Timer. The Time Details tab displays. Enter the following:

– Date Started - The date this labor time started.

– Start Time - The time this labor time started.

– End Time - The time this labor time started.

– Time Spent (hrs) - The duration of hours worked.

– Role - The role best describing the work performed. The role, and optionally the work time, determine the rate
charged for billable hours.

– Work Type - Another way of classifying the work performed.

– General Notes - Optionally enter a note for this labor time entry that will display on the invoice.

– Internal Notes - Optionally enter a hidden not that will not display the invoice.

8 Click the Notifications tab.

– Resourses

– Email templates to use

– Other emails

– Click Save to save the time entry. The green row no longer displays.

9 Click Save to save the Time Logs tab.
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10 Click Save to save the task.

11 Click Save to save the project.

PulsewayPSA Guide

Release 4.0.41 | March 2021

https://www.pulseway.com/


Adding Service Calls to Tasks
Projects > All Projects > (selected project) > Tasks > (selected task) > Service Calls

The Service Calls tab adds service calls to a task.

• Each service call is added to the timesheet of the employee assigned that service call, for tracking purposes.

• Service calls are always non-billable.

• Service calls are first scheduled, then marked as complete after the service call has occurred.

• You can also manage service calls using the Service Desk > Service Calls page and within tickets.

• You can see any unassigned service calls you create on your My Service Calls page.

Adding Service Calls to Tasks

This procedure is based on a standard Task .

1 Select the Projects > All Projects page.

2 Click an existing project.

3 Select the Tasks tab.

4 Click an existing task.

5 On the Service Calls tab click Add.

6 On the Service Call tab enter the following:

– Resource

– Start Date

– End Date

– Description - The description is populated with some basic info.

• Client

• Project Number

• Project Name

• Task Name

7 On the Notification tab optionally enter:

– Resources - Employees to be notified.

– Email template to use

– Other Emails - Other email recipients to be notified.

8 Click Save.

9 Click Save to save the task.
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10 Click Save to save the project.
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Adding Notes to Tasks
Projects > All Projects > (selected project) > Tasks > (selected task) > Notes

The Notes tab adds notes to a task.

Adding Notes to Tasks

This procedure is based on a standard Task .

1 Select the Projects > All Projects page.

2 Click an existing project.

3 Select the Tasks tab.

4 Click an existing task.

5 Click Add Note.

– Note Date

– Details - Enter a note for this task.

– Click Save to save the note.

6 Click Save to save the task.

7 Click Save to save the project.
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Custom Fields, Attachments for Projects
Projects > All Projects > (selected project) > Tasks > (selected task) > Custom Fields, Attachments

Additional tabs for each task include:

• Custom Fields

– Enter values in the custom fields, as appropriate for this record.

– Custom fields are maintained using the Admin > My Company > Custom Fields page.

• Attachments

– Lists all attachments for task.

– The Project > Attachments tab displays all attachments, for both the project and for all tasks.

– Click Upload a new file to upload files to this record. For example, a statement of work.
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Adding Task Dependencies

Projects > All Projects > (selected project) > Tasks >

The Dependency dialog enables you to define a dependency between a selected task and one or more other tasks.

Dependencies

Adding a dependency to a task makes its scheduling dependent on the "other" task.

• If you change the date range of the other task, the dependent task will change automatically to accommodate the
change.

• If you change the date range of the dependent task, the dependency is removed.

• A task can be dependent on multiple other tasks.

Dependencies in the Gantt Chart

Click the Gantt Chart button after setting a dependency. Dependencies are identified by an arrow running between the
tasks. The arrowhead points to the dependent task.

Four Types of Dependency

Dependencies are classified from the point of view of the dependent task looking towards the "other" task.

• Finish-to-Start (FS) - The other task's finish determines the dependent task's start. This is the most common
way to set a dependency between two tasks.

• Start-to-Start (SS) - The other task's start determines the dependent task's start.

• Finish-to-Finish (FF) - The other task's finish determines the dependent task's finish.

• Start-to-Finish (SF) - The other task's start determines the dependent task's finish. This is the least common
way to set a dependency between two tasks.

Lag Days

Lag days shift the dependent task forward in time (positive) or backward in time (negative) from the other task. The
result either causes a scheduling gap between the two tasks, or an scheduling overlap. Lag days do not change the
scheduling of the other task.

Setting a Task Dependency

1 Select the Projects > All Projects page.

2 Click an existing project.

3 Select the Tasks tab.

4 Click the icon for a task and enter the following:

– Row

– Task
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– Type - Defaults to Finish-to-Start (FS).

– Lag Days

– Click OK.

5 Click Gantt Chart to view the dependency.

Click Save to save the project.
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Updating Tasks by Batch
Projects > All Projects > (selected project) > Tasks > Batch Actions

Batch Actions enables you to update several tasks at once. A two step wizard prompts you to:

• Select tasks.

• Select an action.

Running Batch Actions

1 Select the Projects > All Projects page.

2 Click an existing project.

3 Select the Tasks tab.

4 Click Batch Actions.

5 Select tasks on the Choose Tasks tab.

6 Select one of the following actions to perform on the Choose Action tab.

– Slide Tasks - Slide dates forward or backward by a specific number of days or months for selected tasks.

• Slide - Forward or Backward

• Slide Dates - Start Dates, End Dates, Start & End Dates

• Duration - <N><periods>

– Assign Members - Assign selected users to selected tasks.

– Remove Members - Remove selected users from selected tasks.

– Delete Tasks - Delete selected tasks and their related data.

– Update Status - Update the status of selected tasks.

• New Status - Select as status.

– Update Percentage - Update percentage of selected tasks.

• New Percentage - Select as status.

7 Click Finish.

8 Click Save to save the project.
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All Tasks
Projects > All Tasks

The All Tasks page lists all tasks in all projects currently being used. Click a task to display only the details of that task.
This enables you to rapidly update a series of tasks in multiple projects, without having to open each project separately.

When you open a standard task the following tabs display:

• Basics - Sets general properties for a task.

• Time Logs - Enters labor time.

• Service Calls - Schedules a service call.

• Notes - Add notes to a task.

• Custom Fields - Updates custom fields.

• Attachments - Adds attachments.

Additional Guidelines

• All project managers can view all tasks in all projects using the All Tasks page

• The Members tab is hidden when a task is opened using the All Tasks page.

• Tasks are removed from the All Tasks page when their corresponding projects are archived.
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Resource Utilization
Projects > Resource Utilization

The Resource Utilization page shows a timeline of each employee's scheduled task assignments. Click any task to to
edit that task.

Note: You must add an employee to the Members tab of a task and schedule the date range and hours that
employee will work, for that employee's utilization to display on this page.

The resource allocation bar for each employee displays line segments in three colors.

• - Indicates this employee has available hours to allocate to a task.

• - Indicates this employee has been assigned too many hours. Over-utilization occurs when:

– The same employee is scheduled concurrently for multiple tasks.

– The employee is assigned too many hours, even for a single task.

• - Indicates this employee is assigned hours, but not yet fully allocated.

The page displays resource utilization by Week, Month or Year. Use the search bar to filter the page by specific users,
department, start date or end date.
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Multiple Projects Gantt
Projects > Multiple Projects Gantt

The Multiple Projects Gantt page shows a timeline of all projects and tasks. Click any task to to edit the Title, Start, End
and Completion percentage for that task. You can also use this page to check for gaps and overlaps between projects.
The page displays by Week, Month or Year. Use the search bar to filter the page by project, start date or end date.
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Archived Projects
Projects > Archive Projects

The Archived Projects page maintains archived projects. All project data remains intact. You can unarchive a project at
any time. Archiving a project removes it from the following pages:

• Projects Dashboard

• All Projects

• Multiple Projects Gantt

Archiving a Project

1 Open a project on the Projects > All Projects page.

2 Click Actions > Archive Project.

3 Unarchiving a Project

4 Open a project on the Projects > Archived Projects page.

5 Click Actions > Unarchive Project.
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Template Projects
Projects > Template Projects

The Template Projects page maintains template projects. By default, the search filter only displays template projects.
Billables cannot be entered for project templates. Project templates do not display the Time Log and Expenses tabs.
Changes to template projects to not update projects after they are copied.

If billables are already entered for a project and the project is converted to a template, then the data is preserved. If the
template project is converted back to a project, the billable data redisplays.

Converting a Project to a Project Template

Select the Projects > All Projects page.

1 Click the Project tab.

2 Set the Template option to Yes.

– Set this option to No to convert a project template to a project.

3 Click Save.

Copying Projects from Template Projects

1 Select the Projects > Template Projects page.

2 Click an existing template project.

3 Click Actions > Copy Project.

– Original Project Name

– New Project Name

– Start Date

– Planned End Date

– Additional Options

• Copy Tasks - Includes tasks, but not members.

• Copy Tasks and Resources - Includes tasks and members.

• None - Excludes tasks and members.

– Copy Tasks Status - Yes or No

– Enforce Project End Date on Tasks - If Yes, all tasks are scheduled within the Start Date and Planned End
Date you specify in the dialog. If No, the Planned End Date is reset, if necessary.

4 Click Finish. The newly copied project displays.
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Inventory Dashboard
Inventory > Inventory Dashboard

The Inventory Dashboard provides instant access to inventory activities requiring your attention. Drill into dashlet
indicators to view lists of corresponding inventory activities.

Specialized dashlets provided by the Inventory Dashboard include:

• Purchase Order Amount By Status - Today, This Month, This Year, All - Displays a bar chart of purchase order
amounts by status.

• Purchase Orders By Status - Today, This Month, This Year, All - Displays a list of purchase order counts by
status.

See Dashboard (Home) for a description of general purpose dashlets that also display on this page.
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Manage Products
Inventory > Products > Manage Products

The Manage Products page lists all the inventory-managed products in your company. Once a product record is created
you can:

• Assign and adjust quantities of products in inventory storage locations.

• Procure products using purchase orders.

• Add products to tickets as charges.

• Add products to tickets as charges.

• Add products to sales orders.

Products and UPC Codes

Each product can have multiple UPC codes created for it. Each Product and UPC Code record is maintained separately,
using the following set of tabs.

• UPC

• Suppliers - You must add a supplier to a product record before you can create a purchase order for that supplier to
deliver that product. The cross-reference includes the default unit cost for the product from that supplier.

• Locations

• Pricing Levels

• Composition

• Options

• Stock By Location

• Stock By Project

• Notes

• Custom Fields

• Attachments

The parent Product Info tab is shared by all combinations of products and UPS codes.

Creating Product Records

1 Select the Inventory > Products > Manage Products page.

2 Click New.

3 Enter the following on the Product Info tab.

– Product Name

– Product Number
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– Product Type

– Product Category

– Product Sub Category

– Brand

– Manufacturer

– Product Description

4 Enter the following on the UPC tab.

– UPC - Click the gear icon to generate a new universal product code.

You can also click the Add New UPC to add an additional UPC code.

– Maximum Level - Informational only, indicates the maximum level of the product.

– Warranty

– SKU/Unique ID

– Optimal Level

– Expense Account

– Width

– Low Level

– Income Account

– Height

– Reorder Level - Not yet implemented.When Autogen PO is set to Yes on the Options tab and the stock level
for this product drops to equal or below the Reorder Level, a purchase order is automatically created to
replenish inventory to the Maximum Level.

– Cost Code

– Length

– Stacking

– Pack

– Weight

– Color

– UOM - Units of measure.

5 Click Save to save this product record.

– Additional product tabs display.

6 Click the Suppliers tab. Click Add. For each supplier enter:
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– Supplier - You must add a supplier to a product record before you can create a purchase order for that supplier
to deliver that product. The cross-reference includes the default unit cost for the product from that supplier.

– Primary Contact

– Product Id/Part No

– Unit Cost

– Reorder Qty

– Tax Rate

7 Click the Pricing Levels tab. Click Add. For each pricing level enter:

– Pricing Level

– Price

8 Click the Composition tab. Click Add. For each composition enter:

– Material

– Qty

– UOM - Unit of measure.

– Notes

9 Click the Composition tab. Click Add. For each composition enter:

– Material

– Qty

– UOM - Unit of measure.

– Notes

10 Click the Options tab.

– Autogen PO - Not yet implemented.When Yes and the stock level for this product drops to equal or below the
Reorder Level, a purchase order is automatically created to replenish inventory to the Maximum Level.

– Prelabeled - Yes or No

– Requires Procurement - If No, you do not need a purchase order to add quantities to storage locations for this
product. Intended for temporary items.

– Use Levels - Yes or No

– Serialized - Yes or No

– Assembly Req'd - Yes or No

– Discontinued - Yes or No

– Hazardous - Yes or No

– Taxable - Yes or No
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11 Click the Stock By Location tab.

– Review the current quantity stored in each warehouse location list.

12 Click the Stock By Project tab.

– Review the current quantity stored in each warehouse location list, allocated to a project.

13 Click the Notes tab. Click Add to add a note.

14 Click the Custom Fields tab.

– Enter values in the custom fields, as appropriate for this record.

– Custom fields are maintained using the Admin > My Company > Custom Fields page.

15 Click Attachments tab.

– Click Upload a new file to upload files to this record.

16 Click Save to save this product and UPC code record.
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Product Availability
Inventory > Products > Manage Products

Use the Product Availability page to check the quantities available for each product and UPC code combination.
Selecting a row shows two tabs.

• Product by Location - Shows the quantity available at each location for the selected product.

• Product by Project - Shows the quantity available at each location, grouped by project, for the selected product.

The parent Product Information tab displays the following:

• Product Number

• Product Name

• UPC

• Product Description

• Product Type

• Category

• Sub Category

• Brand

• Manufacturer

• QTY In Stock

• QTY Available

• QTY Committed - The quantity committed to pick orders.

• QTY On Order

• Low Level

• Re-Order Level

• Max Level

• Optimal Level
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Purchase Orders
Inventory > Procurement > Purchase Orders

The Purchase Orders page creates an order to purchase products from a supplier. The purchase order includes product
quantities, an expected delivery date, the delivery location, and prices for each product in the purchase order. On delivery
the inventory storage quantities are incremented. Payment terms usually specify an agreed to number of days after
delivery for payment. The supplier sends an invoice, which is matched against the delivery record, then processed by
your company to pay the supplier.

Product/Supplier Cross-Reference

A supplier must be added to the Manage Products > Supplier tab, before you can create a purchase order for that
supplier to deliver that product. The cross-reference includes the default unit cost for the product from that supplier.

Note: For a description of purchase order actions see Processing Purchase Orders.

Creating New Purchase Orders

1 Select the Inventory > Procurement > Purchase Orders page.

2 Click New.

3 Enter the following on the New Purchase Order tab. Notice this tab does does not yet identify the supplier.

– (PO) Date

– Ship Method

– Payment Term

– (PO) Expected Date

– Location

– Default Discount

– Reference #

– Project

– Notes

4 Click Add on the on the Purchase Order Item tab.

– Select one or more Products.

– Click OK.

– QTY - Enter the quantity to order for each time. You can also specify this later.

5 Click Continue in the upper right corner of the page.

– Suppliers who are eligible to deliver the products you added to your purchase order are listed in the upper
panel of the page.
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– If no suppliers are eligible to deliver the products you added in the previous page, that product cannot be
included in the creation of purchase orders.

– Click the Select Lowest Cost button in the lower panel to list each item and the suppliers who can deliver
them. The lower cost supplier for each product is selected by default.

– Optionally change the selected supplier for each item. For example, you may wish to consolidate the creation
of POs by selecting the fewest number of suppliers possible.

6 Click Create POs.

– The message box lists the newly created purchase order numbers.

– The status of the newly created purchase orders is New.

7 Open a purchase order you just created.

– A Supplier Info panel displays in the header of the purchase order.

– A PO # field has been added to the header. It cannot be edited.

8 Optionally adjust the editable fields for each item in the Purchase Orders Items tab. A Grand Total displays at the
bottom of this tab.

– Qty

– Unit Cost

– Discount

– Tax

9 Click the Purchase Order Charges tab click Add.

– Charge

– Currency

– Amount

– Date

– Notes

– Click Save.

10 Click the Custom Fields tab.

– Enter values in the custom fields, as appropriate for this record.

– Custom fields are maintained using the Admin > My Company > Custom Fields page.

11 Click Attachments tab.

– Click Upload a new file to upload files to this record.

12 Click Save.
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Processing Purchase Orders
Inventory > Procurement > Purchase Orders

Note: To create a purchase order see Purchase Orders.

Statuses

Typically each purchase order progresses through one or more of the following statuses:

• New

• Ready to Send

• Sent

• Partially Received

• Received

• Fully Received

• Voided

Actions

Clicking the Action button sets the appropriate status for the purchase order and usually displays a dialog or window for
you to complete the action or review the results.

• Generate Order - Creates a printable purchase order. Sets purchase order to Ready to Send.

• Print Order - Displays a printable PDF of the purchase order.

• Email Order - Sends the PDF to email recipients. Sets purchase order status to Sent.

• Void Order - Cancels the order. Partially Received and Received orders cannot be voided nor regenerated.

Messages confirm an action has completed successfully.

Processing Purchase Orders

1 Select the Inventory > Procurement > Purchase Order tab.

2 Click a purchase order with a Status of New.

3 Click Actions > Generate Order.

– The Status is set to Ready to Send.

4 Click Actions > Print Order.

– Review the PDF to ensure it is correct.

– If necessary, make changes to the purchase order, regenerate and review the PDF again.

5 Click Actions > Email Order.

– Email Template
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– Send Email - Separate Recipients or Combined Recipients

– Contacts - Check to include.

– Other Email - Enter email addresses manually.

– Attachments - Optionally check to include.

– Click Send.

– The Status is set to Sent.

6 Click Save.

– See Receiving Purchase Orders.
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Receiving Purchase Orders
Inventory > Fulfillment > Receiving Purchase Orders

The Receiving Purchase Orders page processes receipt of inventory quantities requested by a purchase order. Each
receiving order is assigned a unique order number. There may be multiple receiving orders created for a single purchase
order, one for each separate delivery by the supplier. A purchase order must be Sent to the supplier to display on this
page.

Receiving Location

Received inventory is received into a warehouse's default "virtual location". The location is identified by the warehouse
prefix and word Default. For example, W105_:Default.

Statuses

Typically each receiving order progresses through one or more of the following statuses:

• Open - No item quantities have been received.

• Partially Received - Some item quantities have been received.

• Fully Received - All item quantities have been received.

• Received - Receiving is finished for this receiving order, regardless of whether it is currently Partially Received
or Fully Received. Typically used to prevent further receiving quantities on a partially received order.

Actions

Clicking the Action button sets the appropriate status for the receiving order.

• Finish Receiving - The receiving order status is set to Received.

Creating Receiving Orders

1 Select the Inventory > Fulfillment > Receiving Purchase Orders page.

2 Select an existing purchase order with an RO Status of Open.

3 Note the following on the Receiving Order tab.

– Supplier

– Contact

– Contact Phone

– Contact Email

– Currency

– RO #

– (PO) Order #

– Order Date
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– (PO) Order Expected Date

– Notes

4 On the Receiving Order Items tab click a row to record receipt of the item quantity.

– For a non-serial controlled quantity enter the following:

• Qty Received - Enter the quantity received for this item. You can compare the quantity entered with the
quantity ordered and quantity already received in the header of this dialog.

• Lot # - The lot number, if item quantities are lot tracked.

• Reference #

• Expiry Date - Enter if the inventory has a shelf life expiration date.

• Notes

5 Click OK.

– For a serial controlled quantity enter the following for each item.

• Serial #

• Lot #

• Expiry Date

• Reference

• Notes

6 Click OK.

7 Click Save to save the receiving order.
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Deliver Product Charges
Inventory > Fulfillment > Deliver Product Charges

The Deliver Product Charges page processes the delivery of product quantities demanded by associated tickets or
projects. By default product deliveries consume inventory. You can optionally populate the list of hardware assets or
software assets with the product quantities delivered.

Listing Product Charge Deliveries

You must first create product charges in tickets or projects. Then on this page:

Click Search Product Charges.

Click Search.

Optionally filter the list by entering a string in the Result field.

Optionally review the history of previous deliveries for any one row by clicking the history icon.

Delivering Product Charges

1 For a selected delivery, click the truck icon.

2 Enter the following:

– Delivery Method

– Delivered By

– Delivery Date

– QTY In Stock - The stock available in inventory to deliver.

– QTY Delivered - The quantity already delivered.

– QTY To Deliver - Accept or modify the quantity to be delivered.

– Remove From Inventory - Yes, No

– Create Asset - None, Hardware, Software
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Stock Adjustments
Inventory > Stock Adjustments

The Stock Adjustments page adjusts the quantity of inventory shown by the system to be available in warehouse
locations. It's a quick way:

• Initialize inventory quantities.

• Correct inventory inaccuracies discovered during cycle job counts.

Each stock adjustment references a single warehouse.

Statuses

Stock adjustments progress through the following statuses:

• Open - The stock adjustment is new and unposted.

• Posted - The stock adjustment has been posted.

Actions

Clicking the Action button sets the appropriate status for the stock adjustment.

• Post Adjustments - Sets the stock adjustment record to Posted.

Adjusting Inventory Stock Levels

1 Select the Inventory > Stock Adjustments page.

2 Click New.

3 Enter the following in the Adjustment tab.

– Adjustment #

– Warehouse

– Created Date

– Posted Date

– Notes

4 Click Save to save the stock adjustment record.

5 Click Add on the Inventory Items tab.

– Select one or more products.

– Click OK.

6 Enter the following for each item:

– New Qty

– Reason
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7 Click Save to save your stock adjustment record.

8 Click the Action > Post Adjustments.

– The stock adjustment is Posted.

– Item quantities are adjusted in the warehouse you specified.
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Chapter 11: Home
Dashboard (Home) 443

Views 445

My Queues 446

My Tickets 447

My Tasks 448

My Grouped Tasks 449

My Service Calls 450

My Calendar 451

My Projects 456

My Expense Reports 457

My Approvals 459

My Templates 460

Collaborations 461

My Timesheet 462

Dispatch Calendar 464

Adjust Timesheets 465

Adjust Expenses 466

Downloads PulsewayPSA 467

Every user in the system has access to the Home. It’s the starting point for day to day use. Your security role determines
what Home options you have.
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Dashboard (Home)
Home > Dashboard

Admin > Dashboard

HR > Dashboard

All modules have a dashboard to display important data. The Administrator Dashboard tracks important events and
activities, not necessarily identified as a ticket or project or CRM activity.

1 Click the Admin module on the far right of the global navigation bar.

2 Click Admin Dashboard, the first selection on the local navigator bar on the left.

– My To Do List - A place to set reminders. For example: stop by HR and get benefit change form. Enter
text, then click the calendar and set the date, or simply enter the word tomorrow. Press the Enter key on your
keyboard to add the entry. To Dos created for a ticket display the name of the ticket along with a link. You can
click the link to access the ticket immediately.

– My Notes - A quick summary of thoughts or ideas that you don’t want to forget during the day.

– News - Company news generated from the Admin module.

Sharing

If user has the rights, he or she can use the system to share information such as events, announcements, and news.
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Removing My To-Do List Items

The user can remove items in the My To-Do List by clicking the red X in the Already Done tab and clicking on the red X.
The user can reset the My To-Do List by clicking the yellow arrow, if an item was completed by mistake.

Deleting

The user can simply erase My Notesby highlighting the words and selecting delete on the keyboard.
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Views
Home > Views

A view is a user-defined filtered search of a specific list page. The Views page shows all views created by yourself or
shared with you by others. Selecting a view selects both the specific list page and the search filter parameters saved
with that view.

Creating a View

To create and save a new view by name on any list page:

1 From the Views combo box, select an existing view, or enter new search parameters from scratch.

2 Click the gear icon, then click the Save As option, then enter a name.

3 Optionally make your view Public or set it be your Default for the page you're working with.

Working with Views

• You can Save, SaveAs, Edit, Delete, or Share your own view.

• You can SaveAs a view shared by someone else.

• When you Share your own view, you can select both individual employees or queues of service desk employees to
share it with.

Column Chooser

All list pages display a Column Choosericon. Click the icon to select and order your column choices for a list page. You
can then optionally save it as a view or export the data.

Export

All list pages support the ability to Export the Current Page or All Pages to an .xls format file. Only currently
displayed columns are exported in the order they are displayed. Use the Column Chooser to add, remove or reorder
columns before exporting.
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My Queues
Home > My Queues

The My Queues folder displays one or more queues if you are a member of any ticket queues. A ticket is assigned to a
queue using the Service > Tickets > Ticket Details tab. You can search for all tickets assigned to the queues you are a
member of using the Queue search parameter on the My Tickets page.

Employees are added to ticket queues using the:

• Admin > Service Desk > Queues page.

• HR > Employee > Associated Queues tab.

If you are not assigned to any queues, the My Queues folder does not display in your Home module.
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My Tickets
Home > My Tickets

Service Desk > My Tickets

The My Tickets page manages tickets assigned to yourself as the primary assignee. If you assign the ticket to another
employee, the ticket no longer displays on this page. Ticket assignments to queues are ignored by this page. You can
search for all tickets assigned to the queues you are a member of using the Queue search parameter.

Note: See Service Desk > Tickets for a detailed description of how to work with tickets on this page.
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My Tasks
Home > My Tasks

The My Tasks page enables you to update tasks assigned to you by project managers of projects. You can enter time
and update other properties of tasks. A task may have child tasks you can update as well. Time entered on tasks
updates your timesheet as well. This page does not display tasks of archived projects.

Note: See Projects > Tasks for a detailed description of how to work with tasks on this page.
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My Grouped Tasks
Home > My Grouped Tasks

The My Grouped Tasks page lists all tasks you are assigned to by project first, then by task.

The My Grouped Tasks page enables you to update tasks assigned to you by project managers of projects. You can
enter time and update other properties of tasks. A task may have child tasks you can update as well. Time entered on
tasks updates your timesheet as well. This page does not display tasks of archived projects.

Note: See Projects > Tasks for a detailed description of how to work with tasks on this page.
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My Service Calls
Home > My Service Calls

The My Service Calls page enables you to update service calls created to assist customers. Service calls are usually
associated with one or more tickets or tasks, but can also be scheduled independently. You can see any unassigned
service calls you create on your My Service Calls page.

Note: See Service Desk > Service Calls for a detailed description of how to work with service calls on this page.
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My Calendar
Outlook Extension 453

Home > My Calendar

The My Calendar page provides a calendar view of all your scheduled PulsewayPSA events.

• Appointments

• Activities

• Tasks

• To-Dos

• Service Calls

Options

• You can hide all events for a category by clicking its button off.

• Calendar views include: Day, Work Week, Month, Timeline.

• You can add a new appointment by clicking anywhere in the calendar. Enter the following:

– Subject

– Start Time

– End Time

– Reminder

– Description

– Recurrence - Click to enter recurring appointment options.

• Click the Export Calendar button to download an "icalendar" file for importing into other calender software
packages.

• Click the Download Outlook Extension to download an Outlook Extension that synchronizes your PulsewayPSA
calendar with your Outlook calendar.
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Outlook Extension
Home > My Calendar

The Outlook Extension synchronizes your PulsewayPSA calendar with your Outlook calendar. This includes:

• Appointments

• Activities

• Tasks

• To-Dos

• Service Calls

Note: The Outlook extension only supports Outlook 2010 and later.

Installing the Extension

1 In PulsewayPSA, select the Home > My Calendar page.

2 Click Download Outlook Extension.

3 Run the installer on the computer containing your Outlook application.

4 Start Outlook.

– A new tab displays in your Outlook application.

5 Enter the following in the Settings > Login tab.

– User Name

– Password

– Company Name

– Click Save.
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6 Set your preferences on the Calendar tab.

– Enable Calendar Integration

– Get Past Calendard Items

– Get Future Calendar Items

– When Opening Outlook

– Calendar Options

– Tasks

– CRM Activities

– To-Dos

– Enable Automatic Update Every <N> Minutes

– Click Save.

A 'data saved' confirmation message displays.
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My Projects
Home > My Projects

The My Projects page enables you to update the projects you are assigned to as project manager.

Note: See Projects > Projects for a detailed description of how to work with projects on this page.
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My Expense Reports
Home > My Expense Reports

The My Expenses page enables you to maintain all your expenses, no matter where they are entered in the system. This
includes expenses for tickets and tasks. You can also enter expenses without linking them to tickets or tasks, such as for
your own company's expenses.

You can enter expense entries for any date on any expense report. You are required to enter a date in the header of the
expense report but the date does not restrict you.

Approving Expense Reports

Submitted expense reports can be manually approved or auto approved.

• If your company uses approval routes, submitted expense reports display in the My Approval folder of the
appropriate persons for review. The submitted expense report is then approved or rejected.

• If your company does not use approval routes, the submitted expense report is auto approved.

• The Approval History tab shows the history of submitted expense reports.

Statuses

An expense report can have the following statuses.

• Open

• Submitted

• Approved

• Rejected

A Submitted or Approved expense report cannot be edited. A Rejected expense report can be subsequently
Submitted and Approved.

Notification

You are notified about approvals and rejections in several ways.

• A message displays in the Settings > My Messages inbox.

• You may also receive an email message.

• The status of the expense report will show Approval or Rejected.

Actions

• Print Expense Sheet

• Submit for Approval

Adding Expenses

1 Select the Home > My Expense Reports page.
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2 Click New.

3 Enter the following in the Expense Sheet Info tab.

– Name

– Date

– Notes

4 Enter the following in the Expense Info tab.

– Expense Type

– Date - The date the expense was incurred

– Amount Spent

– Mark Up / Down - Adjust up or down by amount ($) or percent (%).

– Payment Types - Cash, Check, Debit Card, Credit Card, Other, Company Credit Card.

– Classification - Reimbursable or Non-Reimbursable

– Notes

– Billable - Yes or No

– Expense Associated with

• Project - Select a project.

• Ticket - Select a ticket.

• Internal Expense - Expenses are added internally.

5 Enter the following in the Expense Entries > Receipts tab.

– Upload a new file

– Have Receipt - Yes or No

– Notes

6 Click Save to save the expense report.
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My Approvals
Home > My Approvals

The My Approvals page approves or rejects timesheets and expense reports submitted by employees on two separate
tabs. If you are not an approver, or submitted timesheets and expense reports are auto approved, the My Approvals
page does not display in your Home module.

Your designation as an direct approver or secondary approver is defined using the Admin > Business Process > Approval
Routes page. There are separate approval routes for Expenses and Timesheets.

Notification

You are notified about submitted timesheets and expense reports in several ways.

• A message displays in the Settings > My Messages inbox.

• You may also receive an email message.

• The My Approval page lists timesheets and expense reports waiting to be approved or rejected.

Approving or Rejecting Timesheets and Expense Reports

1 Select the Home > My Approvals page.

2 Click Timesheet Approvals tab.

3 Select submitted timesheets in the Direct Approvals or Secondary Approvals sections.

4 Click Approve Selected or Reject Selected.

– If you reject the selected rows, you can include an explanatory note. Rejected timesheets can be subsequently
submitted for approval.

5 Select the Expense Reports tab.

6 Repeat steps 3 and 4 for expense reports.
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My Templates
Home > My Templates

The My Templates page enables you to maintain your own set of ticket templates. To make ticket creation easier, when
you create a ticket, you can select one of your ticket templates to pre-populate selected fields for you.

Ticket templates can include adding questions in the description field of the ticket. These questions can then prompt
ticket editors to ask these standard questions when contacting customers.

Your ticket templates can be shared with other team members. If you don't share a ticket template, it can only be viewed
by yourself and PulsewayPSA administrators.

Creating Tickets Templates

1 Select the Home > Ticket Templates page.

2 Click New.

3 Select one of three types of ticket template.

– Ticket Templates - Defines custom templates for tickets. You select this type of template using the From
Template field when adding a new ticket.

– Ticket Note Templates - Defines custom templates for notes in tickets. You select this type of template using
the From Template field when adding a note to a ticket.

– Ticket Time Entry Templates - Defines custom templates for time log entries in tickets. You select this type of
template using the From Template field when adding a time log entry to a ticket.

4 Enter values in each of the fields provided.

– These will serve as default field values when you create a new ticket, note, or time entry, based on this
template.

5 Click Save.
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Collaborations
Home > Collaborations

The Collaborations page maintains discussion threads about a project, shared with all project team members. Project
team members include the project manager and any employees assigned to be members of a task. You can create new
thread topic at any time.

Creating Project Discussions Threads

1 Select the Home > Collaboration page.

2 Select a project.

3 Select New Thread to create the first comment in the thread.

– Subject

– Type - Question, Reply, Information, News

– Content

– Click Save.

4 Once you create a comment, you can optionally select the following Actions:

– Edit - Changes a comment you created.

– Comment - Replies to this specific comment.

– Delete - Deletes the comment.

5 As another user reading this thread, you can click Reply to create a new comment for the entire thread.
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My Timesheet
Home > My Timesheets

The My Timesheets page maintains your timesheets. Timesheets are saved automatically after you add or change time
entries.

• Timesheets include all the time entries you enter anywhere in the system. This includes time entries for tickets and
tasks.

• You can also enter timesheet entries without linking them to tickets or tasks, such as for administrative tasks.
Work types for classifying administrative tasks are defined using the Admin > My Company > Administrative Work
page.

• A timesheet specifies a weekly date range when it is created, always starting on the same day of the week. Each
user can only have one timesheet for each weekly date range.

• Timesheets are automatically created the first time a time entry is created within that timesheet's weekly date
range. Or you can manually create a timesheet for a new weekly date range, before any entries have been created.

• The scheduling pattern for creating timesheets is specified using the Admin > Company Settings > Time Sheet tab.
This same page sets whether future and past timesheets can be viewed.

• If Preload Timesheets is Yes on the Time Sheet tab then scheduled events on ticket and tasks will preload any
future timesheets you create. If No, then only actual time entries display on timesheets.

• If your administrative task timesheet entries are similar from one week to the next, you can save time by copying a
timesheet to a new weekly date range. Ticket and task timesheet entries will not be include.

• If you attempt to add a task that is closed or on hold, then 0 time is shown allotted. You cannot change this.

Approving Timesheets

Submitted timesheets can be manually approved or auto approved.

• If your company uses approval routes, submitted timesheets display in the My Approval folder of the appropriate
persons for review. The submitted timesheet is then approved or rejected.

• If your company does not use approval routes, the submitted timesheet is auto approved.

• The Approval History tab shows the history of submitted timesheets.

Statuses

An timesheet can have the following statuses.

• Open

• Submitted

• Approved

• Rejected

A Submitted or Approved timesheet cannot be edited. A Rejected timesheet can be subsequently Submitted and
Approved.
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Notification

You are notified about approvals and rejections in several ways.

• A message displays in the Settings > My Messages inbox.

• You will also receive an email notification.

• The status of the timesheet will show Approval or Rejected.

Actions

• Add Tasks - Adds time entries to tasks in projects.

• Add Admin Tasks - Adds administrative work tasks.

• Submit for Approval - Submits the timesheet for approval.

• Print Timesheet - Creates a PDF of the timesheet.

• Copy Timesheet - Copies administrative task timesheet entries to a new timesheet with a different weekly date
range. Ticket and task time entries are not copied.

Adding Timesheets

1 Select the Home > My Timesheet page.

2 Click New. A Create Timesheet dialog displays.

– Select Week Range - You can only select a weekly date range that does not yet exist for your user account.

– Click Create.

– A blank timesheet display, since this is a new timesheet.

3 Click Add Admin Tasks.

– Select the Training task. The administrative work task is added to the timesheet.

– Enter hours for at least one day of the week.

Note: You must enter hours to prevent an added task from being removed from the timesheet when you leave this
page.

4 Click Add Tasks.

Note: You must be a member of a active project sharing the same date range as this timesheet to see tasks listed in
this dialog.

– Select a project task.

– Enter hours for at least one day in the project task. See Adding Time to Tasks.

– The timesheet is saved automatically.

PulsewayPSA Guide

Release 4.0.41 | March 2021

https://www.pulseway.com/


Dispatch Calendar
Home > Dispatch Calendar

The Dispatch Calendar page provides a calendar view of all employee scheduled PulsewayPSA events. Event types can
include:

• Appointments

• Activities

• Tasks

• To-Dos

• Service Calls

Actions

• Employee calendar filtering - By default you see your own calendar and the calendars of all subordinate employees
that report to you. You filter the list of employee calendars displayed by:

– Resource

– Queue

– Event Type

• Employee calendar time selection - Change the scale of calendar time displayed using the Day, Work Week, Month,
Timeline options. You can also jump to a date by using the date picker.

• Add appointments - Click a date for a single employee to add a new appointment.

– Subject

– Start Time

– End Time

– Reminder

– Description

– Recurrence - Click to enter recurring appointment options.

• Dispatch Actions - Click this link to display:

– Dispatch Only - Displays only employee dispatch calendars.

– View Tickets - Displays a ticket search list. Select a view to filter the ticket list.

• Adding Service Calls to Tickets - When View Tickets is selected, you can drag and drop a specific ticket on to an
employee's calendar date. Doing so opens the service call dialog. Enter additional details for the service call, then
click Save. The new service call now displays in the Dispatch Calendar, employee's My Service Calls page, and in
the corresponding ticket.
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Adjust Timesheets
Home > Adjust Timesheets

Use the Adjust Timesheets page to adjust the timesheets of any employee. Access to this page is determined by your
assigned security role.

By default the page lists all timesheets for all users. Enter search parameters to filter the list.

• Week Start, From, To

• Week End, From, To

• Status

• Employee Name

Click any timesheet row to adjust timesheet entries. See My Timesheet for details about editing timesheet entries.
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Adjust Expenses
Home > Adjust Expenses

Use the Adjust Expenses page to adjust the expenses of any employee. Access to this page is determined by your
assigned security role.

By default the page lists all expense reports for all users. Enter search parameters to filter the list.

• Name

• Status

• Date, From, To

• Last Update, From, To

• Employee Name

Click any expense report row to adjust expense report entries. See My Expense Reports for details about editing
expense report entries.
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Downloads PulsewayPSA
Home > Downloads

The Downloads page provides connector tools you can use to integrate and synchronize data between PulsewayPSA and
external applications.

Click any of the Download buttons to download these tools to your local machine.

• QuickBooks Sync - For more information see Quickbooks Sync.

• Outlook Sync - For more information see Outlook Extension.
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Chapter 12: Client Portal
Enabling Client Portal Access 469

Client Portal Dashboard 470

My Tickets (in Client Portal) 471

My Profile (in Client Profile) 472

My Messages (in Client Profile) 473

Tickets (in Client Portal) 474

Contracts (in Client Portal) 475

Invoices (in Client Portal) 476

The Client Portal module enables customers to log into the PulsewayPSA system and track their own PulsewayPSA
issues.
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Enabling Client Portal Access
Client Portal access is enabled using a Contacts record of a CRM account.

Configuring Client Portal Access

1 Select the CRM > Contacts page.

2 Select a contact record to edit.

3 Click the Client Portal Access tab.

Set the Has Client Portal Access to Yes.

Note: You can filter the Contacts page using the Has Client Portal Access option.

4 Enter a User Name the contact will use to logon to Client Portal.

5 Select a Security Role. There are two built-in security roles you can use immediately that have access to the Client
Portal module enabled.

– External User - Allows the client to view/edit their own profile and messages, as well as tickets assigned to
them.

– External Manager - Allows the client to view/edit their own profile and messages. Also allows the client to
view all of their account's tickets, contracts and invoices.

6 Click Save.

PulsewayPSA Guide

Release 4.0.41 | March 2021

https://www.pulseway.com/


Client Portal Dashboard
Client Portal > Client Portal Dashboard

The Client Portal Dashboard help customers manage their activities in the PulsewayPSA system. Dashlets include:

• My To Do List - A place to set reminders. For example: check on certification for site install. Enter
text, then click the calendar and set the date, or simply enter the word tomorrow.

• My Notes - A quick summary of thoughts or ideas that you don’t want to forget during the day.

• News - Company news.

Removing My To-Do List Items

The user can remove items in the My To-Do List by clicking the red X in the Already Done tab and clicking on the red X.
The user can reset the My To-Do List by clicking the yellow arrow, if an item was completed by mistake.

Deleting

The user can simply erase My Notesby highlighting the words and selecting delete on the keyboard.
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My Tickets (in Client Portal)
Client Portal > My Tickets

The My Tickets page manages tickets assigned to you as the Contact Person of your customer organization. If you
create a new ticket using this page, the ticket is assigned to you as the customer Contact Person by default.

When you open an existing ticket:

• The Ticket View displays general properties of the ticket.

• You can also click Add Note to add a note for support to read.

• You may also see notes about this ticket for you, as the customer contact, to review and possibly act on.

Quick Tickets

Security roles have a Client Portal option called Quick Tickets. When checked in a security role, customers are presented
with a simplified page layout when adding new tickets. If unchecked, customers are presented with the same page
layout that employees see.

Creating a New Ticket

1 Select the Client Portal > My Tickets page.

2 Click New.

3 Enter the following in the Quick Add Ticket page.

– Site

– Ticket Type

– Priority

– Issue Type

– Sub-Issue Type

– Affected Hardware Asset

– Affected Software Asset

– Attach File

– Title - A one line summary of the issue.

– Details - A longer description of the issue.
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My Profile (in Client Profile)
Client Portal > My Profile

The My Profile section enables you to personalize your PulsewayPSA client portal experience.

• Sets your PulsewayPSA photo.

• Displays your personal ticket counts.

• Stores your personal information and contact information.

• Changes your password.

• Sets your default landing page when you login.

Reviewing My Profile

1 Select the Settings > My Profile page.

2 Review the Personal Information tab.

– Reset (Photo)

– Select Photo - jpg, jpeg, png, gif

– Your Ticket Statistics

• Opened

• Resolved

– User Name

– E-mail

– First Name

– Last Name

3 Optionally change your password using the Change Password tab.

– Old Password

– New Password

– Confirm New Password

4 Optionally change the default landing page using the Preferences tab.
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My Messages (in Client Profile)
Client Portal > My Messages

Customer contacts can use the My Messages page to send and receive messages with PulsewayPSA support personnel
and other customer accounts contacts. These messages are not linked to tickets.

When you receive new messages from support personnel, you will see an envelope icon with a count of unopened
tickets in the upper left hand corner, indicating messages are waiting for you.

Actions

• Compose Message - Creates a new message.

• Reply - Replies to receives message.

• Archive/Archived - Move selected messages to the Archived folder.

• Delete - Deletes selected messages.

• Inbox - Moves selected messages to the Inbox folder.

• Starred - This folder lists messages that have the star toggled on.

• Save/Draft - Saved unsent messages are stored in the Draft folder.
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Tickets (in Client Portal)
Client Portal > Tickets

The Tickets page manages all tickets in your customer organization, regardless of the customer contact person assigned
to the ticket. See My Tickets (in Client Portal) for details on how to work with tickets in the Client Portal module.
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Contracts (in Client Portal)
Client Portal > Contracts

The Contracts page enables you to view all active contracts in your customer organization. See Contracts for a
discussion of the different types of contracts and field information.

Contract Information

• Contract Name

• Contract Type - Time & Materials, Recurring, Fixed Price, Retainer by Amount, Retainer by Hours.

• Reference Number

• Start Date

• End Date

• SLA

• Setup Fees

• Contract Status

• Default Contract

• Billing Cycle - Applies to recurring and retainer by hours contracts.

• Contract Billing Price - Applies to recurring, fixed price, and retainer by amount contracts.

• Bill Amount - Applies to fixed priced contracts.

• Remaining Amount - Applies to fixed price contracts.

• Consumed Amount - Applies to retainer by amount contracts.

• Description

Additional Tabs

• Billing Information

• Contract History - Applies to recurring contracts.

• PrePaid Hours Summary - Applies to retainer by hours contracts.

PulsewayPSA Guide

Release 4.0.41 | March 2021

https://www.pulseway.com/


Invoices (in Client Portal)
Client Portal > Invoices

The Contracts page enables you to view all invoices sent by PulsewayPSA to your customer organization.

Contract Information

• Invoice Number

• Invoice Status

• P.O. Number

• From

• To

• Invoice Date

• Due Date

• Sales Representative

• Project

• Payment Due

• Paid Amount

• Total Tax

• Total Price

• Grand Total

• Sent On

• Notes

Additional Tabs

• Invoice Details

• Invoice Discount

• Payments
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Chapter 13: Pulseway PSA SOAP API
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Introduction PulsewayPSA
Open API provides a way for customers to make SOAP-protocol authenticated calls to PulsewayPSA—using
https://psa.pulseway.com/—from their existing applications or third-party tools. This API offers the functionalities for
various operations dealing with projects, tasks and more.

Assumptions

The partner is using PulsewayPSA services and is registered for an account with PulsewayPSA.

API Authentication

As a security mechanism, every call of the PulsewayPSA Open API is authenticated. Each API Call has to be accompanied
by a custom SOAP header holding the authorized user PulsewayPSA credentials consisting of:

• UserName
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• Password

• CompanyName

Supported Operations

The OpenAPI itself provides self-documentation for all supported operations. Add /WS/OpenAPI.asmx to any
PulsewayPSA website URL. For example:

https://psa.pulseway.com/WS/OpenAPI.asmx

Authenticate
Authenticates the connecting user within PulsewayPSA. Returns a boolean representing whether he is authenticated or
not.

Request

URL https://psa.pulseway.com/Authenticate

Type Params Values

Body companyName string

Body userName string

Body password string

Example Request
POST /WS/OpenAPI.asmx HTTP/1.1
Host: psa.pulseway.com
Content-Type: text/xml; charset=utf-8
Content-Length: length
SOAPAction: "https://pulsewaypsalogin.com/Authenticate"

<?xml version="1.0" encoding="utf-8"?>
<soap:Envelope xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
xmlns:xsd="http://www.w3.org/2001/XMLSchema"
xmlns:soap="http://schemas.xmlsoap.org/soap/envelope/">
<soap:Body>
<Authenticate xmlns="https://pulsewaypsalogin.com/">
<companyName>string</companyName>
<userName>string</userName>
<password>string</password>
</Authenticate>
</soap:Body>
</soap:Envelope>
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Response

Type Response

Boolean AuthenticateResult

Example Response

HTTP/1.1 200 OK
Content-Type: text/xml; charset=utf-8
Content-Length: length

<?xml version="1.0" encoding="utf-8"?>
<soap:Envelope xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
xmlns:xsd="http://www.w3.org/2001/XMLSchema"
xmlns:soap="http://schemas.xmlsoap.org/soap/envelope/">
<soap:Body>
<AuthenticateResponse xmlns="https://pulsewaypsalogin.com/">
<AuthenticateResult>boolean</AuthenticateResult>
</AuthenticateResponse>
</soap:Body>
</soap:Envelope>

Create Ticket
Creates a service desk ticket in your PulsewayPSA account using a ticketObj.

Request

URL https://psa.pulseway.com/CreateTicket

Type Params Values

HEAD WSUserCredentials Object

PARAM ticketObj Object

PARAM outputMessage OUTPUT String

• WSUserCredentials - A custom authentication SOAP header object consisting of:

– UserName

– Password

– CompanyName

• ticketObj (Ticket Object) -The ticket information will be specified in this Ticket Object consisting of the following
parameters:
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– ClientId (Int)

– Required

• ClientName (string) - Links the ticket to a specific client. Soap Action https://psa.pulseway.com/GetClientAccounts
can be used to get the Accounts and their IDs

• ClientSiteId (Int) - Optional. If not specified the Main Location will be automatically specified. Soap Action
https://psa.pulseway.com/GetAccountLocations can be used to get the locations and their IDs.

• ClientContactId (Int) - Optional. Soap Action https://psa.pulseway.com/ExportAccountsAndContacts can be used to
get contacts information

• TicketTitle (string) - Required.

• TicketDetails (string) - Required.

• TicketTypeId (Int) - Required. Soap Action https://psa.pulseway.com/GetTicketTypes can be used to get ticket
types.

• TicketStatusId (Int) - Required. Soap Action https://psa.pulseway.com/GetTicketStatuses can be used to get ticket
statuses.

• TicketPriorityId (Int) - Required. Soap Action https://psa.pulseway.com/GetTicketPriorities can be used to get
ticket priorities.

• TicketQueueId (Int) - Optional if Primary Assignee is specified. Soap Action
https://psa.pulseway.com/GetTicketQueues can be used to get ticket Queues.

• TicketPrimaryAssigneeId (Int) - Optional if Queue is specified. Soap Action
https://psa.pulseway.com/GetEmployeesList can be used to Employees User IDs

• TicketSourceId (Int) - Required. Soap Action https://psa.pulseway.com/GetTicketSources can be used to get Ticket
Sources.

• TicketOpenDate (datetime) - Required.

Example Request

POST /WS/OpenAPI.asmx HTTP/1.1
Host:psa.pulseway.com
Content-Type: text/xml; charset=utf-8
Content-Length: length
SOAPAction: "https://pulsewaypsalogin.com/CreateTicket"

<?xml version="1.0" encoding="utf-8"?>
<soap:Envelope xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
xmlns:xsd="http://www.w3.org/2001/XMLSchema"
xmlns:soap="http://schemas.xmlsoap.org/soap/envelope/">
<soap:Header>
<WSUserCredentials xmlns="https://pulsewaypsalogin.com/">
<UserName>string</UserName>
<Password>string</Password>
<CompanyName>string</CompanyName>
</WSUserCredentials>
</soap:Header>
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<soap:Body>
<CreateTicket xmlns="https://pulsewaypsalogin.com/">
<ticketObj>
<ClientId>int</ClientId>
<ClientSiteId>int</ClientSiteId>
<ClientContactId>int</ClientContactId>
<TicketTitle>string</TicketTitle>
<TicketDetails>string</TicketDetails>
<TicketTypeId>int</TicketTypeId>
<TicketStatusId>int</TicketStatusId>
<TicketPriorityId>int</TicketPriorityId>
<TicketQueueId>int</TicketQueueId>
<TicketPrimaryAssigneeId>int</TicketPrimaryAssigneeId>
<TicketSourceId>int</TicketSourceId>
<TicketOpenDate>dateTime</TicketOpenDate>
</ticketObj>
</CreateTicket>
</soap:Body>
</soap:Envelope>

Response

Status Response

Success CreateTicketResult:

• Integer representing the new Ticket ID

outputMessage:

• "Ticket #ticket_number# created successfully."

Failure CreateTicketResult:

• Returns Null

outputMessage:

• "A valid ticket object is required."

• "Ticket Title is required!"

• "Ticket Details is required!"

• "Ticket Assignee or/and Queue must be specified!"

• "Failed to Create new Ticket."

Example Response

HTTP/1.1 200 OK
Content-Type: text/xml; charset=utf-8
Content-Length: length
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<?xml version="1.0" encoding="utf-8"?>
<soap:Envelope xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
xmlns:xsd="http://www.w3.org/2001/XMLSchema"
xmlns:soap="http://schemas.xmlsoap.org/soap/envelope/">
<soap:Body>
<CreateTicketResponse xmlns="https://pulsewaypsalogin.com/">
<CreateTicketResult>int</CreateTicketResult>
<outputMessage>string</outputMessage>
</CreateTicketResponse>
</soap:Body>
</soap:Envelope>

Create Ticket Note
Creates a ticket note for a specific TicketId in your PulsewayPSA account using a ticketNote object.

Request

URL https://psa.pulseway.com/CreateTicketNote

Type Params Values

HEAD WSUserCredentials Object

PARAM ticketNote Object

PARAM outputMessage OUTPUT String

• WSUserCredentials - A custom authentication SOAP header object consisting of:

– UserName

– Password

– CompanyName

• ticketNote (Ticket Note Object) - The ticket note information will be specified in this Ticket Note Object consisting of
the following parameters:

• TicketId (Int) - Required. Links the note to a specific ticket.

• UserId (Int) - Optional. If not specified the note will appear to be created by the system. Soap Action
https://psa.pulseway.com/GetEmployeesList can be used to Employees User IDs

• NoteDetails (string) - Required.

• NoteTypeId (Int) - Required. Soap Action https://psa.pulseway.com/GetTicketNoteTypes can be used to get ticket
types.

• IsInternalNote (boolean) - Required. Specifies if this note is internal or public to the client to see.

• NoteDate (datetime) - Required.
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Example Request

POST /WS/OpenAPI.asmx HTTP/1.1
Host:psa.pulseway.com
Content-Type: text/xml; charset=utf-8
Content-Length: length
SOAPAction: "https://pulsewaypsalogin.com/CreateTicketNote"

<?xml version="1.0" encoding="utf-8"?>
<soap:Envelope xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
xmlns:xsd="http://www.w3.org/2001/XMLSchema"
xmlns:soap="http://schemas.xmlsoap.org/soap/envelope/">
<soap:Header>
<WSUserCredentials xmlns="https://pulsewaypsalogin.com/">
<UserName>string</UserName>
<Password>string</Password>
<CompanyName>string</CompanyName>
</WSUserCredentials>
</soap:Header>
<soap:Body>
<CreateTicketNote xmlns="https://pulsewaypsalogin.com/">
<ticketNote>
<TicketId>int</TicketId>
<UserId>int</UserId>
<NoteDetails>string</NoteDetails>
<NoteTypeId>int</NoteTypeId>
<IsInternalNote>boolean</IsInternalNote>
<NoteDate>dateTime</NoteDate>
</ticketNote>
</CreateTicketNote>
</soap:Body>
</soap:Envelope>

Response

Status Response

Success CreateTicketNoteResult:

• Integer representing the new Ticket Note ID

outputMessage:

• Empty String
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Failure CreateTicketNoteResult:

• Returns Null

outputMessage:

• "Failed to create new note."

• "A valid ticket note object is required."

• "Note Details is required!"

• "Invalid Ticket Number."

• "Referenced Ticket could not be found!"

Example Response

HTTP/1.1 200 OK
Content-Type: text/xml; charset=utf-8
Content-Length: length

<?xml version="1.0" encoding="utf-8"?>
<soap:Envelope xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
xmlns:xsd="http://www.w3.org/2001/XMLSchema"
xmlns:soap="http://schemas.xmlsoap.org/soap/envelope/">
<soap:Body>
<CreateTicketNoteResponse xmlns="https://pulsewaypsalogin.com/">
<CreateTicketNoteResult>int</CreateTicketNoteResult>
<outputMessage>string</outputMessage>
</CreateTicketNoteResponse>
</soap:Body>
</soap:Envelope>

Export Accounts And Contacts
Returns an array of accounts and, if requested, related data such as account locations, contacts, contacts phones and
emails. The result set is returned in a data set format having various data tables filled in case the data is requested.

Request

URL https://psa.pulseway.com/ExportAccountsAndContacts

Type Params Values

HEAD WSUserCredentials Object

PARAM dateFrom dateTime
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PARAM dateTo dateTime

PARAM clientNames string

PARAM businessTypes string

PARAM accountTypes string

PARAM withLocations boolean

PARAM withContacts boolean

PARAM outputMessage OUTPUT String

• WSUserCredentials - A custom authentication SOAP header object consisting of:

– UserName

– Password

– CompanyName

• clientNames - Specify the clients(s) value(s) by which to filter accounts based on. For multiple clients you have to
separate by Comma (,). If Null or Empty ("") this will be ignored.

• dateFrom - Specify the earliest account acquired date. If Null this will be ignored.

• dateTo - Specify the latest account acquired date. If Null this will be ignored.

• businessTypes - Specify the business type(s) value(s) by which to filter accounts based on. For multiple business
types you have to separate by Comma (,). If Null or Empty ("") this will be ignored.

• accountTypes - Specify the account type(s) value(s) by which to filter accounts based on. For multiple account
types you have to separate by Comma (,). If Null or Empty ("") this will be ignored.

• withLocations - Boolean value to specify if the accounts locations should be loaded as well.

• withContacts - Boolean value to specify if the accounts Contacts should be loaded as well.

Example Request

POST /WS/OpenAPI.asmx HTTP/1.1
Host:psa.pulseway.com
Content-Type: text/xml; charset=utf-8
Content-Length: length
SOAPAction: "https://pulsewaypsalogin.com/ExportAccountsAndContacts"

<?xml version="1.0" encoding="utf-8"?>
<soap:Envelope xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
xmlns:xsd="http://www.w3.org/2001/XMLSchema"
xmlns:soap="http://schemas.xmlsoap.org/soap/envelope/">
<soap:Header>
<WSUserCredentials xmlns="https://pulsewaypsalogin.com/">
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<UserName>string</UserName>
<Password>string</Password>
<CompanyName>string</CompanyName>
</WSUserCredentials>
</soap:Header>
<soap:Body>
<ExportAccountsAndContacts xmlns="https://pulsewaypsalogin.com/">
<dateFrom>dateTime</dateFrom>
<dateTo>dateTime</dateTo>
<clientNames>string</clientNames>
<businessTypes>string</businessTypes>
<accountTypes>string</accountTypes>
<withLocations>boolean</withLocations>
<withContacts>boolean</withContacts>
</ExportAccountsAndContacts>
</soap:Body>
</soap:Envelope>

Response

Status Response

Success ExportAccountsAndContactsResult:

• DataSet

outputMessage:

• Empty String

Failure ExportAccountsAndContactsResult:

• Returns Null

outputMessage:

• "An Error has Occurred while processing the request."

Example Response

HTTP/1.1 200 OK
Content-Type: text/xml; charset=utf-8
Content-Length: length

<?xml version="1.0" encoding="utf-8"?>
<soap:Envelope xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
xmlns:xsd="http://www.w3.org/2001/XMLSchema"
xmlns:soap="http://schemas.xmlsoap.org/soap/envelope/">
<soap:Body>
<ExportAccountsAndContactsResponse xmlns="https://pulsewaypsalogin.com/">
<ExportAccountsAndContactsResult>
<xsd:schema>schema</xsd:schema>xml</ExportAccountsAndContactsResult>
<outputMessage>string</outputMessage>
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</ExportAccountsAndContactsResponse>
</soap:Body>
</soap:Envelope>

Get Accounts Locations
Returns an AccountLocation array of possible locations defined in your PulsewayPSA account for a specified client
accountId.

Request

URL https://psa.pulseway.com/GetAccountLocations

Type Params Values

HEAD WSUserCredentials Object

PARAM accountId Int

PARAM outputMessage OUTPUT String

• WSUserCredentials - A custom authentication SOAP header object consisting of:

– UserName

– Password

– CompanyName

• accountId - This represents the identification number of the account (client) for which you would like to retrieve the
list of locations for.

Example Request

POST /WS/OpenAPI.asmx HTTP/1.1
Host:psa.pulseway.com
Content-Type: text/xml; charset=utf-8
Content-Length: length
SOAPAction: "https://pulsewaypsalogin.com/GetAccountLocations"

<?xml version="1.0" encoding="utf-8"?>
<soap:Envelope xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
xmlns:xsd="http://www.w3.org/2001/XMLSchema"
xmlns:soap="http://schemas.xmlsoap.org/soap/envelope/">
<soap:Header>
<WSUserCredentials xmlns="https://pulsewaypsalogin.com/">
<UserName>string</UserName>
<Password>string</Password>
<CompanyName>string</CompanyName>
</WSUserCredentials>
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</soap:Header>
<soap:Body>
<GetAccountLocations xmlns="https://pulsewaypsalogin.com/">
<accountId>int</accountId>
</GetAccountLocations>
</soap:Body>
</soap:Envelope>

Response

Status Response

Success GetAccountLocationsResult:

• Array of AccountLocation:

LocationId (int)

LocationName (string)

IsMain (boolean)

IsActive (boolean)

• outputMessage:

Empty String

Failure GetAccountLocationsResult:

• Returns Null

outputMessage:

• "Failed to get Account Locations list."

Example Response

HTTP/1.1 200 OK
Content-Type: text/xml; charset=utf-8
Content-Length: length

<?xml version="1.0" encoding="utf-8"?>
<soap:Envelope xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
xmlns:xsd="http://www.w3.org/2001/XMLSchema"
xmlns:soap="http://schemas.xmlsoap.org/soap/envelope/">
<soap:Body>
<GetAccountLocationsResponse xmlns="https://pulsewaypsalogin.com/">
<GetAccountLocationsResult>
<AccountLocation>
<LocationId>int</LocationId>
<LocationName>string</LocationName>
<IsMain>boolean</IsMain>
<IsActive>boolean</IsActive>
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</AccountLocation>
<AccountLocation>
<LocationId>int</LocationId>
<LocationName>string</LocationName>
<IsMain>boolean</IsMain>
<IsActive>boolean</IsActive>
</AccountLocation>
</GetAccountLocationsResult>
<outputMessage>string</outputMessage>
</GetAccountLocationsResponse>
</soap:Body>
</soap:Envelope>

Get Client Accounts
Returns an Account array of type "Client" defined in your PulsewayPSA account.

Request

URL https://psa.pulseway.com/GetClientAccounts

Type Params Values

HEAD WSUserCredentials Object

PARAM outputMessage OUTPUT String

• WSUserCredentials - A custom authentication SOAP header object consisting of:

– UserName

– Password

– CompanyName

Example Request

POST /WS/OpenAPI.asmx HTTP/1.1
Host:psa.pulseway.com
Content-Type: text/xml; charset=utf-8
Content-Length: length
SOAPAction: "https://pulsewaypsalogin.com/GetClientAccounts"

<?xml version="1.0" encoding="utf-8"?>
<soap:Envelope xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
xmlns:xsd="http://www.w3.org/2001/XMLSchema"
xmlns:soap="http://schemas.xmlsoap.org/soap/envelope/">
<soap:Header>
<WSUserCredentials xmlns="https://pulsewaypsalogin.com/">
<UserName>string</UserName>
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<Password>string</Password>
<CompanyName>string</CompanyName>
</WSUserCredentials>
</soap:Header>
<soap:Body>
<GetClientAccounts xmlns="https://pulsewaypsalogin.com/" />
</soap:Body>
</soap:Envelope>

Response

Status Response

Success GetClientAccountsResult:

• Array of Account:

AccountId (int)

AccountName (string)

IsActive (boolean)

IsInternal (boolean)

outputMessage:

• Empty String

Failure GetClientAccountsResult:

• Returns Null

outputMessage:

• "Failed to get clients list."

Example Response

HTTP/1.1 200 OK
Content-Type: text/xml; charset=utf-8
Content-Length: length

<?xml version="1.0" encoding="utf-8"?>
<soap:Envelope xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
xmlns:xsd="http://www.w3.org/2001/XMLSchema"
xmlns:soap="http://schemas.xmlsoap.org/soap/envelope/">
<soap:Body>
<GetClientAccountsResponse xmlns="https://pulsewaypsalogin.com/">
<GetClientAccountsResult>
<Account>
<AccountId>int</AccountId>
<AccountName>string</AccountName>
<IsActive>boolean</IsActive>
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<IsInternal>boolean</IsInternal>
</Account>
<Account>
<AccountId>int</AccountId>
<AccountName>string</AccountName>
<IsActive>boolean</IsActive>
<IsInternal>boolean</IsInternal>
</Account>
</GetClientAccountsResult>
<outputMessage>string</outputMessage>
</GetClientAccountsResponse>
</soap:Body>
</soap:Envelope>

Get Employees List
Returns an api_EmployeesListingResult array of your PulsewayPSA Account employees, with the ability to filter by
employee name, department, job title, location and username.

Request

URL https://psa.pulseway.com/GetEmployeesList

Type Params Values

HEAD WSUserCredentials Object

PARAM name string

PARAM departmentName string

PARAM jobTitle string

PARAM location string

PARAM userNames string

PARAM outputMessage OUTPUT String

• WSUserCredentials - A custom authentication SOAP header object consisting of:

– UserName

– Password

– CompanyName

• name - Specify the name value by which to filter employees based on their first name or last name. If Null or Empty
("") this will be ignored.
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• departmentName - Specify the department(s) value(s) by which to filter employees based on. For multiple
departments you have to separate by Comma (,). If Null or Empty ("") this will be ignored.

• jobTitle - Specify the Job Titles(s) value(s) by which to filter employees based on. For multiple Job Titles you have to
separate by Comma (,). If Null or Empty ("") this will be ignored.

• location - Specify the branches(s) value(s) by which to filter employees based on. For multiple branches (locations)
you have to separate by Comma (,). If Null or Empty ("") this will be ignored.

• userNames - Specify the username(s) value(s) by which to filter employees based on. For multiple usernames you
have to separate by Comma (,). If Null or Empty ("") this will be ignored.

Example Request

POST /WS/OpenAPI.asmx HTTP/1.1
Host:psa.pulseway.com
Content-Type: text/xml; charset=utf-8
Content-Length: length
SOAPAction: "https://pulsewaypsalogin.com/GetEmployeesList"

<?xml version="1.0" encoding="utf-8"?>
<soap:Envelope xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
xmlns:xsd="http://www.w3.org/2001/XMLSchema"
xmlns:soap="http://schemas.xmlsoap.org/soap/envelope/">
<soap:Header>
<WSUserCredentials xmlns="https://pulsewaypsalogin.com/">
<UserName>string</UserName>
<Password>string</Password>
<CompanyName>string</CompanyName>
</WSUserCredentials>
</soap:Header>
<soap:Body>
<GetEmployeesList xmlns="https://pulsewaypsalogin.com/">
<name>string</name>
<departmentName>string</departmentName>
<jobTitle>string</jobTitle>
<location>string</location>
<userNames>string</userNames>
</GetEmployeesList>
</soap:Body>
</soap:Envelope>

Response

Status Response
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Success GetEmployeesListResult:

• Array of api_EmployeesListingResult:

UserId (int)

UserName (string)

EmployeeName (string)

MiddleName (string)

Manager (string)

EmployementType (string)

Gender (string)

MaritalStatus (string)

IsActive (boolean)

Description (string)

CreatedOn (dateTime)

ModifiedOn (dateTime)

EmailAddress (string)

EmployeeId (string)

JobTitle (string)

Department (string)

HireDate (dateTime)

TerminationDate (dateTime)

BranchName (dateTime)

outputMessage:

• Empty String

Failure GetEmployeesListResult:

• Returns Null

outputMessage:

• "An Error has Occurred while processing the request."

Example Response

HTTP/1.1 200 OK
Content-Type: text/xml; charset=utf-8
Content-Length: length
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<?xml version="1.0" encoding="utf-8"?>
<soap:Envelope xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
xmlns:xsd="http://www.w3.org/2001/XMLSchema"
xmlns:soap="http://schemas.xmlsoap.org/soap/envelope/">
<soap:Body>
<GetEmployeesListResponse xmlns="https://pulsewaypsalogin.com/">
<GetEmployeesListResult>
<api_EmployeesListingResult>
<UserId>int</UserId>
<UserName>string</UserName>
<EmployeName>string</EmployeName>
<MiddleName>string</MiddleName>
<Manager>string</Manager>
<EmploymentType>string</EmploymentType>
<Gender>string</Gender>
<MaritalStatus>string</MaritalStatus>
<IsActive>boolean</IsActive>
<Description>string</Description>
<CreatedOn>dateTime</CreatedOn>
<ModifiedOn>dateTime</ModifiedOn>
<EmailAddress>string</EmailAddress>
<EmployeeId>string</EmployeeId>
<JobTitle>string</JobTitle>
<Department>string</Department>
<HireDate>dateTime</HireDate>
<TerminationDate>dateTime</TerminationDate>
<BranchName>string</BranchName>
</api_EmployeesListingResult>
<outputMessage>string</outputMessage>
</GetEmployeesListResponse>
</soap:Body>
</soap:Envelope>

Get Expense Sheets
Returns an api_GetExpenseSheetsResult array of expenses and related information based on a date range, clients and
or usernames of employees.

Request

URL https://psa.pulseway.com/GetExpenseSheets

Type Params Values

HEAD WSUserCredentials Object

PARAM dateFrom dateTime
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PARAM dateTo dateTime

PARAM clientNames string

PARAM userNames string

PARAM outputMessage OUTPUT String

• WSUserCredentials - A custom authentication SOAP header object consisting of:

– UserName

– Password

– CompanyName

• clientNames - Specify the clients(s) value(s) by which to filter expenses based on. For multiple clients you have to
separate by Comma (,). If Null or Empty ("") this will be ignored.

• dateFrom - Specify the earliest expense sheet date. If Null this will be ignored.

• dateTo - Specify the latest expense sheet date. If Null this will be ignored.

• userNames - Specify the employee username(s) value(s) by which to filter expenses based on. For multiple
usernames you have to separate by Comma (,). If Null or Empty ("") this will be ignored.

Example Request

POST /WS/OpenAPI.asmx HTTP/1.1
Host:psa.pulseway.com
Content-Type: text/xml; charset=utf-8
Content-Length: length
SOAPAction: "https://pulsewaypsalogin.com/GetExpenseSheets"

<?xml version="1.0" encoding="utf-8"?>
<soap:Envelope xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
xmlns:xsd="http://www.w3.org/2001/XMLSchema"
xmlns:soap="http://schemas.xmlsoap.org/soap/envelope/">
<soap:Header>
<WSUserCredentials xmlns="https://pulsewaypsalogin.com/">
<UserName>string</UserName>
<Password>string</Password>
<CompanyName>string</CompanyName>
</WSUserCredentials>
</soap:Header>
<soap:Body>
<GetExpenseSheets xmlns="https://pulsewaypsalogin.com/">
<dateFrom>dateTime</dateFrom>
<dateTo>dateTime</dateTo>
<clientNames>string</clientNames>
<userNames>string</userNames>
</GetExpenseSheets>
</soap:Body>
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</soap:Envelope>

Response

Status Response

Success GetExpenseSheetsResult:

• Array of api_GetExpensesheetResult:

pkExpenseEntryId (int)

ExpenseSheetId (int)

EmployeeName (string)

ExpenseName (string)

Client (string)

Project_Ticket (string)

ExpenseDate (dateTime)

ExpenseType(string)

Billable (boolean)

Notes (string)

Amount (decimal)

outputMessage:

• Empty String

Failure GetExpenseSheetsResult:

• Returns Null

outputMessage:

• "An Error has Occurred while processing the request."

Example Response

HTTP/1.1 200 OK
Content-Type: text/xml; charset=utf-8
Content-Length: length

<?xml version="1.0" encoding="utf-8"?>
<soap:Envelope xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
xmlns:xsd="http://www.w3.org/2001/XMLSchema"
xmlns:soap="http://schemas.xmlsoap.org/soap/envelope/">
<soap:Body>
<GetExpenseSheetsResponse xmlns="https://pulsewaypsalogin.com/">
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<GetExpenseSheetsResult>
<api_GetExpensesheetResult>
<pkExpenseEntryId>int</pkExpenseEntryId>
<ExpenseSheetId>int</ExpenseSheetId>
<EmployeeName>string</EmployeeName>
<ExpenseName>string</ExpenseName>
<Client>string</Client>
<Project_Ticket>string</Project_Ticket>
<ExpenseDate>dateTime</ExpenseDate>
<ExpenseType>string</ExpenseType>
<Billable>boolean</Billable>
<Reimbursable>boolean</Reimbursable>
<Notes>string</Notes>
<Amount>decimal</Amount>
</api_GetExpensesheetResult>

</GetExpenseSheetsResult>
<outputMessage>string</outputMessage>
</GetExpenseSheetsResponse>
</soap:Body>
</soap:Envelope>

Get Projects
Returns an api_ProjectListingResult array of your projects defined in your PulsewayPSA account, with the ability to filter
by clients, dates, departments, and status.

Request

URL https://psa.pulseway.com/GetProjects

Type Params Values

HEAD WSUserCredentials Object

PARAM clients string

PARAM startDateFrom dateTime

PARAM startDateTo dateTime

PARAM dueDateFrom dateTime

PARAM dueDateTo dateTime

PARAM departments string

PARAM statuses string
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PARAM outputMessage OUTPUT String

• WSUserCredentials - A custom authentication SOAP header object consisting of:

– UserName

– Password

– CompanyName

• clients - Specify the clients(s) value(s) by which to filter projects based on. For multiple clients you have to separate
by Comma (,). If Null or Empty ("") this will be ignored.

• startDateFrom - Specify the earliest project start date. If Null this will be ignored.

• startDateTo - Specify the latest project start date. If Null this will be ignored.

• dueDateFrom - Specify the earliest project due date. If Null this will be ignored.

• dueDateTo - Specify the latest project due date. If Null this will be ignored.

• departments - Specify the department(s) value(s) by which to filter projects based on. For multiple departments
you have to separate by Comma (,). If Null or Empty ("") this will be ignored.

• statuses - Specify the project status(s) value(s) by which to filter projects based on. For multiple statuses you have
to separate by Comma (,). If Null or Empty ("") this will be ignored.

Example Request

POST /WS/OpenAPI.asmx HTTP/1.1
Host:psa.pulseway.com
Content-Type: text/xml; charset=utf-8
Content-Length: length
SOAPAction: "https://pulsewaypsalogin.com/GetProjects"

<?xml version="1.0" encoding="utf-8"?>
<soap:Envelope xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
xmlns:xsd="http://www.w3.org/2001/XMLSchema"
xmlns:soap="http://schemas.xmlsoap.org/soap/envelope/">
<soap:Header>
<WSUserCredentials xmlns="https://pulsewaypsalogin.com/">
<UserName>string</UserName>
<Password>string</Password>
<CompanyName>string</CompanyName>
</WSUserCredentials>
</soap:Header>
<soap:Body>
<GetProjects xmlns="https://pulsewaypsalogin.com/">
<clients>string</clients>
<startDateFrom>dateTime</startDateFrom>
<startDateTo>dateTime</startDateTo>
<dueDateFrom>dateTime</dueDateFrom>
<dueDateTo>dateTime</dueDateTo>
<departments>string</departments>
<statuses>string</statuses>
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</GetProjects>
</soap:Body>
</soap:Envelope>

Response

Status Response

Success GetProjectsResult:

• Array of api_ProjectListingResult:

pkProjectId (int)

ClientName (string)

ProjectNumber (string)

ProjectName (string)

ProjectCode (string)

ContractName (string)

Manager (string)

ProjectStatus(string)

StartDate (dateTime)

DueDate (dateTime)

Completion (dateTime)

PlannedHours (decimal)

UsedHours (decimal)

PlannedBudget (decimal)

ActualBudget (decimal)

outputMessage:

• Empty String

Failure GetProjectsResult:

• Returns Null

outputMessage:

• "An Error has Occurred while processing the request."
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Example Response

HTTP/1.1 200 OK
Content-Type: text/xml; charset=utf-8
Content-Length: length

<?xml version="1.0" encoding="utf-8"?>
<soap:Envelope xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
xmlns:xsd="http://www.w3.org/2001/XMLSchema"
xmlns:soap="http://schemas.xmlsoap.org/soap/envelope/">
<soap:Body>
<GetProjectsResponse xmlns="https://pulsewaypsalogin.com/">
<GetProjectsResult>
<api_ProjectListingResult>
<ClientName>string</ClientName>
<ProjectNumber>string</ProjectNumber>
<ProjectName>string</ProjectName>
<ProjectCode>string</ProjectCode>
<ContractName>string</ContractName>
<Manager>string</Manager>
<ProjectStatus>string</ProjectStatus>
<StartDate>dateTime</StartDate>
<DueDate>dateTime</DueDate>
<Completion>dateTime</Completion>
<PlannedHours>decimal</PlannedHours>
<UsedHours>decimal</UsedHours>
<PlannedBudget>decimal</PlannedBudget>
<ActualBudget>decimal</ActualBudget>
<pkProjectId>int</pkProjectId>
</api_ProjectListingResult>
</GetProjectsResult>
<outputMessage>string</outputMessage>
</GetProjectsResponse>
</soap:Body>
</soap:Envelope>

Get Tasks
Returns an api_TaskListingResult array of your project tasks defined in your PulsewayPSA account, with the ability to
filter by clients, dates, projects, and status.

Request

URL https://psa.pulseway.com/GetTasks

Type Params Values

HEAD WSUserCredentials Object
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PARAM clients string

PARAM startDateFrom dateTime

PARAM startDateTo dateTime

PARAM endDateFrom dateTime

PARAM endDateTo dateTime

PARAM projects string

PARAM statuses string

PARAM outputMessage OUTPUT String

• WSUserCredentials - A custom authentication SOAP header object consisting of:

– UserName

– Password

– CompanyName

• clients - Specify the clients(s) value(s) by which to filter tasks based on. For multiple clients you have to separate by
Comma (,). If Null or Empty ("") this will be ignored.

• startDateFrom - Specify the earliest task start date. If Null this will be ignored.

• startDateTo - Specify the latest task start date. If Null this will be ignored.

• endDateFrom - Specify the earliest task end date. If Null this will be ignored.

• endDateTo - Specify the latest task end date. If Null this will be ignored.

• projects - Specify the project(s) value(s) by which to filter tasks based on. For multiple projects you have to
separate by Comma (,). If Null or Empty ("") this will be ignored.

• statuses - Specify the project status(s) value(s) by which to filter tasks based on. For multiple statuses you have to
separate by Comma (,). If Null or Empty ("") this will be ignored.

Example Request

POST /WS/OpenAPI.asmx HTTP/1.1
Host:psa.pulseway.com
Content-Type: text/xml; charset=utf-8
Content-Length: length
SOAPAction: "https://pulsewaypsalogin.com/GetTasks"

<?xml version="1.0" encoding="utf-8"?>
<soap:Envelope xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
xmlns:xsd="http://www.w3.org/2001/XMLSchema"
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xmlns:soap="http://schemas.xmlsoap.org/soap/envelope/">
<soap:Header>
<WSUserCredentials xmlns="https://pulsewaypsalogin.com/">
<UserName>string</UserName>
<Password>string</Password>
<CompanyName>string</CompanyName>
</WSUserCredentials>
</soap:Header>
<soap:Body>
<GetTasks xmlns="https://pulsewaypsalogin.com/">
<clients>string</clients>
<startDateFrom>dateTime</startDateFrom>
<startDateTo>dateTime</startDateTo>
<endDateFrom>dateTime</endDateFrom>
<endDateTo>dateTime</endDateTo>
<projects>string</projects>
<statuses>string</statuses>
</GetTasks>
</soap:Body>
</soap:Envelope>

Response

Status Response

Success GetTasksResult:

• Array of api_TaskListingResult:

pkTaskId (int)

ParentTaskId (int)

ClientName (string)

ProjectName (string)

TaskStatus (string)

StartDate (dateTime)

EndDate (dateTime)

UsedHours (decimal)

PercentageUsed (decimal)

EstimatedHours (decimal)

TaskType (string)

outputMessage:

• Empty String
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Failure GetTasksResult:

• Returns Null

outputMessage:

• "An Error has Occurred while processing the request."

Example Response

HTTP/1.1 200 OK
Content-Type: text/xml; charset=utf-8
Content-Length: length

<?xml version="1.0" encoding="utf-8"?>
<soap:Envelope xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
xmlns:xsd="http://www.w3.org/2001/XMLSchema"
xmlns:soap="http://schemas.xmlsoap.org/soap/envelope/">
<soap:Body>
<GetTasksResponse xmlns="https://pulsewaypsalogin.com/">
<GetTasksResult>
<api_TaskListingResult>
<TaskName>string</TaskName>
<ProjectName>string</ProjectName>
<ClientName>string</ClientName>
<TaskStatus>string</TaskStatus>
<StartDate>dateTime</StartDate>
<EndDate>dateTime</EndDate>
<UsedHours>decimal</UsedHours>
<PercentUsed>decimal</PercentUsed>
<EstimatedHours>decimal</EstimatedHours>
<TaskType>string</TaskType>
<pkTaskId>int</pkTaskId>
<ParentTaskId>int</ParentTaskId>
</api_TaskListingResult>
</GetTasksResult>
<outputMessage>string</outputMessage>
</GetTasksResponse>
</soap:Body>
</soap:Envelope>

Get Ticket Note Types
Returns a TicketNoteType array of possible ticket note types defined in your PulsewayPSA account.

Request

URL https://psa.pulseway.com/GetTicketNoteTypes

Type Params Values
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HEAD WSUserCredentials Object

PARAM outputMessage OUTPUT String

• WSUserCredentials - A custom authentication SOAP header object consisting of:

– UserName

– Password

– CompanyName

Example Request

POST /WS/OpenAPI.asmx HTTP/1.1
Host:psa.pulseway.com
Content-Type: text/xml; charset=utf-8
Content-Length: length
SOAPAction: "https://pulsewaypsalogin.com/GetTicketNoteTypes"

<?xml version="1.0" encoding="utf-8"?>
<soap:Envelope xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
xmlns:xsd="http://www.w3.org/2001/XMLSchema"
xmlns:soap="http://schemas.xmlsoap.org/soap/envelope/">
<soap:Header>
<WSUserCredentials xmlns="https://pulsewaypsalogin.com/">
<UserName>string</UserName>
<Password>string</Password>
<CompanyName>string</CompanyName>
</WSUserCredentials>
</soap:Header>
<soap:Body>
<GetTicketNoteTypes xmlns="https://pulsewaypsalogin.com/" />
</soap:Body>
</soap:Envelope>

Response

Status Response

Success GetTicketNoteTypesResult:

• Array of TicketNoteType:

TypeId (int)

TypeName (string)

outputMessage:

• Empty String
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Failure GetTicketNoteTypesResult:

• Returns Null

outputMessage:

• "Failed to get note types list."

Example Response

HTTP/1.1 200 OK
Content-Type: text/xml; charset=utf-8
Content-Length: length

<?xml version="1.0" encoding="utf-8"?>
<soap:Envelope xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
xmlns:xsd="http://www.w3.org/2001/XMLSchema"
xmlns:soap="http://schemas.xmlsoap.org/soap/envelope/">
<soap:Body>
<GetTicketNoteTypesResponse xmlns="https://pulsewaypsalogin.com/">
<GetTicketNoteTypesResult>
<TicketNoteType>
<TypeId>int</TypeId>
<TypeName>string</TypeName>
</TicketNoteType>
<TicketNoteType>
<TypeId>int</TypeId>
<TypeName>string</TypeName>
</TicketNoteType>
</GetTicketNoteTypesResult>
<outputMessage>string</outputMessage>
</GetTicketNoteTypesResponse>
</soap:Body>
</soap:Envelope>

Get Ticket Priorities
Returns a TicketPriority array of possible ticket priorities defined in your PulsewayPSA account.

Request

URL https://psa.pulseway.com/GetTicketPriorities

Type Params Values

HEAD WSUserCredentials Object

PARAM outputMessage OUTPUT String

• WSUserCredentials - A custom authentication SOAP header object consisting of:
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– UserName

– Password

– CompanyName

Example Request

POST /WS/OpenAPI.asmx HTTP/1.1
Host:psa.pulseway.com
Content-Type: text/xml; charset=utf-8
Content-Length: length
SOAPAction: "https://pulsewaypsalogin.com/GetTicketPriorities"

<?xml version="1.0" encoding="utf-8"?>
<soap:Envelope xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
xmlns:xsd="http://www.w3.org/2001/XMLSchema"
xmlns:soap="http://schemas.xmlsoap.org/soap/envelope/">
<soap:Header>
<WSUserCredentials xmlns="https://pulsewaypsalogin.com/">
<UserName>string</UserName>
<Password>string</Password>
<CompanyName>string</CompanyName>
</WSUserCredentials>
</soap:Header>
<soap:Body>
<GetTicketPriorities xmlns="https://pulsewaypsalogin.com/" />
</soap:Body>
</soap:Envelope>

Response

Status Response

Success GetTicketPrioritiesResult:

• Array of TicketPriority:

PriorityId (int)

PriorityName (string)

PriorityColor (string)

outputMessage:

• Empty String

Failure GetTicketPrioritiesResult:

• Returns Null

outputMessage:

• "Failed to get Priorities list."
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Example Response

HTTP/1.1 200 OK
Content-Type: text/xml; charset=utf-8
Content-Length: length

<?xml version="1.0" encoding="utf-8"?>
<soap:Envelope xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
xmlns:xsd="http://www.w3.org/2001/XMLSchema"
xmlns:soap="http://schemas.xmlsoap.org/soap/envelope/">
<soap:Body>
<GetTicketPrioritiesResponse xmlns="https://pulsewaypsalogin.com/">
<GetTicketPrioritiesResult>
<TicketPriority>
<PriorityId>int</PriorityId>
<PriorityName>string</PriorityName>
<PriorityColor>string</PriorityColor>
</TicketPriority>
<TicketPriority>
<PriorityId>int</PriorityId>
<PriorityName>string</PriorityName>
<PriorityColor>string</PriorityColor>
</TicketPriority>
</GetTicketPrioritiesResult>
<outputMessage>string</outputMessage>
</GetTicketPrioritiesResponse>
</soap:Body>
</soap:Envelope>

Get Ticket Queues
Returns a TicketQueue array of possible ticket queues defined in your PulsewayPSA account.

Request

URL https://psa.pulseway.com/GetTicketQueues

Type Params Values

HEAD WSUserCredentials Object

PARAM outputMessage OUTPUT String

• WSUserCredentials - A custom authentication SOAP header object consisting of:

– UserName

– Password

– CompanyName
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Example Request

POST /WS/OpenAPI.asmx HTTP/1.1
Host:psa.pulseway.com
Content-Type: text/xml; charset=utf-8
Content-Length: length
SOAPAction: "https://pulsewaypsalogin.com/GetTicketQueues"

<?xml version="1.0" encoding="utf-8"?>
<soap:Envelope xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
xmlns:xsd="http://www.w3.org/2001/XMLSchema"
xmlns:soap="http://schemas.xmlsoap.org/soap/envelope/">
<soap:Header>
<WSUserCredentials xmlns="https://pulsewaypsalogin.com/">
<UserName>string</UserName>
<Password>string</Password>
<CompanyName>string</CompanyName>
</WSUserCredentials>
</soap:Header>
<soap:Body>
<GetTicketQueues xmlns="https://pulsewaypsalogin.com/" />
</soap:Body>
</soap:Envelope>

Response

Status Response

Success GetTicketQueuesResult:

• Array of TicketQueue:

QueueId (int)

QueueName (string)

outputMessage:

• Empty String

Failure GetTicketQueuesResult:

• Returns Null

outputMessage:

• "Failed to get Queues list."

Example Response

HTTP/1.1 200 OK
Content-Type: text/xml; charset=utf-8
Content-Length: length
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<?xml version="1.0" encoding="utf-8"?>
<soap:Envelope xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
xmlns:xsd="http://www.w3.org/2001/XMLSchema"
xmlns:soap="http://schemas.xmlsoap.org/soap/envelope/">
<soap:Body>
<GetTicketQueuesResponse xmlns="https://pulsewaypsalogin.com/">
<GetTicketQueuesResult>
<TicketQueue>
<QueueId>int</QueueId>
<QueueName>string</QueueName>
</TicketQueue>
<TicketQueue>
<QueueId>int</QueueId>
<QueueName>string</QueueName>
</TicketQueue>
</GetTicketQueuesResult>
<outputMessage>string</outputMessage>
</GetTicketQueuesResponse>
</soap:Body>
</soap:Envelope>

Get Ticket Sources
Returns a TicketSource array of possible ticket sources defined in your PulsewayPSA account.

Request

URL https://psa.pulseway.com/GetTicketSources

Type Params Values

HEAD WSUserCredentials Object

PARAM outputMessage OUTPUT String

• WSUserCredentials - A custom authentication SOAP header object consisting of:

– UserName

– Password

– CompanyName

Example Request

POST /WS/OpenAPI.asmx HTTP/1.1
Host:psa.pulseway.com
Content-Type: text/xml; charset=utf-8
Content-Length: length
SOAPAction: "https://pulsewaypsalogin.com/GetTicketSources"
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<?xml version="1.0" encoding="utf-8"?>
<soap:Envelope xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
xmlns:xsd="http://www.w3.org/2001/XMLSchema"
xmlns:soap="http://schemas.xmlsoap.org/soap/envelope/">
<soap:Header>
<WSUserCredentials xmlns="https://pulsewaypsalogin.com/">
<UserName>string</UserName>
<Password>string</Password>
<CompanyName>string</CompanyName>
</WSUserCredentials>
</soap:Header>
<soap:Body>
<GetTicketSources xmlns="https://pulsewaypsalogin.com/" />
</soap:Body>
</soap:Envelope>

Response

Status Response

Success GetTicketSourcesResult:

• Array of TicketSource:

SourceId (int)

SourceName (string)

outputMessage:

• Empty String

Failure GetTicketSourcesResult:

• Returns Null

outputMessage:

• "Failed to get ticket sources list."

Example Response

HTTP/1.1 200 OK
Content-Type: text/xml; charset=utf-8
Content-Length: length

<?xml version="1.0" encoding="utf-8"?>
<soap:Envelope xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
xmlns:xsd="http://www.w3.org/2001/XMLSchema"
xmlns:soap="http://schemas.xmlsoap.org/soap/envelope/">
<soap:Body>
<GetTicketSourcesResponse xmlns="https://pulsewaypsalogin.com/">

510 PulsewayPSA Guide

Release 4.0.41 | March 2021

Chapter 13: PulsewayPSA SOAP API www.pulseway.com

https://www.pulseway.com/


511

Chapter 13: PulsewayPSA SOAP APIwww.pulseway.com

<GetTicketSourcesResult>
<TicketSource>
<SourceId>int</SourceId>
<SourceName>string</SourceName>
</TicketSource>
<TicketSource>
<SourceId>int</SourceId>
<SourceName>string</SourceName>
</TicketSource>
</GetTicketSourcesResult>
<outputMessage>string</outputMessage>
</GetTicketSourcesResponse>
</soap:Body>
</soap:Envelope>

Get Ticket Statuses
Returns a TicketStatus array of possible ticket statuses defined in your PulsewayPSA account.

Request

URL https://psa.pulseway.com/GetTicketStatuses

Type Params Values

HEAD WSUserCredentials Object

PARAM outputMessage OUTPUT String

• WSUserCredentials - A custom authentication SOAP header object consisting of:

– UserName

– Password

– CompanyName

Example Request

POST /WS/OpenAPI.asmx HTTP/1.1
Host:psa.pulseway.com
Content-Type: text/xml; charset=utf-8
Content-Length: length
SOAPAction: "https://pulsewaypsalogin.com/GetTicketStatuses"

<?xml version="1.0" encoding="utf-8"?>
<soap:Envelope xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
xmlns:xsd="http://www.w3.org/2001/XMLSchema"
xmlns:soap="http://schemas.xmlsoap.org/soap/envelope/">
<soap:Header>
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<WSUserCredentials xmlns="https://pulsewaypsalogin.com/">
<UserName>string</UserName>
<Password>string</Password>
<CompanyName>string</CompanyName>
</WSUserCredentials>
</soap:Header>
<soap:Body>
<GetTicketStatuses xmlns="https://pulsewaypsalogin.com/" />
</soap:Body>
</soap:Envelope>

Response

Status Response

Success GetTicketStatusesResult:

• Array of TicketStatus:

StatusId (int)

StatusName (string)

StatusOrder (int)

• outputMessage:

Empty String

Failure GetTicketStatusesResult:

Returns Null

outputMessage:

"Failed to get statuses list."

Example Response

HTTP/1.1 200 OK
Content-Type: text/xml; charset=utf-8
Content-Length: length

<?xml version="1.0" encoding="utf-8"?>
<soap:Envelope xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
xmlns:xsd="http://www.w3.org/2001/XMLSchema"
xmlns:soap="http://schemas.xmlsoap.org/soap/envelope/">
<soap:Body>
<GetTicketStatusesResponse xmlns="https://pulsewaypsalogin.com/">
<GetTicketStatusesResult>
<TicketStatus>
<StatusId>int</StatusId>
<StatusName>string</StatusName>
<StatusOrder>int</StatusOrder>
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</TicketStatus>
<TicketStatus>
<StatusId>int</StatusId>
<StatusName>string</StatusName>
<StatusOrder>int</StatusOrder>
</TicketStatus>
</GetTicketStatusesResult>
<outputMessage>string</outputMessage>
</GetTicketStatusesResponse>
</soap:Body>
</soap:Envelope>

Get Ticket Types
Returns a TicketType array of possible ticket types defined in your PulsewayPSA account.

Request

URL https://psa.pulseway.com/GetTicketTypes

Type Params Values

HEAD WSUserCredentials Object

PARAM outputMessage OUTPUT String

• WSUserCredentials - A custom authentication SOAP header object consisting of:

– UserName

– Password

– CompanyName

Example Request

POST /WS/OpenAPI.asmx HTTP/1.1
Host:psa.pulseway.com
Content-Type: text/xml; charset=utf-8
Content-Length: length
SOAPAction: "https://pulsewaypsalogin.com/GetTicketTypes"

<?xml version="1.0" encoding="utf-8"?>
<soap:Envelope xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
xmlns:xsd="http://www.w3.org/2001/XMLSchema"
xmlns:soap="http://schemas.xmlsoap.org/soap/envelope/">
<soap:Header>
<WSUserCredentials xmlns="https://pulsewaypsalogin.com/">
<UserName>string</UserName>
<Password>string</Password>
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<CompanyName>string</CompanyName>
</WSUserCredentials>
</soap:Header>
<soap:Body>
<GetTicketTypes xmlns="https://pulsewaypsalogin.com/" />
</soap:Body>
</soap:Envelope>

Response

Status Response

Success GetTicketTypesResult:

• Array of TicketType:

TypeId (int)

TypeName (string)

outputMessage:

• Empty String

Failure GetTicketTypesResult:

• Returns Null

outputMessage:

• "Failed to get ticket types list."

Example Response

HTTP/1.1 200 OK
Content-Type: text/xml; charset=utf-8
Content-Length: length

<?xml version="1.0" encoding="utf-8"?>
<soap:Envelope xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
xmlns:xsd="http://www.w3.org/2001/XMLSchema"
xmlns:soap="http://schemas.xmlsoap.org/soap/envelope/">
<soap:Body>
<GetTicketTypesResponse xmlns="https://pulsewaypsalogin.com/">
<GetTicketTypesResult>
<TicketType>
<TypeId>int</TypeId>
<TypeName>string</TypeName>
</TicketType>
<TicketType>
<TypeId>int</TypeId>
<TypeName>string</TypeName>
</TicketType>
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</GetTicketTypesResult>
<outputMessage>string</outputMessage>
</GetTicketTypesResponse>
</soap:Body>
</soap:Envelope>

Get Tickets
Note: The Get Tickets SOAP API no longer returns ticket results. Going forward, please use the 'GET All Tickets' and

'GET Ticket' REST APIs.

Returns an array of objects of type Ticket in your PulsewayPSA account. The list can be filtered by any text value in the
searchStr parameter. The result set can be retrieved in a paged manner by supplying a startIndex and endIndex.

Request

URL https://psa.pulseway.com/GetTickets

Type Params Values

HEAD WSUserCredentials Object

PARAM outputMessage OUTPUT String

• WSUserCredentials - A custom authentication SOAP header object consisting of:

– UserName

– Password

– CompanyName

• searchStr - Remains empty to retrieve all tickets. If a value is supplied the system tries to match all text and date
fields to get the matching tickets.

• startIndex (required) - Allows you to retrieve tickets based on their row index. This will give the ability to implement
paging.

• endIndex (required) - The following example retrieves the first 50 records matching "Ticket xyz".

– searchStr - Ticket xyz

– startIndex - 0

– endIndex - 50

Example Request

POST /ws/OpenAPI.asmx HTTP/1.1
Host: staging.psa.pulseway.com
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Content-Type: text/xml; charset=utf-8
Content-Length: length
SOAPAction: "https://pulsewaypsalogin.com/GetTickets"

<?xml version="1.0" encoding="utf-8"?>
<soap:Envelope xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
xmlns:xsd="http://www.w3.org/2001/XMLSchema"
xmlns:soap="http://schemas.xmlsoap.org/soap/envelope/">
<soap:Header>
<WSUserCredentials xmlns="https://pulsewaypsalogin.com/">
<UserName>string</UserName>
<Password>string</Password>
<CompanyName>string</CompanyName>
</WSUserCredentials>
</soap:Header>
<soap:Body>
<GetTickets xmlns="https://pulsewaypsalogin.com/">
<searchStr>string</searchStr>
<startIndex>int</startIndex>
<endIndex>int</endIndex>
</GetTickets>
</soap:Body>
</soap:Envelope>

Response

Status Response
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Success GetTicketsResult:

• Array of Ticket:

TicketId (int)

TicketNumber (string)

ClientId (int)

ClientName (string)

ClientSiteId (int)

ClientSiteName (string)

ClientContactId (int)

ClientContactName (string)

TicketTitle (string)

TicketDetails (string)

TicketTypeId (int)

TicketType (string)

TicketStatusId (int)

TicketStatus (string)

TicketPriorityId (int)

TicketPriority (string)

TicketQueueId (int)

TicketQueue (string)

TicketPrimaryAssigneeId (int)

TicketPrimaryAssignee (string)

TicketSourceId (int)

TicketSource (string)

TicketOpenDate (DateTime)

TicketDueDate (DateTime)

TicketCompletedDate (DateTime)

TicketWorkType (string)

TicketContractName (string)

TicketLastUpdate (DateTime)

TicketSLAName (string)
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outputMessage:

• Empty String

Failure GetTicketsResult:

• Returns Null

outputMessage:

• "Failed to get tickets list."

Example Response

HTTP/1.1 200 OK
Content-Type: text/xml; charset=utf-8
Content-Length: length

<?xml version="1.0" encoding="utf-8"?>
<soap:Envelope xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
xmlns:xsd="http://www.w3.org/2001/XMLSchema"
xmlns:soap="http://schemas.xmlsoap.org/soap/envelope/">
<soap:Body>
<GetTicketsResult>
<Ticket>
<TicketId>int</TicketId>
<TicketNumber>string</TicketNumber>
<ClientId>int</ClientId>
<ClientName>string</ClientName>
<ClientSiteId>int</ClientSiteId>
<ClientSiteName>string</ClientSiteName>
<ClientContactId>int</ClientContactId>
<ClientContactName>string</ClientContactName>
<TicketTitle>string</TicketTitle>
<TicketDetails>string</TicketDetails>
<TicketTypeId>int</TicketTypeId>
<TicketType>string</TicketType>
<TicketStatusId>int</TicketStatusId>
<TicketStatus>string</TicketStatus>
<TicketPriorityId>int</TicketPriorityId>
<TicketPriority>string</TicketPriority>
<TicketQueueId>int</TicketQueueId>
<TicketQueue>string</TicketQueue>
<TicketPrimaryAssigneeId>int</TicketPrimaryAssigneeId>
<TicketPrimaryAssignee>string</TicketPrimaryAssignee>
<TicketSourceId>int</TicketSourceId>
<TicketSource>string</TicketSource>
<TicketOpenDate>dateTime</TicketOpenDate>
<TicketDueDate>dateTime</TicketDueDate>
<TicketCompletedDate>dateTime</TicketCompletedDate>
<TicketWorkType>string</TicketWorkType>
<TicketContractName>string</TicketContractName>
<TicketLastUpdate>dateTime</TicketLastUpdate>

518 PulsewayPSA Guide

Release 4.0.41 | March 2021

Chapter 13: PulsewayPSA SOAP API www.pulseway.com

https://www.pulseway.com/


519

Chapter 13: PulsewayPSA SOAP APIwww.pulseway.com

<TicketSLAName>string</TicketSLAName>
</Ticket>

</GetTicketsResult>
<outputMessage>string</outputMessage>
</GetTicketsResponse>

</soap:Body>
</soap:Envelope>

Get Time Sheets
Returns an api_GetTimeSheetsResult array of time entries and related information based on a date range, projects,
clients and or usernames of employees.

Request

URL https://psa.pulseway.com/GetTimeSheets

Type Params Values

HEAD WSUserCredentials Object

PARAM dateFrom dateTime

PARAM dateTo dateTime

PARAM clientNames string

PARAM userNames string

PARAM projectNames string

PARAM outputMessage OUTPUT String

• WSUserCredentials - A custom authentication SOAP header object consisting of:

– UserName

– Password

– CompanyName

• clientNames - Specify the clients(s) value(s) by which to filter time logs based on. For multiple clients you have to
separate by Comma (,). If Null or Empty ("") this will be ignored.

• dateFrom - Specify the earliest time entry date. If Null this will be ignored.

• dateTo - Specify the latest time entry date. If Null this will be ignored.
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• userNames - Specify the employee username(s) value(s) by which to filter time logs based on. For multiple
usernames you have to separate by Comma (,). If Null or Empty ("") this will be ignored.

• projectNames - Specify the project(s) value(s) by which to filter time logs based on. For multiple usernames you
have to separate by Comma (,). If Null or Empty ("") this will be ignored.

Example Request

POST /WS/OpenAPI.asmx HTTP/1.1
Host:psa.pulseway.com
Content-Type: text/xml; charset=utf-8
Content-Length: length
SOAPAction: "https://pulsewaypsalogin.com/GetTimeSheets"

<?xml version="1.0" encoding="utf-8"?>
<soap:Envelope xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
xmlns:xsd="http://www.w3.org/2001/XMLSchema"
xmlns:soap="http://schemas.xmlsoap.org/soap/envelope/">
<soap:Header>
<WSUserCredentials xmlns="https://pulsewaypsalogin.com/">
<UserName>string</UserName>
<Password>string</Password>
<CompanyName>string</CompanyName>
</WSUserCredentials>
</soap:Header>
<soap:Body>
<GetTimeSheets xmlns="https://pulsewaypsalogin.com/">
<dateFrom>dateTime</dateFrom>
<dateTo>dateTime</dateTo>
<clientNames>string</clientNames>
<userNames>string</userNames>
<projectNames>string</projectNames>
</GetTimeSheets>
</soap:Body>
</soap:Envelope>

Response

Status Response
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Success GetTimeSheetsResult:

• Array of api_GetTimeSheetsResult:

pkTimeEntryId (int)

TimesheetId (int)

UserName(string)

Client (string)

Source(string)

Title (string)

StartDate(dateTime)

TimeSpent (decimal)

Billable (int)

RoleName (string)

RoleRate (decimal)

WorkTypName (string)

Notes (string)

Billed (boolean)

IsPosted (boolean)

outputMessage:

• Empty String

Failure GetTimeSheetsResult:

• Returns Null

outputMessage:

• "An Error has Occurred while processing the request."

Example Response

HTTP/1.1 200 OK
Content-Type: text/xml; charset=utf-8
Content-Length: length

<?xml version="1.0" encoding="utf-8"?>
<soap:Envelope xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
xmlns:xsd="http://www.w3.org/2001/XMLSchema"
xmlns:soap="http://schemas.xmlsoap.org/soap/envelope/">
<soap:Body>
<GetTimeSheetsResponse xmlns="https://pulsewaypsalogin.com/">
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<GetTimeSheetsResult>
<api_GetTimeSheetsResult>
<pkTimeEntryId>int</pkTimeEntryId>
<TimesheetId>int</TimesheetId>
<UserName>string</UserName>
<Client>string</Client>
<Source>string</Source>
<title>string</title>
<StartDate>dateTime</StartDate>
<TimeSpent>decimal</TimeSpent>
<Billable>int</Billable>
<RoleName>string</RoleName>
<RoleRate>decimal</RoleRate>
<WorkTypName>string</WorkTypName>
<Notes>string</Notes>
<Billed>boolean</Billed>
<IsPosted>boolean</IsPosted>
</api_GetTimeSheetsResult>
</GetTimeSheetsResult>
<outputMessage>string</outputMessage>
</GetTimeSheetsResponse>
</soap:Body>
</soap:Envelope>
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Click https://psa.pulseway.com/api to access the PulsewayPSA REST API documentation.
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